Autor Tópico: warsaw bb no 18.04  (Lida 4660 vezes)

Offline luizluca

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #30 Online: 11 de Maio de 2018, 00:07 »
O warsaw do bb falha no ubuntu 18.04 pois ele nao acha os arquivos do locale pt_BR. Agora no ubuntu só temos o locale padrão C, possivelmente por retrocompatibilidade.

Insira um:

export LC_ALL=C

 lá pelo começo do /etc/init.d/warsaw e reinicie o serviço warsaw.

Offline 3Ricardo8

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #31 Online: 11 de Maio de 2018, 00:52 »
Olha, depois de instalar o ubuntu 18.04, me deparar com esse problemão do warsaw e descobrir que muitos estão tendo esse problema com a última versão do ubuntu, resolvi me cadastrar para colaborar.

Funcionou pra mim com o warsaw versão 1.12.8-7, baixado no site da Diebold-Nixdorf (o mesmo citado por aqui)

Funcionou com o BB e a Caixa. No Firefox 60.0 (que o Ubuntu mostrou pra mim que tinha atualização - sim esse Firefox é bem recente). Mandei atualizar e o engraçado é que, pra mim, foi o esse Firefox que fez o que todo mundo anda dizendo que só o Chrome que faria (rsrs).

Mas com o Chrome 65 aqui não tá rolando não. Como funcionou no Firefox 60, então acredito que a próxima atualização do Chrome deve conseguir reconhecer direito essa versão do warsaw da Diebold-Nixdorf (1.12.8-7).

Então é isso. Tentem atualizar o Firefox. Instalem o warsaw do site da Diebold. E vejam se essa versão 60 também consegue identificar o warsaw 1.12.8-7 e, assim, injetar o certificado no Firefox e fialmente acessar a conta dos bancos que fazem uso do warsaw.

É isso.

Offline Marcopolo

  • Usuário Ubuntu
  • *
  • Mensagens: 680
  • Ubuntu forever, ever!!
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #32 Online: 11 de Maio de 2018, 20:16 »
O warsaw do bb falha no ubuntu 18.04 pois ele nao acha os arquivos do locale pt_BR. Agora no ubuntu só temos o locale padrão C, possivelmente por retrocompatibilidade.

Insira um:

export LC_ALL=C

 lá pelo começo do /etc/init.d/warsaw e reinicie o serviço warsaw.
Luiz, essa linha que você informou tem que ser "comentada", ou seja, com o caracter (#) antes da linha ou pode-se adicionar como mostra sua informação? Já perguntei outra vez(não me lembro onde), mas eu queria ter certeza de como inserir! Mt obrigado, abraço!
"Quanto mais aumenta nosso conhecimento, mais evidente fica nossa ignorância" (JFK).http://ubuntuforum-br.org

Desktop, Intel Core i7, Win 7 64 bits, Windows10 e Ubuntu16.04.3 LTS, HD 500 GB, 4 GB. Dell14",  Core i3, HD 500 GB, 4 GB, Win10- 64 bits-Ununtu16.04. Vaio 15S 8GB -HD 1Tera-Ubuntu 18.04.

Offline DidBrother

  • Usuário Ubuntu
  • *
  • Mensagens: 44
  • Avante. sempre em frente
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #33 Online: 11 de Maio de 2018, 23:19 »
Caro Marcopolo,

Sem o #,

e  depois reinicie o computador.

DidBrother

Offline Marcopolo

  • Usuário Ubuntu
  • *
  • Mensagens: 680
  • Ubuntu forever, ever!!
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #34 Online: 12 de Maio de 2018, 08:29 »
Caro Marcopolo,

Sem o #,

e  depois reinicie o computador.

DidBrother
Falooooooooooooooow, Brother  DidBrother! Muitissimo obrigado e aqui o véio, fica feliz! Um abração e um ótimo e abençoado fds! (Weekend)! :D ;D
"Quanto mais aumenta nosso conhecimento, mais evidente fica nossa ignorância" (JFK).http://ubuntuforum-br.org

Desktop, Intel Core i7, Win 7 64 bits, Windows10 e Ubuntu16.04.3 LTS, HD 500 GB, 4 GB. Dell14",  Core i3, HD 500 GB, 4 GB, Win10- 64 bits-Ununtu16.04. Vaio 15S 8GB -HD 1Tera-Ubuntu 18.04.

Offline reginaldoads

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #35 Online: 15 de Maio de 2018, 07:59 »
Encontrei um tutorial do archlinux, na pagina - https://aur.archlinux.org/packages/warsaw/ - que funcionou perfeitamente no ubuntu 18.04, com as devidas adaptações.

Repassando a sequencia que usei:

1 - Instale o navegador Chrome, pois o warsaw não injeta o certificado na versão 58 ou superior do Firefox

2 - instale pacote libnss3-tools
sudo apt install libnss3-tools

3-  instale o warsaw com  o dpkg.   vai ocorrer o mesmo erro que consta no link https://imgur.com/XVtdRjZ da mensagem 1

4- veja se o warsaw/core está rodando como usuario
ps -ef |grep warsaw
 
5 -Abrir o navegador chrome e no endereço:  chrome://settings/certificates  acessar a aba autoridades e verificar a existência do certificado  "Warsaw Personal CA" .  Se não encontrou - Sudo apt purge warsaw  - e  instale novamente o warsaw. verifique e instale quantas vezes for necessário.

6 - abrir o terminal  e como Root rodar os comandos:

A - Acessando a pasta
# cd /usr/local/lib/warsaw

B. Substituindo os arquivos por links
# rm ld-linux-x86-64.so.2 && ln -s /lib/x86_64-linux-gnu/ld-linux-x86-64.so.2
# rm libc.so.6 && ln -s /lib/x86_64-linux-gnu/libc.so.6
# rm libpthread.so.0 && ln -s /lib/x86_64-linux-gnu/libpthread.so.0
# rm libdl.so.2 && ln -s /lib/x86_64-linux-gnu/libdl.so.2

C: Defina o atributo do diretório /usr/local/lib/warsaw como append-only
# chattr +a /usr/local/lib/warsaw   

D: Ative e inicie o serviço do warsaw :
# systemctl enable warsaw
# systemctl start warsaw
# /usr/local/bin/warsaw/core

5: Verifique que os processos relacionados ao warsaw estão rodando corretamente:

# ps  -ef | grep warsaw
Você deve observar no mínimo 1 [...]/warsaw/core rodando como root e pelo menos um [...]/warsaw/core rodando como usuário.

6: reiniciar  o computador

DidBrother

Valeu muito, amigão! Assim que eu baixar a iso e instalar o 18.04 LTS, uso esse tutorial para poder usar minha conta corrente pelo Banco do Brasil! Um fraternal abraço,
Marcopolo!

Ótimo, funcionou perfeitamente aqui para mim! Segui o passo a passo e não tive problemas.

Offline Miguel-1501

  • Usuário Ubuntu
  • *
  • Mensagens: 24
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #36 Online: 15 de Maio de 2018, 10:55 »
Caros amigos,

Simplificando  ou melhor complicando  a "coisa", digo  warsaw

Está disponível no site da Diebold a versão 1.12.8-7 que apresenta  a vantagem de inserir  o certificado no firefox independentemente da versão e  não  é preciso substituir bibliotecas por links no  ubuntu 18.04.  Nem tudo beira a perfeição.  Entre a lista de dependências está a biblioteca    "python-gpgme" que não está disponível  nos repositórios  oficiais do ubuntu 18.04, embora esteja nos repositórios  das versões 16.04 e 17.10.   O warsaw acima apresentou compatibilidade com o BB,  CEF,  e para o Itaú após reiniciar o computador.  Deixo abaixo o passo  que utilizei na maquina de teste com 18.04.



1. Baixar o Warsaw fornecido pela Diebold, no endereço - https://cloud.gastecnologia.com.br/gas/diagnostico/warsaw-setup-ubuntu_64.deb  - versão 1.12.8-7 -compatível com CEF, BB e Itaú, com os navegadores Chrome, Firefox.

2. Baixar a biblioteca  python-gpgme  no endereço https://www.ubuntuupdates.org/package/core/artful/main/base/python-gpgme

3. Abrir o terminal e remover qualquer versão anteriormente instalada com o comando.
Código: [Selecionar]
sudo apt-get purge warsaw
4. instalar as dependências.

Código: [Selecionar]
sudo apt install libnss3-tools && sudo apt install python-openssl && sudo apt install libcurl3 && sudo apt install zenity
5. Ainda no terminal acessar a pasta onde foi baixada o arquivo  do warsaw e a bibiloteca python-gpgme. Pressupondo que foi na pasta Downloads

Código: [Selecionar]
cd Downloads e logo após
Código: [Selecionar]
sudo dpkg -i python-gpgme_0.3-1.2build2_amd64.deb em seguida manter os navegadores fechados e
Código: [Selecionar]
sudo dpkg -i warsaw-setup-ubuntu_64.deb   e aguardar o termino da instalação.

6. Verificações:
A)  a instalação do warsaw  com o comando;
Código: [Selecionar]
ps -ef |grep -v grep |grep -i warsawVocê deve observar no mínimo 1 [...]/warsaw/core rodando como root e pelo menos um [...]/warsaw/core rodando como usuário. tipo:
root      1103     1  0 13:33 ?        00:00:01 /usr/local/bin/warsaw/core
usuario   2165     1  0 13:33 ?        00:00:01 /usr/local/bin/warsaw/core

B - A presença do certificado " Warsaw Personal CA"  nos navegadores. Firefox  em -   about:preferences#privacy   opção ver certificados ; no  Chrome em - chrome://settings/certificates  acessar a aba autoridades.    Se o certificado não estiver presente,  remova e reinstale o warsaw.

7) para acesso aos bancos:
A) CEF =. Abrir o navegador e acessar a página -     https://internetbanking.caixa.gov.br/sinbc/nb/login/redirecionaDispSeguranca - vai aparecer a mensagem: adicional de segurança instalado incorretamente. Aguarde enquanto configuramos seu computador. encerrado aparece a mensagem: Adicional de Segurança CAIXA instalado. Acesse a sua conta.
B) ITAU = acesse a página do Itau,  insira o numero de agencia e conta - vai aparecer o nome do correntista e na parte inferior a msg guardiao itau instalado. Está configurado o acesso para o banco itau (aqui só funcionou após reiniciar o computador)
C) BB =  acesse a pagina  https://www2.bancobrasil.com.br/aapf/login.jsp e espere configurar o acesso. Quando estiver disponível os campos: agencia, conta e senha Está configurado o acesso para o banco do brasil

DidBrother
Após perder o controle do root em Ubuntu 14.04 seguindo o tutorial do BB, instalei o Linux Mint 18.3 e achei que esta era a opção melhor. Aparentemente, tudo estava dando certo. Reiniciei e conferi que o certificado estava no Firefox. Mas na hora de acessar, após um bom tempo configurando, finalmente apareceu a janeliha, mas dizendo que não tinha instalado o warsaw. Eu verifiquei que o programa estaba rolando [ps -ef |grep -v grep |grep -i warsaw] e na aparentemente tudo estava normal, aparecia a mesma coisa que neste tutorial acima. O Firefox é Quantum 60.0.

Offline DidBrother

  • Usuário Ubuntu
  • *
  • Mensagens: 44
  • Avante. sempre em frente
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #37 Online: 15 de Maio de 2018, 12:42 »


Após perder o controle do root em Ubuntu 14.04 seguindo o tutorial do BB, instalei o Linux Mint 18.3 e achei que esta era a opção melhor. Aparentemente, tudo estava dando certo. Reiniciei e conferi que o certificado estava no Firefox. Mas na hora de acessar, após um bom tempo configurando, finalmente apareceu a janeliha, mas dizendo que não tinha instalado o warsaw. Eu verifiquei que o programa estaba rolando [ps -ef |grep -v grep |grep -i warsaw] e na aparentemente tudo estava normal, aparecia a mesma coisa que neste tutorial acima. O Firefox é Quantum 60.0.

Caro miguel,

O linux mint 18.3  é uma distribuição  similar ao ubuntu 16.04. Do mesmo modo a  instalação do warsaw segue parâmetros iguais ao do ubuntu 16.04, um pouco diferente do Ubuntu 18.04 .  Se estiveres com o firewall ufw ativado, é necessário modificar o arquivo  /etc/ufw/sysctl.conf como administrador.
Código: [Selecionar]
sudo xxxxx /etc/ufw/sysctl.confsubstituir xxxxx por kedit, gedit, pluma, mousepad, leafpad, etc.(editor de texto)  conforme  sua distribuição. No arquivo localizar a linha contendo o  parametro: -   net/ipv4/tcp_syncookies=0  modificar o  paramentro  para net/ipv4/tcp_syncookies=1.

Reinicie o computador e teste o acesso no navegador

Caso não de certo, sugiro que siga exatamente a sequencia  postada na resposta 14 do tópico  https://ubuntuforum-br.org/index.php?topic=122838.0

DidBrother

Offline Miguel-1501

  • Usuário Ubuntu
  • *
  • Mensagens: 24
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #38 Online: 15 de Maio de 2018, 15:46 »


Após perder o controle do root em Ubuntu 14.04 seguindo o tutorial do BB, instalei o Linux Mint 18.3 e achei que esta era a opção melhor. Aparentemente, tudo estava dando certo. Reiniciei e conferi que o certificado estava no Firefox. Mas na hora de acessar, após um bom tempo configurando, finalmente apareceu a janeliha, mas dizendo que não tinha instalado o warsaw. Eu verifiquei que o programa estaba rolando [ps -ef |grep -v grep |grep -i warsaw] e na aparentemente tudo estava normal, aparecia a mesma coisa que neste tutorial acima. O Firefox é Quantum 60.0.

Caro miguel,

O linux mint 18.3  é uma distribuição  similar ao ubuntu 16.04. Do mesmo modo a  instalação do warsaw segue parâmetros iguais ao do ubuntu 16.04, um pouco diferente do Ubuntu 18.04 .  Se estiveres com o firewall ufw ativado, é necessário modificar o arquivo  /etc/ufw/sysctl.conf como administrador.
Código: [Selecionar]
sudo xxxxx /etc/ufw/sysctl.confsubstituir xxxxx por kedit, gedit, pluma, mousepad, leafpad, etc.(editor de texto)  conforme  sua distribuição. No arquivo localizar a linha contendo o  parametro: -   net/ipv4/tcp_syncookies=0  modificar o  paramentro  para net/ipv4/tcp_syncookies=1.

Reinicie o computador e teste o acesso no navegador

Caso não de certo, sugiro que siga exatamente a sequencia  postada na resposta 14 do tópico  https://ubuntuforum-br.org/index.php?topic=122838.0

DidBrother
Obrigado, Sampaio. Finalmente deu certo. Eu segui o seu primeiro tutorial, mas modifiquei o arquivo "sysctl.conf" como você disse. O meu sistema não permitia a instalação da programa teoricamente mais adequado para Ubuntu 16.04, assim que tentei de novo com o "warsaw-setup-ubuntu 64deb". Após reiniciar, provei primeiro com Chrome e não cosegui. Depois, desanimado, testei o firefox y deu certo. Mas percebi um detalhe, a página pedia para permitir flash e eu acho que só depois de autorizar é que completou o processo. Ao fechar sessão para voltar à página de ínicio, ficou sem avançar e precisei ativar flash, que deixei permanente. Será que o problema com Chrome é a falta de Flash. Nesse caso, existirá um modo de funcionar sem flash?

Offline DidBrother

  • Usuário Ubuntu
  • *
  • Mensagens: 44
  • Avante. sempre em frente
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #39 Online: 15 de Maio de 2018, 18:36 »
Obrigado, Sampaio. Finalmente deu certo. Eu segui o seu primeiro tutorial, mas modifiquei o arquivo "sysctl.conf" como você disse. O meu sistema não permitia a instalação da programa teoricamente mais adequado para Ubuntu 16.04, assim que tentei de novo com o "warsaw-setup-ubuntu 64deb". Após reiniciar, provei primeiro com Chrome e não cosegui. Depois, desanimado, testei o firefox y deu certo. Mas percebi um detalhe, a página pedia para permitir flash e eu acho que só depois de autorizar é que completou o processo. Ao fechar sessão para voltar à página de ínicio, ficou sem avançar e precisei ativar flash, que deixei permanente. Será que o problema com Chrome é a falta de Flash. Nesse caso, existirá um modo de funcionar sem flash?

Caro miguel,

Quem me dera um dia  chegar aos pés do Mestre Sampayu. Pessoa dedicada e disponível que ajudou milhares e milhares de  usuários linux  neste forum. Um verdadeiro ícone.

Estou estranhando as informações acima. O "warsaw-setup-ubuntu_64.deb" versao 1.12.8-7 baixado do site da diebold, endereço, -
 https://cloud.gastecnologia.com.br/gas/diagnostico/warsaw-setup-ubuntu_64.deb - nao precisa de flash para  funcionar. 

Acredito que possivelmente foi instalado o warsaw fornecido a partir da pagina do banco do brasil,  que exige  o plugin flash para funcionar. neste caso para funcionar no Crhome  com flash, sugiro que leia  o rodapé da mensagem 59 do tópico https://ubuntuforum-br.org/index.php?topic=121558.45 .

Para que não fique qualquer duvida abra o synaptic , procure por warsaw e veja a versão.

https://imgur.com/a/FZf4VYW
https://imgur.com/a/4pQmxYw

DidBrother



Offline Miguel-1501

  • Usuário Ubuntu
  • *
  • Mensagens: 24
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #40 Online: 16 de Maio de 2018, 08:36 »
Obrigado, Sampaio. Finalmente deu certo. Eu segui o seu primeiro tutorial, mas modifiquei o arquivo "sysctl.conf" como você disse. O meu sistema não permitia a instalação da programa teoricamente mais adequado para Ubuntu 16.04, assim que tentei de novo com o "warsaw-setup-ubuntu 64deb". Após reiniciar, provei primeiro com Chrome e não cosegui. Depois, desanimado, testei o firefox y deu certo. Mas percebi um detalhe, a página pedia para permitir flash e eu acho que só depois de autorizar é que completou o processo. Ao fechar sessão para voltar à página de ínicio, ficou sem avançar e precisei ativar flash, que deixei permanente. Será que o problema com Chrome é a falta de Flash. Nesse caso, existirá um modo de funcionar sem flash?

Caro miguel,

Quem me dera um dia  chegar aos pés do Mestre Sampayu. Pessoa dedicada e disponível que ajudou milhares e milhares de  usuários linux  neste forum. Um verdadeiro ícone.

Estou estranhando as informações acima. O "warsaw-setup-ubuntu_64.deb" versao 1.12.8-7 baixado do site da diebold, endereço, -
 https://cloud.gastecnologia.com.br/gas/diagnostico/warsaw-setup-ubuntu_64.deb - nao precisa de flash para  funcionar. 

Acredito que possivelmente foi instalado o warsaw fornecido a partir da pagina do banco do brasil,  que exige  o plugin flash para funcionar. neste caso para funcionar no Crhome  com flash, sugiro que leia  o rodapé da mensagem 59 do tópico https://ubuntuforum-br.org/index.php?topic=121558.45 .

Para que não fique qualquer duvida abra o synaptic , procure por warsaw e veja a versão.

https://imgur.com/a/FZf4VYW
https://imgur.com/a/4pQmxYw

DidBrother
Caro DidBrother,

Antes de mais nada, desculpe, é a você que eu deveria ter agradecido pela resposta. Não que o Sampayu não mereça, mas em justiça é assim que deve ser. O cansaço fez com que não lesse direitinho as respostas e confundisse os nomes.
 
Sobre o assunto, baixei o arquivo do sítio da Gastecnologia. No buscador Google, aparece em primeiro lugar “Diagnóstico Warsaw – Dieblod”. Desde ai, você é dirigido a uma página onde há um menu com todos os bancos. Ao clicar no do BB, na tela seguinte são mostrados os sistemas operacionais de Linux. Logicamente, eu escolhi Mint. Estou tentando conferir a minha explicação, mas neste momento o sítio da Gastecnologia está indisponível.

Procurei no Synaptic e a versão é a 1.12.8-7. Na anterior tentativa,  também apareceu Flash. Realmente, não sei o que pode estar acontecendo. Até onde eu sei, o Flash era obsoleto e ia desaparecer dos navegadores. Fico surpreso.

O programa oferecido no BB é “diagbb.1.0.64.run”. Ignoro por que o programa da página do BB é diferente do da Gastecnologia.

Surpreendentemente, fiz uma nova tentativa com o Chrome e desta vez deu certo, sem Flash!!

Offline aftavaresjr

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #41 Online: 16 de Maio de 2018, 09:13 »
Encontrei um tutorial do archlinux, na pagina - https://aur.archlinux.org/packages/warsaw/ - que funcionou perfeitamente no ubuntu 18.04, com as devidas adaptações.

Repassando a sequencia que usei:

1 - Instale o navegador Chrome, pois o warsaw não injeta o certificado na versão 58 ou superior do Firefox

2 - instale pacote libnss3-tools
sudo apt install libnss3-tools

3-  instale o warsaw com  o dpkg.   vai ocorrer o mesmo erro que consta no link https://imgur.com/XVtdRjZ da mensagem 1

4- veja se o warsaw/core está rodando como usuario
ps -ef |grep warsaw
 
5 -Abrir o navegador chrome e no endereço:  chrome://settings/certificates  acessar a aba autoridades e verificar a existência do certificado  "Warsaw Personal CA" .  Se não encontrou - Sudo apt purge warsaw  - e  instale novamente o warsaw. verifique e instale quantas vezes for necessário.

6 - abrir o terminal  e como Root rodar os comandos:

A - Acessando a pasta
# cd /usr/local/lib/warsaw

B. Substituindo os arquivos por links
# rm ld-linux-x86-64.so.2 && ln -s /lib/x86_64-linux-gnu/ld-linux-x86-64.so.2
# rm libc.so.6 && ln -s /lib/x86_64-linux-gnu/libc.so.6
# rm libpthread.so.0 && ln -s /lib/x86_64-linux-gnu/libpthread.so.0
# rm libdl.so.2 && ln -s /lib/x86_64-linux-gnu/libdl.so.2

C: Defina o atributo do diretório /usr/local/lib/warsaw como append-only
# chattr +a /usr/local/lib/warsaw   

D: Ative e inicie o serviço do warsaw :
# systemctl enable warsaw
# systemctl start warsaw
# /usr/local/bin/warsaw/core

5: Verifique que os processos relacionados ao warsaw estão rodando corretamente:

# ps  -ef | grep warsaw
Você deve observar no mínimo 1 [...]/warsaw/core rodando como root e pelo menos um [...]/warsaw/core rodando como usuário.

6: reiniciar  o computador

DidBrother

Valeu muito, amigão! Assim que eu baixar a iso e instalar o 18.04 LTS, uso esse tutorial para poder usar minha conta corrente pelo Banco do Brasil! Um fraternal abraço,
Marcopolo!

Ótimo, funcionou perfeitamente aqui para mim! Segui o passo a passo e não tive problemas.
Caros amigos,

Simplificando  ou melhor complicando  a "coisa", digo  warsaw

Está disponível no site da Diebold a versão 1.12.8-7 que apresenta  a vantagem de inserir  o certificado no firefox independentemente da versão e  não  é preciso substituir bibliotecas por links no  ubuntu 18.04.  Nem tudo beira a perfeição.  Entre a lista de dependências está a biblioteca    "python-gpgme" que não está disponível  nos repositórios  oficiais do ubuntu 18.04, embora esteja nos repositórios  das versões 16.04 e 17.10.   O warsaw acima apresentou compatibilidade com o BB,  CEF,  e para o Itaú após reiniciar o computador.  Deixo abaixo o passo  que utilizei na maquina de teste com 18.04.



1. Baixar o Warsaw fornecido pela Diebold, no endereço - https://cloud.gastecnologia.com.br/gas/diagnostico/warsaw-setup-ubuntu_64.deb  - versão 1.12.8-7 -compatível com CEF, BB e Itaú, com os navegadores Chrome, Firefox.

2. Baixar a biblioteca  python-gpgme  no endereço https://www.ubuntuupdates.org/package/core/artful/main/base/python-gpgme

3. Abrir o terminal e remover qualquer versão anteriormente instalada com o comando.
Código: [Selecionar]
sudo apt-get purge warsaw
4. instalar as dependências.

Código: [Selecionar]
sudo apt install libnss3-tools && sudo apt install python-openssl && sudo apt install libcurl3 && sudo apt install zenity
5. Ainda no terminal acessar a pasta onde foi baixada o arquivo  do warsaw e a bibiloteca python-gpgme. Pressupondo que foi na pasta Downloads

Código: [Selecionar]
cd Downloads e logo após
Código: [Selecionar]
sudo dpkg -i python-gpgme_0.3-1.2build2_amd64.deb em seguida manter os navegadores fechados e
Código: [Selecionar]
sudo dpkg -i warsaw-setup-ubuntu_64.deb   e aguardar o termino da instalação.

6. Verificações:
A)  a instalação do warsaw  com o comando;
Código: [Selecionar]
ps -ef |grep -v grep |grep -i warsawVocê deve observar no mínimo 1 [...]/warsaw/core rodando como root e pelo menos um [...]/warsaw/core rodando como usuário. tipo:
root      1103     1  0 13:33 ?        00:00:01 /usr/local/bin/warsaw/core
usuario   2165     1  0 13:33 ?        00:00:01 /usr/local/bin/warsaw/core

B - A presença do certificado " Warsaw Personal CA"  nos navegadores. Firefox  em -   about:preferences#privacy   opção ver certificados ; no  Chrome em - chrome://settings/certificates  acessar a aba autoridades.    Se o certificado não estiver presente,  remova e reinstale o warsaw.

7) para acesso aos bancos:
A) CEF =. Abrir o navegador e acessar a página -     https://internetbanking.caixa.gov.br/sinbc/nb/login/redirecionaDispSeguranca - vai aparecer a mensagem: adicional de segurança instalado incorretamente. Aguarde enquanto configuramos seu computador. encerrado aparece a mensagem: Adicional de Segurança CAIXA instalado. Acesse a sua conta.
B) ITAU = acesse a página do Itau,  insira o numero de agencia e conta - vai aparecer o nome do correntista e na parte inferior a msg guardiao itau instalado. Está configurado o acesso para o banco itau (aqui só funcionou após reiniciar o computador)
C) BB =  acesse a pagina  https://www2.bancobrasil.com.br/aapf/login.jsp e espere configurar o acesso. Quando estiver disponível os campos: agencia, conta e senha Está configurado o acesso para o banco do brasil

DidBrother
Após perder o controle do root em Ubuntu 14.04 seguindo o tutorial do BB, instalei o Linux Mint 18.3 e achei que esta era a opção melhor. Aparentemente, tudo estava dando certo. Reiniciei e conferi que o certificado estava no Firefox. Mas na hora de acessar, após um bom tempo configurando, finalmente apareceu a janeliha, mas dizendo que não tinha instalado o warsaw. Eu verifiquei que o programa estaba rolando [ps -ef |grep -v grep |grep -i warsaw] e na aparentemente tudo estava normal, aparecia a mesma coisa que neste tutorial acima. O Firefox é Quantum 60.0.

Bom dia DidBrother.

Cara se puder ajudar agradeço.

Segui suas dicas e não tive problemas na execução de nenhum comando, nas duas formas de instalação acima que passou, porém o warsaw continua não rodando como root, apenas como usuário.
Teria alguma outra dica pra passar?

Agradeceria.

Vlw abraço
« Última modificação: 16 de Maio de 2018, 09:14 por aftavaresjr »

Offline DidBrother

  • Usuário Ubuntu
  • *
  • Mensagens: 44
  • Avante. sempre em frente
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #42 Online: 16 de Maio de 2018, 10:49 »
Caro aftavaresjr

Vamos tentar.

1 - primeiro precisamos da informação da distro e versão,  navegadores , e qual origem do warsaw (pagina de download).

2 -Não mais recomendo o uso do primeiro tutorial (resposta 3), ele foi substituído pelo da resposta 17.

3 - Se ainda tiver o instalado o 2º tutorial (resposta 25), rode os comandos abaixo e verifique se a instãncia root subiu.
Código: [Selecionar]
sudo systemctl enable warsaw
Código: [Selecionar]
sudo systemctl start warsaw
Código: [Selecionar]
sudo /usr/local/bin/warsaw/core
Código: [Selecionar]
ps -ef |grep -v grep |grep -i warsawcaso positivo basta reiniciar o computador

obs: para remoção completa do warsaw instalado de acordo com o primeiro tutorial(resposta 3) é preciso antes mudar o status de /usr/local/lib/warsaw com o comando.
Código: [Selecionar]
sudo chattr -a /usr/local/lib/warsaw   


Did Brother

Offline aftavaresjr

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #43 Online: 16 de Maio de 2018, 11:05 »
Caro aftavaresjr

Vamos tentar.

1 - primeiro precisamos da informação da distro e versão,  navegadores , e qual origem do warsaw (pagina de download).

2 -Não mais recomendo o uso do primeiro tutorial (resposta 3), ele foi substituído pelo da resposta 17.

3 - Se ainda tiver o instalado o 2º tutorial (resposta 25), rode os comandos abaixo e verifique se a instãncia root subiu.
Código: [Selecionar]
sudo systemctl enable warsaw
Código: [Selecionar]
sudo systemctl start warsaw
Código: [Selecionar]
sudo /usr/local/bin/warsaw/core
Código: [Selecionar]
ps -ef |grep -v grep |grep -i warsawcaso positivo basta reiniciar o computador

obs: para remoção completa do warsaw instalado de acordo com o primeiro tutorial(resposta 3) é preciso antes mudar o status de /usr/local/lib/warsaw com o comando.
Código: [Selecionar]
sudo chattr -a /usr/local/lib/warsaw   


Did Brother

Bom dia,

Vamos lá então.
Minha Distro é a Ubuntu 18.04 64bits.
Navegadores são as atualizações mais recentes, Firefox 60 e Chrome 66.
O Warsaw foi baixado no site da Diebold: https://cloud.gastecnologia.com.br/gas/diagnostico/warsaw-setup-ubuntu_64.deb
Baixei e instalei também a Biblioteca Python-gpgme como pedido.
Primeiramente havia feito os procedimentos da resposta 17 e não deu certo.
Mesma coisa. Todos os comandos ok, mas novamente não rodava como root.

Fiz o procedimento da resposta 25, desinstalei o warsaw e todos os indícios dele e reinstalei seguindo o passo a passo da 25.
Ao finalizar a instalação ele diz que não é possível iniciar o warsaw e diz para tentar iniciá-lo manualmente com "sudo warsaw start".
Fazendo isso ele inicia o warsaw apenas como usuário, e nunca como root.
Reiniciando a máquina logo após o login da a mesma mensagem de erro: "não é possível iniciar o warsaw e diz para tentar iniciá-lo manualmente com "sudo warsaw start".

Outras informações: Certificado Warsaw esta instalado nos Navegadores e alterei o arquivo: /etc/init.d/warsaw e coloquei a variavel: export LC_ALL=C

Alguma idéia do que possa ser?

Vlw pela ajuda.

« Última modificação: 16 de Maio de 2018, 11:09 por aftavaresjr »

Offline Miguel-1501

  • Usuário Ubuntu
  • *
  • Mensagens: 24
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #44 Online: 16 de Maio de 2018, 13:06 »


Após perder o controle do root em Ubuntu 14.04 seguindo o tutorial do BB, instalei o Linux Mint 18.3 e achei que esta era a opção melhor. Aparentemente, tudo estava dando certo. Reiniciei e conferi que o certificado estava no Firefox. Mas na hora de acessar, após um bom tempo configurando, finalmente apareceu a janeliha, mas dizendo que não tinha instalado o warsaw. Eu verifiquei que o programa estaba rolando [ps -ef |grep -v grep |grep -i warsaw] e na aparentemente tudo estava normal, aparecia a mesma coisa que neste tutorial acima. O Firefox é Quantum 60.0.

Caro miguel,

O linux mint 18.3  é uma distribuição  similar ao ubuntu 16.04. Do mesmo modo a  instalação do warsaw segue parâmetros iguais ao do ubuntu 16.04, um pouco diferente do Ubuntu 18.04 .  Se estiveres com o firewall ufw ativado, é necessário modificar o arquivo  /etc/ufw/sysctl.conf como administrador.
Código: [Selecionar]
sudo xxxxx /etc/ufw/sysctl.confsubstituir xxxxx por kedit, gedit, pluma, mousepad, leafpad, etc.(editor de texto)  conforme  sua distribuição. No arquivo localizar a linha contendo o  parametro: -   net/ipv4/tcp_syncookies=0  modificar o  paramentro  para net/ipv4/tcp_syncookies=1.

Reinicie o computador e teste o acesso no navegador

Caso não de certo, sugiro que siga exatamente a sequencia  postada na resposta 14 do tópico  https://ubuntuforum-br.org/index.php?topic=122838.0

DidBrother

Na verdade, é difícil dizer o que faz a diferença. No meu caso, segui o tutorial da resposta 25 de DidBrother. Não consegui acessar, mas conferi que o programa estava rodando como usuário e root. Então desinstalei o warsaw, apliquei a modificação no arquivo de configuração que aparece na citação e reinstalei o programa, baixado da Gastecnologia, escolhendo o do Linux Mint (na verdade, não sei se existe alguma diferença). Reiniciei, abri Chrome e não funcionou. Depois abri Firefox e ai sim deu certo, ativando Flash (aparece uma bolinha azul no cadeado). No dia seguinte, provei de novo com Chrome e funcionou.

Eu não sei se influi a sequência dos navegadores. Em outros tutoriais, ao instalar módulos de diferentes bancos, parece que a ordem é determinante no sucesso da operação. Neste caso, pode ser que a ordem influa, que um navegador ajude a configurar os outros. Então, sugiro provar em todos os navegadores.