Autor Tópico: Impressão em rede Ubuntu 18.04 x Windows (Credenciais)  (Lida 1465 vezes)

Offline PQT

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Impressão em rede Ubuntu 18.04 x Windows (Credenciais)
« Online: 19 de Setembro de 2018, 09:21 »
Bom dia!
Estou com o seguinte problema:
Tenho um micro com Windows 7 x64 com uma impressora instalada e compartilhada.
Configurei a impressora no Ubuntu 18.04, mas acontece que quando envio uma impressão, o Ubuntu fica pedindo autenticação, mesmo colocando um usuário e senha, ele volta a pedir autenticação.
Alguém pode me ajudar?
Já cheguei até reinstalar o Ubuntu, mas acho que não é o caso. Também tentei comentar a linha de autenticação nas configurações do printers.conf, mas também não deu certo.
Obrigado!

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.273
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Impressão em rede Ubuntu 18.04 x Windows (Credenciais)
« Resposta #1 Online: 19 de Setembro de 2018, 12:47 »
Você consegue visualizar os compartilhamentos da máquina Windows 7, com o comando "smbclient -L <maquina Windows>"? (Talvez seja preciso instalar o pacote smbclient para esse comando ficar disponível)
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline PQT

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re:Impressão em rede Ubuntu 18.04 x Windows (Credenciais)
« Resposta #2 Online: 24 de Setembro de 2018, 07:58 »
Bom dia zekkerj!
Cara, qdo executo o comando que vc me passou, pelo nome host dá isso:

smbclient -L Informatica2
WARNING: The "syslog" option is deprecated
Connection to Informatica2 failed (Error NT_STATUS_UNSUCCESSFUL)

Já executando o mesmo comando pelo ip, aparece isso:

smbclient -L 172.30.25.46
WARNING: The "syslog" option is deprecated
Enter INFORMATICA\ivan's password:

   Sharename       Type      Comment
   ---------       ----      -------
   ADMIN$          Disk      Administração remota
   C$              Disk      Recurso compartilhado padrão
   HP LaserJet Professional P1102w Printer   HP LaserJet Professional P1102w
   IPC$            IPC       IPC remoto
   print$          Disk      Drivers de impressora
   Q$              Disk      Recurso compartilhado padrão
Reconnecting with SMB1 for workgroup listing.
Connection to 172.30.25.46 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
Failed to connect with SMB1 -- no workgroup available

Você consegue visualizar os compartilhamentos da máquina Windows 7, com o comando "smbclient -L <maquina Windows>"? (Talvez seja preciso instalar o pacote smbclient para esse comando ficar disponível)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.273
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Impressão em rede Ubuntu 18.04 x Windows (Credenciais)
« Resposta #3 Online: 24 de Setembro de 2018, 17:59 »
Faz um teste por favor. Adicione a linha abaixo à seção "[global]" do seu "smb.conf", reinicie o Samba, depois teste novamente.

Código: [Selecionar]
client max protocol = SMB3
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline PQT

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re:Impressão em rede Ubuntu 18.04 x Windows (Credenciais)
« Resposta #4 Online: 26 de Setembro de 2018, 07:30 »
Mesma coisa zekkerj... :-\
Mesmo adicionando a linha na secão "[global]", ainda continua pedindo autenticação.
Sempre que instalo a impressora via rede, também não consigo configura-la pelo nome host, só pelo número do ip da máquina em que a impressora está instalada.

Faz um teste por favor. Adicione a linha abaixo à seção "[global]" do seu "smb.conf", reinicie o Samba, depois teste novamente.

Código: [Selecionar]
client max protocol = SMB3