Autor Tópico: Qbittorrent não abre  (Lida 1344 vezes)

Offline polidori

  • Usuário Ubuntu
  • *
  • Mensagens: 183
    • Ver perfil
Qbittorrent não abre
« Online: 23 de Novembro de 2018, 23:17 »
Olá pessoal!
Estou com um problema aqui: toda vez que tento abrir o QbitTorrent pelo terminal aparece este erro "qbittorrent: error while loading shared libraries: libQt5Gui.so.5: cannot open shared object file: No such file or directory"
Já procurei algumas soluções e tentei algumas como reinstalar, remover e instalar de novo, instalar o libqT e nada funcionou até agora.
Agradeço qualquer ajuda.
ASUS Intel I7
Ubuntu 18.04.1 LTS 64bits

Offline Anderson_Coelho

  • Usuário Ubuntu
  • *
  • Mensagens: 561
    • Ver perfil
Re:Qbittorrent não abre
« Resposta #1 Online: 24 de Novembro de 2018, 11:17 »
Qual versão do Ubuntu vc está usando? Como instalou o qBittorrent?

Alguns comandos que podem ajudar:

Código: [Selecionar]
sudo apt install -f
Código: [Selecionar]
sudo apt-get install libqt5gui5
Em caso do problema persistir, retorne a saída dos comandos aqui no fórum.

Offline polidori

  • Usuário Ubuntu
  • *
  • Mensagens: 183
    • Ver perfil
Re:Qbittorrent não abre
« Resposta #2 Online: 29 de Novembro de 2018, 20:03 »
Olá Anderson!
Eu tentei pela própria central de programas do Ubuntu e como não tive sucesso tentei também baixando no site do QbitTorrent. Das duas formas não deu certo.
O terminal me dá a seguinte resposta:
libqt5gui5 is already the newest version (5.9.5+dfsg-0ubuntu1).
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 4 não atualizados.
A minha versão é a 18.04 LTS
ASUS Intel I7
Ubuntu 18.04.1 LTS 64bits

Offline polidori

  • Usuário Ubuntu
  • *
  • Mensagens: 183
    • Ver perfil
Re:Qbittorrent não abre
« Resposta #3 Online: 29 de Novembro de 2018, 20:04 »
A impressão que tenho é de que o programa não está achando esta livraria. Isto porque parece já estar instalada, pela resposta do comando.
ASUS Intel I7
Ubuntu 18.04.1 LTS 64bits

Offline Anderson_Coelho

  • Usuário Ubuntu
  • *
  • Mensagens: 561
    • Ver perfil
Re:Qbittorrent não abre
« Resposta #4 Online: 30 de Novembro de 2018, 15:23 »
Quando vc diz que instalou baixando pelo site do programa, seria por PPA, certo? Tem a PPA stable e unstable, então qual versão do Qbittorrent vc tem aí agora? Ou é a versão do repositório mesmo?

Este comando retorna alguma coisa?

Código: [Selecionar]
ls /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
Já tentou reinstalar essa lib?

Código: [Selecionar]
sudo apt purge libqt5gui5 && sudo apt install libqt5gui5

O que mais eu imagino é que você possa ter mexido com LD_LIBRARY_PATH para essa lib, o que faz o programa não localizá-la.

Offline polidori

  • Usuário Ubuntu
  • *
  • Mensagens: 183
    • Ver perfil
Re:Qbittorrent não abre
« Resposta #5 Online: 19 de Dezembro de 2018, 22:11 »
O primeiro comando me dá esta resposta:
~$ ls /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5 ls: não foi possível acessar '/usr/lib/x86_64-linux-gnu/libQt5Gui.so.5': Arquivo ou diretório inexistente
O que corrobora com a sua teoria. Agora tentei rodar o segundo comando e o ícone do qbittorrent sumiu do menu.
Eu já tentei instalar pelo ppa as duas versões, estável e instável. E também pelo site do programa, via .deb, sem sucesso de maneira nenhuma. Acredito que realmente tenha a ver com achar a livraria correta. Talvez por eu ter mudado para o gnome classic, isto faz sentido?
Vou tentar instalar de novo após este segundo comando, ou achar o iniciador dele de alguma forma.

Edit> desculpe-me pela demora para responder, mas estou numa correria danada, casei-me há pouco hehehe
« Última modificação: 19 de Dezembro de 2018, 22:12 por polidori »
ASUS Intel I7
Ubuntu 18.04.1 LTS 64bits

Offline polidori

  • Usuário Ubuntu
  • *
  • Mensagens: 183
    • Ver perfil
Re:Qbittorrent não abre
« Resposta #6 Online: 19 de Dezembro de 2018, 22:26 »
O segundo comando parece ter desinstalado o programa. Instalei novamente pela central de programas e continua sem abrir. Tentei abrir uma sessão do Ubuntu normal e nada, Ubuntu com Wayland, que nem sei o que é, e nada também.
Estou usando o mitorrent, que parece rodar pelo wine e não tem mecanismo de busca embutido. O Qbittorrent é o melhor gerenciador de torrent que conheço. Se possível, gostaria de continuar usando o programa.
Agradeço pela atenção até então dispensada.
ASUS Intel I7
Ubuntu 18.04.1 LTS 64bits

Offline Anderson_Coelho

  • Usuário Ubuntu
  • *
  • Mensagens: 561
    • Ver perfil
Re:Qbittorrent não abre
« Resposta #7 Online: 20 de Dezembro de 2018, 15:26 »
Muito estranho. Talvez vc tenha colocado algum PPA que alterou o que não devia. Em relação ao Gnome Classic, não vejo sentido em alguma relação com o problema, até pq o erro que vc colocou aqui no fórum diz claramente que o problema é o arquivo /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5 (o seu Ubuntu é 64 bits msm né?) que não foi encontrado. E pelo visto, nem reinstalando essa lib vai para o local correto.

Retorne a saída dos comandos aqui para gnt ver quais repositórios vc tem ativos aí:

Código: [Selecionar]
ls /etc/apt/sources.list.d/
Código: [Selecionar]
cat /etc/apt/sources.list
Outro problema é que pode faltar mais lib's no seu sistema. Então para ficar mais claro, poste aqui as saídas:

Código: [Selecionar]
dpkg --get-selections | grep -i libqt5*
Código: [Selecionar]
ls /usr/lib/x86_64-linux-gnu/libQt5*
Por fim, vamos tentar achar essa lib:

Código: [Selecionar]
find /usr/ -name libQt5Gui.so.5
E realmente, ao desinstalar a libqt5gui5 leva junto o Qbittorrent. Não me atentei para isso, mas lembre-se que a saída do apt mostra quais pacotes estão sendo removidos, então é sempre bom dar uma lida  para evitar surpresas ;D

Offline Jose Emilio

  • Usuário Ubuntu
  • *
  • Mensagens: 244
  • Além da Imaginação
    • Ver perfil
Re:Qbittorrent não abre
« Resposta #8 Online: 22 de Dezembro de 2018, 10:26 »
 Não sei se isso ajuda,  mas aqui o Qbittorrent funciona normal e instalei pela central de programas sem complicações


Uso PC normal

com  Ubuntu 16.04.5 LTS   -  Mate 1.12.1


Offline polidori

  • Usuário Ubuntu
  • *
  • Mensagens: 183
    • Ver perfil
Re:Qbittorrent não abre
« Resposta #9 Online: 09 de Janeiro de 2019, 22:42 »
Obrigado pela atenção. Segue abaixo as respostas aos comandos:
Resposta ao ls /etc/apt/sources.list.d/

google-chrome.list
google-chrome.list.save
qbittorrent-team-ubuntu-qbittorrent-stable-bionic.list
qbittorrent-team-ubuntu-qbittorrent-stable-bionic.list.save
qbittorrent-team-ubuntu-qbittorrent-unstable-bionic.list
qbittorrent-team-ubuntu-qbittorrent-unstable-bionic.list.save

Resposta ao cat /etc/apt/sources.list

# deb cdrom:[Ubuntu 18.04.1 LTS _Bionic Beaver_ - Release amd64 (20180725)]/ bionic main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://br.archive.ubuntu.com/ubuntu/ bionic main restricted
# deb-src http://br.archive.ubuntu.com/ubuntu/ bionic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://br.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
# deb-src http://br.archive.ubuntu.com/ubuntu/ bionic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://br.archive.ubuntu.com/ubuntu/ bionic universe
# deb-src http://br.archive.ubuntu.com/ubuntu/ bionic universe
deb http://br.archive.ubuntu.com/ubuntu/ bionic-updates universe
# deb-src http://br.archive.ubuntu.com/ubuntu/ bionic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://br.archive.ubuntu.com/ubuntu/ bionic multiverse
# deb-src http://br.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://br.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
# deb-src http://br.archive.ubuntu.com/ubuntu/ bionic-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://br.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
# deb-src http://br.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu bionic partner
# deb-src http://archive.canonical.com/ubuntu bionic partner

deb http://security.ubuntu.com/ubuntu bionic-security main restricted
# deb-src http://security.ubuntu.com/ubuntu bionic-security main restricted
deb http://security.ubuntu.com/ubuntu bionic-security universe
# deb-src http://security.ubuntu.com/ubuntu bionic-security universe
deb http://security.ubuntu.com/ubuntu bionic-security multiverse
# deb-src http://security.ubuntu.com/ubuntu bionic-security multiverse

Resposta ao dpkg --get-selections | grep -i libqt5*

libqt5core5a:amd64            install
libqt5dbus5:amd64            install
libqt5gui5:amd64            install
libqt5network5:amd64            install
libqt5qml5:amd64            install
libqt5svg5:amd64            install
libqt5widgets5:amd64            install
libqt5xml5:amd64            install

Resposta ao ls /usr/lib/x86_64-linux-gnu/libQt5*


/usr/lib/x86_64-linux-gnu/libQt5EglFSDeviceIntegration.so.5
/usr/lib/x86_64-linux-gnu/libQt5EglFSDeviceIntegration.so.5.9
/usr/lib/x86_64-linux-gnu/libQt5EglFSDeviceIntegration.so.5.9.5
/usr/lib/x86_64-linux-gnu/libQt5EglFsKmsSupport.so.5
/usr/lib/x86_64-linux-gnu/libQt5EglFsKmsSupport.so.5.9
/usr/lib/x86_64-linux-gnu/libQt5EglFsKmsSupport.so.5.9.5
/usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
/usr/lib/x86_64-linux-gnu/libQt5Gui.so.5.9
/usr/lib/x86_64-linux-gnu/libQt5Gui.so.5.9.5
/usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
/usr/lib/x86_64-linux-gnu/libQt5Qml.so.5.9
/usr/lib/x86_64-linux-gnu/libQt5Qml.so.5.9.5
/usr/lib/x86_64-linux-gnu/libQt5Svg.so.5
/usr/lib/x86_64-linux-gnu/libQt5Svg.so.5.9
/usr/lib/x86_64-linux-gnu/libQt5Svg.so.5.9.5
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5.9
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5.9.5
/usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
/usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5.9
/usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5.9.5
/usr/lib/x86_64-linux-gnu/libQt5Xml.so.5
/usr/lib/x86_64-linux-gnu/libQt5Xml.so.5.9
/usr/lib/x86_64-linux-gnu/libQt5Xml.so.5.9.5

E finalmente o arquivo parece estar aqui:
/usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
ASUS Intel I7
Ubuntu 18.04.1 LTS 64bits

Offline Anderson_Coelho

  • Usuário Ubuntu
  • *
  • Mensagens: 561
    • Ver perfil
Re:Qbittorrent não abre
« Resposta #10 Online: 10 de Janeiro de 2019, 18:14 »
A libQt5Gui agora está no local correto. Se não abrir o Qbittorrent deve ser outro problema.

Confirma se a mensagem de erro do seu primeiro post continua?

Persistindo o problema, é válido tentar usar o programa do repositório oficial porque com a lib no lugar, agora deve funcionar. Para isso remova o Qbittorrent e as PPA's e depois reinstale-o. Se for tentar:

Código: [Selecionar]
sudo apt purge qbittorent
sudo apt autoremove

Código: [Selecionar]
sudo add-apt-repository -r ppa:qbittorrent-team/qbittorrent-stable
Código: [Selecionar]
sudo add-apt-repository -r ppa:qbittorrent-team/qbittorrent-unstable
Código: [Selecionar]
sudo apt update
sudo apt install qbittorrent

Offline polidori

  • Usuário Ubuntu
  • *
  • Mensagens: 183
    • Ver perfil
Re:Qbittorrent não abre
« Resposta #11 Online: 15 de Janeiro de 2019, 12:06 »
É um mistério, eu uso Ubuntu desde o 9.04, nunca tive este problema.
Agora com o último comando que manda instalar ele avisa que o qbittorrent "is already the newest version".
E quando tento abrir continua dando o mesmo erro "qbittorrent: error while loading shared libraries: libQt5DBus.so.5: cannot open shared object file: No such file or directory"
Muito estranho!

EDITADO - Reparou que não é exatamente o mesmo erro?  Antes não carregava libQt5Gui.so.5 e agora é o DBus...
E aquele LD library path eu não entendo, não sei o que é e se mexi foi sem querer hehehe
« Última modificação: 15 de Janeiro de 2019, 12:44 por polidori »
ASUS Intel I7
Ubuntu 18.04.1 LTS 64bits

Offline Anderson_Coelho

  • Usuário Ubuntu
  • *
  • Mensagens: 561
    • Ver perfil
Re:Qbittorrent não abre
« Resposta #12 Online: 15 de Janeiro de 2019, 16:14 »
Tenta isso:

Código: [Selecionar]
sudo apt install --reinstall libqt5core5a libqt5dbus5
Coloquei para reinstalar o libqt5core5a também pq analisando com mais calma as saídas dos comando q vc postou, percebi que essa lib também não está instalada corretamente.

Percebe o que está acontecendo? A libqt5gui foi só desinstalar com o "apt purge" e reinstalar e voltou para o lugar correto, só que levou o qbittorrent. O "apt install --reinstall" vai evitar que mais coisa seja desinstalada, mas se não resolver, vc terá que usar o "purge" reinstalar tudo que o apt desinstalar (mas isso não é difícil pq o próprio apt vai te informar isso, se bem que acho que bastaria reinstalar só o qbittorrent pq o resto deveria vir junto como dependência).

Offline polidori

  • Usuário Ubuntu
  • *
  • Mensagens: 183
    • Ver perfil
Re:Qbittorrent não abre
« Resposta #13 Online: 15 de MAR?O de 2019, 20:39 »
Fiz uma nova instalação do Ubuntu e está funcionando. Estava acontecendo o mesmo com alguns outros programas, então não tive outra opção.
ASUS Intel I7
Ubuntu 18.04.1 LTS 64bits