Autor Tópico: Erro conexão com a database xampp ubuntu 14.04  (Lida 382 vezes)

Offline viniciusbig

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Erro conexão com a database xampp ubuntu 14.04
« Online: 25 de Janeiro de 2019, 05:58 »
Tô com um problema quando vou inciar o servidor, ele não conecta com a data base, o apache funciona direitinho, mas quando vou ligar o servidor ele não tá indo, eu tô usando o xampp pq o php dele é compatível com o site que estou utilizando e tal...
Código: [Selecionar]
[5:35:38.396] >> Starting SQL connection
[5:35:38.398] Failed connecting to database - MYSQL ERROR: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) (2002)

[5:35:38.399] > ERROR: Couldn't estabilish connection to SQL database!


Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.060
    • Ver perfil
    • Alexsandro Felix
Re:Erro conexão com a database xampp ubuntu 14.04
« Resposta #1 Online: 25 de Janeiro de 2019, 12:56 »
É necessário averiguar melhor os logs de erro para saber exatamente qual o problema. Você consegue se conectar manualmente a esta base de dados? Usuário e senha estão corretos?

Offline viniciusbig

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Erro conexão com a database xampp ubuntu 14.04
« Resposta #2 Online: 25 de Janeiro de 2019, 15:31 »
Código: [Selecionar]
root@animeinfinityonline:/Otservanime# ./theforgotten
[15:29:46.642] The Forgotten Server 0.4

[15:29:46.642] >> Loading config (config.lua)
[15:29:46.647] >> Opening logs
[15:29:46.657] > Using SHA1 encryption
[15:29:46.657] >> Loading RSA key
[15:29:46.687] >> Starting SQL connection
[15:29:46.758] Failed connecting to database - MYSQL ERROR: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) (2002)

[15:29:46.759] > ERROR: Couldn't estabilish connection to SQL database!
eu consigo me conectar ao banco de dados, eu não coloquei senha por enquanto

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.060
    • Ver perfil
    • Alexsandro Felix
Re:Erro conexão com a database xampp ubuntu 14.04
« Resposta #3 Online: 25 de Janeiro de 2019, 16:20 »
Código: [Selecionar]
root@animeinfinityonline:/Otservanime# ./theforgotten
[15:29:46.642] The Forgotten Server 0.4

[15:29:46.642] >> Loading config (config.lua)
[15:29:46.647] >> Opening logs
[15:29:46.657] > Using SHA1 encryption
[15:29:46.657] >> Loading RSA key
[15:29:46.687] >> Starting SQL connection
[15:29:46.758] Failed connecting to database - MYSQL ERROR: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) (2002)

[15:29:46.759] > ERROR: Couldn't estabilish connection to SQL database!
eu consigo me conectar ao banco de dados, eu não coloquei senha por enquanto

por questões de segurança, configure uma senha então, daí tente novamente.

Offline viniciusbig

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Erro conexão com a database xampp ubuntu 14.04
« Resposta #4 Online: 26 de Janeiro de 2019, 14:36 »
Eu não consigo usar o site quando eu coloco a senha :s, eu uso sudo /opt/lampp/lampp security preencho todas as senhas, coloco a mesma senha que eu coloquei no config.php do site:
Código: [Selecionar]
/*Database information*/
$config['database']['host'] = "127.0.0.1";
$config['database']['login'] = "root";
$config['database']['password'] = "123456a";
$config['database']['database'] = "anime";
e o site não conecta na data base
Código: [Selecionar]
A Database Error Occurred
Unable to connect to your database server using the provided settings.
Código: [Selecionar]
root@animeinfinityonline:/# sudo /opt/lampp/lampp security
XAMPP:  Quick security check...
XAMPP:  MySQL is not accessable via network. Good.
XAMPP:  The MySQL/phpMyAdmin user pma has a passwort set. Fine! :)
XAMPP:  MySQL has no root passwort set!!!
XAMPP: Do you want to set a password? [yes] yes
XAMPP:  Write the password somewhere down to make sure you won't forget it!!!
XAMPP: Password:
XAMPP: Password (again):
XAMPP:  Setting new MySQL root password.
XAMPP:  Change phpMyAdmin's authentication method.
XAMPP:  The FTP password for user 'daemon' is still set to 'xampp'.
XAMPP: Do you want to change the password? [yes] yes
XAMPP: Password:
XAMPP: Password (again):
XAMPP:  Passwords doen't match. Please try again.
XAMPP: Password:
XAMPP: Password (again):
XAMPP: Reload ProFTPD...ok.
XAMPP:  Done.
« Última modificação: 26 de Janeiro de 2019, 14:38 por viniciusbig »