Autor Tópico: Erro no Livepatch  (Lida 629 vezes)

Offline maurov

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
Erro no Livepatch
« Online: 13 de Junho de 2019, 10:00 »
E:Repository 'http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease' changed its 'Label' value from 'Oracle Java (JDK) 8 Installer PPA' to 'Oracle

Parece que este repositorio não existe mais. Removo-o? Como?

Offline edjen

  • Usuário Ubuntu
  • *
  • Mensagens: 183
  • Toda mudança gera resistência.
    • Ver perfil
Re:Erro no Livepatch
« Resposta #1 Online: 14 de Junho de 2019, 13:55 »
O ppa não funciona mais.

A Oracle mudou suas licensas

https://www.oracle.com/technetwork/java/javase/overview/oracle-jdk-faqs.html

A Oracle requer uma conta de usuário para baixar atualizações do Java.

Este PPA não funciona mais.

Para removê-lo:

cd /etc/apt/sources.list.d
rm webupd8team-java-bionic.list

Este comando remove apenas o PPA,    "não remove o JAVA".
GNULinux = Asus P5K-E = Intel Q9450 = Quadro 400 = 3 Hd 80Gb Samsung + Hd 500Gb Seagate = 8Gb RAM DDR2 OCZ 1066 mhz

Offline maurov

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
Re:Erro no Livepatch
« Resposta #2 Online: 17 de Junho de 2019, 13:48 »
Li a declaração da Oracle, mas são vários nomes e ficou confuso para mim. Peço ajuda.

Para usar como usuário final, sem ser o JDK, não preciso de assinatura, ao que parece. Pergunto:
Faço download de qual versão
Como desinstalo a atual
E , como instalo a nova?
tks

Offline maurov

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
Re:Erro no Livepatch
« Resposta #3 Online: 18 de Junho de 2019, 13:54 »
Sobre remover a PPA, agradeço a informação. Parece que é só remover o arquivo da pasta /etc/apt/sources.list.d
No meu caso não é
webupd8team-ubuntu-java-bionic.list
mas
webupd8team-java-bionic.list
Removi.

Agora tenho um java que vai ficar desatualizado, já que aquela ppa da webupd8team foi descontinuada. Para continuar usando o java da Oracle (não sou desenvolvedor), qual a melhor opção?

Offline DidBrother

  • Usuário Ubuntu
  • *
  • Mensagens: 54
  • Avante. sempre em frente
    • Ver perfil
Re:Erro no Livepatch
« Resposta #4 Online: 18 de Junho de 2019, 19:27 »
Sobre remover a PPA, agradeço a informação. Parece que é só remover o arquivo da pasta /etc/apt/sources.list.d
No meu caso não é
webupd8team-ubuntu-java-bionic.list
mas
webupd8team-java-bionic.list
Removi.

Agora tenho um java que vai ficar desatualizado, já que aquela ppa da webupd8team foi descontinuada. Para continuar usando o java da Oracle (não sou desenvolvedor), qual a melhor opção?

Boa noite.

Consegui atualizar o meu java, através da dica contida no site  https://linuxdicasesuporte.blogspot.com/2019/05/java-da-oracle-para-debian-ubuntu-e.html  .

O java baixei de https://www.java.com/pt_BR/download/linux_manual.jsp .  Não foi  necessário  qualquer conta na oracle para baixar.  Acredito que  uso de conta  somente para baixar a versão JDK.

Desvantagem:   Foi necessário refazer os  atalhos de inicialização de programas  que usam o java.  Talvez ocorra o mesmo na proxima atualização.
Did Brother 


Offline maurov

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
Re:Erro no Livepatch
« Resposta #5 Online: 19 de Junho de 2019, 09:36 »
Olá
Como não sei qual a versão de Java tenho instalada. Procurei no "do I have java" e a página da Oracle informa
Código: [Selecionar]
We are unable to verify if Java is currently installed and enabled in your browser.
Pelo terminal,
Código: [Selecionar]
~$ java -version
java version "1.8.0_201"
Java(TM) SE Runtime Environment (build 1.8.0_201-b09)
Java HotSpot(TM) 64-Bit Server VM (build 25.201-b09, mixed mode)

Agora não sei se tem alguma errado na interface java x browser.

Bom, fiz o download da opção Linux x64

Tenho dúvidas da pasta onde deve ser feito o upgrade, Na minha máquina existe a pastao
/usr/lib/jvm/java-8-oracle
mas não sei se é esta a indicada.

Outra coisa
removi aquele arquivo webupd8 na pasta list.d, mas o livepatch continua dando a mensagem de erro:
Código: [Selecionar]
Canonical Livepatch has experienced an internal error. Please refer to https://wiki.ubuntu.com/Kernel/Livepatch#CommonIssues for further information.

Offline DidBrother

  • Usuário Ubuntu
  • *
  • Mensagens: 54
  • Avante. sempre em frente
    • Ver perfil
Re:Erro no Livepatch
« Resposta #6 Online: 19 de Junho de 2019, 21:03 »
Olá
Como não sei qual a versão de Java tenho instalada. Procurei no "do I have java" e a página da Oracle informa
Código: [Selecionar]
We are unable to verify if Java is currently installed and enabled in your browser.
Pelo terminal,
Código: [Selecionar]
~$ java -version
java version "1.8.0_201"
Java(TM) SE Runtime Environment (build 1.8.0_201-b09)
Java HotSpot(TM) 64-Bit Server VM (build 25.201-b09, mixed mode)

Agora não sei se tem alguma errado na interface java x browser.

Bom, fiz o download da opção Linux x64

Tenho dúvidas da pasta onde deve ser feito o upgrade, Na minha máquina existe a pastao
/usr/lib/jvm/java-8-oracle
mas não sei se é esta a indicada.

Outra coisa
removi aquele arquivo webupd8 na pasta list.d, mas o livepatch continua dando a mensagem de erro:
Código: [Selecionar]
Canonical Livepatch has experienced an internal error. Please refer to https://wiki.ubuntu.com/Kernel/Livepatch#CommonIssues for further information.

Boa noite,

pela informação do terminal,  sua versão é o java 8 versão 201 .  A versão atualizada do Java 8 é a 211.   

sobre o Livepatch como não uso não tenho ideia. 

O primeiro procedimento que realizei  foi a desinstalação do java anterior, realizada através do gerenciador synaptic.  Neste processo  foi eliminado a pasta /usr/lib/jvm/java-8-oracle.   Quando instalei o pacote dpkg criado  seguindo o tutorial , o java foi instalado na pasta /usr/lib/jvm/oracle-java8-jre-amd64. Por esta razão motivando  a troca dos atalhos de programas.


DidBrother