Autor Tópico: Grub não reconhece windows 10  (Lida 485 vezes)

Offline flavioml

  • Usuário Ubuntu
  • *
  • Mensagens: 104
    • Ver perfil
Grub não reconhece windows 10
« Online: 08 de Outubro de 2019, 16:46 »
Atualizei por estes dias o meu velho desktop, baseado em um i3 de 2ª geração substituindo os respectivos componentes por um ryzen 3200g, memória ddr4 e mobo asrock A320M-HD. Há pouco mais de um mês havia acrescido ao sistema um SSD Kingston A400, para onde clonei o kubuntu 19.04, que até então ocupava uma partição do HD de 1 tera.
Como todo o sistema original havia sido instalado em modo "legacy", sem UEFI, para que as instalações antigas fossem reconhecidas, habilitei o legacy (CSM) na nova mobo e tudo funcionou perfeitamente, a não ser o fato de o windows 10 passou a acusar o sistema de não original.
Para resolver o problema, formatei a partição ntfs e fiz uma instalação limpa do w10. Isso resolveu a questão daquele sistema mas o grub deixou de reconhecê-lo.
Por outro lado, habilitando-se o UEFI na BIOS o ssd do kubuntu some do menu de boot. Fiz as seguintes tentativas para tentar normalizar as coisas:
1 - habilitei o UEFI e acessei o kubuntu via pendrive de instalação, em modo chroot e reinstalei o grub. Nada mudou!
2 - baixei o Ubuntu Mate e instalei (modo legacy) na antiga partição do kubuntu, em sda5 e o grub do Mate também não reconheceu o windows;
3 - clonei do meu notebook, onde tenho w10 pré-instalado e o kubuntu, a entrada de menu gerada pelo os_prober, adaptando as partições, para o 40_custon do kubuntu instalado no ssd e passei a obter o erro de assinatura inválida ao escolher no menu do grub o "Windows Boot Manager";
Finalmente, tentei a instalação do Manjaro, em modo UEFI, em sda5, e funcionou, com a instalação do grub em sda e o os_prober provendo a entrada de menu para o windows, bastante semelhante à que eu havia tentado manualmente no kubuntu.
A questão que se propõe é como habilitar o boot pelo ssd, sem ter que reinstalar o kubuntu do zero, de modo a tornar esse mesmo boot extremamente mais rápido?
Flavio ML

Offline couscous21

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re:Grub não reconhece windows 10
« Resposta #1 Online: 14 de Outubro de 2019, 01:20 »
mesmo problema

Offline flavioml

  • Usuário Ubuntu
  • *
  • Mensagens: 104
    • Ver perfil
Re:Grub não reconhece windows 10
« Resposta #2 Online: 18 de Outubro de 2019, 14:21 »
Com a iminência do lançamento da versão 19.10 da família Ubuntu, resolvi aguardar e hoje, finalmente, fiz a reinstalação do Kubuntu no ssd e como esperava, sendo a instalação feita em modo UEFI, tudo correu normal e pude setar na BIOS o ssd como boot preferencial, acessando todos os sistemas e não mais dependendo do boot do Manjaro.
Eu imagino que o problema do couscous21 deve resultar, também, da mistura de instalações UEFI e Legacy.
Flavio ML