Autor Tópico: Modem Smartlink no Edgy  (Lida 7812 vezes)

Offline raci0nal

  • Usuário Ubuntu
  • *
  • Mensagens: 15
  • Marcos Jordão''
    • Ver perfil
Modem Smartlink no Edgy
« Online: 29 de Outubro de 2006, 03:16 »
Para quem seja sofredor como eu na internet discada...

Mudei do Dapper para o Edgy e fui à luta de tentar instalar meu modem (LG LM-I56N).
Segui o procedimento normal que seria instalar o module-assistant, o sl-modem-source, rodar m-a a-i slmodem e por fim instalar o sl-modem-daemon.
Fiz tudo certinho e não deu certo, apresentava erro (o qual o module-assistant não descrevia). Fui até a pasta onde é descompactado o sl-modem-source (/usr/src/modules/sl-modem) e tentei dar um make de lá, mas também apresentou erro.
Baixe um pacote (slmodem-2.9.11-20051101.tar.gz) na internet (do meu antigo dapper na outra partição) e ao dar o make também apresentava erro.
Revirei os fóruns e não encontrei nada. Por fim acabei conseguindo com um outro pacote que encontrei.

Bom, se você não quer saber e não tá nem aí pra minha ladainha, vou detalhar o procedimento para compilar o driver SmartLink no Edgy Eft.

- Baixe por outro SO os arquivos:
    http://linmodems.technion.ac.il/packages/smartlink/slmodem-2.9.11-20060727.tar.gz (esse dá certo)
    http://ubuntu.c3sl.ufpr.br/ubuntu/pool/multiverse/s/sl-modem/sl-modem-daemon_2.9.10+2.9.9d+e-pre2-5build1_i386.deb

-Instale o pacote build-essential que é necessário para compilação do driver.
    Insira o CD do Ubuntu, quando aparecer a janela que detectou um CD do Ubuntu, escolha para "Abrir o Gerenciador de Pacotes".
    Vá em Procurar e localize o build-essential, marcando para instalação e aplicando.

- Agora vá até a pasta onde colocou o arquivo: slmodem-2.9.11-20060727.tar.gz
- Clique com o botão direito nele e escolha "Extrair aqui"
- Abra um terminal (Aplicações > Acessórios > Terminal)
- Mude para a pasta do pacote descompactado (por exemplo: cd /home/marcos/slmodem-2.9.11-20060727)
- Execute os comandos (informando a senha caso seja solicitada):
Código: [Selecionar]
make
sudo make install

- Volte ao navegador de arquivos e vá até a pasta onde colocou o arquivo: sl-modem-daemon_2.9.10+2.9.9d+e-pre2-5build1_i386.deb
- Dê dois cliques nele, abrirá o Instalador de Pacotes
- Clique em Instalar.

Pronto... seu modem já deve estar funcionando.


Para realizar a conexão você pode usar o GNOME-PPP, que pode ser baixado em: http://ubuntu.c3sl.ufpr.br/ubuntu/pool/universe/g/gnome-ppp/gnome-ppp_0.3.23-1_i386.deb

Configurações de conexão mais detalhadas você pode encontrar no Tutorial do alarcon:
http://ubuntuforum-pt.org/index.php?topic=4204.0


É isso aí... abraços à todos!

Marcos Antonio Campos Jordão''

Offline blabumbr

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: Modem Smartlink no Edgy
« Resposta #1 Online: 31 de Outubro de 2006, 02:32 »
raci0nal,

Deu tudo cesto na instalação, mas na hora de conectar, eleaté conecta mas logo depois cai. Tentei gedit .wvdial.conf como ensina o alarcon e nada.

Se poder me ajudar fico muito grato.

Abraços.

Arthur

alarcon

  • Visitante
Re: Modem Smartlink no Edgy
« Resposta #2 Online: 02 de Novembro de 2006, 09:04 »
raci0nal,

Deu tudo cesto na instalação, mas na hora de conectar, eleaté conecta mas logo depois cai. Tentei gedit .wvdial.conf como ensina o alarcon e nada.

Se poder me ajudar fico muito grato.

Abraços.

Arthur

alguns modems requerem que a opção verificar portadora da configuração do gnome-ppp esteja desmarcada. Para fazer isso abra o gnome-ppp clique em Configurção e depois na aba opções e desmarque a opção verificar portadora e veja se funciona.

Caso ainda continue sem funcionar faça isso também:

Abra um terminal e vire root (sudo su e depois sua senha)

agora faças estes comandos linha por linha:

echo "Username" * "Password">>/etc/ppp/pap-secrets

echo "Username" * "Password">>/etc/ppp/chap-secrets

Logicamente substituindo Username pelo nome de acesso do seu provedor e Password pela sua senha de acesso do provedor.

OBs: lembre-se que no nome de acesso do provedor (na grande maioria das vezes) é necessário digitar o endereço completo (nome@provedor.com.br) e não só o nome.
« Última modificação: 02 de Novembro de 2006, 19:01 por alarcon »

Offline blabumbr

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: Modem Smartlink no Edgy
« Resposta #3 Online: 02 de Novembro de 2006, 18:27 »
alarcon, muito obrigado pela ajuda, mas não sei se entendi certo, veja o que fiz:

Depois de logar como root no terminal, copiei a primeira linha e colei no terminal apenas trocando a palavra Username pelo meu e-mail (nomedousuário@provedor.com.br e, a palavra Password pela minha senha. Depois de apertar Enter não apareceu nada e continuo com o mesmo problema.

Fiz tudo certo?

grato

Arthur


alarcon

  • Visitante
Re: Modem Smartlink no Edgy
« Resposta #4 Online: 02 de Novembro de 2006, 18:59 »
alarcon, muito obrigado pela ajuda, mas não sei se entendi certo, veja o que fiz:

Depois de logar como root no terminal, copiei a primeira linha e colei no terminal apenas trocando a palavra Username pelo meu e-mail (nomedousuário@provedor.com.br e, a palavra Password pela minha senha. Depois de apertar Enter não apareceu nada e continuo com o mesmo problema.

Fiz tudo certo?

grato

Arthur



O comando echo digitado no terminal escreve no final dos arquivos já existentes pap-secrets e chap-secrets que se encontram em /etc/ppp/ a seguinte linha:

"Username" * "Password"

Que por exemplo se:

Nome de acesso do provedor: fulano@provedor.com.br

Senha de acesso do provedor: senha1234

Seria assim:

"fulano@provedor.com.br" * "senha1234"

que ficaria no final dos arquivos pap-secrets e chap-secrets acrescentando ao que já existe por lá.


Como me parece que vc entendeu errado e possívelmente digitou errado, então abra um terminal como root (comando sudo su e sua senha) novamente e digite:

gedit /etc/ppp/pap-secrets

e altera lá a ultima linha deste arquivo para os valores corretos já falados acima (
"fulano@provedor.com.br" * "senha1234" ).

gedit /etc/ppp/chap-secrets

mesma coisa que o anterior.

« Última modificação: 02 de Novembro de 2006, 19:07 por alarcon »

Offline blabumbr

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: Modem Smartlink no Edgy
« Resposta #5 Online: 02 de Novembro de 2006, 23:14 »
alarcon, obrigada mais uma vez!!! ;)

Fiz tudo direito (o nome de usuário e a senha estava realmente errados, mas continua não conectando. :-\.

PS.: No Dapper (6.06) Pelo menos conectava.

Grato

Arthur

Offline raci0nal

  • Usuário Ubuntu
  • *
  • Mensagens: 15
  • Marcos Jordão''
    • Ver perfil
Re: Modem Smartlink no Edgy
« Resposta #6 Online: 03 de Novembro de 2006, 20:05 »
Amigo, realmente esqueci de citar mas também tive este problema de conectar e logo cair quando conectava como usuário.

O problema era realmente os arquivos pap e chap-secrets.

O alarcon já falou como resolver, mas vou escrever denovo os comandos pois acho que você só digitou um dos comandos.

Entre em um terminal copie, cole e execute o primeiro comando substituindo Username e Password por seu usuário e senha:

Código: [Selecionar]
sudo echo '"'Username'" * "'Password'"'>>/etc/ppp/pap-secrets
Depois copie, cole e execute o segundo comando substituindo também:

Código: [Selecionar]
sudo echo '"'Username'" * "'Password'"'>>/etc/ppp/chap-secrets
Tem mais um comando que por via das dúvidas é bom você digitar também:
Substitua as palavras Usuario (veja que ela aparece 3 vezes) pelo seu nome de usuário do sistema. Preste atenção não é o seu nome de usuário do provedor (internet) e sim do sistema (Ubuntu).

Código: [Selecionar]
sudo chown Usuario.Usuario /home/Usuario/.wvdial.conf
Faça os 3 passos corretamente que deve funcionar.

Abraços!

alarcon

  • Visitante
Re: Modem Smartlink no Edgy
« Resposta #7 Online: 04 de Novembro de 2006, 02:07 »
alarcon, obrigada mais uma vez!!! ;)

Fiz tudo direito (o nome de usuário e a senha estava realmente errados, mas continua não conectando. :-\.

PS.: No Dapper (6.06) Pelo menos conectava.

Grato

Arthur

Abra o gnome-ppp clique no botão Configuração e depois na aba Opções e marque a opção Ignorar sequencias de terminal (modo burro) se não tiver marcada e  para alguns modems a opção verificar portadora deve ser desmarcada também, no meu caso com ela marca funcionava perfeitamente.

Na aba Modem veja se em dispositivo esta esta opção: /dev/ttySL0 que é a do modem.

Offline blabumbr

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: Modem Smartlink no Edgy
« Resposta #8 Online: 05 de Novembro de 2006, 02:08 »
Problema resolvido !!!!! ;D

A conecção tá uma beleza!

Obrigado a todos!!! :D

Offline rafaelmr

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: Modem Smartlink no Edgy
« Resposta #9 Online: 16 de Novembro de 2006, 23:45 »
Para o meu modem Smartlink funcionar sempre que eu reiniciar o computador eu tive que adicionar o seguinte ao /etc/rc.local:

mknod -m 600 /dev/slusb0 c 243 0
modprobe slusb
slmodemd -c BRAZIL /dev/slusb0 &


Offline wdi

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: Modem Smartlink no Edgy
« Resposta #10 Online: 26 de Novembro de 2006, 12:12 »
Muito bom seu tópico vou tentar pra se agora vai.
Valeuuuuuuuuuuuuuuuuu.

Offline wdi

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: Modem Smartlink no Edgy
« Resposta #11 Online: 27 de Novembro de 2006, 12:47 »
Kra muito bom seu tópico e resolveu meu problema velu brother e viva o linux