Autor Tópico: Como configurar conexão VPN que utilize IKEv2  (Lida 401 vezes)

Offline erleybru

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Como configurar conexão VPN que utilize IKEv2
« Online: 23 de Outubro de 2020, 11:33 »
Olá.

Eu utilizo Ubuntu 18.04 LTS.

Preciso configurar uma conexão VPN e o servidor utiliza IKEv2. Com o que tenho instalado no meu Linux não foi possível estabelecer a conexão. Pesquisando no Google eu precisaria instalar os pacotes abaixo para configurar isto.
Os pacotes são: strongswan network-manager-strongswan.

 Após tentar o comando: sudo apt-get install strongswan network-manager-strongswan

O sistema retorna o erro: E: Package 'strongswan' has no installation candidate

Executei o comando:  sudo apt-get install network-manager-strongswan
Esperando que o apt completasse as dependências e recebo a seguinte mensagem de erro:

The following packages have unmet dependencies:
 network-manager-strongswan : Depends: libnm-glib-vpn1 (>= 0.7.999) but it is not installable
                              Depends: libnm-gtk0 (>= 1.0.6) but it is not installable
                              Depends: libnm-util2 (>= 0.8.998) but it is not installable
                              Depends: strongswan-nm (>= 5.5.1-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Resumindo não consigui configurar a conexão VPN até o momento, pois parece que o pacote está quebrado ou as informações que encontrei na internet estão incorretas.

Alguem saberia me ajudar com esta configuração / instalação ?

Observação: Os links que utilizei para chegar nestes pacotes a serem instalados foram:
https://www.securevpn.pro/eng/setup/linux-ikev2-vpn?url=eng%2Fsetup%2Flinux-ikev2-vpn
https://hide.me/pt/vpnsetup/ubuntu/ikev2/
https://www.digitalocean.com/community/tutorials/how-to-set-up-an-ikev2-vpn-server-with-strongswan-on-ubuntu-18-04-2-pt
https://www.atlantic.net/vps-hosting/how-to-install-and-configure-strongswan-vpn-on-ubuntu-18-04/
https://www.xpresservers.com/how-to-set-up-an-ikev2-vpn-server-with-strongswan-on-ubuntu-18-04/

Atenciosamente

Erley

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.503
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re:Como configurar conexão VPN que utilize IKEv2
« Resposta #1 Online: 23 de Outubro de 2020, 17:51 »
Olá @erleybru,
Seu Ubuntu está com as fontes de pacotes atualizadas? Testei em minha máquina Ubuntu 18.04LTS e os pacotes estão prontos pra instalação:
Código: [Selecionar]
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.5 LTS
Release:        18.04
Codename:       bionic

$ sudo apt install strongswan network-manager-strongswan
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-4.15.0-112 linux-headers-4.15.0-112-generic linux-image-4.15.0-112-generic linux-modules-4.15.0-112-generic linux-modules-extra-4.15.0-112-generic
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libcharon-standard-plugins libnm-gtk0 libnma0 libstrongswan libstrongswan-standard-plugins strongswan-charon strongswan-libcharon strongswan-nm strongswan-starter
Suggested packages:
  libstrongswan-extra-plugins libcharon-extra-plugins
The following NEW packages will be installed:
  libcharon-standard-plugins libnm-gtk0 libnma0 libstrongswan libstrongswan-standard-plugins network-manager-strongswan strongswan strongswan-charon strongswan-libcharon strongswan-nm strongswan-starter
0 upgraded, 11 newly installed, 0 to remove and 0 not upgraded.
Need to get 1.070 kB of archives.
After this operation, 4.953 kB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.

$ apt policy strongswan network-manager-strongswan
strongswan:
  Installed: (none)
  Candidate: 5.6.2-1ubuntu2.5
  Version table:
     5.6.2-1ubuntu2.5 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages
     5.6.2-1ubuntu2.3 500
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/main i386 Packages
     5.6.2-1ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu bionic/main i386 Packages
network-manager-strongswan:
  Installed: (none)
  Candidate: 1.4.2-2
  Version table:
     1.4.2-2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages

No teste acima eu não cheguei a instalar os pacotes, mas depois instalei sem problemas. Talvez você precise fazer uma atualização em seu sistema. Aliás, considere atualizá-lo todo para o Ubuntu 20.04 LTS.

EDIT: Agora observei uma coisa que vc escreveu:
Citar
E: Unable to correct problems, you have held broken packages.
É certo que você tem outro problema no ambiente de atualização. Talvez uma sequência dos comandos abaixo retire esses erros:

sudo apt update
sudo apt -f install
dpkg --configure -a

« Última modificação: 23 de Outubro de 2020, 17:58 por zekkerj »
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline FaBMak

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 724
    • Ver perfil
    • fabmak://website
Re:Como configurar conexão VPN que utilize IKEv2
« Resposta #2 Online: 25 de Outubro de 2020, 18:36 »
Esse strongswan é suportado a bastante tempo. Se vc não está conseguindo instalar, ou seu sistema está quebrado, ou está com repositórios configurados incorretamente.

Tente executar os comandos sugeridos pelo zekkerj.
"Não creias impossível o que apenas improvável parece". (Shakespeare)
fabmak://website | http://twitter.com/fabmak