Autor Tópico: usuário comum sem som  (Lida 7074 vezes)

Offline firstr

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
usuário comum sem som
« Online: 21 de Novembro de 2006, 17:08 »
Pois é, eu já pesquisei isso aqui no forum e ao não ser q eu tenha passado por cima sem ver não achei nada q me explicasse como resolver isso.

Problema com o som.
O problema é q não deve ser o som especificamente pq todo mundo sabe q quando se esta instalando o ubuntu ele pede pra criar um usuário q será tipo o administrador.

Blz... com esse cara tudo funciona perfeitamente, mas não funciona com mais NENHUM. Eu tenho uma rede q migrei inteiramente pro ubuntu e ta sendo até q gratificante, mas ao mesmo tempo ta dando esses probleminhas q eu acho estranho... Deveria estar funcionando.

E não é falta de suporte do ubuntu pq no live cd e na hora q eu booto com ele já instalado e entro nesse usuário tudo funciona, mas é só eu criar outro q já era... não acho q isso deveria ter algo haver, mas todo os usuários estão sendo acessados via nis. Seria permissão ou o q? E se for como resolver?

Muito obrigado.
« Última modificação: 21 de Novembro de 2006, 19:09 por firstr »

Offline embryo

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Re: usuário comum sem som
« Resposta #1 Online: 22 de Novembro de 2006, 11:22 »
Os usuários comuns devem pertencer a alguns grupos do sistema para poderem acessar os dispositivos, como o de áudio, por exemplo. Se os usuários forem locais, basta acrescentá-los aos grupos desejados no arquivo /etc/group.

Aqui onde trabalho os usuários estão no LDAP. O que nós fizemos foi criar alguns grupos no LDAP com os mesmos nomes (audio, video, plugdev...) dos grupos das máquinas clientes. Então nós inserimos todos os usuários nesses grupos. Provavelmente um procedimento semelhante funcione com o NIS.

Offline firstr

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: usuário comum sem som
« Resposta #2 Online: 22 de Novembro de 2006, 11:38 »
Pior q eu fiz uma coisa assim ja, mas não deu muito certo.

E como vc falou é permissão mesmo. Eu percebi q nenhum usuário consegue gravar cd também.

Bom eu vou verificar isso novamente. Pode ser q eu tenha deixado algo passar.

Offline firstr

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: usuário comum sem som
« Resposta #3 Online: 27 de Novembro de 2006, 11:03 »
Resolvi a parada, mas vou te contar q não gostei disso.
Bem o ubuntu q de certa forma foi uma das distro q considerei mais adaptável ao usuário final ter esse tipo de restrição é soda. Desde quando um cara q acaba de pegar no linux vai sonhar como fazer isso?

Ainda to gostando pra caramba, mas coisas como essas não deveriam existir.
Certas configurações ainda são meio nebulosas e outras como essa do som q nem deveriam ter restrições pra uma distribuição q mais se aproxima do usuário final. Algumas configurações tem de ser feito como as distro mais cruas ou antigas... pra administrador é show (até melhor), mas pra usuário final é a morte.

Em fim. Pra terminar eu não consegui resolver mudando no NIS as permissões dos usuários. Teve q ser maquina por maquina mesmo. Inclui usuário por usuário em cada um dos grupos q ele já deveria estar. Não sei pq não funcionou. Fui no servidor e cheguei até a criar os grupos q vinham no ubuntu e q não tinha na distro q uso como servidor. Mudei as IDs pra ficar tudo igual e inclui os usuários normalmente... NADA... teve q ser maquina por maquina mesmo. Em fim. Por hora esta resolvido.

Offline lucoutin

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Re: usuário comum sem som
« Resposta #4 Online: 27 de Novembro de 2006, 11:17 »
Caro amigo firstr,

Tbm tive esse mesmo problema em minha rede que esta configurada igual a sua, com NIS e exportando o home do  usuario com NFS.Tive que ir de máquina em máquina configurando um usuario local igual ao do servidor para que tivessem privilégios como ouvir musica.Ainda continuo com alguns problemas como as permissões do arquivo .dmrc, ja configurei de todas as formas possiveis e continua dando a mensagem quando o usuario loga, mas so que ta funcionando assim.
 qq ajuda será bem vinda e o que puder ajudar to aí.

Offline firstr

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: usuário comum sem som
« Resposta #5 Online: 28 de Novembro de 2006, 15:06 »
Vc esta migrando de outra distro?
Pq eu estou. Usava o mandriva q ainda mantenho no servidor pq não to afim de reconfigurar tudo de novo. A minha maior dor de cabeça foi a readaptação e como migrar usuário por usuário de uma distro pra outra. E se o seu caso tiver sido o mesmo problema q eu tive com um usuário aqui eu resolvi apagando o arquivo. O próprio ubuntu cria de novo.
Mas pra vc poder verificar eu copiei aqui pra vc as duas únicas linhas q tem num .dmrc de um usuário qualquer aqui q não esta dando problema.

[Desktop]
Session=default

Espero q ajude.

Offline zohguy

  • Usuário Ubuntu
  • *
  • Mensagens: 89
  • Encontro minha paz na rebeldia.
    • Ver perfil
    • Zohguy_Saiyajin
Re: usuário comum sem som
« Resposta #6 Online: 28 de Novembro de 2006, 16:51 »
Sempre que se migra de um sistema para outro, utilizando as configurações já existentes, tais problemas são bastante suscetíveis de aparecer.
Contudo achei a configuração de usuários em si muito simples no Ubuntu. A organização dos recursos aos quais o usuário pode acessar, divididos em grupos, facilita bastante pelo menos no meu ponto de vista.
Dessa maneira é possível modificar as permissões e restrições de um número infinito de usuários de maneira rápida... Desde que esteja tudo funcionando é claro, o que nem sempre é verdade quando se faz uma migração. (:


Offline firstr

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: usuário comum sem som
« Resposta #7 Online: 29 de Novembro de 2006, 10:51 »
Sabe qual foi a solução q eu encontrei pra resolver mais facilmente o problema de migração de usuários? Acredito q vc vai concordar comigo. Como cada distro resolve configurar tudo a sua maneira e as vezes de forma totalmente diferente as vezes isso complica muito a vida. Nesse caso eu simplesmente, com essa mudança pro ubuntu, mudei todos os programas específicos do gnome ou do kde pra outros como no caso do leitor de e-mail. Antes eu tinha usuários usando o kontact ou o evolution e agora todos usam o thunderbird. Isso me simplificou a vida e padronizou tudo.

Quanto aos diretórios eu também gostava da organização do mandriva, mas gostei também da simplicidade do ubuntu. Mas continuo achando q certas permissões já deveriam vir abertas por padrão. Uma maquina pra desktop não exige tanto (ou pelo menos ele deveria perguntar sobre nível de segurança). Eu como usuário não quero ter q me preocupar em receber permissão pra ouvir meus mp3 ou o gravar um cd. O q não é o caso de um servidor. E na minha concepção certas coisas nem deveriam vir numa instalação pra servidor. Quem vai se preocupar em fazer o som funcionar num proxy, firewall, NFS ou coisa assim? Hoje ta mais complicado pq as distros não estão dando muita opção, mas até um tempo atrás eu nem instalaria o X.

Bom... De qualquer forma felizmente to com praticamente todos os problemas resolvidos nessa migração pro ubuntu. E gostei tanto q estou até recomendando.
« Última modificação: 29 de Novembro de 2006, 13:12 por firstr »

Offline lucoutin

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Re: usuário comum sem som
« Resposta #8 Online: 29 de Novembro de 2006, 11:15 »
firstr,

Estou migrando de conectiva(mandriva) e como disse o nosso amigo zohguy, com certeza os problemas irão aparecer.Tenho tentado solucionar todos, mas ainda sou novato no mundo linux e as suas permissões.Quanto ao erro do arquivo .dmrc, já fiz isso que vc recomendou e constatei que o problema parece ser na maquina local, pq em algumas máquinas o login do usuario funciona perfeito.O maior desafio no momento é ensinar os usuarios a utilizar os drives de disquete e cdrom atravéz da montagem e desmontagem, coisa que nao acontecia no outra distro.No mais estou muito satisfeito com o Ubuntu e inclusive ja utilizo no servidor.
De QQ forma agradeço a atenção e estou a disposição.

Offline welmo

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: usuário comum sem som
« Resposta #9 Online: 30 de MAR?O de 2023, 19:24 »
Os usuários comuns devem pertencer a alguns grupos do sistema para poderem acessar os dispositivos, como o de áudio, por exemplo. Se os usuários forem locais, basta acrescentá-los aos grupos desejados no arquivo /etc/group.

Aqui onde trabalho os usuários estão no LDAP. O que nós fizemos foi criar alguns grupos no LDAP com os mesmos nomes (audio, video, plugdev...) dos grupos das máquinas clientes. Então nós inserimos todos os usuários nesses grupos. Provavelmente um procedimento semelhante funcione com o NIS.
no meu caso os Usuários que foram cadastrado com matricula  e login está com número estão sem  som, já colocamos no /etc/group e nada, pode ser a configuração no Ldap ? mas os outros usuários que estão cadastrado com nome está com normalmente.

Offline creto

  • Usuário Archlinux
  • Usuário Ubuntu
  • *
  • Mensagens: 806
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:usuário comum sem som
« Resposta #10 Online: 03 de Abril de 2023, 10:41 »
Os usuários comuns devem pertencer a alguns grupos do sistema para poderem acessar os dispositivos, como o de áudio, por exemplo. Se os usuários forem locais, basta acrescentá-los aos grupos desejados no arquivo /etc/group.

Aqui onde trabalho os usuários estão no LDAP. O que nós fizemos foi criar alguns grupos no LDAP com os mesmos nomes (audio, video, plugdev...) dos grupos das máquinas clientes. Então nós inserimos todos os usuários nesses grupos. Provavelmente um procedimento semelhante funcione com o NIS.
no meu caso os Usuários que foram cadastrado com matricula  e login está com número estão sem  som, já colocamos no /etc/group e nada, pode ser a configuração no Ldap ? mas os outros usuários que estão cadastrado com nome está com normalmente.
Olá,

O tópico tem a última postagem datada de: "29 de novembro de 2006" de lá pra cá muita coisa mudou, (não uso o ubuntu) mas que pelo que leio sei que hoje ele usa Pipewire ao invés de pulseaudio. Minha recomendação é que abra um tópico seu, dando ao fórum detalhes da configuração da sua instalação, do seu hardware principalmente para que assim "ele" possa tentar auxiliá-lo.

T+
A vida, é feito andar de bicicleta, se parar, você cai! (Gabriel Contino)
Blog do Paulo Corrêa Creto