Autor Tópico: Webcam  (Lida 29350 vezes)

Offline vjagoncalves

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Webcam
« Online: 30 de Outubro de 2005, 20:00 »
Instalei o Ubuntu faz dois dias e recorrí ao "easy ubuntu" para instalar o amsn com suporte de webam. O meu problema é que cada vez que tento configurar a minha webcam o sistema... congela!

Já tive a minha câmara a funcionar em outras versões linux.
Alguém me sabe dizer como resolver este problema?

1 abraço...
vjagoncalves

Offline AlexBR

  • Usuário Ubuntu
  • *
  • Mensagens: 388
    • Ver perfil
Webcam
« Resposta #1 Online: 30 de Outubro de 2005, 22:28 »
Facilitaria bastante se a gente não tivesse que adivinhar o modelo da sua câmera.  :D

Offline vjagoncalves

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Webcam
« Resposta #2 Online: 31 de Outubro de 2005, 00:27 »
Tem razão... :oops:

trata-se de uma PC-2008R
--------------------------------------------------------------------------------
Infra-red LED’s to aid night-time vision:      ra-red LED light,effective distance 》1.5mPicture
Signal System:      PAL/NTSC software regulate
Horizontal  Resolution:    38K Pixels
Lens     3.6mm.6mm
Shutter Speed:    1/50(1/60)-1/100,000 secretary
Chips: DSP:    ZC0301Plus
Main chip:    modern MA360 of Taiwan
Color:     24 true colors
---------------------------------------------------------------------------------
thanks! :D
vjagoncalves

Wesley F

  • Visitante
Webcam
« Resposta #3 Online: 01 de Novembro de 2005, 21:47 »
Também passo pelo mesmo problema,eu uso uma web camera CC-330 ja tentei no amsn, ja tentei no gnome meeting e congela a tela, pq da esse problema? Ah tem algum programa que de para vc tirar foto da sua web cam no Linux igual a esses programas q vem num CD mas so q eh para windows?

Abraços

Offline LaSSarD

  • Usuário Ubuntu
  • *
  • Mensagens: 1.144
    • Ver perfil
Webcam
« Resposta #4 Online: 01 de Novembro de 2005, 22:11 »
Nenhum Linux está bem tratado ainda para receber webcams, vamos esperar pelas próximas versões :)
Se o Ubuntu 6.04 quer realmente concorrer com o Windows Vista, vai precisar corrigir isso, nem que seja pioneiro no assunto, mas é algo que faz muita falta pra galera que gosta de messenger :)
desculpem as mensagens não respondidas, mas eu tô afastado há mais de ano...
um dia eu volto ;)

Offline AlexBR

  • Usuário Ubuntu
  • *
  • Mensagens: 388
    • Ver perfil
Webcam
« Resposta #5 Online: 01 de Novembro de 2005, 23:34 »
vjagoncalves, sua webcam é diferente da minha. Contudo, a sua utiliza o mesmo driver da minha. :-) O problema é que o driver que vem com o Ubuntu está com problemas. Então, você deve baixar o código fonte do driver (http://mxhaard.free.fr/spca5xx.html), compila-lo e instala-lo. Aqui, começam os problemas. :-) A versão do gcc utilizado para compilar o driver deve ser a mesma utilizada para compilar o kernel. No meu caso, a versão correta do gcc é a 3.4. Por isso, eu tive que instalar o pacote (sudo apt-get install gcc-3.4). Além disso, para garantir que a versão correta seja utilizada, pode-se fazer...

# CC=gcc-3.4
# export CC

Isso te garante que o driver será compilado com o versão 3.4 e não a 4.0 (padrão do Ubuntu).

Depois disso, basta compilar o driver usando o make. E intala-lo usando make install.

Infelizmente, o make install instala o driver em...

/lib/modules/2.6.12-9-k7/kernel/drivers/usb/media/

Contudo, o lugar correto é...

/lib/modules/2.6.12-9-k7/kernel/drivers/usb/media/spca5xx/

A solução foi efetuar o seguinte...

$ sudo rm /lib/modules/2.6.12-9-k7/kernel/drivers/usb/media/spca5xx/spca5xx.ko
$ sudo ln -s /lib/modules/2.6.12-9-k7/kernel/drivers/usb/media/spca5xx.ko /lib/modules/2.6.12-9-k7/kernel/drivers/usb/media/spca5xx/spca5xx.ko

(Esse último comando é enorme, mas deve ser executado em uma mesma linha de comando.)

Toda vez que vc instalar um novo kernel, vai ter que reinstalar o driver.

Boa sorte!!!

Wesley F

  • Visitante
Webcam
« Resposta #6 Online: 02 de Novembro de 2005, 16:17 »
Putz continua na mesma eu instalei esse driver ae mas continua travando, to achando que é o V4L pois eu fui em seletor de sistemas multimidia e testei todas as entradas e a unica que travou foi a V4L o resto nao travava chegava a dar uns avisos mas nao travava ae coloco o V4L e abro uma aplicação para webcam e pronto trava tudo, a webcam que eu uso é uma VIMICRO CC-330 no windows funciona direitinho aki no Ubuntu q ta dando bug, alguem sabe como eu resolvo isso? Ja procurei no google, postei no VOL e nada ainda

Se alguem puder me ajudar eu agradeço no gqcam ele me da esse erro
Código: [Selecionar]
root@Wesley:/home/wesley # gqcam
/dev/video: No such file or directory



Abraços

Offline LaSSarD

  • Usuário Ubuntu
  • *
  • Mensagens: 1.144
    • Ver perfil
Webcam
« Resposta #7 Online: 02 de Novembro de 2005, 16:25 »
Tenta:
Código: [Selecionar]
sudo mkdir /dev/video
E vê se o gqcam pelo menos abre...
desculpem as mensagens não respondidas, mas eu tô afastado há mais de ano...
um dia eu volto ;)

Wesley F

  • Visitante
Webcam
« Resposta #8 Online: 02 de Novembro de 2005, 16:29 »
agora me da nisso aki
Código: [Selecionar]
wesley@Wesley:~$ gqcam
/dev/video: Is a directory

Offline AlexBR

  • Usuário Ubuntu
  • *
  • Mensagens: 388
    • Ver perfil
Webcam
« Resposta #9 Online: 02 de Novembro de 2005, 16:38 »
Wesley F, a dica que eu dei foi para o vjagoncalves que, por conicidência, a câmera dele usa o mesmo driver que a minha.

Wesley F

  • Visitante
Webcam
« Resposta #10 Online: 02 de Novembro de 2005, 16:40 »
Assim vou explicar melhor, minha camera eh USB ela monta normal akin no meu ubuntu tanto eh q ela fica ligada mas qdo eu uso esses programas de web cam ele trava =(. Esse que é o problema.

Abraços =)

Offline vjagoncalves

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Webcam
« Resposta #11 Online: 03 de Novembro de 2005, 17:11 »
Após aluns milésimos de segundos :s a tentar configurar a minha webcam... conseguí finalmente ver-me sem espelho :P

Fica aqui descrita a forma como conseguí

Antes de mais... AlexBR... obrigado!!! :D

...Ver a verção do gcc com que o kernel foi compilado (aparece no início do ficheiro)
$ less /proc/version

...instalar a versão do gcc correcta (no meu caso,gcc é a 3.4)
$ sudo apt-get install gcc-3.4

...colocar o gcc-3.4
$ CC=gcc-3.4
$ export CC

...Download do kernel source
$ sudo apt-get install build-essential linux-headers-2.6.12-9-386

...Download do driver da minha webcam ( spca5xx-20050906, por diversas vezes tentei com a versão mais recente mas... não funcionou...)
$ http://mxhaard.free.fr/spca50x/Download/spca5xx-20050906.tar.gz

...descompactar...

Acho que a path onde o kernel foi instalado (a fonte) é diferente do path para o qual o driver aponta por isso criei um link
$ sudo ln -s /usr/include/linux /usr/src/linux

...entrar na directoria do driver e fazer:
$ make clean
$ make
$ sudo make install

...remover o spca5xx.ko pelos motivos já ditos em cima pelo AlexBR
$ sudo rm /lib/modules/2.6.12-9-386/kernel/drivers/usb/media/spca5xx/spca5xx.ko
$ sudo ln -s /lib/modules/2.6.12-9-386/kernel/drivers/usb/media/spca5xx.ko /lib/modules/2.6.12-9-386/kernel/drivers/usb/media/spca5xx/spca5xx.ko

...carregar o módulo
$modprobe spca5xx GRed=217 GBlue=300 GGreen=224 gamma=4

e....funcionou!!! :D

Já testei no amsn e funcionou comigo!

Uma dica... cada vez que tentei instalar a câmara sem sucesso, tive sempre de voltar a indicar qual a versão correcta do gcc a utilizar.

Obrigado pela ajuda!!! ;)
vjagoncalves

Offline AlexBR

  • Usuário Ubuntu
  • *
  • Mensagens: 388
    • Ver perfil
Webcam
« Resposta #12 Online: 03 de Novembro de 2005, 19:35 »
Wesley F, fazer a câmera funcionar no linux é simples se você tiver o driver correto. Por iso, creio que o Ubuntu não tenha o driver para a tua câmera. Daí... Você precisa procurá-lo. Faça uma busca no Google e veja se o linux tem suporte para a sua câmera. Se tem, veja onde pegar o driver. Se achar o driver, instale-o no seu sistema que nem o vjagoncalves fez. Depois disso, sua câmera tá pronta pra usar.

Offline vjagoncalves

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Webcam
« Resposta #13 Online: 04 de Novembro de 2005, 01:41 »
Wesley F :

Não sei se será de grande ajuda mas acredito bem que o seja para muitos... e até para mim brevemente.

Um amigo meu indicou-me mais uma maravilha do Ubuntu
http://wiki.ubuntu-fr.org/materiel/webcam_logitech_msn

Lá se encontra uma forma fácil (script) para instalar diversas webcams...
Espero que saibam francês...hehe!!!

Cumprimentos! :wink:  8)
vjagoncalves

Wesley F

  • Visitante
Webcam
« Resposta #14 Online: 04 de Novembro de 2005, 14:05 »
Bem galera eu axo q finalmente eu consegui achar o drive pra minha camera dei um lsusb e me deu nisso
Código: [Selecionar]
wesley@Wesley:~/downloads/zc030x$ lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 002: ID 0ac8:301b Z-Star Microelectronics Corp. Sansun SN-510 WebCam [hv713d]
Bus 001 Device 001: ID 0000:0000
wesley@Wesley:~/downloads/zc030x$


Ae eu fui no site frances aonde tem diversas cams ae baixei para minha camera creio eu q seja esse, mas na hora de compilar olha no que da.

Código: [Selecionar]
wesley@Wesley:~/downloads/zc030x$ make clean
rm -f *.o zc030x.ko
rm -f .*.cmd
rm -f zc030x.mod.o
rm -rf .tmp_versions
wesley@Wesley:~/downloads/zc030x$ make
   Building ZC030X driver for 2.5/2.6 kernel.
   PLEASE IGNORE THE "Overriding SUBDIRS" WARNING
   Remember: you must have read/write access to your kernel source tree.
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/wesley/downloads/zc030x modules
make[1]: Entrando no diretório `/usr/src/linux-headers-2.6.12-9-386'
  CC [M]  /home/wesley/downloads/zc030x/zc030x_main.o
  CC [M]  /home/wesley/downloads/zc030x/zc030x_i2c.o
  CC [M]  /home/wesley/downloads/zc030x/zc030x_matrix.o
  CC [M]  /home/wesley/downloads/zc030x/zc030x_mm.o
/home/wesley/downloads/zc030x/zc030x_mm.c: In function `uvirt_to_kva':
/home/wesley/downloads/zc030x/zc030x_mm.c:27: warning: passing arg 1 of `pmd_offset' from incompatible pointer type
  CC [M]  /home/wesley/downloads/zc030x/zc030x_isochron.o
  CC [M]  /home/wesley/downloads/zc030x/zc030x_v4l.o
  CC [M]  /home/wesley/downloads/zc030x/zc030x_cameras.o
  CC [M]  /home/wesley/downloads/zc030x/zc030x_jpeg.o
  CC [M]  /home/wesley/downloads/zc030x/zc030x_fp.o
  CC [M]  /home/wesley/downloads/zc030x/zc030x_reg.o
  LD [M]  /home/wesley/downloads/zc030x/zc030x.o
  Building modules, stage 2.
  MODPOST
Warning: could not open /home/wesley/downloads/zc030x/zc030x_proc.h: Invalid argument
/home/wesley/downloads/zc030x/zc030x.mod.c: Permission denied
make[2]: ** [__modpost] Erro 1
make[1]: ** [modules] Erro 2
make[1]: Saindo do diretório `/usr/src/linux-headers-2.6.12-9-386'
make: ** [default] Erro 2


Como que eu resolvo essa parte da compilação, to quase lá.

Abraços to quase la tomara q eu consiga to seguindo varias dicas aki =)