Autor Tópico: Placa de som ADI AD1986A High Definition Audio 6-Channel, barulho estranho.  (Lida 61866 vezes)

Offline Edilbert

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re: Placa de som ADI AD1986A High Definition Audio 6-Channel, barulho estranho.
« Resposta #30 Online: 24 de Dezembro de 2006, 08:51 »
Self_Control, vc tentou instalar o pacote oss-linux_v4.0rc2-179_i386.deb?????
kra instalei aqui e o (piiii) SUMIU mesmo.
consigo diminuuir/aumentar o som deboa, porem tem aquele problema que so posso escutar uma coisa de cada vez. Nao posso abrir o AMAROK E O MPLAYER ao mesmo tempo




Edilbert

Offline Self_Control

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: Placa de som ADI AD1986A High Definition Audio 6-Channel, barulho estranho.
« Resposta #31 Online: 24 de Dezembro de 2006, 22:28 »
Edilbert,

Onde baixo esse pacote?

Eu não posso escutar duas coisas as mesmo tempo? Más posso abrir dois players sem escutar?

Offline Edilbert

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re: Placa de som ADI AD1986A High Definition Audio 6-Channel, barulho estranho.
« Resposta #32 Online: 24 de Dezembro de 2006, 23:05 »
Self, pelo menos aqui basta eu abrir dois player que o som ja para.
Vamos la... tipo vc ta escutando uma musica por exemplo no amarok.... e ta afim de mostrar um filme ou tocar um nova lista de musica em outro programa xmms por exemplo quando vc abre (mplayer) o Amorok para de tocar. Ai vc tem que fechar o mplayer e apertar player de novo. ou vice versa. E estou usando dessa forma melhor que ficar com a quele piiiii
Galera esse e o link onde se baixa o oss-linux
Após instalação do oss, o alsa automaticamente nao funciona, se caso nao der certo, bastar vc ir no synapitc e pedir pra fazer a remoção completa. do pacote oss-linux, ai o alsa volta ao normal com o (piiiii)

http://www.4front-tech.com/download.cgi


Abraços

Edilbert
« Última modificação: 24 de Dezembro de 2006, 23:27 por Edilbert »

rbpitrovski

  • Visitante
Re: Placa de som ADI AD1986A High Definition Audio 6-Channel, barulho estranho.
« Resposta #33 Online: 09 de Janeiro de 2007, 14:55 »
E aí, galera!
Tentei postar sem me registrar, mas não consegui ... Me registrei só para postar essa resposta aqui. Espero que seja útil para vocês.
Eu tenho uma Asus P5LD2-SE, que vem com o AD1986A. Segundo o site do ALSA (www.alsa-project.org) não há suporte para esse dispositivo ainda.
Tentei as dicas de vocês e também não tive sucesso. Então, fiz o seguinte e funcionou. Estou há dois dias com o som 100%, podendo até alterar o volume ;)
Basta recompilar o kernel, desabilitando o ALSA e o OSS e, em seguida, baixar o alsa do site oficial e compilá-lo. Aí, só rodar o "alsaconf".

Só um detalhe: estou usando o Debian Sid. Mas, apesar das mudanças estruturais que o Ubuntu faz, acredito que deva funcionar. Estou usando o kernel 2.8.18.

Qualquer coisa, mail me: rafael (at) iei (dot) org (dot) br.

Abraços.

Offline Self_Control

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: Placa de som ADI AD1986A High Definition Audio 6-Channel, barulho estranho.
« Resposta #34 Online: 13 de Janeiro de 2007, 18:55 »
Caraca, será que precisa recompilar um Kernel por causa de um som?

Pra usuários como eu é um pouco complicado fazer isso.

Será que se eu remover o alsa e depois instalar ele novamente não dá?

Dá ultima vez que tentei remove-lo não consegui mais nada de som, só voltou quando eu instalei o ubuntu de novo.

Offline Self_Control

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: Placa de som ADI AD1986A High Definition Audio 6-Channel, barulho estranho.
« Resposta #35 Online: 13 de Janeiro de 2007, 18:58 »
Se que aqui é um fórum de Linux só que alem de resolver esse problema do linux também queria resolver o que está ocorrendo no Ruindows.

No Ruindows o som fica estalando com alguns videos. Será como posso resolver isso?

Já reinstalei o drivers e nada.

Offline Self_Control

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: Placa de som ADI AD1986A High Definition Audio 6-Channel, barulho estranho.
« Resposta #36 Online: 26 de Janeiro de 2007, 21:32 »
Galera me explica ai como eu recompilo o kernel que nem o amigo falou e instalo o alsa.

Será que não vai dá problema(sou novo em linux)

Tenho medo pq meu ubuntu tá arrumandinho(mp3, codec's, programas...)

Estragar isso é chato.

Li alguma coisas sobre recompilação de kernel só que nem quis fazer.

Achei um pouco complicado.

ajuda ai galera.


Alguem mais conseguiu arrumar o som?

Vocês estão tendo problema com esse som no windows?

Offline _Luks

  • Usuário Ubuntu
  • *
  • Mensagens: 202
  • Debian Lenny
    • Ver perfil
    • Meu Blog
Re: Placa de som ADI AD1986A High Definition Audio 6-Channel, barulho estranho.
« Resposta #37 Online: 10 de MAR?O de 2007, 00:10 »
faz tempo que venho sofrendo com esse maldito piii
já que nao consegui fazer nada, eu desativei o altofalante esquerdo ai o pii para de enxer o meu saco, porém so sai som pelo alto falante direito.

Eu já compilei a ultima versao do alsa, mas mesmo assim nao funcionou :/
vou baixar esse oss-linux_v4.0rc2-179_i386 e vê se funciona.
Se não funcionar, eu vou recompilar o kernel e compilar o alsa


 :(

Offline _Luks

  • Usuário Ubuntu
  • *
  • Mensagens: 202
  • Debian Lenny
    • Ver perfil
    • Meu Blog
Re: Placa de som ADI AD1986A High Definition Audio 6-Channel, barulho estranho.
« Resposta #38 Online: 10 de MAR?O de 2007, 00:36 »
esse pacote do oss parou o PII, mas o alto falante esquerdo continua mudo (sim, eu já olhei o alsamixer)
agora to recompilando o kernel:
http://www.howtoforge.com/kernel_compilation_ubuntu

Offline _Luks

  • Usuário Ubuntu
  • *
  • Mensagens: 202
  • Debian Lenny
    • Ver perfil
    • Meu Blog
Re: Placa de som ADI AD1986A High Definition Audio 6-Channel, barulho estranho.
« Resposta #39 Online: 11 de MAR?O de 2007, 01:44 »
argh
essa compilação apenas serviu para me stressar
a compilação foi bem sucedida, mas meu pendrive kingston 1gb nao foi mais reconhecido.
A compilação do ALSA nao adiantou de nada ...


Acho que só restam duas coisas a se fazer ...
* torcer para que o ubuntu feisty tenha suporte a nossa placa
ou
*comprar uma placa de som pci ¬¬

Offline orca

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: Placa de som ADI AD1986A High Definition Audio 6-Channel, barulho estranho.
« Resposta #40 Online: 16 de MAR?O de 2007, 17:32 »
Caros amigos,

Desisti, depois de pelejar um bom tempo, de tentar configurar o som onboard da minha placa mae P5LD2 SE, com sistema de som ADI1986A Intel. Comprei, seguindo sugestao do phgliberal, uma placa de som da Genius: Sound Maker Value 5.1.

Espetei a tal placa num slot PCI da placa-mae, desabilitei na BIOS o sistema de som HDA onboard e bootei a maquina, que tem um Debian Etch para AMD64. Houve logo uma mensagem informativa do KDE dizendo algo como nao haver dispositivo de som (sound driver) e que ele usaria algo como o /dev/null...

Pois bem, gostaria de instrucoes especificas sobre como fazer agora tal placa offboard funcionar. Meu kernel e':

orca@andromeda:~$ uname -r
2.6.18-4-amd64

O resultado do comando lspci e':

orca@andromeda:~$ lspci
00:00.0 Host bridge: Intel Corporation 945G/GZ/P/PL Express Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 945G/GZ/P/PL Express PCI Express Root Port (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) Serial ATA Storage Controller IDE (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
04:00.0 VGA compatible controller: nVidia Corporation Unknown device 016a (rev a1)

ou seja, agora nao aparece, por enquanto, mais nada de audio, como aparecia quando o sistema onboard estava habilitado na BIOS...

Nao rodei o alsaconf, nem usei o CD com eventual driver da Genius ainda...

Qual o proximo passo a tomar?? Por favor deem explicacoes detalhadas, se possivel... No CD da Genius, sugere que provavlemente teria que compilar o driver (fornecido num arquivo comprimido do CD), mas, em principio, gostaria de evitar isso e manter-me, se possivel, com os drivers default do Debian...

Abracos!

boi

  • Visitante
Re: Placa de som ADI AD1986A High Definition Audio 6-Channel, barulho estranho.
« Resposta #41 Online: 16 de MAR?O de 2007, 17:36 »
Citar
Nao rodei o alsaconf

E está esperando o que?

Offline orca

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: Placa de som ADI AD1986A High Definition Audio 6-Channel, barulho estranho.
« Resposta #42 Online: 16 de MAR?O de 2007, 18:02 »
Pois bem,

Acbei de rodar o alsaconf. Ele propoe como driver para a tal placa nova de som (Genius Sound Maker Value 5.1) o mpu401 snd-mpu401, que eu aceitei; depois ele diz que vai alterar o arquivo /etc/modprobe.d/sound e eu tambem aceitei. finalmente ele diz que confgurou o driver e vai carrega-lo e ajustar o nivel  do som. Tudo parece correr direito. Contudo, um teste trivial como

# speaker-test

nao emite som nenhum nas caixas, diferentemente do que acontecia com o som onboard. Outra coisa: o icone do kmix, na linha de baixa do desktop, apresenta agora um botao vermelho com uma cruz e nada interessante pode ser aberto clicando-se nele...

Sera' que e' necessario compilar o driver fornecido no CD e "agrega-lo ao kernel???

[]'s

boi

  • Visitante
Re: Placa de som ADI AD1986A High Definition Audio 6-Channel, barulho estranho.
« Resposta #43 Online: 17 de MAR?O de 2007, 08:52 »
Está errado, mpu401 é um interface midi, que é usada, por exemplo, pra comunicação com um teclado musical. Muitas placas de som tem esse recurso, mas não é isso que precisa ser configurado. Tem que saber qual o chipset usado por essa plaquinha da Genius, talvez nem seja bem suportado pelo Linux. Aliás, não sei quem te indicou essa placa, mas o cara merece uma chinelada. Se for para comprar uma placa de som offboard, a única que compensa é a Soundblaster, mesmo que seja a velha Live.

Offline orca

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: Placa de som ADI AD1986A High Definition Audio 6-Channel, barulho estranho.
« Resposta #44 Online: 17 de MAR?O de 2007, 10:34 »
Oi boi,

Quem sugeriu tal placa foi o phgliberal deste mesmo thread, numa mensagem anterior... De qualquer maneira, ele afirma que o driver seria snd_cmipci. O problema e' que o alsaconf, quando vai apresentar as opcoes de placas, na janela Soundcard  Selection, nao da esta como uma delas, somente:

mpu401 snd-mpu401
legacy Probe legacy ISA (non-PnP) chips

...

Esta placa Genius ate veio com um CD de documentacao e driver, inclusive para Linux; nao sei, contudo, se valeria a pena tentar compila-lo e carrega-lo como modulo do kernel...

Outra opcao e' o que voce mencionou: passar para uma Creative Labs, mas gostaria de saber o seguinte. Pelo site do alsa project, a Sound Blaster Live 5.1 e' suportada com driver emu10k1, e a Live 7.1 com driver ca0106. As Audigy parecem um pouco menos suportadas... Quais placas Sound Blaster exatamente voce recomenda com certeza de compatibilidade com o kernel 2.6.18-4 (do Debian Etch)? Qual placa de som voce tem?

[]'s