Autor Tópico: "/" no modo de texto  (Lida 5294 vezes)

Offline Sergius

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
"/" no modo de texto
« Online: 08 de Dezembro de 2006, 16:59 »
galera quando eu entro no modo de texto a tecla q contem o caracter "/" nao está funcionando.. alguem sabe o q fazer e pq q isso ocorre?

ginho

  • Visitante
Re: "/" no modo de texto
« Resposta #1 Online: 08 de Dezembro de 2006, 17:17 »
Provavelmente é configuração do teclado, não sei resolver, raramente uso neste modo e quando
uso, uso a tecla do teclado numérico.

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.369
  • @Ceará
    • Ver perfil
Re: "/" no modo de texto
« Resposta #2 Online: 08 de Dezembro de 2006, 17:44 »
No ambiente gráfico funciona o "/"?
O modo texto é o terminal ou um login não-gráfico?

Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline aleixo

  • Usuário Ubuntu
  • *
  • Mensagens: 55
    • Ver perfil
Re: "/" no modo de texto
« Resposta #3 Online: 08 de Dezembro de 2006, 23:44 »
Oi, pessoal;
Também acontece comigo este fato de a tecla / não funcionar
quando vou para o modo texto através do Ctrl Alt F1.
No modo gráfico a tecla / funciona sem problemas.
Sem essa tecla no modo texto fica quase impossível fazer qualquer coisa.
Tomara que logo alguém tenha alguma dica.
[ ]'s.

Offline k7br

  • Usuário Ubuntu
  • *
  • Mensagens: 770
  • Ubuntu 9.04
    • Ver perfil
Re: "/" no modo de texto
« Resposta #4 Online: 17 de Dezembro de 2006, 08:41 »
Salve !  talvez ajude
http://ubuntuforum-pt.org/index.php?topic=12936.0

Boa sorte ! ;)

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: "/" no modo de texto
« Resposta #5 Online: 18 de Dezembro de 2006, 10:34 »
Use o / do teclado numérico, à direita do teclado.
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |

Offline Kursk

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: "/" no modo de texto
« Resposta #6 Online: 18 de Dezembro de 2006, 21:54 »
 Esse foi um problema bem chato para resolver!

 Por razões que não vem ao caso, eu uso bastante o console (Ctrl+Alt+F1) e a falta da tecla "/" estava perturbando.

 Primeiro tentei usar a tecla "/" do console numérico. Perfeito até certo ponto. Quando você está utilizando um desktop, tudo bem; mas quando você está com um notebook e, pior ainda, quando o notebook está ao lado do desktop, a confusão se instala e nada sai direito.

 Depois tentei seguir a "receita" sugerida acima ( http://ubuntuforum-pt.org/index.php?topic=12936.0 ) mas também deu problema (só funciona na sessão atual; quando você "reboota" ou desliga o micro, ao retornar, cadê a "/"?)

 Aí "apelei":

1 - Baixei o arquivo contendo o mapa de teclado abnt2 com todas as teclas habilitadas:

 
Código: [Selecionar]
wget http://www.iei.org.br/~rafael/down/br-abnt2.kmap.gz
2 - copiei o arquivo para o lugar onde deveria estar:

Código: [Selecionar]
sudo cp br-abnt2.kmap.gz /usr/share/keymaps/i386/qwerty/
3 - editei o arquivo "bootmisc.sh"

Código: [Selecionar]
sudo kwrite /etc/init.d/bootmisc.sh
 Lá pelas tantas, já quase no final do arquivo, há um trecho assim:

Código: [Selecionar]
        ...........
  # Remove bootclean's flag files.
# Don't run bootclean again after this!
rm -f /tmp/.clean


}

case "$1" in
  start|"")
do_start
;;
  restart|reload|force-reload)
.....

Modifiquei esse trecho, deixando da seguinte forma:

Código: [Selecionar]
        ......
# Remove bootclean's flag files.
# Don't run bootclean again after this!
rm -f /tmp/.clean

loadkeys /usr/share/keymaps/i386/qwerty/br-abnt2.kmap.gz

INITTTY=/dev/tty[1-6]
for tty in $INITTTY; do
setleds -D +num < $tty
done


}

case "$1" in
  start|"")
do_start
;;
  restart|reload|force-reload)
.......

4 - Salvei, "rebootei" (para o arquivo ser lido pelo sistema) e o problema acabou!!

Observações:

a) O que faz a "mágica" é a linha "loadkeys..........". Concordo que a solução não é elegante; mas que funciona, funciona!

b) As outras linhas que adicionei:

Código: [Selecionar]
       INITTTY=/dev/tty[1-6]
for tty in $INITTTY; do
setleds -D +num < $tty
done

servem para ligar o teclado numérico também no console. Obviamente estas linhas NÂO devem ser adicionadas caso você esteja utilizando um notebook.

---------------------
Kursk

Adendo: Caso alguém se interesse em conhecer a raiz do problema, ele está no arquivo de mapa do teclado que vem com o sistema. Nesse arquivo (/etc/console/boottime.kmap.gz) está em branco a definição da tecla de keycode 89, que é exatamente a "/","?", "°".Isso pode ser verificado abrindo-o com o Ark.
 
« Última modificação: 19 de Dezembro de 2006, 15:16 por Kursk »

Offline LedStyle

  • Usuário Ubuntu
  • *
  • Mensagens: 1.345
    • Ver perfil
    • http://www.tuxresources.org
Re: "/" no modo de texto
« Resposta #7 Online: 19 de Dezembro de 2006, 10:52 »
Também tenho esse problema, e a solução anterior que o pessoal mandava só ativou o "ç" e não essa "/" que também me irrita.

Obrigado por postar a solução aqui amigo. Todos deveriam seguir seu exemplo e voltar pra postar como resolveram o problema. Vou tentar aqui agora.

[]s

Offline LedStyle

  • Usuário Ubuntu
  • *
  • Mensagens: 1.345
    • Ver perfil
    • http://www.tuxresources.org
Re: "/" no modo de texto
« Resposta #8 Online: 19 de Dezembro de 2006, 11:01 »
Funcionou muito bem.

Só recomendo que você edite o post e tire aqueles bbcodes perdidos tentando deixar o texto negrito. Dentro da tag "code" o bbcode é ignorado. O pessoal pode acabar copiando com aquelas tags e não funcionar.

[]s

Offline Kursk

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: "/" no modo de texto
« Resposta #9 Online: 19 de Dezembro de 2006, 15:18 »
Editado. Grato pelo aviso.

---------------
Kursk

Offline Akuhn

  • Usuário Ubuntu
  • *
  • Mensagens: 384
  • Ubuntu 9.04
    • Ver perfil
    • Blog do FAX
Re: "/" no modo de texto
« Resposta #10 Online: 19 de Dezembro de 2006, 21:59 »
Já tentou configurar o teclado corretamente?

Uma maneira elegante de fazer:

Citar
sudo dpkg-reconfigure console-data

Selecione a arquitetura e em seguida o idioma e por último o modelo do teclado. Já configurei vários teclados diferentes e sempre funcionou 100%

lembrando que essa configuração nada tem haver com o modo gráfico e não faz nenhuma alteração no xorg.conf, vale apenas para o modo texto puro.
Aldefax Gilvan Kuhn

Linux User 410689

Offline D_0ne

  • Usuário Ubuntu
  • *
  • Mensagens: 26
  • Ubuntu 8.10 x64
    • Ver perfil
    • ..::: Paradoxo :::..
Re: "/" no modo de texto
« Resposta #11 Online: 20 de Janeiro de 2007, 00:15 »
Eu achei uma alternativa diferente: ao invés de ter todo o trabalho de reconfigurar o teclado, descobri esses dias que apertando as teclas "Alt Gr+q" tinha o mesmo resultado que "/".

Pelo menos aqui no teclado de casa funciona perfeitamente!
HP DV6636 (AMD Turion 64 X2 1,9GHz / 2GB DDR2 / HD 160GB / Geforce 7150 128MB)
Ubuntu 8.10 x64 Hardy Heron / Windows Vista x64 / Vector Linux 5.9 x64