Autor Tópico: Problema no Mplayer  (Lida 16497 vezes)

Offline Rwainder Miller

  • Usuário Ubuntu
  • *
  • Mensagens: 102
    • Ver perfil
Problema no Mplayer
« Online: 10 de Dezembro de 2006, 08:09 »
esse programa funcionava no dapper mas agora no edgy ele ta enchendo saco,simplesmente não toca nada,nos outros players que tenho aqui funcionam perfeitamente: totem, VLC.

mas o mplayer não toca nem vídeo nem audio:
Vídeo:


audio:

(esse eu executando com uma mp3) ele até executou porem deu nisso... afinal o que há com o mplayer?


Offline Rwainder Miller

  • Usuário Ubuntu
  • *
  • Mensagens: 102
    • Ver perfil
Re: Problema no Mplayer
« Resposta #1 Online: 10 de Dezembro de 2006, 08:11 »
me desculpem coloquei no local errado o tópico,deveria ser em audio e vídeo


Offline Magneto

  • Usuário Ubuntu
  • *
  • Mensagens: 768
    • Ver perfil
Re: Problema no Mplayer
« Resposta #2 Online: 10 de Dezembro de 2006, 08:21 »
Aqui ocorre o mesmo erro da primeira figura.

Offline JeffersonX

  • Usuário Ubuntu
  • *
  • Mensagens: 442
  • Linux User: #364092
    • Ver perfil
Re: Problema no Mplayer
« Resposta #3 Online: 10 de Dezembro de 2006, 08:45 »
Oh fii, o w32codecs está instalado? Faz o que o tutorial do Galactus pede pra fazer que vai funcionar na boa!
Linux Professional Institute Certified - Level 1, Novell CLA - Certified Linux Administrator, Microsoft Certified Professional - Windows Server 2003, ITIL Foundation Certified
Meu Blog: http://tibyjeffersonx.blogspot.com

Offline Magneto

  • Usuário Ubuntu
  • *
  • Mensagens: 768
    • Ver perfil
Re: Problema no Mplayer
« Resposta #4 Online: 10 de Dezembro de 2006, 08:49 »
Não sei se é o mesmo caso, mas, eu particularmente tenho todos os codecs instalados, além do mais, isso ocorre apenas no Edgy.

Offline Magneto

  • Usuário Ubuntu
  • *
  • Mensagens: 768
    • Ver perfil
Re: Problema no Mplayer
« Resposta #5 Online: 10 de Dezembro de 2006, 08:58 »
esse programa funcionava no dapper mas agora no edgy ele ta enchendo saco,simplesmente não toca nada,nos outros players que tenho aqui funcionam perfeitamente: totem, VLC.

mas o mplayer não toca nem vídeo nem audio:
Vídeo:


audio:

(esse eu executando com uma mp3) ele até executou porem deu nisso... afinal o que há com o mplayer?

Sobre a segunda figura, achei uma dica no fórum gringo, no caso faça assim:

Vá até Preferences>codecs & demuxer e selecione a opção "FFmpeg.....", tanto para vídeo quanto para áudio.

Sobre a primeira figura, a dica seria usar x11 como saída de vídeo, funciona, mas não em tela cheia, apenas um pequeno espaço central.

Offline Rwainder Miller

  • Usuário Ubuntu
  • *
  • Mensagens: 102
    • Ver perfil
Re: Problema no Mplayer
« Resposta #6 Online: 10 de Dezembro de 2006, 09:51 »
grande Agent Orange  ;D

problemas resolvidos! o primeiro fiz exatamente como você citou e funcionou

o segundo coloquei como X11 (OpenGL), to com o beryl ativo e mesmo assim consigo rodar ele em fullscreen sem problema

valeu cara


Offline Magneto

  • Usuário Ubuntu
  • *
  • Mensagens: 768
    • Ver perfil
Re: Problema no Mplayer
« Resposta #7 Online: 10 de Dezembro de 2006, 09:55 »
 ;D.

Aqui consegui colocar em tela cheia, valeu pela dica do X11 OpenGL, não tinha testado ainda.

Offline mrc_sp

  • Usuário Ubuntu
  • *
  • Mensagens: 103
    • Ver perfil
Re: Problema no Mplayer
« Resposta #8 Online: 10 de Dezembro de 2006, 11:06 »
Aqui consegui colocar em tela cheia, valeu pela dica do X11 OpenGL, não tinha testado ainda.
Comigo está acontecendo o mesmo da figura 1
Explica melhor como se aplica esta dica do X11 OpenGL?

Offline advogama

  • Usuário Ubuntu
  • *
  • Mensagens: 181
    • Ver perfil
Re: Problema no Mplayer
« Resposta #9 Online: 10 de Dezembro de 2006, 11:12 »
Vá até Preferences>codecs & demuxer e selecione...


Eu não encontro o local para essas configurações, aparentemente o MPlayer não tem local para configurações. Como configurar?
Prepare-se para o Vista. Aprenda Linux.


Offline Magneto

  • Usuário Ubuntu
  • *
  • Mensagens: 768
    • Ver perfil
Re: Problema no Mplayer
« Resposta #10 Online: 10 de Dezembro de 2006, 11:14 »
Abra o Mplayer, botão direito do mouse,Preferences, aba Video, onde diz Available Drivers escolha a opção X11 OpenGL, clique em OK e reinicie o Mplayer.

Offline advogama

  • Usuário Ubuntu
  • *
  • Mensagens: 181
    • Ver perfil
Re: Problema no Mplayer
« Resposta #11 Online: 10 de Dezembro de 2006, 11:43 »
Agora já consigo abrir o video, mas ele exibe quadro a quadro, como uma progressão de slides.

ah, essas configurações influenciam no Mozilla-Mplayer? por que nele também eu só consigo ouvir o som?

Dúvidas: qual a congiguração da aba "codecs & Demuxer" - ela se altera dependendo do vídeo?

Na Aba Video, quais as configurações de drivers estão marcadas Ex: Enable doble buffering


« Última modificação: 10 de Dezembro de 2006, 11:48 por advogama »
Prepare-se para o Vista. Aprenda Linux.


Offline Magneto

  • Usuário Ubuntu
  • *
  • Mensagens: 768
    • Ver perfil
Re: Problema no Mplayer
« Resposta #12 Online: 10 de Dezembro de 2006, 11:45 »
Agora já consigo abrir o video, mas ele exibe quadro a quadro, como uma progressão de slides.

ah, essas configurações influenciam no Mozilla-Mplayer? por que nele também eu só consigo ouvir o som?


Aqui funciona normal apenas se não for utilizado em tela cheia, estou procurando ainda como deixar sem esses travamentos.

Offline mrc_sp

  • Usuário Ubuntu
  • *
  • Mensagens: 103
    • Ver perfil
Re: Problema no Mplayer
« Resposta #13 Online: 10 de Dezembro de 2006, 12:50 »
Valeu!
Acho que este problema só existe no Ubuntu edgy.
No kubuntu o mplayer funciona bem!

Offline glaubergoncalves

  • Usuário Ubuntu
  • *
  • Mensagens: 511
  • Ubuntu User # 10537
    • Ver perfil
Re: Problema no Mplayer
« Resposta #14 Online: 10 de Dezembro de 2006, 13:55 »

Sobre a segunda figura, achei uma dica no fórum gringo, no caso faça assim:

Vá até Preferences>codecs & demuxer e selecione a opção "FFmpeg.....", tanto para vídeo quanto para áudio.


Aqui a coisa se resolveu de forma um pouco estranha... segui tua dica e deu errado, mas quando pus as opções de volta no que estavam antes (no caso, "None", tanto no áudio como no vídeo), daí deu certo. Interessante que no meu caso o áudio sempre tocou sem problemas, mas mesmo assim aquela segunda figura aparecia quando tentava reproduzir algo, nem precisava ser um áudio MP3 necessariamente. Mas de qualquer forma tá resolvido!  ;D