Autor Tópico: Ajuda! Xubuntu 6.10 + OpenGL  (Lida 3778 vezes)

Offline lorota

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Ajuda! Xubuntu 6.10 + OpenGL
« Online: 15 de Dezembro de 2006, 13:48 »
Galera preciso de ajuda com opengl no linux.

Primeiramente instalei os drivers da nvidia no linux, parece ter sido uma instalção correta, pois com a inicialização do X, o logo da Nvidia aparece correntamente.

Mas o problema vem com a utilização dos jogos que necessitam de Opengl, pois este parece não estar instalado.

Bom, qndo abro o terminal e dou um glxinfo aparece o seguinte:

name of display: :0.0
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

E qndo dou um glxgears:

Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual

E finalmente qndo vou rodar o quake3 que esta corretamente instalado ele começa a carregar, a tela fica preta e logo em seguida sai dando um erro no terminal:

----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 640x480
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Couldn't get a visual
...WARNING: could not set the given mode (3)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem


Bom espero que alguem me de uma luz qnto ao opengl no linux!!

PS: A VGA é uma TNT2 M64

Obrigado!

Offline Gilson Miranda

  • Usuário Ubuntu
  • *
  • Mensagens: 69
  • Temido pelos homens, amado pelas mulheres
    • Ver perfil
    • HARDPLUS
Re: Ajuda! Xubuntu 6.10 + OpenGL
« Resposta #1 Online: 16 de MAR?O de 2007, 21:25 »
Estou com o mesmo problema em um notebook Asus F3J de um amigo

Instalei os drivers da nvidia pelo Adicionar/Remover Programas, pois no site da nvidia não tinha os drivers da GeForce 7300Go para Linux.
Temido pelos homens, amado pelas mulheres