Autor Tópico: Monitor fora de frequência  (Lida 6676 vezes)

Offline zackshinra

  • Usuário Ubuntu
  • *
  • Mensagens: 308
    • Ver perfil
Monitor fora de frequência
« Online: 21 de Dezembro de 2006, 18:24 »
  Olá, estou com o seguinte problema.

  Instalei o Edubuntu 6.10, e na tela de inicio (aquela onde o sistema fica carregando, o que antecede a tela de login) fica tudo preto e fica a seguinte mensagem:

Citar
Fora de Frequência
HF: 63,9 KHz
VF: 60,0 Hz

Frequência de operação
HF: 30 - 61 KHz
VF: 50 - 120 Hz

Gerenciamento de energia 15 (e diminuindo) sec

  Pelo que entendi, tenho que mudar este tal de HF. A pergunta é, como fazer?

  Obs: a tela de login, e da área de trabalho ficam normais.

  O monitor utilizado é: LG StudioWorks 563A

--------------------
  Como teste, coloquei o cpu a qual instalei o Edubuntu no seguinte monitor: LG Flatron ez T730SH. Nele, a mensagem acima não aparece, mas a tela de carregamento (não sei se é esse o nome) fica pequena, com tarjas pretas em volta.
  Novamente a tela de login, e da área de trabalho ficam normais.
"Ao se deparar com um problema, a primeira atitude deve ser a busca de soluções, e não a de culpados."
Lauro Adriano

Offline Versuri

  • Usuário Ubuntu
  • *
  • Mensagens: 912
  • Linux#436528 ● Ubuntu#9933 MacBook Pro SL 10.6.7
    • Ver perfil
Re: Monitor fora de frequência
« Resposta #1 Online: 21 de Dezembro de 2006, 22:04 »
No boot do CD altere a resolução (tecla VGA) para 800x600 e experimente.

Offline Akuhn

  • Usuário Ubuntu
  • *
  • Mensagens: 384
  • Ubuntu 9.04
    • Ver perfil
    • Blog do FAX
Re: Monitor fora de frequência
« Resposta #2 Online: 22 de Dezembro de 2006, 09:41 »
Você tem que mexer no grub para resolver esse problema.

Na tela de inicio você pode acessar o grub e fazer alterações nele.

Procure pelo item vga e mude para vga=normal, isso deve resolver.
Aldefax Gilvan Kuhn

Linux User 410689

Offline zackshinra

  • Usuário Ubuntu
  • *
  • Mensagens: 308
    • Ver perfil
Re: Monitor fora de frequência
« Resposta #3 Online: 23 de Dezembro de 2006, 12:02 »
  Vou tentar e depois posto se deu certo (o pc fica na minha empresa e lá não tem internet).

  Obrigado pela ajuda até então.
"Ao se deparar com um problema, a primeira atitude deve ser a busca de soluções, e não a de culpados."
Lauro Adriano

Offline zackshinra

  • Usuário Ubuntu
  • *
  • Mensagens: 308
    • Ver perfil
Re: Monitor fora de frequência
« Resposta #4 Online: 24 de Dezembro de 2006, 10:09 »
  Infelizmente não deu certo, nenhuma das sugestões.
 
  Alterei o vga no boot do cd, ele altera a tela de carregamento do live cd, mas não altera do que já esta instalado (re-instalar o ubuntu não é uma opção para mim).

  Olhei no grub, apertei "e", e não encontrei nada citando vga.
  Com o linux ligado entrei em /boot/grub/menu.lts , encontrei um local que citava vga.
Citar
## e.g. defoptions=vga=791 resume=/dev/hda5
  Mudei para o seguinte:
Citar
## e.g. defoptions=vga=normal resume=/dev/hda5
  E não mudou em nada, fiz assim então:
Citar
e.g. defoptions=vga=normal resume=/dev/hda5
  E também não mudou nada.

  Obrigado pela ajuda até agora, mas ainda não resolvi o problema.

  Obs: o pc com problema tem instalado o nvidia settings (acho que é esse o nome) que é instalado pelo automatix, será que é uma configuração de lá? A placa de video é um gforce 4 mx.
« Última modificação: 24 de Dezembro de 2006, 10:11 por zackshinra »
"Ao se deparar com um problema, a primeira atitude deve ser a busca de soluções, e não a de culpados."
Lauro Adriano

Offline Akuhn

  • Usuário Ubuntu
  • *
  • Mensagens: 384
  • Ubuntu 9.04
    • Ver perfil
    • Blog do FAX
Re: Monitor fora de frequência
« Resposta #5 Online: 26 de Dezembro de 2006, 14:24 »
Tem uma lista com as resoluções de tela e profundidade de cores que são usadas no framebuffer do console, só que no momento não lembro qual a man-page com as descrições. Vou procurar e posto aqui assim que achar.
Tenta ao invés de colocar vga=791 ou vga=normal coloque:
vga=788

Eu tive alguns casos que resolveu, isso é um problema de incompatibilidade com alguns modelos de placas de vídeo/fb/monitor.

[ ]'s.
Aldefax Gilvan Kuhn

Linux User 410689

Offline Akuhn

  • Usuário Ubuntu
  • *
  • Mensagens: 384
  • Ubuntu 9.04
    • Ver perfil
    • Blog do FAX
Re: Monitor fora de frequência
« Resposta #6 Online: 26 de Dezembro de 2006, 14:45 »
Achei!!!

Lista com as possíveis resoluções para console:
Citar
# Normal VGA console
vga = normal
# VESA framebuffer console @ 1024x768x64k
vga=791
# VESA framebuffer console @ 1024x768x32k
vga=790
# VESA framebuffer console @ 1024x768x256
vga=773
# VESA framebuffer console @ 800x600x64k
vga=788
# VESA framebuffer console @ 800x600x32k
vga=787
# VESA framebuffer console @ 800x600x256
vga=771
# VESA framebuffer console @ 640x480x64k
vga=785
# VESA framebuffer console @ 640x480x32k
vga=784
# VESA framebuffer console @ 640x480x256
vga=769

Acho que isso deve resolver o problema, [ ]'s.
Aldefax Gilvan Kuhn

Linux User 410689

Offline zackshinra

  • Usuário Ubuntu
  • *
  • Mensagens: 308
    • Ver perfil
Re: Monitor fora de frequência
« Resposta #7 Online: 26 de Dezembro de 2006, 17:27 »
 
  Obrigado Akuhn, mas não entendi, é para eu modificar mesmo o /boot/grub/menu.lts ?
  E naquele local que eu coloquei ?
Citar
## e.g. defoptions=vga=791 resume=/dev/hda5

  Tá se for isso, o que devo fazer, des-comentar a linha e tentar vga=790, vga=773, etc. Até ver qual dá certo?
"Ao se deparar com um problema, a primeira atitude deve ser a busca de soluções, e não a de culpados."
Lauro Adriano

Offline Akuhn

  • Usuário Ubuntu
  • *
  • Mensagens: 384
  • Ubuntu 9.04
    • Ver perfil
    • Blog do FAX
Re: Monitor fora de frequência
« Resposta #8 Online: 26 de Dezembro de 2006, 20:26 »
edite o arquivo /boot/grub/menu.lst:
Citar
sudo gedit /boot/grub/menu.lst

Nele procure por...

Citar
## ## End Default Options ##

title           Ubuntu, kernel 2.6.15-27-k7
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.15-27-k7 root=/dev/hda1 ro quiet splash
initrd          /boot/initrd.img-2.6.15-27-k7
savedefault
boot

Na linha que se refere ao kernel basta adicionar a opção vga=xxx, comece com as resoluções maiores até chegar a uma que funcione no seu monitor (vga=788 deve funcionar com certeza).

Ficaria assim, por exemplo:
Citar
## ## End Default Options ##

title           Ubuntu, kernel 2.6.15-27-k7
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.15-27-k7 root=/dev/hda1 ro quiet splash vga=788
initrd          /boot/initrd.img-2.6.15-27-k7
savedefault
boot

Dúvidas? Comente...
Aldefax Gilvan Kuhn

Linux User 410689

Offline zackshinra

  • Usuário Ubuntu
  • *
  • Mensagens: 308
    • Ver perfil
Re: Monitor fora de frequência
« Resposta #9 Online: 27 de Dezembro de 2006, 06:34 »
  Agora acho que entendi, assim que eu for para o computador da empresa (onde esta o problema) vou tentar isso. Valeu Akuhn.
"Ao se deparar com um problema, a primeira atitude deve ser a busca de soluções, e não a de culpados."
Lauro Adriano

Offline zackshinra

  • Usuário Ubuntu
  • *
  • Mensagens: 308
    • Ver perfil
Re: Monitor fora de frequência
« Resposta #10 Online: 27 de Dezembro de 2006, 22:29 »
  Fiz, testei um a um, mas não teve um que tenha ficado perfeito. O que ficou melhor foi o vga=773. Com ele, a tela de carregamente aparece, só que fica caida para a direita. Mesmo assim obrigado.

  Segue o meu menu.lts:
Citar
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default      0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout      10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title      Windows 95/98/NT/2000
# root      (hd0,0)
# makeactive
# chainloader   +1
#
# title      Linux
# root      (hd0,1)
# kernel   /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=e6483e74-957e-49c9-a37f-2bf84f53ac5b ro
# kopt_2_6=root=/dev/hda2 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,1)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash locale=pt_BR

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## ## End Default Options ##

title      Ubuntu, kernel 2.6.17-10-386
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.17-10-386 root=/dev/hda2 ro quiet splash locale=pt_BR vga=773
initrd      /boot/initrd.img-2.6.17-10-386
quiet
savedefault
boot

title      Ubuntu, kernel 2.6.17-10-386 (recovery mode)
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.17-10-386 root=/dev/hda2 ro single
initrd      /boot/initrd.img-2.6.17-10-386
boot

title      Ubuntu, memtest86+
root      (hd0,1)
kernel      /boot/memtest86+.bin
quiet
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title      Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title      Microsoft Windows XP Professional
root      (hd0,0)
savedefault
makeactive
chainloader   +1

"Ao se deparar com um problema, a primeira atitude deve ser a busca de soluções, e não a de culpados."
Lauro Adriano

Offline Network-Coder

  • Usuário Ubuntu
  • *
  • Mensagens: 52
    • Ver perfil
Re: Monitor fora de frequência
« Resposta #11 Online: 29 de Dezembro de 2006, 12:40 »
Código: [Selecionar]
sudo gedit /etc/usplash.conf

HF = Horizontal Frequence

 :-\

K.O

irc.freenode.net - #nerd_republic go! go! go!