Autor Tópico: Instalar um programa a partir do source  (Lida 1495 vezes)

Offline _Seven_

  • Usuário Ubuntu
  • *
  • Mensagens: 38
    • Ver perfil
Instalar um programa a partir do source
« Online: 30 de Dezembro de 2006, 12:27 »
Quero instalar a ultima versao do geany e entao saquei o source e agora pretendo instalar. Seguindo as instruçoes dadas para instalar o geany depois de usar o comando ./configure aparece a seguinte mensagem de erro:

"checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for PACKAGE... configure: error: Package requirements (gtk+-2.0 >= 2.6.0) were not met:

No package 'gtk+-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PACKAGE_CFLAGS
and PACKAGE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details."

O que tenho de fazer para resolver este problema?
Desde já obrigado pela explicação
By Seven

Offline tfmoraes

  • Usuário Ubuntu
  • *
  • Mensagens: 444
    • Ver perfil
Re: Instalar um programa a partir do source
« Resposta #1 Online: 30 de Dezembro de 2006, 17:09 »
Eu acho que você preciso instalar o libgtk2.0-dev:
# apt-get install libgtk2.0-dev

Offline JeffersonX

  • Usuário Ubuntu
  • *
  • Mensagens: 442
  • Linux User: #364092
    • Ver perfil
Re: Instalar um programa a partir do source
« Resposta #2 Online: 30 de Dezembro de 2006, 19:27 »
Outra dica amigo, instala o build-essential. É uma mão na roda. Também procura a dica do auto apt. Ele facilita compilação de programas baixando as bibliotecas faltantes para o processo.

EDIT:
Segura aí!
http://ubuntuforum-pt.org/index.php?topic=14706.0
Linux Professional Institute Certified - Level 1, Novell CLA - Certified Linux Administrator, Microsoft Certified Professional - Windows Server 2003, ITIL Foundation Certified
Meu Blog: http://tibyjeffersonx.blogspot.com