Autor Tópico: Problema com Locale - Solução  (Lida 6941 vezes)

Evitark

  • Visitante
Problema com Locale - Solução
« Online: 19 de Novembro de 2005, 10:28 »
Olá pessal!
Bem, eu instalei o Ubuntu há mais ou menos uma semana (Já tinha recebido os CDs há vários meses... hehehe), e desde então eu praticamente larguei o Windows! Tinha usado várias distribuições, como Kurumin, Slackware, SuSE, Mandrake, Conectiva, mas nunca conseguia me acostumar, e acabava voltando pro OS da Micro$oft.
Enfim, depois de instalar o Ubuntu, eu comecei a fuçar, como todo bom newbie que quer aprender, e acabei instalando uma versão do libc6 (libc6_2.3.4-3_i386.deb) que acabou gerando aquele famoso erro de locale que alguma pessoas tem recebido, e também aquele problema um tanto quanto chato de apertar " ' " + "c"  e aparecer um C com acento.
Depois de muita pesquisa no Google, até mesmo para entender o que era o tal Locale, descobri que isso era problema de codificação. Parece que a nova "versão" do UTF-8 gera o C acentuado quando pressionamos essa combinação de teclas porque no Russo isso é muito utilizado, e lá estavam tendo problemas. Para exibir o C com cedilha, tinha que apertar "alt gr" + " ," (vírgula) e depois a tecla C. Mas achei isso bastante incômodo, já que o alt gr fica em uma posição bastante desconfortável. Então fui atrás da solução, mesmo sem saber com o que estava mexendo : )
E o resultado foi que finalmente consegui resolver! Pelo menos no meu caso, o problema era aparentemente com o libc6 que eu instalei. Então baixei a versão 2.3.2.ds1-20 (http://www.op2.dk/debianmirror/pool/main/g/glibc/libc6_2.3.2.ds1-20_i386.deb) e instalei. Depois disso digitei

Código: [Selecionar]
sudo apt-get -f install

e ele removeu um pacote que não me lembro exatamente o nome, desculpe :oops:
Aí, quando ele acabou de remover, eu digitei
Código: [Selecionar]
sudo apt-get install libc6
e também
Código: [Selecionar]
sudo apt-get install locales

Quando acabou o download dos 2 pacotes ( em torno de 8mb) e a instalação, eu reiniciei o Ubuntu, e pronto! Estava resolvido o problema, com o ç funcionando normalmente, e sem aquelas mensagens de erro no locale : )

Como eu já disse, sou iniciante no Linux, comecei a utilizá-lo de verdade há uma semana, então já vou pedir desculpas caso tenha escrito alguma besteira, ou caso esse problema já tenha sido solucionado antes. Mas eu acredito que não tenha, visto que eu procurei nesse fórum, e no fórum em inglês, e não achei absolutamente nada.
Qualquer adição de usuários mais experientes será muito bem-vinda : )

Até mais!

Offline AlexBR

  • Usuário Ubuntu
  • *
  • Mensagens: 391
    • Ver perfil
Problema com Locale - Solução
« Resposta #1 Online: 19 de Novembro de 2005, 12:49 »
Meu, que coisa louca! Quando você instala essa versão do lib6, na verdade, você está fazendo um downgrade deste pacote. Assim, quando você faz apt-get install libc6, você instala a mesma versão do lib6 que havia antes no teu sistema.  Quer dizer.. trocou 6 por meia-dúzia. Assim, não sei o que esse pacote libc6_2.3.2.ds1 pode ter feito pra ter solucionar o problema.

Evitark

  • Visitante
Problema com Locale - Solução
« Resposta #2 Online: 19 de Novembro de 2005, 13:53 »
Quanto à parte do downgrade eu concordo, realmente instalei uma versão mais antiga do pacote e voltou a funcionar. Mas trocar 6 por meia dúzia acho que não, hehehe... tinha um número diferente nos 2 pacotes.
O pacote que eu baixei e instalei manualmente é libc6_2.3.2.ds1-20_i386. A versão que o apt-get instalou é libc6_2.3.2.ds1-23_i386.
Eu não faço a menor idéia do que seja esse número que alterou, mas números maiores indicam versões mais recentes : ) Então downgrade não foi...
O que eu acho que deve ter corrigido o problema, foi que quando tava instalando o Locale, ele exibiu uma mensagem que estava "reconstruindo as entradas". Só falta agora alguma outra pessoa, que estiver com esse problema, testar e ver se realmente funciona a solução que eu encontrei.
O único problema é que depois de reinstalar esse locale, o Ubuntu ficou meio português meio inglês... mas isso acho que é fácil de resolver.

Offline AlexBR

  • Usuário Ubuntu
  • *
  • Mensagens: 391
    • Ver perfil
Problema com Locale - Solução
« Resposta #3 Online: 19 de Novembro de 2005, 14:56 »
Sim, foi um downgrade. [:)] A versão padrão do Ubuntu é a 2.3.5. Eu acho que você deve ter alterado o source.list padrão instalado pelo Ubuntu. No seu source.list atual, a versão mais recente do lib6 é a 2.3.2. Assim, isso tudo que você fez teria o mesmo efeito que um apt-get --reinstall install lib6, ou seja, trocaria a versão libc6 2.3.5-1ubuntu12 (padrão do Ubuntu) pela versão que resolveu o seu problema (libc6_2.3.2.ds1-23).

Coloca aqui o conteúdo do seu source.list pra gente ver.

Para deixar o seu ubuntu 100% português novamente, tente fazer dpkg-reconfigure locales.

Evitark

  • Visitante
Problema com Locale - Solução
« Resposta #4 Online: 19 de Novembro de 2005, 15:20 »
Ah sim, eu alterei o sources.list várias vezes : ) Peguei uns repositórios que tem aqui mesmo no fórum... como já disse eu quase não tenho noção do que to fazendo, então se tivé alguma coisa muito errada é só me falar... :P
Citar

# Aplicativos (BR)
deb http://br.archive.ubuntu.com/ubuntu hoary main restricted universe multiverse
deb-src http://br.archive.ubuntu.com/ubuntu hoary main restricted universe multiverse

# Atualização (BR)
deb http://br.archive.ubuntu.com/ubuntu hoary-updates main restricted universe multiverse
deb-src http://br.archive.ubuntu.com/ubuntu hoary-updates main restricted universe multiverse

# Segurança
deb http://security.ubuntu.com/ubuntu hoary-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu hoary-security main restricted universe multiverse

## Skype
deb http://download.skype.com/linux/repos/debian/ stable non-free

## Backports
deb http://archive.ubuntu.com/ubuntu hoary-backports main restricted universe multiverse
deb http://ubuntu-backports.mirrormax.net/ hoary-extras main universe multiverse restricted

# Pacotes raros
#deb http://www.rarewares.org/debian/packages/unstable/ ./

# Poucos pacotes, entre eles gaim-vv
#deb http://people.debian.org/~smimram/debian/ unstable main

deb ftp://ftp.nerim.net/debian-marillat/ etch main


Esse último, se não me engano, é para tentar instalar os drivers da NVidia, que ainda não deu certo...
E também não consegui colocar o Ubuntu 100% em português com isso ae que vc me falou :P mas sem problemas, sei bem ingles... acho que isso é o de menos.