Autor Tópico: pacotes debian do OSS  (Lida 6861 vezes)

Offline Canellas

  • Usuário Ubuntu
  • *
  • Mensagens: 62
    • Ver perfil
pacotes debian do OSS
« Online: 21 de Novembro de 2005, 10:11 »
Olá!



Alguém sabe quais são os pacotes necessários para instalar o OSS?



Eu instalei o Ubuntu 5.10 num Toshiba CDT 4025, consegui fazer o som funcionar(http://ubuntuforum-pt.org/index.php?topic=1798), mas não consigo controlar o volume, q fica muito baixo.



Eu tentei instalar o pacote 'sndconfig', mas não achei. Tentei baixar o .deb mas houve erro de compatibilidade (não anotei...) com pgms já instalados.



[]s

Offline eggx.geo

  • Usuário Ubuntu
  • *
  • Mensagens: 222
    • Ver perfil
pacotes debian do OSS
« Resposta #1 Online: 21 de Novembro de 2005, 12:58 »
Se for só o problema de Som Baixo,

De uma olhada neste tópico.

http://ubuntuforum-pt.org/index.php?topic=975

Pode ser que ajude.
Egg

Offline Canellas

  • Usuário Ubuntu
  • *
  • Mensagens: 62
    • Ver perfil
pacotes debian do OSS
« Resposta #2 Online: 21 de Novembro de 2005, 13:25 »
O problema é q qdo executo o 'alsamixer' acontece isso:

alsamixer: function snd_ctl_open failed for default: No such file or directory

E qdo faço

# ls -la /dev/sndstat
lrwxrwxrwx  1 root root 24 2005-11-21 07:25 /dev/sndstat -> /proc/asound/oss/sndstat

o link '/dev/sndstat' está quebrado.

[]

Offline eggx.geo

  • Usuário Ubuntu
  • *
  • Mensagens: 222
    • Ver perfil
pacotes debian do OSS
« Resposta #3 Online: 21 de Novembro de 2005, 13:35 »
Realmente não sei o que pode ser.

Tem algumas coisas que você pode fazer para ver o que acontece com o som.

Já alterou as configurações em sistema/preferencias/seletor de sistemas multimidia.

Você já se certificou se o controle de volume do seu toshiba está no máximo?
Egg

Offline Canellas

  • Usuário Ubuntu
  • *
  • Mensagens: 62
    • Ver perfil
pacotes debian do OSS
« Resposta #4 Online: 21 de Novembro de 2005, 14:04 »
Já tentei as 2 coisas

No 'sistema/preferencias/seletor de sistemas multimidia', eu coloquei no primeiro combo-box (eu não estou c/ o notebook aqiu) p/ usar o OSS, só assim q consegui som, mas o volume... nada feito

Offline eggx.geo

  • Usuário Ubuntu
  • *
  • Mensagens: 222
    • Ver perfil
pacotes debian do OSS
« Resposta #5 Online: 21 de Novembro de 2005, 14:50 »
Tentou colocar sistema ESD para ver o que acontece?
Egg

Offline Canellas

  • Usuário Ubuntu
  • *
  • Mensagens: 62
    • Ver perfil
pacotes debian do OSS
« Resposta #6 Online: 21 de Novembro de 2005, 15:06 »
No 'sistema/preferencias/seletor de sistemas multimidia'? Já, e o resultado é uma msg de q não foi possível criar um "encanamento" (é isso mesmo o q aparece) p/ fazer o teste.

Offline eggx.geo

  • Usuário Ubuntu
  • *
  • Mensagens: 222
    • Ver perfil
pacotes debian do OSS
« Resposta #7 Online: 21 de Novembro de 2005, 16:42 »
Canellas,

Tem essa dica no Ubuntuguide Antiga (versão do 5.04 ainda), mas que resolvia muitos problemas no som.

Talvez possa te ajudar.

Código: [Selecionar]

Q: How to configure sound to work properly in GNOME?


sudo killall esd
sudo cp /etc/esound/esd.conf /etc/esound/esd.conf_backup
sudo gedit /etc/esound/esd.conf

   4. Find this section

...
auto_spawn=0
spawn_options=-terminate -nobeeps -as 5
...

   5. Replace with the following lines

auto_spawn=1
spawn_options=-terminate -nobeeps -as 2 -d default

   6. Save the edited file (sample)
   7.

sudo apt-get install libesd-alsa0
sudo gedit /etc/asound.conf

   8. Insert the following lines into the new file

pcm.card0 {
type hw
card 0
}

pcm.!default {
type plug
slave.pcm "dmixer"
}

pcm.dmixer {
type dmix
ipc_key 1025
slave {
pcm "hw:0,0"
period_time 0
period_size 2048
buffer_size 32768
rate 48000
}
bindings {
0 0
1 1
}
}

   9. Save the edited file (sample)
  10.

sudo ln -fs /usr/lib/libesd.so.0 /usr/lib/libesd.so.1

  11. System -> Preferences -> Sound
  12. Sound preferences

General Tab -> Sounds for events (Un-Checked)



Você pode tentar.

Boa sorte
Egg

Offline Canellas

  • Usuário Ubuntu
  • *
  • Mensagens: 62
    • Ver perfil
pacotes debian do OSS
« Resposta #8 Online: 21 de Novembro de 2005, 17:25 »
Assim  q chegar em casa vou testar. Valeu!

Offline Canellas

  • Usuário Ubuntu
  • *
  • Mensagens: 62
    • Ver perfil
pacotes debian do OSS
« Resposta #9 Online: 21 de Novembro de 2005, 19:27 »
nenhuma alteração...

Offline tH.

  • Usuário Ubuntu
  • *
  • Mensagens: 64
    • Ver perfil
pacotes debian do OSS
« Resposta #10 Online: 21 de Novembro de 2005, 21:21 »
Bom eu tive problemas com o OSS também, mas no meu caso o problema foi que os modulos deles nao estavam sendo carregados(quanta raiva passei pra perceber isso), mas ele estava lá
caso vc digite $ lsmod | grep oss
e nao apareca nada, tente isso:
$ sudo modprobe snd-pcm-oss
$ sudo modprobe snd-mixer-oss
pra testar:
$ gnome-sound-properties
selecione OSS e teste


edit: infelizmente acho que a minha reposta nao vai ajudar em nada, mas talvez a google ache algo pra vc