Autor Tópico: sudo apt-get dist-upgrade ERRO com dpkg udev  (Lida 260 vezes)

Offline cunhaandre

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
sudo apt-get dist-upgrade ERRO com dpkg udev
« Online: 01 de Julho de 2019, 15:02 »
Olá,

Quando executo este comando "sudo apt-get dist-upgrade", acontece isto:

A ler as listas de pacotes... Pronto
A construir árvore de dependências       
A ler a informação de estado... Pronto
Você pode querer executar 'apt --fix-broken install' para corrigir isso.
Os pacotes a seguir têm dependências não satisfeitas:
 eudev : Depende: libeudev1 (= 232:3.2.7.3) mas não está instalado
         Estraga: systemd (> 220) mas 241-5 está instalado
 init : Pré-Depende: systemd-sysv mas não está instalado ou
                      sysvinit-core mas não está instalado ou
                      runit-init mas não é instalável
 xserver-xorg-input-aiptek : Depende: xorg-input-abi-24
                             Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-input-elographics : Depende: xorg-input-abi-24
                                  Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-input-evdev : Depende: xorg-input-abi-24
                            Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-input-joystick : Depende: xorg-input-abi-24
                               Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-input-kbd : Depende: xorg-input-abi-24
                          Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-input-libinput : Depende: xorg-input-abi-24
                               Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-input-synaptics : Depende: xorg-input-abi-24
                                Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-amdgpu : Depende: xorg-video-abi-23
                             Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-ati : Depende: xorg-video-abi-23
                          Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-cirrus : Depende: xorg-video-abi-23
                             Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-fbdev : Depende: xorg-video-abi-23
                            Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-glide : Depende: xorg-video-abi-23
                            Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-intel : Depende: xorg-video-abi-23
                            Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-mach64 : Depende: xorg-video-abi-23
                             Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-mga : Depende: xorg-video-abi-23
                          Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-neomagic : Depende: xorg-video-abi-23
                               Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-nouveau : Depende: xorg-video-abi-23
                              Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-openchrome : Depende: xorg-video-abi-23
                                 Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-qxl : Depende: xorg-video-abi-23
                          Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-r128 : Depende: xorg-video-abi-23
                           Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-radeon : Depende: xorg-video-abi-23
                             Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-savage : Depende: xorg-video-abi-23
                             Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-siliconmotion : Depende: xorg-video-abi-23
                                    Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-sisusb : Depende: xorg-video-abi-23
                             Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-tdfx : Depende: xorg-video-abi-23
                           Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-trident : Depende: xorg-video-abi-23
                              Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-vesa : Depende: xorg-video-abi-23
                           Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
 xserver-xorg-video-vmware : Depende: xorg-video-abi-23
                             Depende: xserver-xorg-core (>= 2:1.18.99.901) mas não está instalado
E: Dependências não satisfeitas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).
root@linux:/home/linux#


Em seguida executo este comando "apt --fix-broken install" e acontece isto:

A ler as listas de pacotes... Pronto
A construir árvore de dependências       
A ler a informação de estado... Pronto
A corrigir dependências... Feito
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
  klibc-utils libatasmart4 libelogind0 libexpect-perl libfile-copy-recursive-perl
  libgcr-3-common libglide3 libio-pty-perl libio-stty-perl libklibc libudisks2-0
  libxatracker2 libxfont1 libxfont2 libxvmc1 linux-base live-usb-maker-gui-antix
  samba-common set-screen-blank-antix
Utilize 'sudo apt autoremove' para os remover.
The following additional packages will be installed:
  libeudev1 systemd-sysv
Serão REMOVIDOS os seguintes pacotes:
  eudev libudev1 xserver-xorg-input-aiptek xserver-xorg-input-all
  xserver-xorg-input-elographics xserver-xorg-input-evdev xserver-xorg-input-joystick
  xserver-xorg-input-kbd xserver-xorg-input-libinput xserver-xorg-input-synaptics
  xserver-xorg-video-all xserver-xorg-video-amdgpu xserver-xorg-video-ati
  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-glide
  xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-neomagic xserver-xorg-video-nouveau xserver-xorg-video-openchrome
  xserver-xorg-video-qxl xserver-xorg-video-r128 xserver-xorg-video-radeon
  xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sisusb
  xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-vesa
  xserver-xorg-video-vmware
Serão instalados os seguintes NOVOS pacotes:
  libeudev1 systemd-sysv
0 pacotes actualizados, 2 pacotes novos instalados, 32 a remover e 31 não actualizados.
1 pacotes não totalmente instalados ou removidos.
É necessário obter 184 kB de arquivos.
Após esta operação, será libertado 17,1 MB de espaço em disco.
Deseja continuar? [S/n] s
Obter:1 http://ftp.pt.debian.org/debian stretch/main i386 systemd-sysv i386 232-25+deb9u11 [82,4 kB]
Obter:2 http://ftp.cica.es/mirrors/Linux/MX-Packages/antix/stretch stretch/main i386 libeudev1 i386 232:3.2.7.3 [102 kB]
Obtidos 184 kB em 1s (191 kB/s)                                       
(A ler a base de dados ... 139488 ficheiros e directórios actualmente instalados.)
A remover eudev (232:3.2.7.3) ...
No udevd found running; none killed.
dpkg: erro ao processar o pacote eudev (--remove):
 o subprocesso instalado, do pacote eudev, o script pre-removal retornou erro do status de saída 1
Foram encontrados erros enquanto processava:
 eudev
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@linux:/home/linux#


Alguém poderá explicar-me como posso resolver este problema e porque é que isto acontece?

Obrigado.



Offline swatquest

  • Usuário Ubuntu
  • *
  • Mensagens: 139
    • Ver perfil
Re:sudo apt-get dist-upgrade ERRO com dpkg udev
« Resposta #1 Online: 17 de Julho de 2019, 00:43 »
tenta reinstalar tudo

https://unix.stackexchange.com/questions/79125/reinstalling-all-debian-packages

dpkg --get-selections > selections
sudo dpkg --clear-selections
sudo dpkg --set-selections < selections
sudo apt-get --reinstall dselect-upgrade

Offline selvaking

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.038
  • Parque Anchieta - Rio de Janeiro - RJ
    • Ver perfil
Re:sudo apt-get dist-upgrade ERRO com dpkg udev
« Resposta #2 Online: 17 de Julho de 2019, 09:41 »
Código: [Selecionar]
sudo apt -f install
Dê-me um computador com o Tux que movo o mundo!

Linux User #323049

Offline nomade

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.141
  • O negócio não tem alma
    • Ver perfil
Re:sudo apt-get dist-upgrade ERRO com dpkg udev
« Resposta #3 Online: 17 de Julho de 2019, 17:42 »
Pra quê você tem essas duas fontes de softwares?

Citar
Obter:1 http://ftp.pt.debian.org/debian stretch/main i386 systemd-sysv i386 232-25+deb9u11 [82,4 kB]
Obter:2 http://ftp.cica.es/mirrors/Linux/MX-Packages/antix/stretch stretch/main i386 libeudev1 i386 232:3.2.7.3 [102 kB]

Quase certeza que elas não são para o Ubuntu.
Não é tudo a mesma coisa. Debian e Ubuntu seguem caminhos diferentes em relação a versão de pacotes.
Se adicionar PPAs, faça só de PPAs para o Ubuntu na versão que usa.
Essas PPAs aí estão causando o erro.

Vai em Softwares e Updates e experimente remover elas, depois:

Código: [Selecionar]
sudo apt update && sudo apt full-upgrade -y
« Última modificação: 17 de Julho de 2019, 18:01 por nomade »
Rodando Ubuntu 18.04 com: AMD Ryzen 5 2600 3.4GHz/ Gigabyte A320M-S2H/ 8GB 2400MHz DDR4/ Radeon R7 260X 2GB GDDR5