Autor Tópico: Arquivo $HOME/.dmrc ignorado  (Lida 32486 vezes)

Offline JFMMão de Ferro

  • Usuário Ubuntu
  • *
  • Mensagens: 638
  • Morada: Angra do Heroísmo - Açores
    • Ver perfil
Re: Arquivo $HOME/.dmrc ignorado
« Resposta #45 Online: 10 de Junho de 2009, 11:31 »
Também estou com este problema em que a redacção do aviso é um pouco diferente

O ficheiro $HOME/.dmrc do utilizador está a ser ignorado. Isto impede que o idioma e a sessão por omissão sejam gravados. O ficheiro deve pertencer ao utilizador e possuir permissões 644. O diretório $HOME do utilizador deverá pertencer ao utilizador e não permitir a escrita a outros utilizadores

Isto apareceu depois de tentativas para me ligar a outra máquina em que,no NAUTILUS dei permissão de partilha a HOME , tenho muita dificuldade em escrever isto, nem me vou atrever a desligar a máquina, tenho o pressentimento que depois não vou acessá-la,não posso voltar atrás para corrigir a redacção ou acrescentar algum acento porque apaga tudo , seguem comandos que executei
chown jfmmf /home/jfmmf
chgrp jfmmf /home/jfmmf
rm /.dmrc
não é possível remover /.dmrc : Ficheiro ou directoria inexistente
rm /home/jfmmf/.dmrc
chmod 770 /home/jfmmf
chown jfmmf /home/jfmmf
chrgp jfmmf /home/jfmmf
chmod 644 /home/jfmmf
rm /home/jfmmf/.dmrc
não é possível remover /home/jfmmf/.dmrc :Permissão negada

Antes das tentativas acima feitas dei com o ficheiro .dmrc que continha ou contém isto
 [desktop]
Session=default

Nem vou fechar a CONSOLA na esperança de haver uma ajuda apesar da diferença horária

João Fernando Machado Mão de Ferro

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.279
    • Ver perfil
Re: Arquivo $HOME/.dmrc ignorado
« Resposta #46 Online: 10 de Junho de 2009, 12:39 »
Olá colega, tipo creio eu que neste próprio tópico tem a solução do seu problemas, mas por ver seu desespero
tente assim.

Código: [Selecionar]
sudo chown jfmmf:jfmmf /home/jfmmf/*.*
sudo chmod 644 /home/jfmmf/.dmrc

caso persista o erro, coloque o log do arquivo .xsession-errors aqui para vermos.

Offline JFMMão de Ferro

  • Usuário Ubuntu
  • *
  • Mensagens: 638
  • Morada: Angra do Heroísmo - Açores
    • Ver perfil
Re: Arquivo $HOME/.dmrc ignorado
« Resposta #47 Online: 10 de Junho de 2009, 13:36 »
Olá colega, tipo creio eu que neste próprio tópico tem a solução do seu problemas, mas por ver seu desespero
tente assim.

Código: [Selecionar]
sudo chown jfmmf:jfmmf /home/jfmmf/*.*
sudo chmod 644 /home/jfmmf/.dmrc

caso persista o erro, coloque o log do arquivo .xsession-errors aqui para vermos.
Executei os comandos obtenho a informação:
chmod: não consigo aceder a '/home/jfmmf/.dmrc : Ficheiro ou directoria inexistente

                             O log do arquivo .xsession-errors

/etc/gdm/Xsession: Beginning session setup...
Setting IM through im-switch for locale=pt_PT.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
SESSION_MANAGER=local/Pessoal:/tmp/.ICE-unix/6050
** Message: another SSH agent is running at: /tmp/ssh-qGUeyj6050/agent.6050
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
Shutdown failed or nothing to shut down.
/usr/share/themes/Human/gtk-2.0/gtkrc:51: Invalid symbolic color 'metacity_frame_color'
/usr/share/themes/Human/gtk-2.0/gtkrc:51: error: invalid identifier `metacity_frame_color', expected valid identifier
xrdb:  "*Label.background" on line 220 overrides entry on line 150
xrdb:  "*Text.background" on line 226 overrides entry on line 191
xrdb:  "*Label.foreground" on line 232 overrides entry on line 151
xrdb:  "*Text.foreground" on line 238 overrides entry on line 192
Checking for Xgl: gpilotd-Message: gnome-pilot 2.0.15 starting...
gpilotd-Message: compiled for pilot-link version 0.12.3
gpilotd-Message: compiled with [VFS] [USB] [IrDA] [Network]
not present.
Detected PCI ID for VGA: 01:00.0 0300: 10de:0422 (rev a1) (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: seahorse nautilus module initialized
present.
Checking for non power of two support: present.
Checking for Composite extension: Initializing nautilus-share extension
present.
Comparing resolution (1280x1024) to maximum 3D texture size (8192): Passed.
Checking for nVidia: present.


Tracker version 0.6.6 Copyright (c) 2005-2007 by Jamie McCracken (jamiemcc@gnome.org)

This program is free software and comes without any warranty.
It is licensed under version 2 or later of the General Public License which can be viewed at http://www.gnu.org/licenses/gpl.txt

Initialising tracker...
Checking for FBConfig: present.
Could not set idle IO priority...attempting best effort 7 priority
starting HAL detection for ac adaptors...none found
11
Checking for Xgl: not present.

** (nautilus:6204): WARNING **: Unable to add monitor: Não suportado
Throttle level is 0
evolution-alarm-notify-Message: Setting timeout for 40231 1244678400 1244638169
evolution-alarm-notify-Message:  Thu Jun 11 00:00:00 2009

evolution-alarm-notify-Message:  Wed Jun 10 12:49:29 2009

evolution-alarm-notify-Message: Setting timeout for 40231 1244678400 1244638169
evolution-alarm-notify-Message:  Thu Jun 11 00:00:00 2009

evolution-alarm-notify-Message:  Wed Jun 10 12:49:29 2009


(gnome-panel:6201): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -3 and height 32

(gpilotd:6216): libgpilotdcm-WARNING **: Número de dispositivos é 0

(gpilotd:6216): libgpilotdcm-WARNING **: Não está disponível nenhum dispositivo acedivel

(gpilotd:6216): libgpilotdcm-WARNING **: Number of PDAs is configured to 0
gpilotd-Message: Activating CORBA server
gpilotd-Message: bonobo_activation_active_server_register = 0

(evolution-alarm-notify:6253): evolution-alarm-notify-WARNING **: Incapaz de criar a fábrica de serviço de notificação de alarme, talvez já se encontre em execução...
Starting gtk-window-decorator
Debug: Done reading conf from /etc/beagle/config-files/BeagleSearch.xml
/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
Got accel 65481, 0, 0
Got keycode 96
Got modmask 0
Debug: Done reading conf from /etc/beagle/config-files/Daemon.xml
Got Event! 33, -1
Got Event! 33, -1
/usr/bin/compiz.real (cube) - Warn: Failed to load slide:
connect: Operação agora em progresso
  PID TTY          TIME CMD
 6146 ?        00:00:00 pulseaudio
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)

(firefox:6481): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(firefox:6481): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
(firefox:6481): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(firefox:6481): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)'

...Too much output, ignoring rest...


Agora pergunto será que depois daqueles comandos é preciso reeniciar ?

Muito reconhecidamente agradeço a sua resposta
« Última modificação: 10 de Junho de 2009, 14:02 por JFMMão de Ferro »

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.279
    • Ver perfil
Re: Arquivo $HOME/.dmrc ignorado
« Resposta #48 Online: 10 de Junho de 2009, 13:57 »
Você deve ter apagado o arquivo, não há necessidade de reiniciar faça um logout e um novo login e digite
Código: [Selecionar]
sudo /etc/init.d/gdm restartpara ver o conteudo do .xsession-errors
digite.

Código: [Selecionar]
cat .xsession-errors
levando em consideração que você está em seu diretório /home

Offline JFMMão de Ferro

  • Usuário Ubuntu
  • *
  • Mensagens: 638
  • Morada: Angra do Heroísmo - Açores
    • Ver perfil
Re: Arquivo $HOME/.dmrc ignorado
« Resposta #49 Online: 10 de Junho de 2009, 16:40 »
Você deve ter apagado o arquivo, não há necessidade de reiniciar faça um logout e um novo login e digite
Código: [Selecionar]
sudo /etc/init.d/gdm restartpara ver o conteudo do .xsession-errors
digite.

Código: [Selecionar]
cat .xsession-errors
levando em consideração que você está em seu diretório /home


Pode crer  que o desespero era tão grande que suava mas a sua ajuda valeu de muito e estou-lhe reconhecido, só que ainda tenho dois agraves em Sistema >Administração >Rede  ----  Não consigo destrancar
E também em Sistema  >Administração Utilizadores e Grupos  ----  Não Consigo destrancar

A palavra passe não é aceite