Autor Tópico: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04  (Lida 46455 vezes)

alarcon

  • Visitante
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #15 Online: 24 de Junho de 2007, 09:51 »
Olá Gabriel.goc

A instalação ocorre sem erros, tive a curiosidade de olhar todos os passos da instalaçao que aparecem no terminal e não vi nenhum erro. Troquei de provedor, tentei Oi internet, Ig, mas deu na mesma. Com Oi Internet foi até pior. Se vc achar necessário, posso instalar tudo novamente e mandar para vc a tela do terminal de instalação.
Mas não houve, em momento algum mensagem de erro.
Podemos verificar manualmente a rota que o apt-get segue para se conectar a internet? Talvez o problema esteja na rota que ele está apontando. Talvez seja um erro durante a instalação do sistema. Será que podemos verificar este parâmetro e talvez modificá-lo?
Achamos que ele estava apontando para a placa de rede, mesmo desabilitada, e se ainda continua apontando, não podemos forçar uma mudança de rota?
Já troquei o CD Live durante a instalação e deu o mesmo, verifiquei se o CD não estava sujo ou arranhado para não comprometer a gravação.
No último caso espero o lançamento da próxima versão; quem sabe.

De qualquer modo agradeço muitíssimo a ajuda, e a paciência, de todos voces, e vamos continuar tentando, pois a coisa esta ficando cada vez mais interessante.

Caro jaioliver é muito estranho o que ocorre com você, mas vamos tentar encontrar uma solução.

Cola aqui o resultado dos seguintes comandos (no terminal):

dmesg | grep slamr

ps -aux | grep slmodemd

lsmod

Agora tenta isso aqui também:

no terminal faça:

sudo ln -sf /dev/ttySL0 /dev/modem

sudo chmod 666 /dev/modem

Vá em Sistema > Administração > Rede na janela Configurações de rede que se abre clique em Conexão por modem e depois no botão Propriedades. Na janela Settings for interface ppp0 e na aba Geral marque habilitar esta conexão e entre com seus dados do provedor.

Na aba modem em porta do modem coloque /dev/modem e o resto coloque como for o seu caso. Na aba Opções marque a opção Definir o modem como rota padrão para internet e Usar os servidores de nome do provedor de internet. Por fim clique no ok.

Veja pra mim também o se nos seguintes arquivos chap-secrets e pap-secrets que se encontram em /etc/ppp/ existe, no final de cada arquivo, uma informação assim:

"user@provedor.com.br" * "senha1234"

onde user@provedor.com.br seria, obviamente, o seu nome de acesso do provedor e senha1234 sua senha de acesso do provedor. Isso para cada conta de provedor. O meu pacote só adiciona uma conta ok.

Para verificar isso faça:

sudo gedit /etc/ppp/chap-secrets

e

sudo gedit /etc/ppp/pap-secrets

bom por fim faça mais isso:

sudo chmod a+x /usr/sbin/pppd

Há, ia me esquecendo, no sua pasta de usuário dentro da /home/ tem um arquivo oculto chamado de .wvdial.conf em que o Init1 e o Init2 (padrão) deve ficar assim:

Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0


Mas para alguns usuários o Init2  padrão não serve, então veja se algum destes aqui:

Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0

Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2  +MS=34

Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2  +MS=90

funciona melhor no seu caso ok.

para editá-lo faça:

gedit .wvdial.conf




« Última modificação: 24 de Junho de 2007, 10:02 por alarcon »

Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #16 Online: 24 de Junho de 2007, 12:54 »
Caro Alarcon,

Respondendo a sua sugestão:

Resultado do comado:
dmesg | grep slamr

rosa@rosa-desktop:~$ dmesg | grep slamr
[   36.635767] slamr: module license 'Smart Link Ltd.' taints kernel.
[   36.821802] slamr: SmartLink AMRMO modem. [   36.829887]
slamr: probe 1106:3068 VIA3058 card...
[   36.990107] slamr: mc97 codec is SIL21
[   36.990168] slamr: slamr0 is VIA3058 card.

ps -aux | grep slmodemd

rosa@rosa-desktop:~$ ps -aux | grep slmodemd Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html root      4704  0.0  0.8   3908  3908 ?        SLs  10:48   0:00 /usr/sbin/slmodemd --perm=0666 -c BRAZIL /dev/slamr0 rosa      5597  0.0  0.1   2892   764 pts/1    R+   10:54   0:00 grep slmodemd

lsmod

rosa@rosa-desktop:~$ lsmod
Module                  Size  Used by
ipv6                  268704  8 
binfmt_misc            12680  1 
rfcomm                 40856  0 
l2cap                  25728  5 rfcomm
bluetooth              55908  4 rfcomm,l2cap
ppdev                  10116  0 
speedstep_lib           6148  0 
cpufreq_userspace       5408  0 
cpufreq_conservative     8200  0 
cpufreq_stats           7360  0 
cpufreq_powersave       2688  0 
cpufreq_ondemand        9228  0 
freq_table              5792  2 cpufreq_stats,cpufreq_ondemand
tc1100_wmi              8068  0 
sony_acpi               6284  0 
pcc_acpi               13184  0 
dev_acpi               12292  0 
video                  16388  0 
container               5248  0 
asus_acpi              17308  0 
button                  8720  0 
sbs                    15652  0 
backlight               7040  1 asus_acpi
battery                10756  0 
ac                      6020  0 
dock                   10268  0 
i2c_ec                  5888  1 sbs
af_packet              23816  0 
nls_utf8                3072  1 
ntfs                  107764  1 
lp                     12452  0 
fuse                   46612  0 
snd_via82xx            29208  1 
gameport               16520  1
snd_via82xx snd_mpu401_uart         9472  1
snd_via82xx snd_via82xx_modem      16008  0
snd_ac97_codec         98336  2 snd_via82xx,snd_via82xx_modem
ac97_bus                3200  1 snd_ac97_codec
snd_pcm_oss            44544  0 
snd_mixer_oss          17408  1 snd_pcm_oss
snd_seq_dummy           4740  0 
snd_seq_oss            32896  0 
snd_seq_midi            9600  0 
snd_rawmidi            25472  2 snd_mpu401_uart,snd_seq_midi
snd_seq_midi_event      8448  2 snd_seq_oss,snd_seq_midi snd_seq                52592  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_pcm                79876  4 snd_via82xx,snd_via82xx_modem,snd_ac97_codec,snd_pcm_oss
usblp                  14848  0 
snd_page_alloc         10888  3 snd_via82xx,snd_via82xx_modem,snd_pcm
parport_pc             36388  1  parport                36936  3 ppdev,lp,parport_pc
pcspkr                  4224  0 
i2c_viapro             10132  0 
i2c_core               22784  2 i2c_ec,i2c_viapro
snd_timer              23684  2 snd_seq,snd_pcm
snd_seq_device          9100  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    54020  14 snd_via82xx,snd_mpu401_uart,snd_via82xx_modem,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_seq_oss,snd_rawmidi,snd_seq,snd_pcm,snd_timer,snd_seq_device
slamr                 433448  2 
psmouse                38920  0 
serio_raw               7940  0 
shpchp                 34324  0 
pci_hotplug            32576  1 shpchp
soundcore               8672  1 snd
ungrab_winmodem         3712  0 
via_agp                11264  1 
agpgart                35400  1 via_agp
evdev                  11008  4 
tsdev                   8768  0 
ext3                  133128  1 
jbd                    59816  1 ext3
mbcache                 9604  1 ext3
ide_cd                 32672  0 
cdrom                  37664  1 ide_cd
ide_disk               17024  4 
via82cxxx              10372  0 [permanent]
generic                 5124  0 [permanent]
floppy                 59524  0 
via_rhine              25608  0 
mii                     6528  1 via_rhine
ehci_hcd               34188  0 
uhci_hcd               25360  0 
usbcore               134280  4 usblp,ehci_hcd,uhci_hcd
ata_generic             9092  0 
sata_via               12548  0 
libata                125720  2 ata_generic,sata_via
scsi_mod              142348  1 libata
thermal                14856  0 
processor              31048  1 thermal
fan                     5636  0 
fbcon                  42656  0 
tileblit                3584  1 fbcon
font                    9216  1 fbcon
bitblit                 6912  1 fbcon
softcursor              3200  1 bitblit
vesafb                  9220  0 
capability              5896  0 
commoncap               8192  1 capability


Para - sudo gedit /etc/ppp/chap-secrets
Na penultima linha "user@provedor.com.br" * "senha1234".
mas na última tem o “nomedeusuário”*”senhadeusuário”

Para -  sudo gedit /etc/ppp/pap-secrets
Idem anterior

Depois de sudo chmod a+x /usr/sbin/pppd e do uso dos Ini2 diferentes da ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0, que é que estava originalmente, o discador não funcionou mais.
Reinstalei só o discador mas continuou sem funcionar.
Aí reinstalei o pacote do drive completo, como se fosse a primeira vez e refiz os comandos sugeridos por vc. mas continuo na mesma, osistema não atualiza, o navegador funciona parcialmente e o apt-get upadate nem ver.

Desculpe pelo tamanho da mensagem, mas infelizmente é necessário.

Muit obrigado pela atenção dispensada.

alarcon

  • Visitante
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #17 Online: 24 de Junho de 2007, 13:23 »
Caro Alarcon,

Respondendo a sua sugestão:

Resultado do comado:
dmesg | grep slamr

rosa@rosa-desktop:~$ dmesg | grep slamr
[   36.635767] slamr: module license 'Smart Link Ltd.' taints kernel.
[   36.821802] slamr: SmartLink AMRMO modem. [   36.829887]
slamr: probe 1106:3068 VIA3058 card...
[   36.990107] slamr: mc97 codec is SIL21
[   36.990168] slamr: slamr0 is VIA3058 card.

ps -aux | grep slmodemd

rosa@rosa-desktop:~$ ps -aux | grep slmodemd Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html root      4704  0.0  0.8   3908  3908 ?        SLs  10:48   0:00 /usr/sbin/slmodemd --perm=0666 -c BRAZIL /dev/slamr0 rosa      5597  0.0  0.1   2892   764 pts/1    R+   10:54   0:00 grep slmodemd

lsmod

rosa@rosa-desktop:~$ lsmod
Module                  Size  Used by
ipv6                  268704  8 
binfmt_misc            12680  1 
rfcomm                 40856  0 
l2cap                  25728  5 rfcomm
bluetooth              55908  4 rfcomm,l2cap
ppdev                  10116  0 
speedstep_lib           6148  0 
cpufreq_userspace       5408  0 
cpufreq_conservative     8200  0 
cpufreq_stats           7360  0 
cpufreq_powersave       2688  0 
cpufreq_ondemand        9228  0 
freq_table              5792  2 cpufreq_stats,cpufreq_ondemand
tc1100_wmi              8068  0 
sony_acpi               6284  0 
pcc_acpi               13184  0 
dev_acpi               12292  0 
video                  16388  0 
container               5248  0 
asus_acpi              17308  0 
button                  8720  0 
sbs                    15652  0 
backlight               7040  1 asus_acpi
battery                10756  0 
ac                      6020  0 
dock                   10268  0 
i2c_ec                  5888  1 sbs
af_packet              23816  0 
nls_utf8                3072  1 
ntfs                  107764  1 
lp                     12452  0 
fuse                   46612  0 
snd_via82xx            29208  1 
gameport               16520  1
snd_via82xx snd_mpu401_uart         9472  1
snd_via82xx snd_via82xx_modem      16008  0
snd_ac97_codec         98336  2 snd_via82xx,snd_via82xx_modem
ac97_bus                3200  1 snd_ac97_codec
snd_pcm_oss            44544  0 
snd_mixer_oss          17408  1 snd_pcm_oss
snd_seq_dummy           4740  0 
snd_seq_oss            32896  0 
snd_seq_midi            9600  0 
snd_rawmidi            25472  2 snd_mpu401_uart,snd_seq_midi
snd_seq_midi_event      8448  2 snd_seq_oss,snd_seq_midi snd_seq                52592  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_pcm                79876  4 snd_via82xx,snd_via82xx_modem,snd_ac97_codec,snd_pcm_oss
usblp                  14848  0 
snd_page_alloc         10888  3 snd_via82xx,snd_via82xx_modem,snd_pcm
parport_pc             36388  1  parport                36936  3 ppdev,lp,parport_pc
pcspkr                  4224  0 
i2c_viapro             10132  0 
i2c_core               22784  2 i2c_ec,i2c_viapro
snd_timer              23684  2 snd_seq,snd_pcm
snd_seq_device          9100  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    54020  14 snd_via82xx,snd_mpu401_uart,snd_via82xx_modem,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_seq_oss,snd_rawmidi,snd_seq,snd_pcm,snd_timer,snd_seq_device
slamr                 433448  2 
psmouse                38920  0 
serio_raw               7940  0 
shpchp                 34324  0 
pci_hotplug            32576  1 shpchp
soundcore               8672  1 snd
ungrab_winmodem         3712  0 
via_agp                11264  1 
agpgart                35400  1 via_agp
evdev                  11008  4 
tsdev                   8768  0 
ext3                  133128  1 
jbd                    59816  1 ext3
mbcache                 9604  1 ext3
ide_cd                 32672  0 
cdrom                  37664  1 ide_cd
ide_disk               17024  4 
via82cxxx              10372  0 [permanent]
generic                 5124  0 [permanent]
floppy                 59524  0 
via_rhine              25608  0 
mii                     6528  1 via_rhine
ehci_hcd               34188  0 
uhci_hcd               25360  0 
usbcore               134280  4 usblp,ehci_hcd,uhci_hcd
ata_generic             9092  0 
sata_via               12548  0 
libata                125720  2 ata_generic,sata_via
scsi_mod              142348  1 libata
thermal                14856  0 
processor              31048  1 thermal
fan                     5636  0 
fbcon                  42656  0 
tileblit                3584  1 fbcon
font                    9216  1 fbcon
bitblit                 6912  1 fbcon
softcursor              3200  1 bitblit
vesafb                  9220  0 
capability              5896  0 
commoncap               8192  1 capability


Para - sudo gedit /etc/ppp/chap-secrets
Na penultima linha "user@provedor.com.br" * "senha1234".
mas na última tem o “nomedeusuário”*”senhadeusuário”

Para -  sudo gedit /etc/ppp/pap-secrets
Idem anterior

Depois de sudo chmod a+x /usr/sbin/pppd e do uso dos Ini2 diferentes da ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0, que é que estava originalmente, o discador não funcionou mais.
Reinstalei só o discador mas continuou sem funcionar.
Aí reinstalei o pacote do drive completo, como se fosse a primeira vez e refiz os comandos sugeridos por vc. mas continuo na mesma, osistema não atualiza, o navegador funciona parcialmente e o apt-get upadate nem ver.

Desculpe pelo tamanho da mensagem, mas infelizmente é necessário.

Muit obrigado pela atenção dispensada.


Olha só, nos arquivos chap-secrets e pap-secrets o nome de usuário deve ser completo (usuário@provedor.com.br) e não só o nome (usuário). Talvez seja este o seu problema. Isso por esta sua resposta:

Citar
Para - sudo gedit /etc/ppp/chap-secrets
Na penultima linha "user@provedor.com.br" * "senha1234".
mas na última tem o “nomedeusuário”*”senhadeusuário”

Para cada provedor que você usa deve ter uma linha correspondente nestes arquivos ( chap-secrets e pap-secrets) da forma como falei acima, ou seja, com o nome completo e a senha.

Como assim o discador não funcionou mais?

Quais foram os erros relatados?

reinstale o discador gnome-ppp que está no meu pacote, via terminal, assim:

sudo dpkg -i --force-all gnome-ppp_0.3.23-1_i386.deb

Você tentou conectar a internet também por aqui:

Citar
Vá em Sistema > Administração > Rede na janela Configurações de rede que se abre clique em Conexão por modem e depois no botão Propriedades. Na janela Settings for interface ppp0 e na aba Geral marque habilitar esta conexão e entre com seus dados do provedor.

Na aba modem em porta do modem coloque /dev/modem e o resto coloque como for o seu caso. Na aba Opções marque a opção Definir o modem como rota padrão para internet e Usar os servidores de nome do provedor de internet. Por fim clique no ok.

ao invés de usar o gnome-ppp.
« Última modificação: 24 de Junho de 2007, 13:47 por alarcon »

gabriel.goc

  • Visitante
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #18 Online: 24 de Junho de 2007, 17:41 »
Bom, o comando que faz apontar para o modem é este:
sudo route add default ppp0

Mas você utilizou ele depois que já estava conectado???

Flwss...

Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #19 Online: 24 de Junho de 2007, 19:58 »
Olá Alarcon,

As mensagens de erro do discador foi para as três sugestões de INIT2

ERROR
Band init string

Reinstalei o discador usando o procedimento padrão do pacote e voltou a funcionar; também tentei usando o ícone de rede e deu o mesmo resultado de quando utilizo o discador, conecta mas o resto...

Sim dei o comando sudo route add default ppp0
quando estava conectado e quando estava desconectado.
Mas confesso da desta última vez, dei o comando enquanto estava desconectado, vou tentar conectado.
Como tenho que reiniciar a máquina, deseje-me sorte.
« Última modificação: 24 de Junho de 2007, 20:38 por jaioliver »

Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #20 Online: 24 de Junho de 2007, 20:28 »
Olá Gabriel.goc,

Fiz o que vc sugeriu e ficamos na mesma:
o comando:
sudo route add default ppp0
teve como resposta:
SIOCADDRT - O arquivo já existe.
Um detalhe interessante:
quando conecto com o discador o ícone do monitor de rede pisca indicando o funcionamento,juntamente com o ícone do discador, mas o ícone de rede continua indicando que não nenhuma rede configurada. Quando conecto utilizando o ícone de rede, que agora aparece a opção:
Conecção discada - conectar via ppp0
o ícone do monitor de rede pisca, mas o ícone de rede continua informando que não há rede configurada disponível.
Mais uma coisa, quando ativo O gerenciador de atualizações os ícones do monitor de rede e do discador (quando eu conecto via discador) piscam, às vezes em sincronia, às vezes não, porém não conectar com nenhum site.
O Firefox também continua com o mesmo problema, algumas páginas ele abre, outras - como as do Ubuntu e do próprio Mozilla - não.
« Última modificação: 24 de Junho de 2007, 20:39 por jaioliver »

gabriel.goc

  • Visitante
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #21 Online: 24 de Junho de 2007, 20:39 »
pow..Muito estranho seu problema, mas me informa algumas coisas...
Vá em Sistemas>Administração>Rede...
Quais conexões tem??E quais estão ativas??
Na aba "geral", qual é o nome da máquina e do domínio??
E o que está listado na aba "máquinas"??

Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #22 Online: 24 de Junho de 2007, 21:19 »
Ola Gabriel.goc,

tenho duas conecções:
rede por fios  LAN - que esta desabilitada
por modem - que está ativa

o nome da máquina é rosa-desktop e não há domínio (está em branco)

na aba máquinas tem-se:
Endereço de IP            Apelidos
127.0.0.1                   localhost
127.0.1.1                   rosa-desktop
::1                            ip6-localhost ip6lookback
fe00::0                      ip6-localnet
ff00::0                       ip6-mcastprofix
ff02::1                       ip6-allmodes
ff02::2                       ip6-allrouters
ff02::3                       ip6-allhosts

outra coisa, quando inicio o sistema ele está sempre habilitando a rede por fios, entenda que deixo a conecção por modem habilitada anteriormente, e agora estava habilitada as duas modalidades(por fios e por modem). Desabilitei a rede por fios e testei; deu o resultado anterior.
Será que seria interessante desabilitar a placa de rede on-board no setup do pc?

gabriel.goc

  • Visitante
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #23 Online: 25 de Junho de 2007, 13:49 »
Ola Gabriel.goc,

tenho duas conecções:
rede por fios  LAN - que esta desabilitada
por modem - que está ativa


Faça esta alteração aqui também:
o nome da máquina é rosa-desktop e não há domínio (está em branco)

na aba máquinas tem-se:
Endereço de IP            Apelidos
127.0.0.1                   localhost
127.0.1.1                   rosa-desktop
::1                            ip6-localhost ip6lookback
fe00::0                      ip6-localnet
ff00::0                       ip6-mcastprofix
ff02::1                       ip6-allmodes
ff02::2                       ip6-allrouters
ff02::3                       ip6-allhosts

outra coisa, quando inicio o sistema ele está sempre habilitando a rede por fios, entenda que deixo a conecção por modem habilitada anteriormente, e agora estava habilitada as duas modalidades(por fios e por modem). Desabilitei a rede por fios e testei; deu o resultado anterior.
Será que seria interessante desabilitar a placa de rede on-board no setup do pc?

Bom, no  meu a conexão por fios está habilitada, e o modem está desabilitado, visto que eu uso o gnome-ppp, e não essa interface, você pode experimentar isso...

Endereço de IP            Apelidos
127.0.0.1                   localhost <<<< aqui add o nome do seu pc.

Vai ficar assim:
127.0.0.1                   localhost rosa-desktop

Para issso, selecione localhost, vá em propiedades... e coloque o nome do seu pc, am baixo do localhost..

Tente agora, se mesmo assim não conseguir, desabilite a sua placa de rede...

Aguardo resposta.
flws





Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #24 Online: 26 de Junho de 2007, 08:37 »
Olá Gabriel.goc,

Desculpe a demora mas foi por motivo de trabalho.
Fiz a mudança que vc sugeriu no endereço de IP e o sistema agora não ignora as mudanças na rede, quando reinicio o sistema mantem o modem. Mas continuo sem conseguir navegar corretamente e nem atualizar o sistema e nem instalar nada.
Fiz uma atualização através do APTonCD usando o computador do trabalho que foi instalado a partir do mesmo cd live, o sitema agora está em todo em portugues do Brasil e consegui instalar o APTonCD e foi só; o resto esta na mesma.

Podemos reinstalar o mozilla-firefox, o synaptic e/ou o apt-get para ver se funciona? Talvez este problema seja erro de instalação.

Agradeço a paciência e a atenção.

alarcon

  • Visitante
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #25 Online: 26 de Junho de 2007, 10:32 »
Ola Gabriel.goc,

tenho duas conecções:
rede por fios  LAN - que esta desabilitada
por modem - que está ativa

o nome da máquina é rosa-desktop e não há domínio (está em branco)

na aba máquinas tem-se:
Endereço de IP            Apelidos
127.0.0.1                   localhost
127.0.1.1                   rosa-desktop
::1                            ip6-localhost ip6lookback
fe00::0                      ip6-localnet
ff00::0                       ip6-mcastprofix
ff02::1                       ip6-allmodes
ff02::2                       ip6-allrouters
ff02::3                       ip6-allhosts

outra coisa, quando inicio o sistema ele está sempre habilitando a rede por fios, entenda que deixo a conecção por modem habilitada anteriormente, e agora estava habilitada as duas modalidades(por fios e por modem). Desabilitei a rede por fios e testei; deu o resultado anterior.
Será que seria interessante desabilitar a placa de rede on-board no setup do pc?

Seu modem está, aparentemente, instalado e bem configurado. Talvez seja aquele famoso problemas conecta mas não navega. Só que a forma de resolver isso já foi tentada por você pelo comando sudo route add default ppp0 e não surtiu efeito até o momento.

Você não me respondeu se corrigiu os arquivos chap-secrets e pap-secrets no seu final, com relação ao nome e senha de acesso do seu provedor. Recapitulando, devria ficar assim para cada provedor que você utiliza: “usuário@provedor.com.br” * “senha1234” ( nome de acesso completo entre duas aspas espaço asterisco espaço senha de acesso entre duas aspas).

Você baixou o LiveCD da internet ou recebeu o mesmo?

 Se você baixou da internet teve o cuidado de verificar o md5sum do mesmo?

Seu problema é bem estranho. Note que nas configurações do gnome-ppp na aba Opções deve estar marcada as opções:

Mostrar na área de notificação
Abortar conexão se a linha estiver ocupada
Abortar conexão se não tiver tom de discagem
Verificar portadora
Verificar rota padrão
Ignorar seqüencias de terminal (modo burro)

Você instalou algum tipo de firewall?

Bom tente mais isso aqui, abra um terminal e digite:

sudo /etc/init.d/sl-modem-daemon stop

sudo /etc/init.d/networking stop

sudo /etc/init.d/sl-modem-daemon restart

Agora tente usar o gnome-ppp. Caso ele funcione agora, então realmente sua placa de rede está influenciando no problema de conexão via softmodem.

Lembre-se que no arquivo oculto .wvdial.conf na sua pasta de usuário na /home/ o Init e Init2 deveriam ficar assim:

Init = ATZ

Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

Outra coisa ao tentat usar o gnome-ppp clicando em conectar, na janela seguinte clique em Resgistro e cole aqui o resultado dela ok.

Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #26 Online: 26 de Junho de 2007, 21:13 »
Olá Alarcon,

 :-[Desculpe por não ter feito o que voce sugeriu antes, foi um deslize meu. ;D
Mas respondendo ao que voce solicitou:
Fiz as mudanças nos arquivos /chap-secrets e /pap-secrets e ficamos na mesma, conecta e navega parcialmente.
Os cd-lives que possuia, hoje só tenho um, recebi solicitando pelo site e recebendo já gravado via correio, tentei baixar o arquivo no trabalho onde tem banda larga, mas os arquivos vieram corrompidos aí deletei e solicitei os cd's.
Das opções do gnome-ppp que voce lista só não está marcada a verificação da portadora, pois a conecção fica instável quando ele está selecionado.
Não tenho nenhum firewall instalado.
Executei exatamente, os comando que voce listou e segue as telas do Registro do gnome-ppp, coloquei antes e depois dos comandos:
Antes:
--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.56
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L1DP17001013
--> Waiting for carrier.
ATM1L1DP17001013
CONNECT 52000
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Tue Jun 26 20:19:50 2007
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 5967
--> Using interface ppp0
--> [06][08]p[1c][06][08]
--> [06][08]p[1c][06][08]
--> [06][08]p[1c][06][08]
--> [06][08]p[1c][06][08]
--> local  IP address 201.4.77.85
--> [06][08]p[1c][06][08]
--> remote IP address 200.217.127.132
--> [06][08]p[1c][06][08]
--> primary   DNS address 200.223.0.135
--> [06][08]p[1c][06][08]
--> secondary DNS address 200.223.0.83
--> [06][08]p[1c][06][08]

Depois:
--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.56
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L1DP17001013
--> Waiting for carrier.
ATM1L1DP17001013
CONNECT 52000
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Tue Jun 26 20:34:55 2007
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 6581
--> Using interface ppp0
--> local  IP address 201.4.77.85
--> remote IP address 200.217.127.132
--> primary   DNS address 200.223.0.135
--> secondary DNS address 200.223.0.83

Notei que a conecção ficou um pouco instável, diculdade para conectar em alguns sites (como bol) ,depois que foi mudado o Ini2.

Obrigado pela paciência e desculpe a demora, mas estou meio atolado no trabalho.

alarcon

  • Visitante
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #27 Online: 30 de Junho de 2007, 10:25 »
Olá Alarcon,

 :-[Desculpe por não ter feito o que voce sugeriu antes, foi um deslize meu. ;D
Mas respondendo ao que voce solicitou:
Fiz as mudanças nos arquivos /chap-secrets e /pap-secrets e ficamos na mesma, conecta e navega parcialmente.
Os cd-lives que possuia, hoje só tenho um, recebi solicitando pelo site e recebendo já gravado via correio, tentei baixar o arquivo no trabalho onde tem banda larga, mas os arquivos vieram corrompidos aí deletei e solicitei os cd's.
Das opções do gnome-ppp que voce lista só não está marcada a verificação da portadora, pois a conecção fica instável quando ele está selecionado.
Não tenho nenhum firewall instalado.
Executei exatamente, os comando que voce listou e segue as telas do Registro do gnome-ppp, coloquei antes e depois dos comandos:
Antes:
--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.56
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L1DP17001013
--> Waiting for carrier.
ATM1L1DP17001013
CONNECT 52000
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Tue Jun 26 20:19:50 2007
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 5967
--> Using interface ppp0
--> [06][08]p[1c][06][08]
--> [06][08]p[1c][06][08]
--> [06][08]p[1c][06][08]
--> [06][08]p[1c][06][08]
--> local  IP address 201.4.77.85
--> [06][08]p[1c][06][08]
--> remote IP address 200.217.127.132
--> [06][08]p[1c][06][08]
--> primary   DNS address 200.223.0.135
--> [06][08]p[1c][06][08]
--> secondary DNS address 200.223.0.83
--> [06][08]p[1c][06][08]

Depois:
--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.56
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L1DP17001013
--> Waiting for carrier.
ATM1L1DP17001013
CONNECT 52000
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Tue Jun 26 20:34:55 2007
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 6581
--> Using interface ppp0
--> local  IP address 201.4.77.85
--> remote IP address 200.217.127.132
--> primary   DNS address 200.223.0.135
--> secondary DNS address 200.223.0.83

Notei que a conecção ficou um pouco instável, diculdade para conectar em alguns sites (como bol) ,depois que foi mudado o Ini2.

Obrigado pela paciência e desculpe a demora, mas estou meio atolado no trabalho.

Veja que com o script Networking ativo o registro do gnome-ppp mostra isso:

Citar
--> Using interface ppp0
--> [06][08]p[1c][06][08]
--> [06][08]p[1c][06][08]
--> [06][08]p[1c][06][08]
--> [06][08]p[1c][06][08]
--> local  IP address 201.4.77.85
--> [06][08]p[1c][06][08]
--> remote IP address 200.217.127.132
--> [06][08]p[1c][06][08]
--> primary   DNS address 200.223.0.135
--> [06][08]p[1c][06][08]
--> secondary DNS address 200.223.0.83
--> [06][08]p[1c][06][08]

e que depois de pará-lo o registro do gnome-ppp mostra isso:

Citar
--> Using interface ppp0
--> local  IP address 201.4.77.85
--> remote IP address 200.217.127.132
--> primary   DNS address 200.223.0.135
--> secondary DNS address 200.223.0.83

Percebo que a rede causa alguma interferência, o que é muito esquisito.

Como disse antes seu modem está perfeitamente instalado e ativado. Veja até que sua velocidade de conexão é muito boa CONNECT 52000 (pelo registro do gnome-ppp).

Bom quando fiz o meu pacote usava exatamente este modem (HSP56 MR VIA) e o mesmo funcionava com a opção verificar portadora selecionada e o Init e Init2 assim:

Init = ATZ

Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0


Vejo agora que o mesmo modem pode funcionar de maneira diferente em outro PC.

Infelizmente não tenho mais nenhuma solução no momento para lhe oferecer.

Quem sabe alguém por aqui que leia este tópico apresente uma nova solução para o seu caso.


Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #28 Online: 30 de Junho de 2007, 23:07 »
Oi Alarcon,

De qualquer forma muito obrigado pela ajuda, serviu para aprimorarmos nossos conhecimentos sobre o Linux e um pouco subre as suas variações.
Muito obrigado pelas dicas e pela ajuda, não conseguimos - é verdade - mas o importante é que tentamos.
Muitíssimo obrigado pela atenção e pela ajuda.

gabriel.goc

  • Visitante
Re: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04
« Resposta #29 Online: 30 de Junho de 2007, 23:41 »
Mas e aí???...Como ficou seu caso???
Desistiu de linux ou comprou modem novo?

flws