Autor Tópico: não altera permissão de pasta, mesmo logando como root  (Lida 8116 vezes)

Offline rogeriojlle

  • Usuário Ubuntu
  • *
  • Mensagens: 83
    • Ver perfil
não altera permissão de pasta, mesmo logando como root
« Online: 11 de Novembro de 2005, 21:56 »
isto está contecendo nas partições não linux.
no meu caso uma é fat32 e outra é ntfs.
na ntfs eu me logando como usário comum não posso nada nem ler
a fat32 eu leio e executo coisas nela
como root faço o que quero na ntfs e na fat32 mas não estou conseguindo mudar isso
clico com o direito na partição, escolho permissões mas não dá pra alterar nada lá mesmo me logando como root

Offline Magneto

  • Usuário Ubuntu
  • *
  • Mensagens: 768
    • Ver perfil
não altera permissão de pasta, mesmo logando como root
« Resposta #1 Online: 11 de Novembro de 2005, 22:15 »
Cara , comigo acontece algo parecido, se eu copio algo da partição do windows ou de um cd de dados por exemplo o arquivo fica com um simbolo de cadeado, sempre, eu consigo executar, e tudo mais, e alterando para escrita da certo para modificar, mas ao copiar para o Win o arquivo não abre, ou então no Linux aparece um simbolo descrito como Mime, o que será?

Offline LedStyle

  • Usuário Ubuntu
  • *
  • Mensagens: 1.345
    • Ver perfil
    • http://www.tuxresources.org
não altera permissão de pasta, mesmo logando como root
« Resposta #2 Online: 12 de Novembro de 2005, 01:02 »
Bom... pra começar o sistema de arquivos do Tio Bill não suporta permissões do Linux. Não adianta dar chmod nem chown em nada por lá que não vai funcionar mesmo.

Em segundo lugar o kernel do Ubuntu não consegue gravar em partições NTFS, só pode ler. Já nas FAT ele pode ler e gravar.

Em terceiro da uma olhada nesse link que deve resolver seu problema: http://www.ubuntuguide.org/#mountunmountntfs

[]s

Offline Magneto

  • Usuário Ubuntu
  • *
  • Mensagens: 768
    • Ver perfil
não altera permissão de pasta, mesmo logando como root
« Resposta #3 Online: 12 de Novembro de 2005, 07:15 »
Obrigado pela ajuda, quanto a poder gravar em ntfs, realmente eu estou sabendo desse detalhe, que sacanagem, bom, como só uso o Rwuindows para o Scanner, nem ligo de não pode usar os arquivos do linux no Win, hehe.Abraços.

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
não apaga mais...
« Resposta #4 Online: 02 de Dezembro de 2005, 10:46 »
Prezado LedStyle, coisas estranhas acontecem por aqui...

Já fucei no fórum e no Guia, mas não encontrei solução. De ontem para hoje, não consigo mais apagar arquivos na partição fat32 (hdc4). Meu fstab estava como descrito em http://ubuntuforum-pt.org/index.php?topic=2095&highlight=. Então, segui sua dica:

Citação de: "LedStyle"

Em terceiro da uma olhada nesse link que deve resolver seu problema: http://www.ubuntuguide.org/#mountunmountntfs


Depois, dei mount -a, mas o problema continuou. Então, mudei para umask=0222, dica que encontrei em http://ubuntuforum-pt.org/index.php?topic=1528&highlight=umask+0222, mas ainda não consigo apagar nenhum arquivo e continuo com o problema do perfil do Thunderbird, mencionado acima.

Como resolvo a encrenca?
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |

Offline rogeriojlle

  • Usuário Ubuntu
  • *
  • Mensagens: 83
    • Ver perfil
não altera permissão de pasta, mesmo logando como root
« Resposta #5 Online: 02 de Dezembro de 2005, 11:58 »
não sei como é com voce mas comigo apareceram as partições windows na area de trabalho quando instalei o sistema, porem estavam com o problema que postei logo acima.
então usei a dica do guia não oficial 5.04 que era de criar novos diretórios e associá-los às partições windows
O que fiz de diferente foi não criar as tais pastas, apenas alterei o resto da linha ignorando a parte que dizia a localização das partiçoes e pastas onde veriam só mudando o resto ex:

# <file system> | <mount point> | <type> | <options> | <dump> | <pass>
/dev/hda1 |  /media/windows | ntfs | nls=utf8,umask=0222 | 0 | 0
não mexi | nao mexi | mexi | mexi | mexi | mexi
 onde tem o "|" são as colunas não deu pra formatar como eu queria usando a resposta rápida do fórum mas dá pra entender

aí sim fiz o #mount -a e mesmo assim tive de reiniciar para as alterações darem certo

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.279
    • Ver perfil
Re: não apaga mais...
« Resposta #6 Online: 02 de Dezembro de 2005, 11:59 »
Citação de: "Perícope"
Prezado LedStyle, coisas estranhas acontecem por aqui...

Já fucei no fórum e no Guia, mas não encontrei solução. De ontem para hoje, não consigo mais apagar arquivos na partição fat32 (hdc4). Meu fstab estava como descrito em http://ubuntuforum-pt.org/index.php?topic=2095&highlight=. Então, segui sua dica:

Citação de: "LedStyle"

Em terceiro da uma olhada nesse link que deve resolver seu problema: http://www.ubuntuguide.org/#mountunmountntfs


Depois, dei mount -a, mas o problema continuou. Então, mudei para umask=0222, dica que encontrei em http://ubuntuforum-pt.org/index.php?topic=1528&highlight=umask+0222, mas ainda não consigo apagar nenhum arquivo e continuo com o problema do perfil do Thunderbird, mencionado acima.

Como resolvo a encrenca?


A umask está incorreta ;-)
já citei isto anteriormente, mas vou colocar mais uma vez, antes de modificar estas coisas, seria legal se aprofundar mais um pouco no assunto não acha ?
http://ubuntuforum-pt.org/index.php?topic=135&highlight=user+mask

http://focalinux.cipsga.org.br/guia/inic_interm/ch-perm.htm#s-perm-umask

13.11 umask

A umask (user mask) são 3 números que definem as permissões iniciais do dono, grupo e outros usuários que o arquivo/diretório receberá quando for criado ou copiado. Digite umask sem parâmetros para retornar o valor de sua umask atual.

A umask tem efeitos diferentes caso o arquivo que estiver sendo criado for binário (um programa executável) ou texto (Arquivo texto e binário, Seção 2.2.3) . Veja a tabela a seguir para ver qual é a mais adequada a sua situação:

    ---------------------------------------------
     |       |        ARQUIVO       | DIRETÓRIO  |
     | UMASK |----------------------|            |
     |       |   Binário  |  Texto  |            |
     |------------------------------|------------|
     |   0   |    r-x     |   rw-   |    rwx     |
     |   1   |    r--     |   rw-   |    rw-     |
     |   2   |    r-x     |   r--   |    r-x     |
     |   3   |    r--     |   r--   |    r--     |
     |   4   |    --x     |   -w-   |    -wx     |
     |   5   |    ---     |   -w-   |    -w-     |
     |   6   |    --x     |   ---   |    --x     |
     |   7   |    ---     |   ---   |    ---     |
     ---------------------------------------------

Um arquivo texto criado com o comando umask 012;touch texto.txt receberá as permissões -rw-rw-r--, pois 0 (dono) terá permissões rw-, 1 (grupo), terá permissões rw- e 2 (outros usuários) terão permissões r--. Um arquivo binário copiado com o comando umask 012;cp /bin/ls /tmp/ls receberá as permissões -r-xr--r-x (confira com a tabela acima).

Por este motivo é preciso um pouco de atenção antes de escolher a umask, um valor mal escolhido poderia causar problemas de acesso a arquivos, diretórios ou programas não sendo executados. O valor padrão da umask na maioria das distribuições atuais é 022. A umask padrão no sistema Debian é a 022 .

A umask é de grande utilidade para programas que criam arquivos/diretórios temporários, desta forma pode-se bloquear o acesso de outros usuários desde a criação do arquivo, evitando recorrer ao chmod.

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: não apaga mais...
« Resposta #7 Online: 02 de Dezembro de 2005, 12:49 »
Citação de: "Xterminator"

A umask está incorreta ;-)


Esta é a perigosa beleza de um fórum: dicas erradas são dadas e seguidas...

Citar
já citei isto anteriormente, mas vou colocar mais uma vez, antes de modificar estas coisas, seria legal se aprofundar mais um pouco no assunto não acha ?
http://ubuntuforum-pt.org/index.php?topic=135&highlight=user+mask
http://focalinux.cipsga.org.br/guia/inic_interm/ch-perm.htm#s-perm-umask


Concordo. A ingenuidade é em confiar em todas as dicas aqui postadas.

Bem, se entendi direito,então, a umask mais ampla, de plenos poderes, é a 000. Correto?

Mas consertando para 022, ainda não consigo deletar arquivos.

Observo que em algumas dicas para fstab há linhas como /dev/hdc4       /media/windows  vfat    iocharset=utf8,umask=022   0       0, enquanto outras usam user e rw ou ro. Essas opções são "sinônimas"?

Grato pelo puxão de orelha...  :oops:
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |