Autor Tópico: Problemas Com A Interface Gráfica...  (Lida 4584 vezes)

Offline Mithos

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Problemas Com A Interface Gráfica...
« Online: 16 de Junho de 2007, 17:20 »
Bom, antes de tudo, gostaria de esclarecer que sou novato no Linux.
O que aconteceu, é o seguinte, eu estava usando o Beryl e tudo estava funcionando perfeitamente. Então eu resolvi baixar o driver mais novo da placa de vídeo(NVIDIA GeForce 6800 GT) para o Linux.
Porém antes de iniciar a instalação, decidi desativar o driver de aceleração gráfica na seção de drivers restritos na dúvida se isto viria a causar algum problema na instalação. Após desabilitar isto, fui solicitado para reiniciar o sistema.
O problema é que depois que reiniciei o sistema e fiz o login no Ubuntu, em vez do sistema iniciar normalmente, a tela ficava totalmente branca. Creio que isto é porque o Beryl utiliza o driver de aceleração gráfica que agora está desativado e o Beryl estava configurado para iniciar junto com o sistema.
Basicamente o problema é este, mas acontece que afim de resolver isto através de pesquisas que fiz em fóruns acabei vendo algo sobre reconfigure xserver-xorg. Ao fazer isto creio que acabei configurando as coisas de forma errada. ;(
Pois agora ele nem aparece mais pra colocaro login, apenas da um erro dizendo que o X está configurado de forma incorreta e então ele vai para aquele tela de prompt que aparece quando pressionado CRTL + ALT + F1.
Não sei o que fazer pra voltar a poder usar o sistema sem ter que formatar tudo, por favor me ajudem.

Offline ricardofantin

  • Usuário Ubuntu
  • *
  • Mensagens: 105
    • Ver perfil
Re: Problemas Com A Interface Gráfica...
« Resposta #1 Online: 20 de Junho de 2007, 11:34 »
Primeiro você tem que fazer a tela de "log on" voltar:
depois de ligar a máquina entre o seu usuário e sua senha e digite:
cd /etc/X11/

Nessa pasta esta o arquivo de configuração do X (interface gráfica). Se você utilizou o cfgx86 (não tenho certeza o nome do comando) ele criou um arquivo de backup antes de fazer as alterações na configuração.
então digite:

ls

vai aparecer diversos nomes na tela. O arquivo da configuração se chama xorg.conf  . Eu acho que devem ter outros arquivos com esse nome seguido da data e hora da mudança (lembre que em inglês primeiro colocamos o mes e depois o dia).
Eu acho que se você configurasse no mês 06, dia 20, ano 2007 no horário 11:30 o nome seria mais ou menos assim "xorg.conf0622071130" . Enfim, você tem que substituir esse arquivo pelo xorg.conf.

mv xorg.conf xorg.conf.nem_inicia_logon
(renomeia o arquivo xorg.conf para xorg.conf.nem_inicia_logon para caso vocÊ precise voltar)
mv xorg.conf0622071130 xorg.conf
(renomeia o velho arquivo para xorg.conf)

Devem ter diversos arquivos começando com xorg.conf tente mover o da data que a placa de vídeo estava ativa, ou vá tentando um por um.

depois disso reinicie a máquina:
sudo reboot

vai pedir a senha, pois não é qualquer usuário que pode reiniciar o computador.


Boa Sorte,
Ricardo

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.369
  • @Ceará
    • Ver perfil
Re: Problemas Com A Interface Gráfica...
« Resposta #2 Online: 20 de Junho de 2007, 11:47 »
Tenta este comando:
Código: [Selecionar]
sudo dpkg-reconfigure -phigh xserver-xorg
Vê qual driver ficou. Já que tem o driver funcionando muda de "nv" para "nvidia".

Advogado e analista de sistema cearense.
Twitter: @glaydson