Autor Tópico: Placa TV Pinnacle Pctv Pro Usb (150e/55e) Som (Delay)  (Lida 45584 vezes)

Offline mstr

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
    • instalar qualquer placas de captura PCI
Re: Placa TV Pinnacle Pctv Pro Usb (150e/55e) Som (Delay)
« Resposta #45 Online: 21 de Setembro de 2007, 00:15 »
o teclado, mouse, video e sei la quantas coisas mais estão ligas no pacote xserver-xorg

e os devices estão em /dev/input, pelo menos teclado mouse

acho que algum erro na atualização dos pacotes

confere a sources.list pode ser isso também

Offline Intruder_A6

  • Usuário Ubuntu
  • *
  • Mensagens: 232
  • Kubuntu 14.04
    • Ver perfil
Re: Placa TV Pinnacle Pctv Pro Usb (150e/55e) Som (Delay)
« Resposta #46 Online: 21 de Setembro de 2007, 06:18 »
o teclado, mouse, video e sei la quantas coisas mais estão ligas no pacote xserver-xorg

e os devices estão em /dev/input, pelo menos teclado mouse

acho que algum erro na atualização dos pacotes

confere a sources.list pode ser isso também

Na hora que fui atualizar eu troquei o nome dos endereços do source.list de dapper para feisty , fiz apenas isto, não sei se isto explicaria o problema ( é assim que eu sempre faço ), me parece simples demais se for apenas isto, mas mesmo assim darei uma conferida por via das dúvidas.

Offline Intruder_A6

  • Usuário Ubuntu
  • *
  • Mensagens: 232
  • Kubuntu 14.04
    • Ver perfil
Re: Placa TV Pinnacle Pctv Pro Usb (150e/55e) Som (Delay)
« Resposta #47 Online: 21 de Setembro de 2007, 20:37 »
Intruder_A6,

na captura esta tudo correto
Citar
[   34.044000] em28xx #0: V4L2 device registered as /dev/video1 and /dev/vbi0

tenta assim no terminal
tvtime -d /dev/video1

A imagem ficou perfeita ( mesmo ), mas infelizmente sem som, acho que deve ser mais fácil agora para resolver. Em anexo a mensagem que recebi ao executar o script do Tota ( modificado para usar o /dev/video1 ).
Código: [Selecionar]
sox: Failed reading hw:1: cannot open audio device

Input Filename : /dev/dsp1
Sample Size    : 16-bits
Sample Encoding: signed (2's complement)
Channels       : 2
Sample Rate    : 32000

Running tvtime 1.0.2.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/a458/.tvtime/tvtime.xml
Time: 00:19.58 [00:00.00] of 00:00.00 (  0.0%) Output Buffer: 626.69KThank you for using tvtime.
wait: 16: Illegal number: tvtime
Simple mixer control 'PCM',0
  Capabilities: pvolume cvolume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 80 [80%] [-8.00dB] Capture 80 [80%] [-8.00dB]
  Front Right: Playback 80 [80%] [-8.00dB] Capture 80 [80%] [-8.00dB]
Time: 00:19.71 [00:00.00] of 00:00.00 (  0.0%) Output Buffer: 630.78K

Aborted.

Offline mstr

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
    • instalar qualquer placas de captura PCI
Re: Placa TV Pinnacle Pctv Pro Usb (150e/55e) Som (Delay)
« Resposta #48 Online: 22 de Setembro de 2007, 22:56 »
da uma olhada na pagina as vezes tem mais alguma coisa

http://mstr.ueuo.com

e tenta reinstalar o sox

Offline Intruder_A6

  • Usuário Ubuntu
  • *
  • Mensagens: 232
  • Kubuntu 14.04
    • Ver perfil
Re: Placa TV Pinnacle Pctv Pro Usb (150e/55e) Som (Delay)
« Resposta #49 Online: 22 de Setembro de 2007, 23:34 »
da uma olhada na pagina as vezes tem mais alguma coisa

http://mstr.ueuo.com

e tenta reinstalar o sox

Tentei, continuou na mesma, continuo sem som.

Continuo também sem conseguir ajeitar a configuração do teclado.

Esta novela vai longe.
« Última modificação: 23 de Setembro de 2007, 00:04 por Intruder_A6 »

Offline Intruder_A6

  • Usuário Ubuntu
  • *
  • Mensagens: 232
  • Kubuntu 14.04
    • Ver perfil
Re: Placa TV Pinnacle Pctv Pro Usb (150e/55e) Som (Delay)
« Resposta #50 Online: 27 de Setembro de 2007, 22:12 »
da uma olhada na pagina as vezes tem mais alguma coisa

http://mstr.ueuo.com

e tenta reinstalar o sox

E ai, não mais nenhuma idéia de como botar a minha Pinnacle para funcionar corretamente ? Eu não consegui nada ainda usando o Google.

Offline mstr

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
    • instalar qualquer placas de captura PCI
Re: Placa TV Pinnacle Pctv Pro Usb (150e/55e) Som (Delay)
« Resposta #51 Online: 28 de Setembro de 2007, 00:24 »
e a configuração do teclado resolveu?

não tenho ideia pq ela não funciona pois as usbs geralmente são carregadas automaticamente no boot

elas dependem de um firmware (modulo binario) que desta placa tem, mas precisa ver se a atualização não mexeu com ele

outra coisa que poderia te sugerir seria forçar o carregamento no boot

crie o arquivo '/etc/modprobe.d/captura' com o seguinte conteudo
options em28xx card=3 tuner=37

e reinicia e verifique com
dmesg | grep em28
dmesg | grep tuner

se foi reconhecida conforme mostra no inicio desse topico
verifique se o video esta como 0 ou 1 e não esqueça de setar o tvtime se estiver em 1

e tenta com tvtime se consegue ver e ou ouvir alguma coisa
« Última modificação: 28 de Setembro de 2007, 00:28 por mstr »

Offline Intruder_A6

  • Usuário Ubuntu
  • *
  • Mensagens: 232
  • Kubuntu 14.04
    • Ver perfil
Re: Placa TV Pinnacle Pctv Pro Usb (150e/55e) Som (Delay)
« Resposta #52 Online: 28 de Setembro de 2007, 00:49 »
Fiz as mudanças, agora a pinnacle estah no /dev/video0 ( antes estava no /dev/video1 ), mas continuou sem som.

dmesg | grep em28
Código: [Selecionar]
[   33.896000] em28xx v4l2 driver version 0.0.1 loaded
[   33.896000] em28xx new video device (2304:0208): interface 0, class 255
[   33.896000] em28xx #0: Alternate settings: 8
[   33.896000] em28xx #0: Alternate setting 0, max size= 0
[   33.896000] em28xx #0: Alternate setting 1, max size= 1024
[   33.896000] em28xx #0: Alternate setting 2, max size= 1448
[   33.896000] em28xx #0: Alternate setting 3, max size= 2048
[   33.896000] em28xx #0: Alternate setting 4, max size= 2304
[   33.896000] em28xx #0: Alternate setting 5, max size= 2580
[   33.896000] em28xx #0: Alternate setting 6, max size= 2892
[   33.896000] em28xx #0: Alternate setting 7, max size= 3072
[   34.756000] saa7115 2-0025: saa7113 found (1f7113d0e100000) @ 0x4a (em28xx #0)
[   35.512000] tuner 2-0043: chip found @ 0x86 (em28xx #0)
[   35.512000] tuner 2-0063: chip found @ 0xc6 (em28xx #0)
[   35.552000] em28xx #0: i2c eeprom 00: 1a eb 67 95 04 23 08 02 10 00 1c 03 98 20 6a 2e
[   35.552000] em28xx #0: i2c eeprom 10: 00 00 06 57 6e 00 00 00 8e 00 00 00 07 00 00 00
[   35.552000] em28xx #0: i2c eeprom 20: 16 00 01 00 00 00 00 00 00 00 00 00 00 00 00 00
[   35.552000] em28xx #0: i2c eeprom 30: 00 00 20 40 20 80 02 20 01 01 00 00 00 00 00 00
[   35.552000] em28xx #0: i2c eeprom 40: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
[   35.552000] em28xx #0: i2c eeprom 50: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
[   35.552000] em28xx #0: i2c eeprom 60: 00 00 00 00 00 00 00 00 00 00 2e 03 50 00 69 00
[   35.552000] em28xx #0: i2c eeprom 70: 6e 00 6e 00 61 00 63 00 6c 00 65 00 20 00 53 00
[   35.552000] em28xx #0: i2c eeprom 80: 79 00 73 00 74 00 65 00 6d 00 73 00 20 00 47 00
[   35.552000] em28xx #0: i2c eeprom 90: 6d 00 62 00 48 00 00 00 20 03 50 00 43 00 54 00
[   35.552000] em28xx #0: i2c eeprom a0: 56 00 20 00 55 00 53 00 42 00 32 00 20 00 4e 00
[   35.552000] em28xx #0: i2c eeprom b0: 54 00 53 00 43 00 00 00 00 00 00 00 00 00 00 00
[   35.552000] em28xx #0: i2c eeprom c0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
[   35.552000] em28xx #0: i2c eeprom d0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
[   35.552000] em28xx #0: i2c eeprom e0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
[   35.552000] em28xx #0: i2c eeprom f0: 00 00 00 00 00 00 00 00 0e 5d 62 3a 03 c4 8e bc
[   35.972000] em28xx #0: V4L2 device registered as /dev/video0 and /dev/vbi0
[   35.972000] em28xx #0: Found Pinnacle PCTV USB 2
[   35.972000] em28xx audio device (2304:0208): interface 1, class 1
[   35.972000] em28xx audio device (2304:0208): interface 2, class 1
[   35.972000] usbcore: registered new interface driver em28xx

dmesg | grep tuner
Código: [Selecionar]
[   35.512000] tuner 2-0043: chip found @ 0x86 (em28xx #0)
[   35.512000] tda9887 2-0043: tda988[5/6/7] found @ 0x43 (tuner)
[   35.512000] tuner 2-0063: chip found @ 0xc6 (em28xx #0)
[   35.512000] tuner 2-0063: type set to 37 (LG PAL (newer TAPC series))
[   35.512000] tuner 2-0063: type set to 37 (LG PAL (newer TAPC series))


Em relação ao teclado, continuou como internacional sem possibilidade de selecionar ABNT2.
« Última modificação: 28 de Setembro de 2007, 00:54 por Intruder_A6 »

Offline mstr

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
    • instalar qualquer placas de captura PCI
Re: Placa TV Pinnacle Pctv Pro Usb (150e/55e) Som (Delay)
« Resposta #53 Online: 28 de Setembro de 2007, 16:36 »
instala o script do tota, ele ta no inicio do topico

so presta atenção com o /dev/dspX, verifica qual vc tem

acho que isso deve ter resolvido para o outro usuario, não postou mais

deveria ter avisado se funcionou !!!

Offline Intruder_A6

  • Usuário Ubuntu
  • *
  • Mensagens: 232
  • Kubuntu 14.04
    • Ver perfil
Re: Placa TV Pinnacle Pctv Pro Usb (150e/55e) Som (Delay)
« Resposta #54 Online: 28 de Setembro de 2007, 17:02 »
instala o script do tota, ele ta no inicio do topico

so presta atenção com o /dev/dspX, verifica qual vc tem

acho que isso deve ter resolvido para o outro usuario, não postou mais

deveria ter avisado se funcionou !!!

Isto foi uma das primeiras coisas que fiz ( desde o início ).

Eu lembro que já tentei com vários /dev/dsp(0;1;2;3; ... ). Se não tivesse conseguido fazer funcionar o som com a imagem em preto e branco antes de atualizar o Kubuntu, eu até pensaria que a Pinnacle estaria com defeito.

Offline lordhell

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Placa TV Pinnacle Pctv Pro Usb (150e/55e) Som (Delay)
« Resposta #55 Online: 28 de Setembro de 2007, 17:09 »
quando ligava o pc com o cabo usb plugado não funcionava o som.

Offline Intruder_A6

  • Usuário Ubuntu
  • *
  • Mensagens: 232
  • Kubuntu 14.04
    • Ver perfil
Re: Placa TV Pinnacle Pctv Pro Usb (150e/55e) Som (Delay)
« Resposta #56 Online: 28 de Setembro de 2007, 19:00 »
quando ligava o pc com o cabo usb plugado não funcionava o som.

É o cumulo, mas vou testar.

Offline Intruder_A6

  • Usuário Ubuntu
  • *
  • Mensagens: 232
  • Kubuntu 14.04
    • Ver perfil
Re: Placa TV Pinnacle Pctv Pro Usb (150e/55e) Som (Delay)
« Resposta #57 Online: 28 de Setembro de 2007, 21:43 »
quando ligava o pc com o cabo usb plugado não funcionava o som.

Por incrível que pareça, fazendo como você sugeriu, funcionou perfeito, com som sincronizado, é uma ótima imagem ( com alguns ajustes no script do Tota ).

Vou colocar aqui o script do Tota da forma como funcionou perfeito comigo.

Código: [Selecionar]
#!/bin/sh
#
#Arquivo para configurar a placa PixelView PlayTV Mobile no Brasil
#Sistema PAL-M
#Por tota
#   
# Liga o som
#

#sox -c 2 -s -w -r 32000 -t ossdsp /dev/dsp1 -t ossdsp -w -r 32000 /dev/dsp &
sox -c 2 -s -w -r 48000 -t ossdsp /dev/dsp1 -t ossdsp -w -r 48000 /dev/dsp &

#tvtime --mixer=/dev/mixer:pcm
#tvtime | sox -t alsa hw:1 -t alsa -w default
tvtime -d /dev/video0 | sox -t alsa hw:1 -t alsa -w default
wait tvtime
t=`pidof sox`;
kill $t;
amixer -c 0 sset PCM 80%,80% unmute

#Sai

exit

A mensagem da execução do script do Tota.
Código: [Selecionar]
Running tvtime 1.0.2.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/a458/.tvtime/tvtime.xml
sox: Failed reading hw:1: cannot open audio device

Input Filename : /dev/dsp1
Sample Size    : 16-bits
Sample Encoding: signed (2's complement)
Channels       : 2
Sample Rate    : 48000

Time: 00:05.97 [00:00.00] of 00:00.00 (  0.0%) Output Buffer: 286.72K
Time: 00:06.06 [00:00.00] of 00:00.00 (  0.0%) Output Buffer: 286.72K

Aborted.

Mesmo com esta mensagem de erro o som funcionou perfeito e sincronizado ( não entendi nada ??? ).
Será que toda vez que eu der boot no Linux eu terei que desligar o Pinnacle e ligar depois ? E imaginar que eu comprei o sintonizador da Pinnacle para não ter dor de cabeça, e estou tendo muita ( mesmo no Janelas que costuma ter menos problemas com driver, nele continua sem áudio, e ainda consome muita CPU )

Agora só sobrou o problema de configuração do teclado ( e mais umas coisinhas ).
« Última modificação: 28 de Setembro de 2007, 21:45 por Intruder_A6 »

Offline mstr

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
    • instalar qualquer placas de captura PCI
Re: Placa TV Pinnacle Pctv Pro Usb (150e/55e) Som (Delay)
« Resposta #58 Online: 29 de Setembro de 2007, 01:45 »
entendeu ... USB tem dessas coisas

uma pergunta ficou no ar
precisa do script para funcionar o som?

Citar
sox: Failed reading hw:1: cannot open audio device
tenta outro numero

no teclado tenta reinstalar o pacote
xserver-xorg-input-kbd

veja as configurações do abnt2
« Última modificação: 29 de Setembro de 2007, 01:52 por mstr »

Offline Intruder_A6

  • Usuário Ubuntu
  • *
  • Mensagens: 232
  • Kubuntu 14.04
    • Ver perfil
Re: Placa TV Pinnacle Pctv Pro Usb (150e/55e) Som (Delay)
« Resposta #59 Online: 29 de Setembro de 2007, 07:23 »
entendeu ... USB tem dessas coisas

uma pergunta ficou no ar
precisa do script para funcionar o som?
Não, mas o som fica um pouco pior, com o script do Tota o som fica limpo ( na maioria das vezes, mas tem vez que fica reverberando um pouco, fica meio estranho ).

Citar
sox: Failed reading hw:1: cannot open audio device
tenta outro numero

Mudei, para hw:0 e parou de dar aquela mensagem de erro, mas ainda preciso desconectar o sintonizador da Pinnacle e reconectar ( se eu partir o Kubuntu com ele conectado ) para que tenha áudio.

no teclado tenta reinstalar o pacote
xserver-xorg-input-kbd

veja as configurações do abnt2





Olhe o que aconteceu quando eu reinstalei o pacote.

Código: [Selecionar]
sudo aptitude reinstall xserver-xorg-input-kbd
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following packages will be REINSTALLED:
  xserver-xorg-input-kbd
0 packages upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0B/14.0kB of archives. After unpacking 0B will be used.
Writing extended state information... Done
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "pt_BR:pt:pt_PT",
        LC_ALL = "pt_BR",
        LC_MESSAGES = "pt_BR",
        LANG = "pt_BR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
(Reading database ... 124079 files and directories currently installed.)
Preparing to replace xserver-xorg-input-kbd 1:1.1.0-4ubuntu1 (using .../xserver-xorg-input-kbd_1.1.0-4ubuntu1_i386.deb) ...
Unpacking replacement xserver-xorg-input-kbd ...
Setting up xserver-xorg-input-kbd (1.1.0-4ubuntu1) ...

Infelizmente continuo na mesma, continuo sem conseguir configurar para ABNT2 ( na Configurações do Sistema ), provavelmente se conseguir resolver esta pendência que aparece no warning a configuração do teclado deve se resolver ( imagino eu ).


Tem um erro que acontece toda vez que entro no X, que já está enchendo o saco.

Quando entro no X sempre abre uma janela de erro ( 3 vezes ) com a seguinte mensagem:

A janela tem o nome de Framework do Bluetooth para o KDE - KBluetoothD
Código: [Selecionar]
Falha para conectar ao servidor SDP

Detalhes
Por favor tenha certeza de que o sdpd está rodando;
sem isso, outros dispositivos não serão capazes de
descobrir quais serviços seu computador oferece.


Como é que são as coisas. No passado recente tinha uma ATI 9800 Pro AIW, tinha uma imagem fantástica e uma boa captura, mas a captura não funcionava no Linux ( enchi o saco de tanto tentar resolver, existia um grupo que estava trabalhando na solução, mas não para o chipset da AIW da 9800 ), e para piorar o driver dela para Linux era horrível ( acho que ainda é ). Hoje tenho duas placas nVidia, uma Geforce 6800 GT ( na minha máquina principal ), e na segunda tenho uma Geforce 6600 Pro, e com elas nunca mais tive dor de cabeça com aceleração 3D no Linux ( eu até que gostava das ATI, mas sem um suporte decente ao Linux eu estou fora ). Mas agora a coisa virou, a Pinnacle PCTV Pro USB está funcionando direito no Kubuntu ( ou quase ) mesmo a Pinnacle não falando nada a respeito dessa característica dela, mas no Janelas ( Ruindows XP ), só funciona a imagem, mesmo assim consumindo muita CPU, e bem menos nítida, que diferença.

Quem sabe eu tome vergonha na cara e abandone de vez o Janelas ( cada dia que passa tem periférico que funciona bem melhor nele do que no Janelas XP ).
« Última modificação: 29 de Setembro de 2007, 09:09 por Intruder_A6 »