Autor Tópico: agere systems pci soft modem  (Lida 40289 vezes)

Offline Tetsuo

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re: agere systems pci soft modem
« Resposta #30 Online: 04 de Setembro de 2007, 17:35 »
Fiz tudo o que você me recomendou e pela milésima vez não deu certo. Quando tentei me conectar, deu a mensagem: "o modem não respondeu". Mas eu anotei a informação do log de conexão. Aqui está:

Ignoring malformed imput line: ";Do NOT edit this file by hand!"

WVdial: Internet dialer version 1.56

Cannot set information for serial port

Initializing modem

Sending: ATZ

Sending: ATQ0

Re-sending: ATZ

Modem not responding



É isso.  :(


Offline Tetsuo

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re: agere systems pci soft modem
« Resposta #31 Online: 04 de Setembro de 2007, 21:46 »
Eu descobri uma coisa que eu não tinha percebido antes.

depois de entrar no diretório do driver, eu digito o comando make e aparece essa informação de alerta:

Warning: could not find /home/tetsuo/agrsm/. agrsm_core.o.cmd for /home/tetsuo/agrsm_core.o

Isso pode ser um indício de arquivo corrompido?

Se for, talvez por isso não esteja dando certo o procedimento. Vou procurar um outro driver na internet e tentar repetir make e make install.




alarcon

  • Visitante
Re: agere systems pci soft modem
« Resposta #32 Online: 05 de Setembro de 2007, 10:43 »
Eu descobri uma coisa que eu não tinha percebido antes.

depois de entrar no diretório do driver, eu digito o comando make e aparece essa informação de alerta:

Warning: could not find /home/tetsuo/agrsm/. agrsm_core.o.cmd for /home/tetsuo/agrsm_core.o

Isso pode ser um indício de arquivo corrompido?

Se for, talvez por isso não esteja dando certo o procedimento. Vou procurar um outro driver na internet e tentar repetir make e make install.





Mensagem de Warning: não são erros apenas avisos e acontece muito nas compilações este tipo de aviso, não se preocupe.

Agora vamos recapitular tudo que foi feito até agora para tentarmos encontrar algum erro.

Vá no menu Sistema > Administração > Gerenciador de pacotes Synaptic quando abrir clique no botão procurar e procure por estes pacotes aqui:

make
gcc
build-essential
linux-headers-2.6.20-15-generic


se aparecer com um quadrado verde à sua esquerda é por que foram  instalados.

Só para ter certeza faça isso também:

sudo depmod -a
sudo modprobe agrmodem
sudo modprobe agrserial

Agora verifique pra mim o seguinte, vá em /etc/udev/rules.d pelo nautilus e verifique se existe o seguinte arquivo agrsm.rules e se seu conteúdo é esse:

Citar
#
# UDEV rule for ltmodem
#  creates symlink /dev/modem to /dev/ttyAGS?, and takes care of permissions

KERNEL="ttyAGS[0-9]", NAME="%k", MODE="0660", GROUP="dialout", SYMLINK="modem"

caso não exista ainda no terminal faça:

sudo gedit /etc/udev/rules.d/agrsm.rules

e coipe e cole o que coloquei logo acima. Atenção copie e cole exatamente tudo e da forma que está aí.

Depois reinicie seu PC e no gnome-ppp use como dispositivo na aba modem: /dev/modem

depois de reiniciar o pc cole aqui o resultado dos seguintes comandos:

lsmod | grep agr

dmesg | grep agr
« Última modificação: 05 de Setembro de 2007, 15:01 por alarcon »

Offline Tetsuo

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re: agere systems pci soft modem
« Resposta #33 Online: 05 de Setembro de 2007, 14:05 »
Esquece o agere, cara. Eu comprei hoje de manhã um Motorola SM56 Speakerphone Modem V92 (lá vem esse maldito V92! hehehehe!!!)

Agora no cd que veio com ele, tem drivers para:

Conectiva
Debian Linux 3.1
Fedora
Kurumin Linux 4.1
Linpus
Linspare
Mandrake
Mandriva
Redhat Linux
Redhat Linux Workstation
Suse
Turbolinux

qual destes eu uso para o Ubuntu 7.04?

Espero que o parto seja menos dramático agora.

Ah, antes que eu me esqueça. Sobre os drivers que eu já tinha instalado para o agere. Eu tenho que desisntalar primeiro ou posso instalar os do modem novo assim mesmo?
« Última modificação: 05 de Setembro de 2007, 14:08 por Tetsuo »

alarcon

  • Visitante
Re: agere systems pci soft modem
« Resposta #34 Online: 05 de Setembro de 2007, 14:17 »
Esquece o agere, cara. Eu comprei hoje de manhã um Motorola SM56 Speakerphone Modem V92 (lá vem esse maldito V92! hehehehe!!!)

Agora no cd que veio com ele, tem drivers para:

Conectiva
Debian Linux 3.1
Fedora
Kurumin Linux 4.1
Linpus
Linspare
Mandrake
Mandriva
Redhat Linux
Redhat Linux Workstation
Suse
Turbolinux

qual destes eu uso para o Ubuntu 7.04?

Espero que o parto seja menos dramático agora.

Ah, antes que eu me esqueça. Sobre os drivers que eu já tinha instalado para o agere. Eu tenho que desisntalar primeiro ou posso instalar os do modem novo assim mesmo?

Um conselho é que você reinstale o seu Ubuntu para começar do zero, por que um driver pode atrapalhar no outro.

Agora quero saber o seguinte qual é a ID deste novo modem e você sabe me dizer se o driver que tem nele é o Smartlink?

Pergunto isso por que o modem motorola só possuia driver para linux em versões muito antigas, ainda do kernel 2.4.x e hoje o kernel é da versão 2.6.x, portanto mais novo e me parece que o que vem no CD é para os antigos, pois fala em kurumin 4.1, por exemplo, que já é bastante antigo. Recentemente descobri que o driver Smartlink dá suporte para um determinado Motorola e por isso quero saber qual é a ID do seu.

OBS: Depois de reinstalar o Ubuntu e antes de isntalar o driver você tem de instalar aqueles arquivos necessários para se compilar um driver que já tinha dito antes:

- make
- gcc
- build-essential
- linux-headers-2.6.20-15-generic

Com o Ubuntu já reinstalado e com o modem motorola também instalado, vá no terminal e digite:

lspci -d 1057:3052

se retornar algo parecido com isso:

01:01.0 Modem: Motorola Unknown device 3052 (rev 04)

Caso seja, este é seu dia de sorte  ;D e então você poderá usar um pacote que fiz para uma ativação + ou - automática vendo este link:

http://ubuntuforum-pt.org/index.php/topic,4204.msg113490.html#msg113490

Atenção: Caso o motorola seja o que falei e você pegue o meu pacote chamado de modem-arquivos-16.tar.gz, descompacte-o leia o arquivo de texto chamado Leia-me ou o guia de instalação em pdf para saber como usar este meu pacote. Nele não é preciso instalar os compiladores por ele vai ser instalado durante o processo de execução do script desde que você vá fazendo o que for pedido ok.
« Última modificação: 05 de Setembro de 2007, 14:30 por alarcon »

Offline Tetsuo

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re: agere systems pci soft modem
« Resposta #35 Online: 05 de Setembro de 2007, 14:30 »
Os drivers do cd dele estão como pacotes. Basta instalar e pronto. Inclusive na embalagem tá escrito que ele é compatível com linux, além de XP e Windows ME. Você acha que ainda assim pode haver problemas? Basta reinstalar o Ubuntu sem precisar formatar o outro? Por cima mesmo? Desses drivers que eu citei, nenhum serve pro Ubuntu? Bem, se não servirem, eu tenho os 5 cds do Fedora Core 5.0 e o Kurumin. Vou sair agora, mas quando eu chegar coloco a informação sobre o ID.

alarcon

  • Visitante
Re: agere systems pci soft modem
« Resposta #36 Online: 05 de Setembro de 2007, 14:39 »
Os drivers do cd dele estão como pacotes. Basta instalar e pronto. Inclusive na embalagem tá escrito que ele é compatível com linux, além de XP e Windows ME. Você acha que ainda assim pode haver problemas? Basta reinstalar o Ubuntu sem precisar formatar o outro? Por cima mesmo? Desses drivers que eu citei, nenhum serve pro Ubuntun? Bem, se não servirem, eu tenho os 5 cds do Fedora Core 5.0 e o Kurumin. Vou sair agora, mas quando eu chegar coloco a informação sobre o ID.

Instale o Ubuntu formatando novamente a partição que estava anteriormente instalado o próprio Ubuntu.

É por que devem ser driver antigos destas distribuições Linux, mas primeiramente faça o que pedi, ou seja, reinstale o Ubuntu, veja pra mim a ID dele e só depois veremos que atitude tomar.

Caso o modem já esteja instalado você pode obter esta informação da ID dele pelo próprio windows, bastando ir em IniciarConfigurações > Painel de controle > Sistema > Aba Hardware > Gerenciador de dispositivo >  clicar no sinal de + ao lado do modem e depois com o botão direito do mouse sobre o tipo de modem e ir em Propriedades > na janela que abrir, ir na Aba Diagnótico e logo abaixo copiar a informação do tipo:

PCI\VEN_1057&DEV_3052....

E a ID seria 1057:3052

Atenção: retire qualquer outro softmodem que esteja conectado no PCI da sua placa mãe, deixando somente o da motorola ok.
« Última modificação: 05 de Setembro de 2007, 14:50 por alarcon »

Offline Tetsuo

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re: agere systems pci soft modem
« Resposta #37 Online: 05 de Setembro de 2007, 17:30 »
ID do modem: PCI\VEN_1057&DEV_3052&SUBSYS_30201057&REV_04

O próprio cd do Ubuntu tem essa função pra formatar partiçoes Linux? Mas formatar sem desmanchar as partições é o que eu quero.

À propósito, o modem custou 29,90.

No momento, o único modem na minha placa mãe é o da Motorola.
« Última modificação: 05 de Setembro de 2007, 17:33 por Tetsuo »

alarcon

  • Visitante
Re: agere systems pci soft modem
« Resposta #38 Online: 05 de Setembro de 2007, 17:42 »
ID do modem: PCI\VEN_1057&DEV_3052&SUBSYS_30201057&REV_04

O próprio cd do Ubuntu tem essa função pra formatar partiçoes Linux? Mas formatar sem desmanchar as partições é o que eu quero.

À propósito, o modem custou 29,90.

No momento, o único modem na minha placa mãe é o da Motorola.


Não estou entendendo, você não tem o Ubuntu instalado no HD?

Ou você está usando o Ubuntu pelo LiveCD?

Se tem instalado, faça novamente da mesma maneira que fez da primeira vez que instalou ele.

Bom se você não quer reinstalar o Ubuntu ou não tem tanta experiência nisto e acha que pode apagar o outro sistema operacional, então vá neste link:

http://ubuntuforum-pt.org/index.php/topic,4204.msg113490.html#msg113490

baixe o arquivo modem-arquivos-v16.tar.gz e coloque na sua pasta de usuário dentro da /home.

Clique com o botão direito nela e escolha a opção extrair aqui, será criada uma pasta chamada de modem-arquivos-16 aí você abre ela e lê o guia_instalação.pdf que explica com ilustrações como usar este pacote. Atenção leia tudo que tem neste arquivo. Também tem um arquivo de texto chamado Leia-me que resume o processo de instalação.

Depois de responder corretamente as perguntas que lhe forem feitas durante o processo de instalação é só usar o gnome-ppp que deverá funcionar.

Quando falo para reinstalar é para diminuir que outras tentativas anteriores com outros drivers possam causar qualquer tipo de interferencia neste, ou seja, conflitos.

Veja este link aqui que explica e pode tirar dúvidas do processo de instalação do Ubuntu:

http://ubuntuforum-pt.org/index.php/topic,19226.0.html
« Última modificação: 05 de Setembro de 2007, 17:54 por alarcon »

Offline Tetsuo

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re: agere systems pci soft modem
« Resposta #39 Online: 05 de Setembro de 2007, 18:32 »
Eu já reinstalei o Ubuntu. Eu uso ele no HD, ok?

Offline Tetsuo

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re: agere systems pci soft modem
« Resposta #40 Online: 05 de Setembro de 2007, 19:32 »
Ufa! Graças ao seu manual pdf eu já estou on-line no Ubuntu. E essa mensagem é a prova disso. Cara, muito obrigado pela sua ajuda e pela paciência que teve comigo. É claro que eu tenho que aprender muitas coisas relacionadas a esse sistema, até porque eu passei muito tempo no windows. Dúvidas não faltarão e, com certeza, serei mais do que nunca um usuário assíduo do fórum. Valeu mesmo!

Offline Tetsuo

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re: agere systems pci soft modem
« Resposta #41 Online: 05 de Setembro de 2007, 19:34 »
Tá vendo? Já apareceu uma dúvida. Eu cliquei em "detalhes" na conexão, mas não vi a velocidade. Outra coisa. É necessário usar anti-vírus e firewall no Linux?

alarcon

  • Visitante
Re: agere systems pci soft modem
« Resposta #42 Online: 05 de Setembro de 2007, 21:12 »
Que bom que meu pacote funcionou para você também.

Bom para saber a velocidade de conexão você ao clicar em conectar no gnome-ppp aparece outra janela e lá você deve clicar no botão registro e só então aí é possível ver a velocidade que ele conectou ok.

Com relação a antivírus não há necessidade, só se for para varrer os arquivos que você recebe por email e precisar repassar para outra pessoa, para não disseminar vírus para o windows. ;D

Firewall tem o firestarter, no momento vou ter de sair e não posso explicar agora, mas pesquise aqui no fórum sobre o firestarter. Amanhã falo com mais detalhe sobre ele.

Outra coisa escreva no meu tópico aqui:

http://ubuntuforum-pt.org/index.php/topic,4204.495.html

relatando seu sucesso com o modem motorola e o meu pacote para que outros usuários que possívelmente tenham este tipo de modem também passem a usar ele no Ubuntu ok.

O que você achou do pacote que fiz, ou seja, é de fácil compreenção e facilita realmente o uso?

outra dica para saber a sua velocidade é acessar este site:

http://www.rjnet.com.br/2velocimetro.php
« Última modificação: 05 de Setembro de 2007, 21:14 por alarcon »

Offline Tetsuo

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re: agere systems pci soft modem
« Resposta #43 Online: 05 de Setembro de 2007, 22:08 »
O pacote foi fundamental para o sucesso da minha conexão. Do jeito que as explicações estão detalhadas lá, realmente não tem como alguém errar. Eu fui lendo e ao mesmo tempo executando o procedimento. Achava até que, como leigo, não ia acertar de primeira, mas tudo deu certo. Para os iniciantes o pacote é definitivamente uma mão na roda. Parabéns!

Offline Shakmatton

  • Usuário Ubuntu
  • *
  • Mensagens: 213
    • Ver perfil
Re: agere systems pci soft modem
« Resposta #44 Online: 21 de Setembro de 2007, 02:48 »
Olá a todos. Sou iniciante no mundo linux, e venho há uma semana (desde que instalei o Ubuntu em minh máquina) tentando configurar a internet.
Já vi vários posts por todo este fórum, casos de sucesso, muitos de fracasso, e alguns no meio-termo... mas lendo este último post do tetsuo minha fé foi renovada, e continuarei tentando fazer meu Motorola SM56 Speakerphone funcionar (é o tal do 1057:xxxx (rev 04) - os detalhes eu não lembro).

Bom, disseram que para resolver o problema teria que reinstalar o Ubuntu... o meu é 7.04, roda no hd, e é a segunda partição do disco (primeira é o XP)... e como iniciante que se preze, tentei resolver por meios próprios (via google da vida, etc), até ter a idéia óbvia de vir procurar com quem sabe e no lugar certo, ou seja , por aqui no fórum oficial... cheguei a instalar o pacote do alarcon, foi bem elaborado mesmo, mas não consegui fazer funcionar).
Antes que eu esqueça, com dual boot, reinstalar Ubuntu = formatar tudo e instalar backups do windows e cd do Ubuntu ??? O que fazer ? (Chega de atirar primeiro e perguntar depois...)

Continuando, o tal do ttySL0 não apareceu, na hora de conectar o gnome-ppp tenta e não consegue (no log aparece device busy). Além disso o modem não é detectado. O pacote ALSA aparece na seção de quebrados no synaptic por conflito (acho que foi por causa das doideiras que tentei instalar a esmo...).

Enfim, sei que deve haver uma maneira, mas estou cansado de lutar sozinho, por isso finalmente resolvi pedir ajuda... terrível a sensação de dependência do windows, o Ubuntu é bonito, eficiente, mas está no seu estado bruto, primitivo, cru, já que preciso ir baixando os tais pacotes (como iniciante ainda não entendi  muita coisa sobre isso, de repente meu problema pode envolver isso também...), e sem internet ele no momento está mais para uma curiosidade a ser mostrada pros meus pais, hehe...

Desculpem escrever disparando desse jeito, depois eu vou mandando detalhes de tudo.
Agradeço desde já a quem puder me ajudar... Obrigado.