Autor Tópico: Problema no grub???(Resolvido)  (Lida 33327 vezes)

alarcon

  • Visitante
Re: Problema no grub???(Resolvido)
« Resposta #15 Online: 28 de Setembro de 2007, 20:41 »
não estou conseguindo nesta parte:
grub edit > root (hd0,2)

e aí, o que faço?

Não consigo entrar no linux e estou precisando de uns documentos que estão na partiçao ??? ;D

Você entendeu como edita temporariamente as entradas relativas ao Ubuntu no grub?

Para lhe ajudar eu preciso saber onde está instalado o Ubuntu, em qual partição.

Seu grub deu defeito após alguma atualização do kernel?

Quando você entra no modo de edição do grub, basta se movimentar para esquerda ou direita com as setas do teclado e quando o cursor ficar na posição adequada você deleta o valor errado e digita o certo, depois é só teclar enter e depois a letra b ( de boot).
« Última modificação: 28 de Setembro de 2007, 20:47 por alarcon »

alarcon

  • Visitante
Re: Problema no grub???(Resolvido)
« Resposta #16 Online: 28 de Setembro de 2007, 21:13 »
Cara!
Ve se vc pod me ajudar?
Eu to tentando fazer isso desde hoje de manhã!
Eu não consigo entrar no menu.lst, eu entro no grub e consigo editar, mas da erro!
Mudo a partição para (sda,1)

Valew!

Já expliquei sobre isso (sda,1) e acho que você não entendeu. Tentarei ver se melhoro o que disse.

Se você tem o Ubuntu instalado na partição sda isso quer dizer que seu HD é SATA e que o Ubuntu está instalado na primeira partição  isso no grub é representado assim (hd0,0)=sda1, como acho difícil que seja assim, pois muito provavelmente você está usando windows em dual boot com o linux e ele deve sempre ficar na primeira partição primária, então acho que a partição que deve esta o Ubuntu é a partição sda2 = (hd0,1).

Entendeu agora?

Nesta linha do grub, por exemplo:

root      (hd0,5)

mude para o número, o em negrito, que você achar que seja sua partição


Talvez esta:

root      (hd0,1)

Você ainda não me respondeu em que ponto seu grub passou a apresentar defeito.

Em alguma atualização do kernel?

/dev/hda1 e /dev/sda1 = (hd0,0)  ;  (hda ou sda = hd0 ,  1 = 0)

/dev/hda2 e /dev/sda2 = (hd0,1)  ;  (hda ou sda = hd0 ,  2 = 1)

/dev/hda3 e /dev/sda3 = (hd0,2)  ;  (hda ou sda = hd0 ,  3 = 2)

/dev/hda4 e /dev/sda4 = (hd0,3)  ;  (hda ou sda = hd0 ,  4 = 3)

e etc.

hd?= HD IDE

sd?=HD SATA



« Última modificação: 28 de Setembro de 2007, 21:34 por alarcon »

Offline juliana.yszcz

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Problema no grub???(Resolvido)
« Resposta #17 Online: 28 de Setembro de 2007, 21:20 »
Isso aconteceu depois de uma atualização.
Uso windows e linux.
Não diga Linux. Diga GNU/Linux. O senhor barbudo de olho verde também merece os méritos!

Offline juliana.yszcz

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Problema no grub???(Resolvido)
« Resposta #18 Online: 28 de Setembro de 2007, 21:25 »
mudo de (hd0,1) para (sda,1) ou

e aparece erro 23:
número não encontrado
Não diga Linux. Diga GNU/Linux. O senhor barbudo de olho verde também merece os méritos!

alarcon

  • Visitante
Re: Problema no grub???(Resolvido)
« Resposta #19 Online: 28 de Setembro de 2007, 21:33 »
mudo de (hd0,1) para (sda,1) ou

e aparece erro 23:
número não encontrado

preste atenção no que estou dizendo, no grub  não existe isso ( sda,1) que você está tentando fazer. É o que estou dizendo acima.

se sua partição linux é essa sda1 no grub é assim (hd0,0) que se representa

se sua partição linux é essa sda2 no grub é assim (hd0,1) que se representa

se sua partição linux é essa sda3 no grub é assim (hd0,2) que se representa

se sua partição linux é essa sda4 no grub é assim (hd0,3) que se representa

e etc.
« Última modificação: 28 de Setembro de 2007, 21:38 por alarcon »

alarcon

  • Visitante
Re: Problema no grub???(Resolvido)
« Resposta #20 Online: 28 de Setembro de 2007, 21:46 »
Supondo que o seu grub, com relação ao Ubuntu, tivesse assim:

Citar
title      Ubuntu, kernel 2.6.20-16-generic
root      (hd0,0)
kernel      /boot/vmlinuz-2.6.20-16-generic root=UUID=da838fb4-de57-4a7c-bf60-9b5f4685fa69 ro quiet splash
initrd      /boot/initrd.img-2.6.20-16-generic
quiet
savedefault

com as informações em negrito ( e vermelho) erradas e as certa fossem:

Citar
title      Ubuntu, kernel 2.6.20-16-generic
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.20-16-generic root=/dev/sda2 ro quiet splash
initrd      /boot/initrd.img-2.6.20-16-generic
quiet
savedefault

aí você editava estas linhas no grub colocando os valores corretos ( os em negrito e verde).



« Última modificação: 28 de Setembro de 2007, 21:48 por alarcon »

Offline juliana.yszcz

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Problema no grub???(Resolvido)
« Resposta #21 Online: 28 de Setembro de 2007, 21:59 »
Valeu!!!

Estou no linux......

 :D :D :D
Não diga Linux. Diga GNU/Linux. O senhor barbudo de olho verde também merece os méritos!

alarcon

  • Visitante
Re: Problema no grub???(Resolvido)
« Resposta #22 Online: 28 de Setembro de 2007, 22:00 »
Valeu!!!

Estou no linux......

 :D :D :D

Nada, mas onde estava o erro.

Edite o menu.lst para que as mudanças fiquem permanentes ok.

Offline juliana.yszcz

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Problema no grub???(Resolvido)
« Resposta #23 Online: 28 de Setembro de 2007, 22:10 »
O erro estava como vc postou na última mensagem. Mudei e deu certo
Se não fosse a mensagem, não mudaria isso nunca aquela parte do /dev/sda2.
Não diga Linux. Diga GNU/Linux. O senhor barbudo de olho verde também merece os méritos!

alarcon

  • Visitante
Re: Problema no grub???(Resolvido)
« Resposta #24 Online: 28 de Setembro de 2007, 22:15 »
O erro estava como vc postou na última mensagem. Mudei e deu certo
Se não fosse a mensagem, não mudaria isso nunca aquela parte do /dev/sda2.

É o seguinte o Ubuntu nesta ultima versão inventou esta tal de UUID=numero enorme, mas isso quando você altera o kernel muda de valor e o grub não consegue identificar o novo valor, ficando com o antigo e aí dá erro. Representando da fora antiga não tem erro (/dev/sda?). Para saber o novo valor desta tal de  UUID basta abrir um terminal e digitar: blkid este comando vai informar as UUID de todas as partições existentes no seu HD.

Depois era só mudar o valor para o novo, mas era mais complicado falar assim e como você não podia entrar no linux para verificar qual seria este novo código, então achei melhor da forma antiga.
« Última modificação: 28 de Setembro de 2007, 22:19 por alarcon »

Offline juliana.yszcz

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Problema no grub???(Resolvido)
« Resposta #25 Online: 28 de Setembro de 2007, 22:35 »
Interessante, vou estudar mais sobre isso.

Muito obrigado pelas dicas.
Não diga Linux. Diga GNU/Linux. O senhor barbudo de olho verde também merece os méritos!

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problema no grub???(Resolvido)
« Resposta #26 Online: 28 de Setembro de 2007, 23:27 »
É o seguinte o Ubuntu nesta ultima versão inventou esta tal de UUID=numero enorme, mas isso quando você altera o kernel muda de valor e o grub não consegue identificar o novo valor, ficando com o antigo e aí dá erro. Representando da fora antiga não tem erro (/dev/sda?). Para saber o novo valor desta tal de  UUID basta abrir um terminal e digitar: blkid este comando vai informar as UUID de todas as partições existentes no seu HD.

Depois era só mudar o valor para o novo, mas era mais complicado falar assim e como você não podia entrar no linux para verificar qual seria este novo código, então achei melhor da forma antiga.

alarcon concordo com você que usar as informações sem o UUID são mais fáceis de entender, e também de mexer, mas dai você dizer que alterar o kernel provoca problemas porque o grub não consegue identificar o novo valor é algo falso.

Só como exemplo, esta semana instalei várias máquinas novas com o Ubuntu 7.04, em nenhuma delas eu alterei o arquivo /etc/fstab e /boot/grub/menu.lst (ou seja, o UUID ficou lá). Todas foram atualizadas, inclusive kernel, e absolutamente nenhuma delas deu problemas.

Quando você mexe nos seus HD's, ou nas partições, pode mesmo ocorrer do UUID mudar, e o GRUB não identifica mesmo a mudança, desde que você não o reinstale, pois se fizer isto o arquivo /boot/grub/menu.lst será refeito perfeitamente (ao menos em teoria).
« Última modificação: 28 de Setembro de 2007, 23:30 por clcampos »
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

alarcon

  • Visitante
Re: Problema no grub???(Resolvido)
« Resposta #27 Online: 29 de Setembro de 2007, 10:35 »
É o seguinte o Ubuntu nesta ultima versão inventou esta tal de UUID=numero enorme, mas isso quando você altera o kernel muda de valor e o grub não consegue identificar o novo valor, ficando com o antigo e aí dá erro. Representando da fora antiga não tem erro (/dev/sda?). Para saber o novo valor desta tal de  UUID basta abrir um terminal e digitar: blkid este comando vai informar as UUID de todas as partições existentes no seu HD.

Depois era só mudar o valor para o novo, mas era mais complicado falar assim e como você não podia entrar no linux para verificar qual seria este novo código, então achei melhor da forma antiga.

alarcon concordo com você que usar as informações sem o UUID são mais fáceis de entender, e também de mexer, mas dai você dizer que alterar o kernel provoca problemas porque o grub não consegue identificar o novo valor é algo falso.

Só como exemplo, esta semana instalei várias máquinas novas com o Ubuntu 7.04, em nenhuma delas eu alterei o arquivo /etc/fstab e /boot/grub/menu.lst (ou seja, o UUID ficou lá). Todas foram atualizadas, inclusive kernel, e absolutamente nenhuma delas deu problemas.

Quando você mexe nos seus HD's, ou nas partições, pode mesmo ocorrer do UUID mudar, e o GRUB não identifica mesmo a mudança, desde que você não o reinstale, pois se fizer isto o arquivo /boot/grub/menu.lst será refeito perfeitamente (ao menos em teoria).

clcampos tudo que falo aqui é sobre o que já aconteceu comigo, ou seja, por experiência própria e o que pude observar é que na atualização do kernel, por estas duas ultimas vezes, ocorreu de o menu.lst do grub não atualizar corretamente as informações, ou seja:

esta parte do meu grub:

root      (hd0,5)

se altera para (após a atualização do kernel):

root      (hd0,4)

portanto um valor completamente errado, pois o meu ubuntu está na partição sda6 = (hd0,5) e não na partição sda5=(hd0,4)

Esta outra parte do grub também fica de forma errada:

kernel      /boot/vmlinuz-2.6.20-15-generic root=UUID=da838fb4-de57-4a7c-bf60-9b5f4685fa69 ro
single

a parte em negrito se altera para outro valor de código e portanto causa erro. No fstab a UUID muda para o novo valor, mas no menu.lst do grub não, ou seja, permanece no antigo e causa conflito.

Você pode observar como ultimamente apareceram vários tópicos aqui com problemas no grub, coisa que antigamente não ocorria. Podem ser só coincidências ou os motivos de erros até outros, pois não lembro dos motivos de todos, mas que cresceu falhas nesta parte não há como negar.

Não sei se isso ocorre com todos, mas aqui comigo aconteceu por duas vezes e foi na atualização do kernel. Na hora do comando que executa a verificação do novo kernel e altera as entradas no menu.lst do grub está fazendo errado.

Nas duas vezes que ocorreu não fiz qualquer alteração no HD, foi só mesmo a atualização do kernel via gerenciador de atualizações do Ubuntu.

Foi o que suspeitei ter ocorrido com nossa colega acima, pois ela alterava o valor (hd0,1) e não conseguia ainda entrar no Ubuntu, então suspeitei que o UUID estivesse errado e foi só ela colocar na forma tradicional /dev/sda2 que funcionou. Perguntei a ela se havia atualizado o kernel recentemente e ela confirmou. Será apenas coincidência?

Está parecendo aquele personagem do filme Auto da Compadecida, o Chicó (Selton Mello) que dizia: " Não sei, só sei que foi assim"  ;D
« Última modificação: 29 de Setembro de 2007, 11:41 por alarcon »

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problema no grub???(Resolvido)
« Resposta #28 Online: 29 de Setembro de 2007, 20:53 »
Tenho 2 PC's e um note. Um destes três equipamentos apresenta problema bastante semelhante ao seu toda vez que atualizo o kernel. Tenho este problema com ele a muito tempo, com certeza desde o Dapper.

Acho que o meu problema, assim como o seu, são problemas isolados. Digo isolados porque cuido, de certa forma,  de mais de 80 máquinas (entre as minhas, de amigos, família e trabalho) e somente esta é assim.

Só fiz a intervenção anterior porque não vi em  seu texto algo que mostre que isto é um problema isolado, ou de uma minoria,  e ainda o liga ao uso do UUID, e como pode ver eu tenho problema semelhante a muito mais tempo que isto.

Citar
É o seguinte o Ubuntu nesta ultima versão inventou esta tal de UUID=numero enorme, mas isso quando você altera o kernel muda de valor e o grub não consegue identificar o novo valor, ficando com o antigo e aí dá erro.

De qualquer forma ainda não vi nenhuma utilidade  que justifique o uso do UUID.
« Última modificação: 29 de Setembro de 2007, 20:56 por clcampos »
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

alarcon

  • Visitante
Re: Problema no grub???(Resolvido)
« Resposta #29 Online: 29 de Setembro de 2007, 21:01 »
Tenho 2 PC's e um note. Um destes três equipamentos apresenta problema bastante semelhante ao seu toda vez que atualizo o kernel. Tenho este problema com ele a muito tempo, com certeza desde o Dapper.

Acho que o meu problema, assim como o seu, são problemas isolados. Digo isolados porque cuido, de certa forma,  de mais de 80 máquinas (entre as minhas, de amigos, família e trabalho) e somente esta é assim.

Só fiz a intervenção anterior porque não vi em  seu texto algo que mostre que isto é um problema isolado, ou de uma minoria,  e ainda o liga ao uso do UUID, e como pode ver eu tenho problema semelhante a muito mais tempo que isto.

Bom isso só ocorreu agora nas atualizações dos pacotes linux-image-2.6.20-16-generic_2.6.20-16.31_all.deb e linux-image-2.6.20-16-generic_2.6.20-16.32_all.deb, ou seja nas duas ultimas atualizações do kernel versão 2.6.20-16-generic. Perceba que nas atualizações anteriores a estas do kernel 2.6.20-16-generic e na atualização do kernel 2.6.20-15-generic  para o  kernel 2.6.20-16-generic não houve qualquer tipo de erro. O PC continua sendo o mesmo.

Que eu me lembre o Dapper não tinha esta entrada UUID no fstab e nem no grub. No Edgy não posso falar por que não usei. Pulei do Dapper para Feisty.

Pensei até ser algum erro no script que deve ter no pacote do kernel (postinst) que esteja com algum tipo de erro e que não atualiza direito o menu.lst do grub.
« Última modificação: 29 de Setembro de 2007, 21:08 por alarcon »