Autor Tópico: problema com reconhecimento do modem  (Lida 2871 vezes)

Offline Lacrimas

  • Usuário Ubuntu
  • *
  • Mensagens: 4
  • Ushiha Sasuke
    • Ver perfil
problema com reconhecimento do modem
« Online: 30 de Setembro de 2007, 04:40 »

In-Build CX11252-41z modem

fabricante: conexant

Alguem sabe como posso instalar este modem em meu Ubuntu 7.04?

Por favor quero logo a net no linux pra sair do windows.
set your mind free with linux!

alarcon

  • Visitante
Re: problema com reconhecimento do modem
« Resposta #1 Online: 30 de Setembro de 2007, 11:13 »

In-Build CX11252-41z modem

fabricante: conexant

Alguem sabe como posso instalar este modem em meu Ubuntu 7.04?

Por favor quero logo a net no linux pra sair do windows.


É modem para conexão discada?

Abra um terminal  (Menu Aplicações > Acessórios > Terminal) e digite:

lspci

cole aqui o resultado.

e também do comando:

lspci -n

Offline Lacrimas

  • Usuário Ubuntu
  • *
  • Mensagens: 4
  • Ushiha Sasuke
    • Ver perfil
Re: problema com reconhecimento do modem
« Resposta #2 Online: 01 de Outubro de 2007, 03:24 »
É para discada mesmo!

emerson@Glory:~$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:07.0 Communication controller: Conexant Unknown device 2f30 (rev 01)
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: VIA Technologies, Inc. UniChrome Pro IGP (rev 01)


emerson@Glory:~$ lspci -n
00:00.0 0600: 1106:0314
00:00.1 0600: 1106:1314
00:00.2 0600: 1106:2314
00:00.3 0600: 1106:3208
00:00.4 0600: 1106:4314
00:00.7 0600: 1106:7314
00:01.0 0604: 1106:b198
00:07.0 0780: 14f1:2f30 (rev 01)
00:0f.0 0101: 1106:3149 (rev 80)
00:0f.1 0101: 1106:0571 (rev 06)
00:10.0 0c03: 1106:3038 (rev 81)
00:10.1 0c03: 1106:3038 (rev 81)
00:10.2 0c03: 1106:3038 (rev 81)
00:10.3 0c03: 1106:3038 (rev 81)
00:10.4 0c03: 1106:3104 (rev 86)
00:11.0 0601: 1106:3227
00:11.5 0401: 1106:3059 (rev 60)
00:12.0 0200: 1106:3065 (rev 78)
01:00.0 0300: 1106:3344 (rev 01)
set your mind free with linux!

alarcon

  • Visitante
Re: problema com reconhecimento do modem
« Resposta #3 Online: 01 de Outubro de 2007, 11:02 »
É para discada mesmo!

emerson@Glory:~$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:07.0 Communication controller: Conexant Unknown device 2f30 (rev 01)
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: VIA Technologies, Inc. UniChrome Pro IGP (rev 01)


emerson@Glory:~$ lspci -n
00:00.0 0600: 1106:0314
00:00.1 0600: 1106:1314
00:00.2 0600: 1106:2314
00:00.3 0600: 1106:3208
00:00.4 0600: 1106:4314
00:00.7 0600: 1106:7314
00:01.0 0604: 1106:b198
00:07.0 0780: 14f1:2f30 (rev 01)
00:0f.0 0101: 1106:3149 (rev 80)
00:0f.1 0101: 1106:0571 (rev 06)
00:10.0 0c03: 1106:3038 (rev 81)
00:10.1 0c03: 1106:3038 (rev 81)
00:10.2 0c03: 1106:3038 (rev 81)
00:10.3 0c03: 1106:3038 (rev 81)
00:10.4 0c03: 1106:3104 (rev 86)
00:11.0 0601: 1106:3227
00:11.5 0401: 1106:3059 (rev 60)
00:12.0 0200: 1106:3065 (rev 78)
01:00.0 0300: 1106:3344 (rev 01)


É o seguinte seu modem é esse:

00:07.0 Communication controller: Conexant Unknown device 2f30 (rev 01)

e tem esta ID: 14f1:2f30

Portanto ele deve usar o driver Conexant para softmodems, só que este driver é fornecido pela Linuxant e até onde sei não é um driver gratuito, ou seja, tem de comprar uma licença para que o modem funcione na velocidade de 56k por que sem a licença ele até funciona mais na velocidade de 14k o que é muito baixa para os dias atuais.

Navegando na internet encontrei o site da DELL , na seção de Drivers & Downloads, o driver para modems Conexant. Como estas páginas são para se baixar drivers para os computadores de tal marca, creio que os driver disponibilizados lá são gratuitos, ou seja, não deverá pedir licença para uso por que não fala nada a esse respeito nas instruções de uso por lá, portanto você deveria testá-lo para ver se funciona sem pedir licença e se funciona para outros PC que não sejam da DELL.

O Site é esse:

http://support.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R155004&SystemID=INSPIRONI6400/E1505&servicetag=&os=UBLN&osl=en&deviceid=8593&devlib=0&typecnt=0&vercnt=1&catid=-1&impid=-1&formatcnt=1&libid=20&fileid=206745

e o arquivo que você deve baixar se chama hsfmodem_7.60.00.06oem_i386.deb. Depois de baixá-lo e colocar no Ubuntu basta dar dois clique sobre ele e escolher aplicar digitando depois sua senha.

Atenção que quando ele estiver instalando e na sua janela de instalação clique numa seta preta próximo a palavra terminal para abrir uma janela de terminal, pois parece que nesta janela vai ser feita algumas perguntas que você terá de apenas tclar enter para fica com as opções que são padrões segundo se entende das intruções aqui:

Citar
Installation Instructions
Custom Instructions for hsfmodem_7.60.00.06oem_i386.deb:

* Download the hsfmodem_(version).deb to your desktop.
* Double-click the hsfmodem_(version).deb file. The Package Installer will launch
* Click "Install Package"
* The system prompts you for your system password. Type your password in the password field and press .
* The Installing Package File window appears. Click on the empty right triangle to the left of the word Terminal in the Installing Package File window.
* A terminal window appears within the Installing Package File window. Click anywhere inside the terminal window and press . The system builds the correct driver for your system.
* Press to accept the default when the terminal prompts you to enter a region name for the modem.
* After a few seconds, the name of the window changes from Installing Package File to Installation Finished. Click Close.

The hsfmodem modem driver is now installed on your system.

Depois de instalado o driver instale o discador para o Ubuntu baixando-o daqui:

http://mirrors.kernel.org/ubuntu/pool/universe/g/gnome-ppp/gnome-ppp_0.3.23-1_i386.deb

mesma coisa depois de baixá-lo e colocar no Ubuntu clique nele duas vezes e escolha instalar digitando sua senha.

Considerando que você tenha instalado corretamente o seu modem através do driver correto e que você também tem instalado o discador gnome-ppp, faça mais isso:

abra um terminal ( Menu Aplicações > Acessórios > Terminal) e digite:

sudo gedit /etc/ppp/pap-secrets

e coloque no seu final exatamente isso:

"usuario@provedor.com.br" * "senha1234"

ainda no terminal digite:

sudo gedit /etc/ppp/chap-secrets

e coloque no seu final exatamente isso:

"usuario@provedor.com.br" * "senha1234"

Sendo que as informações contidas entre duas aspas (" "), mude obviamente para o seu nome de acesso do provedor completo (onde tem usuario@provedor.com.br)  e  para sua senha de acesso  do provedor (onde tem senah1234).

Abra o gnome-ppp clique em Configuração vá na aba Opções e deixe marcada a opção Ignorar sequências de terminal (modo burro). Deixe marca a opção verificar portadora e se ainda sim não funcionar, desmarque a opção verificar portadora.

Na aba Modem, ainda na janela de configuração do gnome-ppp clique no botão Detectar par adetectar o dispositivo que o modem irá usar.


OBS: No discador gnome-ppp, que se encontra no Menu Aplicações > Internet > GNOME PPP, coloque como nome de acesso do provedor o seu nome de acesso completo ( usuario@provedor.com.br) e não apenas o nome como é de costume nos discadores dos provedores (discador Ibest).



« Última modificação: 01 de Outubro de 2007, 11:05 por alarcon »

Offline Lacrimas

  • Usuário Ubuntu
  • *
  • Mensagens: 4
  • Ushiha Sasuke
    • Ver perfil
Re: problema com reconhecimento do modem
« Resposta #4 Online: 02 de Outubro de 2007, 02:49 »
Fiz o q pediu mas quando eu tento conectar ele diz q não consegue achar o modem, acho que o arquivo não reconheceu meu modem, ai quando dei lspci ele continua acusando que é deconhecido!
set your mind free with linux!

alarcon

  • Visitante
Re: problema com reconhecimento do modem
« Resposta #5 Online: 02 de Outubro de 2007, 10:09 »
Fiz o q pediu mas quando eu tento conectar ele diz q não consegue achar o modem, acho que o arquivo não reconheceu meu modem, ai quando dei lspci ele continua acusando que é deconhecido!

Olha só quando você clicou duas vezes no arquivo baixado ele abre uma janela para instalar. Quando você clica em instalar e depois digita sua seha ele começa o processo com uma barra de progresso nesta mesma janela. Se você observar logo em baixo tem a palavra terminal e uma seta preta (apontando para à direita acho) clique nela, durante o processo de instalação, e vá respondendo ou teclando enter quando pedido por lá.

Acho pouco provável que o driver não seja esse, pois pela ID do seu modem que é essa: 14f1:2f30

Sei que seu modem é compatível com o driver Conexant. O que poderia acontecer era ele só funcionar na velocidade mínima devido a falta de licença, mas não ficar sem funcionar, então veja aí se você não fez nada de errado.

o comando lspci é para listar componentes PCI no seu sistema e o modem no caso é identificado como sendo: 00:07.0 Communication controller: Conexant Unknown device 2f30 (rev 01). Esta informação não muda com o driver instalado, é apenas a forma como o Ubuntu o identifica e que no caso no windows deverá ter outro nome por isso que identificar um modem pelo nome não é a forma mais adequando e sim pela ID do mesmo, pois tal informação não muda de um sistema operacional para o outro.
« Última modificação: 02 de Outubro de 2007, 10:37 por alarcon »

alarcon

  • Visitante
Re: problema com reconhecimento do modem
« Resposta #6 Online: 02 de Outubro de 2007, 10:29 »
O link que te forneci é para baixar o driver em formato .deb, portanto já compilado. Agora se ele está no formato .deb, mas ainda precisa ser compilado, então antes é preciso ter alguns pacotes instalados no seu sistema para que você possa compilar algo nele.

Para se compilar algo antes é necessário ter instalado no seu sistema os seguintes pacotes .deb:

make
gcc
build-essential
linux-headers-versão_kernel


onde versão_kernel deve ser o valor do seu kernel e para saber esta informação abra um terminal ( Menu Aplicações > Acessórios > Terminal) e digite: uname -r

por exemplo se ao digitar uname -r der isso como resultado 2.6.20-15-generic aí o pacote a ser baixado seria linux-headers-2.6.20-15-generic

OBS: muito provavelmente será este linux-headers-2.6.20-15-generic

para instalar estes pacotes basta primeiro você adicionar o LiveCd do Ubunu na lista de repositórios do apt-get assim:

Abra um terminal ( Menu Aplicações > Acessórios > Terminal) e digite:

sudo apt-cdrom add

aparecerá uma informação no terminal pedindo para você colocar o CD-Rom no driver e depois teclar ENTER para adicionar o CD na lista de repositórios, como mostrado abaixo:

Citar
Usando ponto de montagem de CD-ROm /cdrom/
Desmontando CD-ROM
Aguardando por disco ...
Por favor, insira um Disco no leitor e pressione enter

depois disso faça:

sudo apt-get --assume-yes install make gcc build-essential linux-headers-versão_kernel

Atenção: mude a parte em vermelho para o valor correto ok.

aguarde o processo de instalação terminar.

baixe também estes pacotes .deb aqui:

http://mirrors.kernel.org/ubuntu/pool/main/a/alsa-lib/libasound2_1.0.13-1ubuntu5_i386.deb

http://mirrors.kernel.org/ubuntu/pool/main/a/alsa-lib/libasound2-dev_1.0.13-1ubuntu5_i386.deb

http://mirrors.kernel.org/ubuntu/pool/universe/g/gnome-ppp/gnome-ppp_0.3.23-1_i386.deb

depois de baixá-los é só dar um duplo clique em cada um deles para instalá-los ok.

Só então tente instalr o driver do modem ok.

agora digite:

gedit /home/seu_usuario/.wvdial.conf

onde a parte em vermelho troque para exatamente o nome da sua pasta de usuario dentro da home.

será aberto um arquivo vazio e cole isso aqui nele:

Citar
[Dialer Defaults]
Modem = /dev/ttySHSF0
ISDN = off
Modem Type = Analog Modem
Baud = 115200
Init = ATZ
Init2 = AT&FW3+MS=V90,1,28800,33600,28800,56000
Init3 =
Init4 =
Init5 =
Init6 =
Init7 =
Init8 =
Init9 =
Phone = Telefone_de_acesso
Phone1 =
Phone2 =
Phone3 =
Phone4 =
Dial Prefix =
Dial Attempts = 1
Dial Command = ATM1L1DT
Ask Password = off
Password = Sua_Senha
Username = Seu_nome_de_acesso_completo
Auto Reconnect = off
Abort on Busy = on
Carrier Check = on
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = on
Idle Seconds = 0
Auto DNS = on
;Minimize = off
;Dock = on
;Do NOT edit this file by hand!

Alterando, obviamente, as partes em negrito para suas informações pessoais.


Por fim ainda no terminal faça mais isso:

sudo gedit /etc/ppp/pap-secrets

e coloque no final deste arquivo isso:

"usuario@provedor.com.br" * "senha1234"

obviamente mudando usuario@provedor.com.br para o valor correto do seu nome de usuário(completo) e senha1234 para sua senha do provedor. Copie e cole e só altere os valores falados entre as duas aspas (" ").

sudo gedit /etc/ppp/chap-secrets

Repita a mesma coisa do já falado acima neste outro arquivo, ou seja:

coloque no final deste arquivo isso:

"usuario@provedor.com.br" * "senha1234"

obviamente mudando usuario@provedor.com.br para o valor correto do seu nome de usuário(completo) e senha1234 para sua senha do provedor. Copie e cole e só altere os valores falados entre as duas aspas (" ").

Bom é isso, estes são os procedimentos para serem feitos no seu Ubuntu 7.04 Original, ou seja, nada de CD rematerizado.
« Última modificação: 02 de Outubro de 2007, 10:31 por alarcon »

Offline Lacrimas

  • Usuário Ubuntu
  • *
  • Mensagens: 4
  • Ushiha Sasuke
    • Ver perfil
Re: problema com reconhecimento do modem
« Resposta #7 Online: 02 de Outubro de 2007, 16:49 »
Fiz todo este processo e instalei todos os arquivos que vc pediu com sucesso, mas o problema continua...

quando clico em conhectar ele aparece q esta enviando senha e não sai dai, então cancelo e tento de novo ai ele diz q não foi possivel encontrar o modem.

e em configuração no gnome-ppp qnd clico em detectar o dispositivo, ele diz que não encontrou nehum modem no sistema.

set your mind free with linux!

alarcon

  • Visitante
Re: problema com reconhecimento do modem
« Resposta #8 Online: 02 de Outubro de 2007, 17:01 »
Fiz todo este processo e instalei todos os arquivos que vc pediu com sucesso, mas o problema continua...

quando clico em conhectar ele aparece q esta enviando senha e não sai dai, então cancelo e tento de novo ai ele diz q não foi possivel encontrar o modem.

e em configuração no gnome-ppp qnd clico em detectar o dispositivo, ele diz que não encontrou nehum modem no sistema.



Durante o processo de instalação do driver, você notou algum erro?

Foi reportado no terminal algum erro?