Autor Tópico: Barra de Aplicativos  (Lida 25420 vezes)

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Barra de Aplicativos
« Resposta #30 Online: 16 de Novembro de 2007, 00:09 »
No synaptic tem como usar filtros, e se não me engano você ve os arquivos quebrados.

Pegue o nome dele e execute o comando ai para acertar seu sistema. Ai é só começar tudo de novo.

[]'s

Cristiano
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline costa

  • Usuário Ubuntu
  • *
  • Mensagens: 83
    • Ver perfil
Re: Barra de Aplicativos
« Resposta #31 Online: 16 de Novembro de 2007, 00:28 »
clcampos,

Conseguimos acertar a questão dos pacotes "quebrados".

Já instalei novamente o AWN.

Agora é o seguinte:

   - Sobre a instalação dos pacotes que recomendou, tento novamente ou tem alguma prevenção antes?

Bem vamos lá, nunca tinha testado a barra, apenas instalado e brincado muito pouco com ela.

Como você precisou fui fazer alguns testes, e além de seguir as dicas do link que você passou, queria mexer nas preferências da barra, acessado através do clique com botão direito nela, mas não abria nada... e ai?

Bem, abri o Synaptic e fui pesquisar, e acabei instalando os pacotes:

  • awn-core-applets
  • awn-manager

Até!

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Barra de Aplicativos
« Resposta #32 Online: 16 de Novembro de 2007, 00:49 »
Você já sabe voltar atrás se der erro. E sem eles você não consegue fazer o que deseja.

Tente instalar ao menos o awn-manager.

[]'s

Cristiano
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline costa

  • Usuário Ubuntu
  • *
  • Mensagens: 83
    • Ver perfil
Re: Barra de Aplicativos
« Resposta #33 Online: 16 de Novembro de 2007, 00:57 »
Opa amigo!!

Já vi que entramos em uma...

olha o que deu..

Citar
E: /var/cache/apt/archives/libawn0_0.1.9-1+bzr20071006~3v1ubuntu0_i386.deb: tentando sobrescrever `/usr/lib/libawn.so.0.0.1', que também está no pacote libawn-bzr

Offline costa

  • Usuário Ubuntu
  • *
  • Mensagens: 83
    • Ver perfil
Re: Barra de Aplicativos
« Resposta #34 Online: 16 de Novembro de 2007, 01:12 »
Bem já voltei tudo ao normal.

Já apaguei tudo de novo.

Só que agora, fiquei meio recioso em instalar o AWN.

Uma coisa que percebi,

Existem esses pacotes pra instalar.

Citar
awn-core-applets

 awn-core-applets-bzr

 awn-manager


O que percebi, foi o seguinte na hora de instalar o AWN eu instalei com esse comando.

sudo apt-get install avant-window-navigator-bzr

O que faço agora?? Instalo esses dois?

Citar
awn-core-applets-bzr

 awn-manager
[/quote]

Offline costa

  • Usuário Ubuntu
  • *
  • Mensagens: 83
    • Ver perfil
Re: Barra de Aplicativos
« Resposta #35 Online: 16 de Novembro de 2007, 10:40 »
Olha o que eu consegui.



Tem como deixar "parecido" com os demais, que vejo por aqui ?

Eu abri as propriedades, e não tem muito applets.
« Última modificação: 16 de Novembro de 2007, 10:44 por costa »

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Barra de Aplicativos
« Resposta #36 Online: 16 de Novembro de 2007, 10:47 »
Bem, eu não instalei o pacote avant-window-navigator-bzr, e sim o pacote avant-window-navigator, portanto os pacotes a instalar ai devem ser diferentes.
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline costa

  • Usuário Ubuntu
  • *
  • Mensagens: 83
    • Ver perfil
Re: Barra de Aplicativos
« Resposta #37 Online: 16 de Novembro de 2007, 10:55 »
e quais seriam?

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Barra de Aplicativos
« Resposta #38 Online: 16 de Novembro de 2007, 10:57 »
Não uso este pacote. Abra o synaptic e pesquise, não tenha medo que não morde... hehehe
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline costa

  • Usuário Ubuntu
  • *
  • Mensagens: 83
    • Ver perfil
Re: Barra de Aplicativos
« Resposta #39 Online: 16 de Novembro de 2007, 11:12 »
Pois é rapaz.

Já fiz isso, varias vezes hoje.

Deu o mesmo problema de ontem. Acertei os pacotes quebrados e tudo mais.

Só que sinceramente, tô dando tiro no escuro. Não sei nem o que faço.

Offline costa

  • Usuário Ubuntu
  • *
  • Mensagens: 83
    • Ver perfil
Re: Barra de Aplicativos
« Resposta #40 Online: 16 de Novembro de 2007, 11:19 »
Sinceramente DESISTO!

Fui tentar instalar o pacote sem o final bzr, dá uma olhada no resultado.

Citar
bruno@bruno-desktop:~$ sudo apt-get install avant-window-navigator awn-core-appletsLendo Lista de Pacotes... Pronto
Construindo Árvore de Dependências       
Lendo informação de estado... Pronto
Os seguintes pacotes foram instalados automaticamente e não são mais necessários:
  libtrackerclient0
Use 'apt-get autoremove' para removê-los.
Os pacotes extra a seguir serão instalados:
  libawn0
Pacotes recomendados :
  awn-manager python-libawn0
Os pacotes a seguir serão REMOVIDOS:
  awn-core-applets-bzr
Os NOVOS pacotes a seguir serão instalados:
  avant-window-navigator awn-core-applets libawn0
0 pacotes atualizados, 3 pacotes novos instalados, 1 a serem removidos e 0 não atualizados.
É preciso fazer o download de 65,8kB/1374kB de arquivos.
Depois de desempacotamento, 4657kB adicionais de espaço em disco serão usados.
Quer continuar [S/n] ? s
Obtendo:1 http://download.tuxfamily.org feisty/eyecandy libawn0 0.1.9-1+bzr20071006~3v1ubuntu0 [65,8kB]
Baixados 65,8kB em 1s (37,0kB/s)
(Lendo banco de dados ... 121614 arquivos e diretórios atualmente instalados.)
Removendo awn-core-applets-bzr ...
(Lendo banco de dados ... 121587 arquivos e diretórios atualmente instalados.)
Descompactando libawn0 (de .../libawn0_0.1.9-1+bzr20071006~3v1ubuntu0_i386.deb) ...
dpkg: erro processando /var/cache/apt/archives/libawn0_0.1.9-1+bzr20071006~3v1ubuntu0_i386.deb (--unpack):
 tentando sobrescrever `/usr/lib/libawn.so.0.0.1', que também está no pacote libawn-bzr
Selecionando pacote previamente não selecionado avant-window-navigator.
Descompactando avant-window-navigator (de .../avant-window-navigator_0.1.9-1+bzr20071006~3v1ubuntu0_i386.deb) ...
Selecionando pacote previamente não selecionado awn-core-applets.
Descompactando awn-core-applets (de .../awn-core-applets_0.1.0+bzr20071005~3v1ubuntu0_i386.deb) ...
Erros foram encontrados durante processamento de:
 /var/cache/apt/archives/libawn0_0.1.9-1+bzr20071006~3v1ubuntu0_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Dessa vez, me venceram pelo cansaço :-\

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Barra de Aplicativos
« Resposta #41 Online: 16 de Novembro de 2007, 11:27 »
Olha só finalizando aqui o assunto faça assim. Desinstale os pacotes que você tem instalados, relativos a sua barra, usando o comando abaixo:

Código: [Selecionar]
sudo   apt-get   remove   --purge   avant-window-navigator-bzr
Execute exatamente o mesmo comando para cada um dos pacotes instalados.

Execute tambem o comando:

Código: [Selecionar]
sudo apt-get autoremove
e

Código: [Selecionar]
sudo apt-get clean
Ao final abra o synaptic e tente instalar (pacote a pacote) os seguintes pacotes:

  • avant-window-navigator
  • awn-manager
  • awn-core-applets

Caso volte a ter problemas acho melhor tentar outra opções, pois pode ter outro software dando conflito com o awn.

[]'s

Cristiano

--EDIT--

Editei a mensagem, favor conferir.
« Última modificação: 16 de Novembro de 2007, 11:30 por clcampos »
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline costa

  • Usuário Ubuntu
  • *
  • Mensagens: 83
    • Ver perfil
Re: Barra de Aplicativos
« Resposta #42 Online: 16 de Novembro de 2007, 11:33 »
Vou te dizer uma coisa.

Nessa nossa longa tentativa, no momento de utilizar o comando.

sudo apt-get update no final disse que eu teria que utilizar o comando pra atualizar os arquivos.

Uma parte do terminal...
Citar
Atingido http://archive.ubuntu.com feisty-updates/multiverse Packages
Baixados 27,1kB em 4s (5922B/s)
Lendo Lista de Pacotes... Pronto
W: GPG error: http://download.tuxfamily.org feisty Release: As assinaturas a seguir não puderam ser verificadas devido a chave pública não estar disponível : NO_PUBKEY 3E231AC7F4ECF181
W: Você terá que executar apt-get update para corrigir esses arquivos faltosos
bruno@bruno-desktop:~$

Agora, acho que não foi uma idéia muito boa da minha parte de tentar instalar esse tal de AWN.
Só "enchi" o meu computador de arquivos que eu nem sei pra que servem e onde estão.

O máximo que nós conseguimos chegar foi o que mostrei. 

Quanto aos applets, no momento que me disse pra entrar no gerenciador e marcar o pacote "x", ficou disponíveis alguns
no meu AWN-manager.  Só que tinha pacotes "quebrados".

Enfim....acho que pra você isso não significa nada! ( não estou indo pro lado emocional, é verdade sim )

Sempre que começo uma coisa, tenho que terminar. Enquanto não ver a funcionalidade correta, não sossego.

Mais fui "vencido" pelo computador. Infelizmente só tive dor de cabeça e sono durante o dia.

........então é isso....não sei mais o que faço!!  :(

//Editado

Tentei fazer o que disse no tópico anterior.  Quer saber o que aconteceu??? Adivinha??

Deu erro novamente. Pacote avant-window-navigator quebrado.

 :P
« Última modificação: 16 de Novembro de 2007, 11:39 por costa »

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Barra de Aplicativos
« Resposta #43 Online: 16 de Novembro de 2007, 12:10 »
Bem, deixa eu tentar responder.

Vou te dizer uma coisa.

Nessa nossa longa tentativa, no momento de utilizar o comando.

sudo apt-get update no final disse que eu teria que utilizar o comando pra atualizar os arquivos.

Uma parte do terminal...
Citar
Atingido http://archive.ubuntu.com feisty-updates/multiverse Packages
Baixados 27,1kB em 4s (5922B/s)
Lendo Lista de Pacotes... Pronto
W: GPG error: http://download.tuxfamily.org feisty Release: As assinaturas a seguir não puderam ser verificadas devido a chave pública não estar disponível : NO_PUBKEY 3E231AC7F4ECF181
W: Você terá que executar apt-get update para corrigir esses arquivos faltosos
bruno@bruno-desktop:~$

Isto é normal, e é devido a algum problema durante a execução do comando. Normalmente seguindo a dica (que é a execução do comando apt-get update novamente) isto costuma ser resolvido.

Citar
Agora, acho que não foi uma idéia muito boa da minha parte de tentar instalar esse tal de AWN.
Só "enchi" o meu computador de arquivos que eu nem sei pra que servem e onde estão.

Como encheu seu computador de arquivos desnecessários? Para remover os que foram baixados basta usar o apt-get remove com a opção --purge e tudo relativo aquele pacote é removido.

Citar
O máximo que nós conseguimos chegar foi o que mostrei. 

Quanto aos applets, no momento que me disse pra entrar no gerenciador e marcar o pacote "x", ficou disponíveis alguns
no meu AWN-manager.  Só que tinha pacotes "quebrados".

Enfim....acho que pra você isso não significa nada! ( não estou indo pro lado emocional, é verdade sim )

Não entendi, o que não significa nada para mim?

Citar
Sempre que começo uma coisa, tenho que terminar. Enquanto não ver a funcionalidade correta, não sossego.

Mais fui "vencido" pelo computador. Infelizmente só tive dor de cabeça e sono durante o dia.

........então é isso....não sei mais o que faço!!  :(

//Editado

Tentei fazer o que disse no tópico anterior.  Quer saber o que aconteceu??? Adivinha??

Deu erro novamente. Pacote avant-window-navigator quebrado.

 :P


Como disse no tópico anterior você deve ter algum pacote entrando em conflito com os do awn. A melhor solução talvez seja remover tudo do awn (usando o --purge), e no final limpar o cache do apt, e também limpar os pacotes que não são mais usados.

Limpar cache:
Código: [Selecionar]
sudo apt-get clean
Código: [Selecionar]
sudo apt-get autoclean
Limpar pacotes que não estão mais sendo usados:
Código: [Selecionar]
apt-get autoremove
Agora se você deseja tentar novamente é com você.

[]'s e boa sorte ai!

Cristiano.
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline costa

  • Usuário Ubuntu
  • *
  • Mensagens: 83
    • Ver perfil
Re: Barra de Aplicativos
« Resposta #44 Online: 16 de Novembro de 2007, 12:30 »
Tentei fazer esse comando  apt-get autoremove  é olha o que deu.

Citar
bruno@bruno-desktop:~$ apt-get autoremove
E: Não foi possível abri arquivo de trava /var/lib/dpkg/lock - open (13 Permissão negada)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
bruno@bruno-desktop:~$