Autor Tópico: Problema com edição de som [Resolvido]  (Lida 1920 vezes)

Offline Thorn Striff

  • Usuário Ubuntu
  • *
  • Mensagens: 142
  • Live together or die alone
    • Ver perfil
Problema com edição de som [Resolvido]
« Online: 28 de Dezembro de 2007, 01:08 »
Olá,
estou trabalhando em um video que possui uma cena que requer o som de uma parada cardiaca registrada por uma daquelas máquinas de hospital. O famoso "pi".
Encontrei uma música do Oficina G3 com isso no começo. Recortei o que eu queria e salvei em um arquivo separado. Porém, o trecho tem menos de 0,8 s, e eu preciso de aproximadamente 4s do som.
Como é um ruído monotônico pensei em dar um "copiar, colar" e assim aumentar o tempo.
Minha primeira tentativa foi no Goldwave. Um editor que gosto muito de usar no Windows. Consegui fazer o que queria com facilidade, mas sempre que copio e colo qualquer parte do som o programa adiciona uma "marca" na frequência. Seria como uma lombadinha que demarca a área recortada.
Depois disso, pensando ser um bug do programa, tentei o Audacity no Linux. Ele possui uma opção que repete o trecho automaticamente, mas tem o mesmo defeito.

Estou postando o download do "pi" original e do "pi" repetido para vocês terem idéia do que estou falando:
http://www.thornstriff.kit.net/video/pi.mp3
http://www.thornstriff.kit.net/video/pi_repetido.mp3

Alguém sabe o porque disso estar acontecendo e como fazer o que estou querendo sem essa ondulação no som?
Ou ao menos algum lugar aonde eu encontre esse mesmo "pi" só que com maior duração.
« Última modificação: 28 de Dezembro de 2007, 05:34 por Thorn Striff »

Offline alexmatos

  • Usuário Ubuntu
  • *
  • Mensagens: 792
  • Arch Linux / Ubuntu 7.04
    • Ver perfil
Re: Problema com edição de som
« Resposta #1 Online: 28 de Dezembro de 2007, 02:02 »
Olá,
estou trabalhando em um video que possui uma cena que requer o som de uma parada cardiaca registrada por uma daquelas máquinas de hospital. O famoso "pi".
Encontrei uma música do Oficina G3 com isso no começo. Recortei o que eu queria e salvei em um arquivo separado. Porém, o trecho tem menos de 0,8 s, e eu preciso de aproximadamente 4s do som.
Como é um ruído monotônico pensei em dar um "copiar, colar" e assim aumentar o tempo.
Minha primeira tentativa foi no Goldwave. Um editor que gosto muito de usar no Windows. Consegui fazer o que queria com facilidade, mas sempre que copio e colo qualquer parte do som o programa adiciona uma "marca" na frequência. Seria como uma lombadinha que demarca a área recortada.
Depois disso, pensando ser um bug do programa, tentei o Audacity no Linux. Ele possui uma opção que repete o trecho automaticamente, mas tem o mesmo defeito.

Estou postando o download do "pi" original e do "pi" repetido para vocês terem idéia do que estou falando:
http://www.thornstriff.kit.net/video/pi.mp3
http://www.thornstriff.kit.net/video/pi_repetido.mp3

Alguém sabe o porque disso estar acontecendo e como fazer o que estou querendo sem essa ondulação no som?
Ou ao menos algum lugar aonde eu encontre esse mesmo "pi" só que com maior duração.

Bom, na experiência que eu tenho usando o Sony Vegas para editar vídeos e seus respectivos áudios, quando eu corto um trecho de uma faixa de áudio, o programa automaticamente adiciona um pequeno efeito fade in e fade out nos locais que eu corto. Para evitar o efeito de som picotado, eu removo esse efeito definindo o tempo dele como 0 (zero). Não sei se há essa opção, ou se os programas que você usou também fazem isso, mas fica aí algo que talvez te ajude.

Offline Thorn Striff

  • Usuário Ubuntu
  • *
  • Mensagens: 142
  • Live together or die alone
    • Ver perfil
Re: Problema com edição de som
« Resposta #2 Online: 28 de Dezembro de 2007, 05:07 »
ACHEI!!!

Graças ao Zoom do Audacy e assistir aulas de física sobre ondulatória consegui encontrar o problema. Problema esse que não era de programa algum, apenas eu é que não estava lembrando de um pequeno grande detalhe sobre ondas que tentarei explicar.

Uma onda sonora é composta de um vale (parte mais baixa da onda) e uma crista (parte mais alta da onda). Com a variação da distância vertical e horizontal entre esses dois pontos muda-se uma série de características do som.


Essa é a onda sonora que eu quero repetir. Sua correta cópia resultará de um periodo indefinido de "pi"s.
Para que isso ocorra eu tenho que ter o cuidado de copiar a onda mantendo a mesma exata distância entre a crista e o vale e o tamanho de cada uma das partes. Se eu errar um milimetro terei alterações no som final.

Como todo bom desatento, eu estava selecionando as seguinte partes (selecionadas com a cor mais escura) para cópia:

e


Como podem ver, é um vale quase inteiro e um outro pedaço de um vale. Quando eu repetia o trecho as bordas ficavam com as seguintes ondas:

Elas possuem a crista idêntica a original, mas possuem um vale muito maior. Isso causa as ocilações que comentei no primeiro post.

O que eu fiz foi dar um zoom no começo e no final do trecho que eu iria repetir e ter certeza de pegar o começo de uma crista e o final de um vale. Pronto.

http://www.thornstriff.kit.net/video/pi_ok.mp3

Agradeço a atenção de todos, principalmente do colega alexmatos.
Qualquer dúvida é só perguntar!
« Última modificação: 28 de Dezembro de 2007, 05:10 por Thorn Striff »

Offline alexmatos

  • Usuário Ubuntu
  • *
  • Mensagens: 792
  • Arch Linux / Ubuntu 7.04
    • Ver perfil
Re: Problema com edição de som [Resolvido]
« Resposta #3 Online: 28 de Dezembro de 2007, 09:40 »
E tem gente que acha que física não serve pra nada!

Parabéns por ter resolvido seu problema e pela explicação mais do que esclarecedora. Um abraço!

Offline kakita

  • Usuário Ubuntu
  • *
  • Mensagens: 285
    • Ver perfil
Re: Problema com edição de som [Resolvido]
« Resposta #4 Online: 03 de Janeiro de 2008, 09:21 »
Fisica so serve para uma coisa


TUDO ;D ;D ;D