Autor Tópico: Ubuntu não inicia com resolução do monitor especificada no driver.RESOLVIDO  (Lida 2874 vezes)

Offline z3cU3c4

  • Usuário Ubuntu
  • *
  • Mensagens: 82
    • Ver perfil
O problema é que toda vez tenho que setar a resolução nativa do monitor pelo nvidia-settings quando o omputador inicia...
O driver da nvidia dá a opção de salvar as especificações no XORG.. salvo-as, porem quando reinicio tenho que novamente setar a resolução correta...
Tenho uma nforce 7300Se , monitor com resolução nativa 1440x900, e oi problema ocorre sempre com o início de um nova sessão;;;
O arquivo do xorg está assim
Citar
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "abnt2"
   Option      "XkbLayout"   "br"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "ZAxisMapping"      "4 5"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "stylus"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "eraser"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "cursor"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "nVidia Corporation G72 [GeForce 7300 SE]"
   Driver      "nvidia"
   BusID      "PCI:1:0:0"
   Option      "UseFBDev"      "true"
EndSection

Section "Monitor"
   Identifier   "LG 194WT "
   Option      "DPMS"
   HorizSync   28-72
   VertRefresh   43-60
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "nVidia Corporation G72 [GeForce 7300 SE]"
   Monitor      "LG 194WT "
   DefaultDepth   24
   SubSection "Display"
      Modes      "1440x900"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"

# Uncomment if you have a wacom tablet
#   InputDevice     "stylus"   "SendCoreEvents"
#   InputDevice     "cursor"   "SendCoreEvents"
#   InputDevice     "eraser"   "SendCoreEvents"
EndSection
« Última modificação: 05 de Janeiro de 2008, 19:22 por z3cU3c4 »

Offline Hqxriven

  • Usuário Ubuntu
  • *
  • Mensagens: 1.456
    • Ver perfil
Re: Ubuntu não inicia com resolução do monitor especificada no driver...
« Resposta #1 Online: 05 de Janeiro de 2008, 01:10 »
Ubuntu ou kubuntu????

Tive o mesmo problema...

E no kubuntu fui na configuração do sistema e disse a resolução que queria pelo Kde (não pela nvidia) e funcionou...

Meu xorg nesse momento...

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder3)  Thu Oct  4 10:34:46 PDT 2007

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Thu Oct  4 10:33:51 PDT 2007
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"

# Uncomment if you have a wacom tablet
#   InputDevice     "stylus"   "SendCoreEvents"
#   InputDevice     "cursor"   "SendCoreEvents"
#   InputDevice     "eraser"   "SendCoreEvents"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "Files"
    FontPath        "/usr/local/share/fonts"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "abnt2"
    Option         "XkbLayout" "br"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ImPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
    Identifier     "stylus"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "stylus"
    Option         "ForceDevice" "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier     "eraser"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "eraser"
    Option         "ForceDevice" "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier     "cursor"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "cursor"
    Option         "ForceDevice" "ISDV4"      # Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier     "Monitor Genérico"
    HorizSync       30.0 - 70.0
    VertRefresh     50.0 - 160.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync       30.0 - 71.0
    VertRefresh     50.0 - 160.0
EndSection

Section "Device"
    Identifier     "Placa de Vídeo Genérica"
    Driver         "nvidia"
Option     "RenderAccel" "true"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 6150SE nForce 430"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Placa de Vídeo Genérica"
    Monitor        "Monitor Genérico"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1024x768_85 +0+0; nvidia-auto-select +0+0"
EndSection
Section "Extensions"
    Option "Composite" "Enable"
EndSection



Fique com Deus

Hqx
Sem distro Linux fixa - Kernel Omnislash
Meu objetivo nesse fórum é ajudar. Sou um mero humano mas desejo sempre aprender e melhorar em tudo o que faço em minha vida. Então, por favor, quando eu postar me notifique depois

Offline z3cU3c4

  • Usuário Ubuntu
  • *
  • Mensagens: 82
    • Ver perfil
Re: Ubuntu não inicia com resolução do monitor especificada no driver.RESOLVIDO
« Resposta #2 Online: 05 de Janeiro de 2008, 19:21 »
Resolvido! Obrigado pela dica Hqxriven... Acabei me esquecendo do gerenciador do UBUNTU por achar que a do driver estava num nível de controle "superior"...