Autor Tópico: [RESOLVIDO] Mplayer: problema na acentuação  (Lida 25698 vezes)

Offline Kursch

  • Usuário Ubuntu
  • *
  • Mensagens: 37
    • Ver perfil
[RESOLVIDO] Mplayer: problema na acentuação
« Online: 06 de Janeiro de 2008, 19:07 »
Estou tendo alguns problemas quando vou ver vídeos com legenda (.srt):

Primeiro problema: quando há o cedilha, a legenda inverte a ordem das letras
Ex.: proteção torna-se proteãço.

Segundo problema: quando a legenda tem uma letra acentuada e esta letra está em maiusculo, no lugar da mesma aparece uma interrogação de cabeça para baixo.
Ex.: É, tá tudo bem torna-se ?, tá tudo bem

p.s.: segui o tutorial de multímidia para o ubuntu 7.10 que há na comunidade, instalando todos os codecs e etc.
« Última modificação: 08 de Janeiro de 2008, 06:57 por Kursch »

Offline pinduvoz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.494
    • Ver perfil
Re: Mplayer: problema na acentuação
« Resposta #1 Online: 06 de Janeiro de 2008, 19:32 »
Isso decorre de erro na codificação do arquivo de legenda, que geralmente não usa UTF-8.

Para selecionar a codificação da legenda abra o MPLAYER, clique com o botão direito do mouse na área onde o filme é apresentado e vá em Preferences > Subtitles & OSD e mude a opção encoding, escolhendo a codificação correta: Western European Languages (ISO-8859-1).
:: Linux Registered User nº 439378 ::

Offline Kursch

  • Usuário Ubuntu
  • *
  • Mensagens: 37
    • Ver perfil
Re: Mplayer: problema na acentuação
« Resposta #2 Online: 07 de Janeiro de 2008, 02:55 »
Isso decorre de erro na codificação do arquivo de legenda, que geralmente não usa UTF-8.

Para selecionar a codificação da legenda abra o MPLAYER, clique com o botão direito do mouse na área onde o filme é apresentado e vá em Preferences > Subtitles & OSD e mude a opção encoding, escolhendo a codificação correta: Western European Languages (ISO-8859-1).

Reiniciei o MPlayer após ter feito esta mudança e não deu certo.

Veja que mostrei nos exemplos que os acentos aparecem normalmente, exceto nas situações descritas: 1. quando há o cedilha, a legenda inverte a ordem das letras 2. quando a legenda tem uma letra acentuada e esta letra está em maiusculo, no lugar da mesma aparece uma interrogação de cabeça para baixo.

Offline pinduvoz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.494
    • Ver perfil
Re: Mplayer: problema na acentuação
« Resposta #3 Online: 07 de Janeiro de 2008, 18:29 »
Mais uma vez vá em "Preferences", só que desta vez acione a aba "Font" e mude a opção "encoding", escolhendo a codificação correta: Western European Languages (ISO-8859-1).

Editado: instale, se já não tiver instalado, o pacote "mplayer-fonts".
« Última modificação: 07 de Janeiro de 2008, 18:48 por pinduvoz »
:: Linux Registered User nº 439378 ::

Offline Kursch

  • Usuário Ubuntu
  • *
  • Mensagens: 37
    • Ver perfil
Re: Mplayer: problema na acentuação
« Resposta #4 Online: 08 de Janeiro de 2008, 06:57 »
Mais uma vez vá em "Preferences", só que desta vez acione a aba "Font" e mude a opção "encoding", escolhendo a codificação correta: Western European Languages (ISO-8859-1).

Editado: instale, se já não tiver instalado, o pacote "mplayer-fonts".

mplayer-fonts já é a versão mais nova.

Mas deu certo indo em "Font". Valeu. Obrigado.