Autor Tópico: Problema com Ambiente Gráfico - Resolução de Tela [RESOLVIDO]  (Lida 16960 vezes)

Offline skeletiom

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Problema com Ambiente Gráfico - Resolução de Tela [RESOLVIDO]
« Online: 26 de Janeiro de 2008, 00:05 »
Olá pessoal,

Eu instalei o Ubuntu recentemente e estou adorando. Está quase tudo funcionando perfeitamente, criei máquinas virtuais com o vmware e etc. No entanto, estou com um problema:

A resolução não está legal. Apesar da placa de video está aparentemente configurada correta, só aparece a opção de 1024x768, quando entro em Sistema, Preferências, Resolução de Tela (1024x768) só tem essa ou menores.

Eu consigo executar vídeos, áudio e tudo mais. No entanto, a resolução ainda não está agradável e eu não sei como fazer para melhorar, visto que na resolução de tela não tem muitas opções.

Alguém sabe dizer o que é? No windows a resolução/qualidade da imagem era muito superior. Será que é por causa de alguma configuração/limitação na placa de video?

Abraços Fraternais,
« Última modificação: 24 de MAR?O de 2008, 23:24 por skeletiom »

Offline coyoterj

  • Usuário Ubuntu
  • *
  • Mensagens: 349
  • #Xenial Xerus
    • Ver perfil
    • Pier de Ipanema - A referência em Ipanema/RJ
Re: Ambiente Gráfico
« Resposta #1 Online: 26 de Janeiro de 2008, 00:44 »
Acabei de fazer um upgrade (mother+cpu+memória) e como a nova placa não tem agp tive que usar a onboard. Estava com o mesmo problema, em resolução só aparecia 1280, 840. Reconfigurei o xorg e nada. Aí entrei em Sistemas >> Administração >> Telas e Placas de Vídeo, aonde troquei o monitor pelo meu e pronto agora está perfeito.. :-)

Outra opção é reconfigurar o xorg, caso não de certo a primeira opção.

Abs
Dell Inspiron 5447 Intel Core i5-4210U CPU @ 1.70GHz × 4 | HD sata 1 também | 4 Gb ram
Pier de Ipanema | Facebook Pier de Ipanema
[IMG]http://www.pierdeipanema.com.br/sites/default/files/outras/ubuntu-user

Offline skeletiom

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Ambiente Gráfico
« Resposta #2 Online: 26 de Janeiro de 2008, 01:13 »
Ae meu caro,

No meu Ubuntu 7.04 não aparece essa opção. Qual sua versão?

Além disso, eu editei o xorg.conf conforme outros tópicos aqui e nada. Eu coloquei a resolução 1280x720 que é a máxima que meu monitor LG Flatron L177Ws aceita. Só que não aparece nas opçãos de Resolução de tela. Se eu colocar 1280x1024 ele aparece, mas fica horrível no meu monitor. As letras meias embassadas.

Eu não sei o que fazer, se alguém puder me ajudar, eu agradeço.

Offline coyoterj

  • Usuário Ubuntu
  • *
  • Mensagens: 349
  • #Xenial Xerus
    • Ver perfil
    • Pier de Ipanema - A referência em Ipanema/RJ
Re: Ambiente Gráfico
« Resposta #3 Online: 26 de Janeiro de 2008, 01:17 »
Ae meu caro,

No meu Ubuntu 7.04 não aparece essa opção. Qual sua versão?

#Ubuntu Gutsy Gibbon, tá junto com meu avatar...

Qual tua placa ? Posta teu xorg.conf.

Dell Inspiron 5447 Intel Core i5-4210U CPU @ 1.70GHz × 4 | HD sata 1 também | 4 Gb ram
Pier de Ipanema | Facebook Pier de Ipanema
[IMG]http://www.pierdeipanema.com.br/sites/default/files/outras/ubuntu-user

Offline skeletiom

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Ambiente Gráfico
« Resposta #4 Online: 26 de Janeiro de 2008, 01:21 »
Ae, segue o arquivo. Se eu colocar a resolução que eu quero (1280x720) ele não aparece essa opção. Eu coloco lá do lado de modes, assim:
SubSection "Display"
Depth      24
Modes      "1280x720" "1024x768" "800x600" "640x480

Meu xorg.conf

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/fonts/X11/misc"
   FontPath   "/usr/share/fonts/X11/cyrillic"
   FontPath   "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/Type1"
   FontPath   "/usr/share/fonts/X11/100dpi"
   FontPath   "/usr/share/fonts/X11/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "abnt2"
   Option      "XkbLayout"   "br"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "stylus"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "eraser"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "cursor"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "Intel Corporation 82945G/GZ Integrated Graphics Controller"
   Driver      "i810"
   BusID      "PCI:0:2:0"
   Option      "UseFBDev"      "true"
EndSection

Section "Monitor"
   Identifier   "SyncMaster"
   Option      "DPMS"
   HorizSync   30-71
   VertRefresh   50-160
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Intel Corporation 82945G/GZ Integrated Graphics Controller"
   Monitor      "SyncMaster"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus"   "SendCoreEvents"
   InputDevice     "cursor"   "SendCoreEvents"
   InputDevice     "eraser"   "SendCoreEvents"

Offline coyoterj

  • Usuário Ubuntu
  • *
  • Mensagens: 349
  • #Xenial Xerus
    • Ver perfil
    • Pier de Ipanema - A referência em Ipanema/RJ
Re: Ambiente Gráfico
« Resposta #5 Online: 26 de Janeiro de 2008, 01:44 »
Minha placa é igual a sua.
Opções:
1 - provavelmente é a configuração errada do monitor, vc tem um LG Flatron L177Ws e no xorg está com a resolução do Syncmaster (30-71/50-160)

tenta descobrir a resolução dele e troca, dá uma busca aqui ou no google pelo modelo do teu monitor que vc deve encontrar algo.

Foi o que aconteceu comigo, configuração errada do monitor, so que no 7.10 tem essa vantagem...
Dell Inspiron 5447 Intel Core i5-4210U CPU @ 1.70GHz × 4 | HD sata 1 também | 4 Gb ram
Pier de Ipanema | Facebook Pier de Ipanema
[IMG]http://www.pierdeipanema.com.br/sites/default/files/outras/ubuntu-user

Offline skeletiom

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Ambiente Gráfico
« Resposta #6 Online: 26 de Janeiro de 2008, 02:07 »
Ah sim, esqueci de comentar, eu troquei para a seguinte configuração (trocando a frequencia), mas não adiantou.

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/fonts/X11/misc"
   FontPath   "/usr/share/fonts/X11/cyrillic"
   FontPath   "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/Type1"
   FontPath   "/usr/share/fonts/X11/100dpi"
   FontPath   "/usr/share/fonts/X11/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "abnt2"
   Option      "XkbLayout"   "br"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "stylus"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "eraser"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "cursor"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "Intel Corporation 82945G/GZ Integrated Graphics Controller"
   Driver      "i810"
   BusID      "PCI:0:2:0"
   Option      "UseFBDev"      "true"
EndSection

Section "Monitor"
   Identifier   "SyncMaster"
   Option      "DPMS"
   HorizSync   28-83
   VertRefresh   56-75
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Intel Corporation 82945G/GZ Integrated Graphics Controller"
   Monitor      "SyncMaster"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1280x720" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1280x720" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1280x720" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1280x720" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1280x720" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1280x720" "1280x1024" "1024x768" "800x600"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus"   "SendCoreEvents"
   InputDevice     "cursor"   "SendCoreEvents"
   InputDevice     "eraser"   "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection


Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.369
  • @Ceará
    • Ver perfil
Re: Ambiente Gráfico
« Resposta #7 Online: 26 de Janeiro de 2008, 09:53 »
Substitua:
Código: [Selecionar]
Section "Monitor"
   Identifier   "SyncMaster"
   Option      "DPMS"
   HorizSync   30-71
   VertRefresh   50-160
EndSection

Por:
Código: [Selecionar]
Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
   HorizSync   30-83
   VertRefresh   56-75
EndSection

Dados de acordo com o site oficial:
http://br.lge.com/md/product/prodcategorylist.do?actType=detail&currPage=1&categoryId=0000040102&parentCategoryId=0000000401&categoryLevel=4&productId=1100001523

« Última modificação: 26 de Janeiro de 2008, 09:56 por agente100gelo »
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline k7br

  • Usuário Ubuntu
  • *
  • Mensagens: 770
  • Ubuntu 9.04
    • Ver perfil
Re: Ambiente Gráfico
« Resposta #8 Online: 26 de Janeiro de 2008, 11:22 »
Salve!
skeletiom , já tentou procurar no Synaptic por  915resolution ?

Boa sorte!

Offline skeletiom

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Ambiente Gráfico
« Resposta #9 Online: 26 de Janeiro de 2008, 13:48 »
Ae pessoal, o problema persiste.

Eu procurei e encontrei no Gerenciador de Pacotes Synaptic o pacote 915resolution indicado pelo amigo. Eu instalei ele, mas não alterou em nada. A limitação da resolução ainda persiste. Eu preciso executar algum comando ou fazer outra coisa depois de instalar (instalei ele automáticamente, através do gerenciador de pacotes synaptic).

A outra sugestão eu também segui, mas também não deu certo. Eu já tinha lido em outros tópicos de ajuda dizendo que não era pra fazer alterações no Identifier e no Options, mas como o amigo deu a sugestão, eu fiz um backup (a sorte) do arquivo xorg.conf e fiz as alterações. O resultado foi que não iniciou a parte gráfica, dando um erro assim:

"Undefined Monitor "Syncmaster" referenced by screen "default screen".

Alguém sabe o que pode ser? Alguma outra sugestão? Estou procurando pelo fórum algumas dicas, mas até agora nenhuma funcionou comigo.

Abraços Fraternais,

Offline skeletiom

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Ambiente Gráfico
« Resposta #10 Online: 26 de Janeiro de 2008, 14:00 »
Só pra complementar:

Eu incluiu o seguinte código
Código: [Selecionar]
Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
   HorizSync   30-83
   VertRefresh   56-75
EndSection

Depois que deu o problema e não consegui iniciar a parte gráfica devido ao erro "Undefined Monitor "Syncmaster" referenced by screen "default screen", eu também alterei a parte do código
Código: [Selecionar]
Section "Screen"
   Identifier   "Default Screen"
   Device      "Intel Corporation 82945G/GZ Integrated Graphics Controller"
   Monitor      "SyncMaster"

para a seguinte:
Código: [Selecionar]
Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation 82945G/GZ Integrated Graphics Controller"
Monitor "Generic Monitor"

Com isso, ele iniciou normal, mas continua não permitindo alterações na resolução para o ideal. Não houve nenhuma mudança, mesmo eu fazendo essas alterações no arquivo xorg.conf



Offline coyoterj

  • Usuário Ubuntu
  • *
  • Mensagens: 349
  • #Xenial Xerus
    • Ver perfil
    • Pier de Ipanema - A referência em Ipanema/RJ
Re: Ambiente Gráfico
« Resposta #11 Online: 26 de Janeiro de 2008, 14:22 »
Tentou desabilitar o frame buffer ?

 Option      "UseFBDev"      "true"

Se não der certo, vamos mais uma tentativa (não esquece de salvar teu xorg.conf para o caso de dar nhaca) :-)

Considerando que estava funcionando normal (exceto a resolução) com a configuração que vc passou inicialmente do SyncMaster, faz as seguintes alterações no teu xorg (trocando as seções abaixo pela que está no teu):

Código: [Selecionar]
Section "Device"
Identifier "Intel Corporation 82945G/GZ Integrated Graphics Controller"
Boardname "intel"
Busid "PCI:0:2:0"
Driver "intel"
Screen 0
EndSection

Section "Monitor"
Identifier "Monitor Genérico"
Vendorname "Samsung"
Modelname "Samsung SyncMaster 793S/793V/CM173G"
Horizsync 30-71
Vertrefresh 50-160
modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline  "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline  "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
modeline  "1024x768@85" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline  "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation 82945G/GZ Integrated Graphics Controller"
Monitor "Monitor Genérico"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1400 1050
Modes "1024x768@60" "1024x768@43" "1024x768@70" "1152x864@75" "1024x768@75" "1280x960@60" "1024x768@85" "1280x1024@60" "832x624@75" "1400x1050@60" "800x600@60" "800x600@85" "800x600@75" "800x600@72" "800x600@56" "640x480@85" "640x480@75" "640x480@72" "640x480@60"
EndSubSection
EndSection

Abs
Dell Inspiron 5447 Intel Core i5-4210U CPU @ 1.70GHz × 4 | HD sata 1 também | 4 Gb ram
Pier de Ipanema | Facebook Pier de Ipanema
[IMG]http://www.pierdeipanema.com.br/sites/default/files/outras/ubuntu-user

alarcon

  • Visitante
Re: Ambiente Gráfico
« Resposta #12 Online: 26 de Janeiro de 2008, 15:03 »
Tenta assim:

Citar
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/fonts/X11/misc"
   FontPath   "/usr/share/fonts/X11/cyrillic"
   FontPath   "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/Type1"
   FontPath   "/usr/share/fonts/X11/100dpi"
   FontPath   "/usr/share/fonts/X11/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "abnt2"
   Option      "XkbLayout"   "br"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "stylus"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "eraser"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "cursor"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "Intel Corporation 82945G/GZ Integrated Graphics Controller"
   Driver      "i810"
   BusID      "PCI:0:2:0"
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
   HorizSync   28-83
   VertRefresh   56-75
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Intel Corporation 82945G/GZ Integrated Graphics Controller"
   Monitor      "Generic Monitor"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1280x720"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1280x720"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1280x720"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1280x720"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1280x720"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1280x720"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus"   "SendCoreEvents"
   InputDevice     "cursor"   "SendCoreEvents"
   InputDevice     "eraser"   "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection
« Última modificação: 26 de Janeiro de 2008, 15:13 por alarcon »

Offline skeletiom

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Ambiente Gráfico
« Resposta #13 Online: 26 de Janeiro de 2008, 15:12 »
Aeeeeee, conseguimos!

Antigamente eu só utilizava o Windows, justamente por causa da facilidade das configurações. Mas a sensação é indescritível quando você consegue arrumar tudo do jeito que quer no Linux. Agora os recursos que tenho são infinitamente superiores ao Windows.

Antes de tudo, procurando a solução eu encontrei o seguinte tutorial sobre o 915resolution
http://caminholivre.wordpress.com/2007/10/17/configurando-seu-video-intel-915gm-com-o-915resolution/

Resultado: não alterou em absolutamente nada. Eu fazia tudo conforme explicado, mas quando reiniciava não tinha efeito nenhum.

Antes disso eu já tinha feito o que o amigo Alarcon sugeriu, mas sem sucesso também.

Só então que segui a dica do coyoterj e alterei
Código: [Selecionar]
Option      "UseFBDev"      "true" para
Código: [Selecionar]
Option      "UseFBDev"      "false" e pimba! Tudo perfeito. Agora consigo alterar a resolução perfeitamente.

Aí coloquei a resolução para 1280x720 e ficou muito melhor. Tá resolvido o problema.

Valeu pessoal! Realmente 100% o fórum, e valeu a paciência!

Abraços Fraternais,

Offline skeletiom

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Problema com Ambiente Gráfico - Resolução de Tela [MAL RESOLVIDO]
« Resposta #14 Online: 27 de Janeiro de 2008, 19:40 »
Ae pessoal,

Eu não sei o que houve, mas depois de eu ter reiniciado o computador uma outra vez, voltou o mesmo problema. Voltou a resolução de 1024x768 e não apresenta mais a opção de 1280x720 que estava anteriormente, mesmo eu conferindo e verificando que não houve alterações no meu arquivo xorg.conf

Meu arquivo xorg.conf
Código: [Selecionar]
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "abnt2"
Option "XkbLayout" "br"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "Intel Corporation 82945G/GZ Integrated Graphics Controller"
Driver "i810"
BusID "PCI:0:2:0"
Option "UseFBDev" "false"
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
   HorizSync   30-83
   VertRefresh   56-75
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation 82945G/GZ Integrated Graphics Controller"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x720" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice     "stylus" "SendCoreEvents"
InputDevice     "cursor" "SendCoreEvents"
InputDevice     "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection