Autor Tópico: Problema com Ambiente Gráfico - Resolução de Tela [RESOLVIDO]  (Lida 16959 vezes)

boi

  • Visitante
Re: Problema com Ambiente Gráfico - Resolução de Tela [MAL RESOLVIDO]
« Resposta #15 Online: 27 de Janeiro de 2008, 19:53 »
Você precisar gerar uma modeline própria para seu monitor e a resolução que você quer. Eu acho simples, mas não sei se você também vai achar. Dá uma olhada nesse tópico, que é de um problema parecido:

http://ubuntuforum-br.org/index.php/topic,30933.0.html

Offline skeletiom

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Problema com Ambiente Gráfico - Resolução de Tela [MAL RESOLVIDO]
« Resposta #16 Online: 27 de Janeiro de 2008, 19:54 »
Ae pessoal, só pra complementar meu problema, se eu coloco outra resolução no xorg.conf, por exemplo 1280x1024, ele aparece. No entanto, se eu coloco outra, tipo 1600x1200 ou a que eu REALMENTE PRECISO e que deu certo um tempo atrás de 1280x720, não aparece nas opções de configuração.

Ou seja, acho que alguma coisa está bloqueando. Ante eu só mudei o valor de
Código: [Selecionar]
Option "UseFBDev" "true" para
Código: [Selecionar]
Option "UseFBDev" "false", mas agora não tá dando certo mais.

Abraços Fraternais,

Offline coyoterj

  • Usuário Ubuntu
  • *
  • Mensagens: 349
  • #Xenial Xerus
    • Ver perfil
    • Pier de Ipanema - A referência em Ipanema/RJ
Re: Problema com Ambiente Gráfico - Resolução de Tela [MAL RESOLVIDO]
« Resposta #17 Online: 27 de Janeiro de 2008, 20:03 »
Salva o xorg.conf e tenta reconfigurar ele pelo sudo dpkg-reconfigure xserver-xorg

abs
Dell Inspiron 5447 Intel Core i5-4210U CPU @ 1.70GHz × 4 | HD sata 1 também | 4 Gb ram
Pier de Ipanema | Facebook Pier de Ipanema
[IMG]http://www.pierdeipanema.com.br/sites/default/files/outras/ubuntu-user

Offline skeletiom

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Problema com Ambiente Gráfico - Resolução de Tela [MAL RESOLVIDO]
« Resposta #18 Online: 27 de Janeiro de 2008, 20:06 »
Você precisar gerar uma modeline própria para seu monitor e a resolução que você quer. Eu acho simples, mas não sei se você também vai achar. Dá uma olhada nesse tópico, que é de um problema parecido:

http://ubuntuforum-br.org/index.php/topic,30933.0.html

Ae amigo, eu olhei o tópico e vi que o problema é quase igual. No entanto, quando entrei no endereço para gerar a modeline tomei até um susto, rsrsrs. Não sei nem pra onde vai com aquelas informações. Será que pode me ajudar? Meu monitor é um LG Flatron L177WS e as únicas especificações que encontrei no manual é
Resolução Máxima : 1280x720@ 75Hz
Frequência Horizontal : 30 ~ 83kHz
Frequência Vertical : 56 ~ 75kHz

Minha placa é
"Intel 800/900 Series VBIOS Hack : version 0.5.2 - Chipset: 945G"

Valeu pela ajuda!

Offline skeletiom

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Problema com Ambiente Gráfico - Resolução de Tela [MAL RESOLVIDO]
« Resposta #19 Online: 27 de Janeiro de 2008, 21:12 »
Salva o xorg.conf e tenta reconfigurar ele pelo sudo dpkg-reconfigure xserver-xorg

abs

Amigo, eu executei esse comando e olha a mensagem que apareceu:

debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Recurso temporariamente indisponível

Sabe me dizer o que pode ser?
Abraços

Offline coyoterj

  • Usuário Ubuntu
  • *
  • Mensagens: 349
  • #Xenial Xerus
    • Ver perfil
    • Pier de Ipanema - A referência em Ipanema/RJ
Re: Problema com Ambiente Gráfico - Resolução de Tela [MAL RESOLVIDO]
« Resposta #20 Online: 27 de Janeiro de 2008, 21:17 »
Que outro processo travou seu arquivo de configuração. Verifique se está tudo fechado, se não tem outro programa sendo executado.
Dell Inspiron 5447 Intel Core i5-4210U CPU @ 1.70GHz × 4 | HD sata 1 também | 4 Gb ram
Pier de Ipanema | Facebook Pier de Ipanema
[IMG]http://www.pierdeipanema.com.br/sites/default/files/outras/ubuntu-user

Offline skeletiom

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Problema com Ambiente Gráfico - Resolução de Tela [MAL RESOLVIDO]
« Resposta #21 Online: 27 de Janeiro de 2008, 21:31 »
Eu dei um reboot e funcionou para entrar na configuração lá.

Agora, quando chegou na autodetecção do monitor, ele simplesmente travou. Ficou tudo preto e as luzes do teclado piscando. Tive que dar um reset pelo computador pra voltar a funcionar. Sabe me dizer onde tem um tutorial explicando sobre a configuração do xorg? Porque apesar de estar bem especificado durante a configuração, talvez tenha alguma coisa que possa resolver esse problema.

Abraços,

Offline coyoterj

  • Usuário Ubuntu
  • *
  • Mensagens: 349
  • #Xenial Xerus
    • Ver perfil
    • Pier de Ipanema - A referência em Ipanema/RJ
Re: Problema com Ambiente Gráfico - Resolução de Tela [MAL RESOLVIDO]
« Resposta #22 Online: 27 de Janeiro de 2008, 21:41 »
http://www.x.org/wiki/

No google vc encontra mais...  ;)
Dell Inspiron 5447 Intel Core i5-4210U CPU @ 1.70GHz × 4 | HD sata 1 também | 4 Gb ram
Pier de Ipanema | Facebook Pier de Ipanema
[IMG]http://www.pierdeipanema.com.br/sites/default/files/outras/ubuntu-user

Offline velox256

  • Usuário Ubuntu
  • *
  • Mensagens: 1.915
  • Debian é Debian... :)
    • Ver perfil
    • Linux Inside
Re: Problema com Ambiente Gráfico - Resolução de Tela [MAL RESOLVIDO]
« Resposta #23 Online: 02 de Fevereiro de 2008, 07:51 »
Olha, realmente tem que ter paciência com algumas coisas no Linux, mas nada dá tanta satisfação (depois de ganhar na loteria ou fazer sexo, heheheh...) do que resolver um pepino qq que tenha surgido. Quer uma sugestão radical? Tasca uma placa de vídeo da nVidia, não teve uma instalação de Ubuntu que eu tenha feito onde a resolução do monitor não tenha sido aceita por ela.
Mas só faça isso depois de tentar tudo que puder, já que vc conseguiu fazer o bagulho funcionar antes. Esses monitores WS são mesmo um saco pra se configurar.

:)



Eu dei um reboot e funcionou para entrar na configuração lá.

Agora, quando chegou na autodetecção do monitor, ele simplesmente travou. Ficou tudo preto e as luzes do teclado piscando. Tive que dar um reset pelo computador pra voltar a funcionar. Sabe me dizer onde tem um tutorial explicando sobre a configuração do xorg? Porque apesar de estar bem especificado durante a configuração, talvez tenha alguma coisa que possa resolver esse problema.

Abraços,
Computador perereca, com disco perereca, monitor perereca e sistema super xuxu. Visitem a minha página em http://sidserra.k6.com.br ou meu blog em http://sidserra.blogspot.com.br.

Offline skeletiom

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Problema com Ambiente Gráfico - Resolução de Tela [MAL RESOLVIDO]
« Resposta #24 Online: 03 de Fevereiro de 2008, 23:48 »
Será que alguém tem mais alguma idéia para tentar resolver o problema?

Eu executei o comando
sudo dpkg-reconfigure xserver-xorg

e configurei conforme instruções, mas não resolveu em nada.

Alguém tem outra idéia? Já tentei o 915resolution, mas nada também. Já estou pensando em desistir do ubuntu.  :'( :'(

Offline k7br

  • Usuário Ubuntu
  • *
  • Mensagens: 770
  • Ubuntu 9.04
    • Ver perfil
Re: Problema com Ambiente Gráfico - Resolução de Tela [MAL RESOLVIDO]
« Resposta #25 Online: 04 de Fevereiro de 2008, 00:14 »
Papai vai no chute ,beleza?
Coloque na Section "Device" do xorg.conf a linha :
Citar
Option "ModeValidation" "NoDFPNativeResolutionCheck"

Mais informações aqui http://www.blog.adilson.net/?p=12

Boa sorte!

Offline skeletiom

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Problema com Ambiente Gráfico - Resolução de Tela [MAL RESOLVIDO]
« Resposta #26 Online: 05 de Fevereiro de 2008, 23:42 »
Papai vai no chute ,beleza?
Coloque na Section "Device" do xorg.conf a linha :
Citar
Option "ModeValidation" "NoDFPNativeResolutionCheck"

Mais informações aqui http://www.blog.adilson.net/?p=12

Boa sorte!

Rapaz, acho que nem com reza braba. Olha como ficou meu xorg.conf e mesmo assim não deu certo:

Código: [Selecionar]
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "abnt2"
Option "XkbLayout" "br"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "Intel Corporation 82945G/GZ Integrated Graphics Controller"
Driver "i810"
BusID "PCI:0:2:0"
Option "ModeValidation"  "NoDFPNativeResolutionCheck"
EndSection

Section "Monitor"
Identifier "SyncMaster"
Option "DPMS"
HorizSync 30-71
VertRefresh 50-160
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation 82945G/GZ Integrated Graphics Controller"
Monitor "SyncMaster"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x720" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice     "stylus" "SendCoreEvents"
InputDevice     "cursor" "SendCoreEvents"
InputDevice     "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection

Alguém, pelo amor de Deus, tem mais dicas? Eu realmente quero resolver o problema e estou me esforçando pra isso. Abraços!

Offline coyoterj

  • Usuário Ubuntu
  • *
  • Mensagens: 349
  • #Xenial Xerus
    • Ver perfil
    • Pier de Ipanema - A referência em Ipanema/RJ
Re: Problema com Ambiente Gráfico - Resolução de Tela [MAL RESOLVIDO]
« Resposta #27 Online: 06 de Fevereiro de 2008, 00:54 »

Alguém, pelo amor de Deus, tem mais dicas? Eu realmente quero resolver o problema e estou me esforçando pra isso. Abraços!

Salva teu xorg (vc já deve estar cansado de fazer isso, mas não custa lembrar. :D ), troca ele todo por este e vê que bicho que vai dar... ::)

Código: [Selecionar]
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "abnt2"
Option "XkbLayout" "br"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
Identifier "Intel Corporation 82945G/GZ Integrated Graphics Controller"
Boardname "intel"
Busid "PCI:0:2:0"
Driver "intel"
Screen 0
EndSection

Section "Monitor"
Identifier "Monitor Genérico"
Vendorname "Samsung"
Modelname "Samsung SyncMaster 793S/793V/CM173G"
Horizsync 30-71
Vertrefresh 50-160
modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline  "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline  "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
modeline  "1024x768@85" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline  "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation 82945G/GZ Integrated Graphics Controller"
Monitor "Monitor Genérico"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1400 1050
Modes "1024x768@60" "1024x768@43" "1024x768@70" "1152x864@75" "1024x768@75" "1280x960@60" "1024x768@85" "1280x1024@60" "832x624@75" "1400x1050@60" "800x600@60" "800x600@85" "800x600@75" "800x600@72" "800x600@56" "640x480@85" "640x480@75" "640x480@72" "640x480@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
  screen 0 "Default Screen" 0 0
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice     "stylus" "SendCoreEvents"
# InputDevice     "cursor" "SendCoreEvents"
# InputDevice     "eraser" "SendCoreEvents"
EndSection
Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection
Section "ServerFlags"
EndSection

Abs e muita sorte para nós!
Dell Inspiron 5447 Intel Core i5-4210U CPU @ 1.70GHz × 4 | HD sata 1 também | 4 Gb ram
Pier de Ipanema | Facebook Pier de Ipanema
[IMG]http://www.pierdeipanema.com.br/sites/default/files/outras/ubuntu-user

Offline skeletiom

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Problema com Ambiente Gráfico - Resolução de Tela [MAL RESOLVIDO]
« Resposta #28 Online: 23 de Fevereiro de 2008, 18:31 »
Ae coyoterj,

Não iniciou a parte gráfica e apareceu várias mensagens de erro. Entre elas
"Failed to load module intel (module does not exist, o)
No devices detected
fatal server error
no screens found"

É, vou chutar o balde com o ubuntu. Realmente não prestou pra mim.

logaritmo

  • Visitante
Re: Problema com Ambiente Gráfico - Resolução de Tela [MAL RESOLVIDO]
« Resposta #29 Online: 01 de MAR?O de 2008, 22:45 »
Nesta altura do campeonato você deve já ter resolvido o seu problema. Mas, de qqer forma, só pra registrar, hoje tive um problema semelhante ao seu. Ao voltar da oficina para manutenção, o Linux abria com resolução muito baixa, e em Administração > Preferências > Resolução de Tela só a resolução mais baixa aparecia. Depois de muito lutar com o arquivo xorg.conf (sempre fazendo backup antes de modificar) sem sucesso, fiz o que diz o texto inicial do próprio arquivo xorg.conf e digitei o comando

$ sudo dpkg-reconfigure -phigh xserver.xorg

e aí abriu uma tela para escolher e marcar as configurações de interesse e depois tudo voltou a funcionar com a resolução adequada.