Autor Tópico: Problema sério de segurança encontrado no Linux  (Lida 4568 vezes)

Offline dop182

  • Usuário Ubuntu
  • *
  • Mensagens: 202
  • Ubuntu User since Breezy Badger
    • Ver perfil
Problema sério de segurança encontrado no Linux
« Online: 13 de Fevereiro de 2008, 18:01 »
O problema da exploração foi pela primeira vez mostrado no site Milw0rm segurança.O problema é específico com o kernel do sistema chamada sys_vmsplice.

Este sistema call move dados de um usuário de memória através de um endereço gama pipe para outro destino.Tal como as suas relações, splice, que lê e escreve dados de / para o buffer e tee, que é comumente utilizado para apresentar um programa de produção e envia-la em um arquivo, este é um sistema de transferência de dados chamada.É usado principalmente na gestão de memória virtual.Assim, por si só, os utilizadores finais, nunca diretamente encontrão ele.

No entanto, graças à liberação do explorar código, o usuário apenas com um pouco de conhecimento sobre a forma de elaborar o seu próprio programa em Linux será capaz de explorar um servidor.O bug do efeito é, nestas versões do Linux usado nestes kernels com este sistema de chamada compilados,para permitir que os usuários comuns obter acesso root, superuser privilégios.A segurança desse buraco tem sido demonstrado em Debian, Fedora e Ubuntu.

Pode-se seguramente esperar que o problema esteja presente em outras vesões Linux.

Não há um perfeito patch para o problema neste momento.Existe, contudo, um hot fix, o que impede que sejam exploradas pelo menos em alguns sistemas.Desenvolvedores do kernel Linux estão a trabalhar arduamente nos próximos up universal com uma correção para o problema. Depois que uma permanente reparação esteja disponível, os distribuidores Linux serão esperados para divulgá-la como um patch de segurança dentro de horas.

Fonte: http://olinux.uol.com.br/news/open_news.phl?id=7325

PS: Me parece que o Ubuntu está atualizando o kernel pro causa desse bug. Então, atualizem suas distros.


Ubuntu User Nº:

Offline Hqxriven

  • Usuário Ubuntu
  • *
  • Mensagens: 1.456
    • Ver perfil
Re: Problema sério de segurança encontrado no Linux
« Resposta #1 Online: 13 de Fevereiro de 2008, 18:46 »
Pelo que sei o 2.6.23.16 e o 2.6.24.2 não tem esse bug...

http://secunia.com/advisories/28835/

Me corrijam se estou enganado...
Sem distro Linux fixa - Kernel Omnislash
Meu objetivo nesse fórum é ajudar. Sou um mero humano mas desejo sempre aprender e melhorar em tudo o que faço em minha vida. Então, por favor, quando eu postar me notifique depois

Offline FaBMak

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 722
    • Ver perfil
    • fabmak://website
Re: Problema sério de segurança encontrado no Linux
« Resposta #2 Online: 13 de Fevereiro de 2008, 19:56 »
"Não creias impossível o que apenas improvável parece". (Shakespeare)
fabmak://website | http://twitter.com/fabmak