Autor Tópico: Problemas com gcc , cc e cl  (Lida 5335 vezes)

skymads

  • Visitante
Problemas com gcc , cc e cl
« Online: 07 de Julho de 2005, 03:06 »
Estou tentando instalar o scan NMAP aki, mas da o seguinte erro:

root@smallville:~/nmap-3.30 # ./configure
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

Ai qdo eu vo la no Synaptic, tento instalar as bibliotecas gcc ele da esse erro:

dpkg: erro processando /cdrom//pool/main/g/gcc-3.3/g++-3.3_3.3.5-8ubuntu2_i386.deb (--unpack):
 sistema de arquivos de arquivo tar corrompido - arquivo de pacote corrompido : Sucesso
dpkg-deb: subprocesso paste morto por sinal (Pipe quebrado)
Selecionando pacote previamente não selecionado g++.
Descompactando g++ (de .../g++_3.3.5-1_i386.deb) ...
Erros foram encontrados durante processamento de:
 /cdrom//pool/main/g/gcc-3.3/gcc-3.3_3.3.5-8ubuntu2_i386.deb
 /cdrom//pool/main/g/gcc-defaults/gcc_3.3.5-1_i386.deb
 /cdrom//pool/main/g/gcc-3.3/libstdc++5-3.3-dev_3.3.5-8ubuntu2_i386.deb
 /cdrom//pool/main/g/gcc-3.3/g++-3.3_3.3.5-8ubuntu2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


alguem poderia me ajudar, pois nao consigo instalar nada aki.

[]ś

Offline piike

  • Usuário Ubuntu
  • *
  • Mensagens: 128
    • Ver perfil
    • Blog do Piike
Problemas com gcc , cc e cl
« Resposta #1 Online: 13 de Julho de 2005, 01:30 »
jah tentou da um >$ apt-get install gcc e >$ apt-get install g++ ???
Sony Vaio Fz250AE

Oompawampa

  • Visitante
Problemas com gcc , cc e cl
« Resposta #2 Online: 18 de Setembro de 2005, 21:43 »
:oops:  :oops:  também não consigo instalar nada com make dá erro "makefile nada a fazer" e não consigo instalar minha rede rtl8180 por causa disso, alguem tem alguma dica?? estou usando o ubuntu 5.04
amd64

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.285
    • Ver perfil
Problemas com gcc , cc e cl
« Resposta #3 Online: 18 de Setembro de 2005, 22:45 »
apt-get install build-essential

é o necessário para compilação de pacotes simples, para drivers linux-headers-XXX ,linux-image-XXX

XXX representa o kernel que tú usa "uname -r"
se uname -r retorna 2.XXX-686
instale linux-headers-686 e linux-image-686

Oompawampa

  • Visitante
Problemas com gcc , cc e cl
« Resposta #4 Online: 18 de Setembro de 2005, 23:09 »
:oops: Deu erro, fala alguma coisa de erro pq o pacote não é amd64 :oops: