Autor Tópico: Configurando sua Webcam no Ubuntu  (Lida 157638 vezes)

Offline ampop

  • Usuário Ubuntu
  • *
  • Mensagens: 38
    • Ver perfil
    • Alexandre Mota
Re: Configurando sua Webcam no Ubuntu
« Resposta #45 Online: 28 de Novembro de 2006, 04:44 »
Eu tenho a camera integrada no meu laptop Acer Aspire 5601. Há mais de 2 meses que pesquiso uma forma de configurar a webcamera e nada feito. Alguém tem alguma ideia?
Obrigado.



Offline rjbgbo

  • Usuário Ubuntu
  • *
  • Mensagens: 3.889
  • Xubuntu 18.04LTS
    • Ver perfil
    • Twitter
Re: Configurando sua Webcam no Ubuntu
« Resposta #46 Online: 15 de Dezembro de 2006, 14:07 »
Cara, já tive este problema e resolvi lendo um blog sobre o assunto. 
Coloquei até o link no tópico dicas para instalação de webcam, mas depois retirei pq saiu do ar.

Mas o link que melhor funcionou numa minha webcam que usa driver spca5xx , foi este:
 
http://ubuntuforums.org/showthread.php?t=75284&highlight=spca

Webcam ainda é problemático a instalação no linux, mas está melhorando.
E o processo de instalação geralmente não é igual. Estou com 3 webcans, a ultima comprei esta semana.
Uma, seguindo a orientação do forum gringo, funcionou bem, mas é um modelo especifico para notebooks e está no laptop.
Outra, a LG lic-300, não consegui nada com o linux.
A mais recente instalei pelo EasyCam numa boa, está funcionando bem tanto no breezy como no dapper.

Acabei de achar no tópico abaixo a resposta para a webcam LG LIC-300:
http://ubuntuforum-pt.org/index.php?topic=14220.0

Instalei i programa Camorama indicado e funcionou tudo normalmente, e rodando pelo CD.  ;D
« Última modificação: 15 de Dezembro de 2006, 14:23 por rjbgbo »
Linux User #440843 | Ubuntu User #11469

Offline ampop

  • Usuário Ubuntu
  • *
  • Mensagens: 38
    • Ver perfil
    • Alexandre Mota
Re: Configurando sua Webcam no Ubuntu
« Resposta #47 Online: 15 de Dezembro de 2006, 19:02 »
Com estas dicas já foi possível instalar a webcam que vem integrada no laptop Acer Aspire 5601. Mas a imagem está a preto, não se vê nada. Pelo que pesquisei o driver ainda está em desenvolvimento, e será uma questão de tempo até sair um driver compatível.
Utilizei o driver gspca, com o spca5xx não funciona.
Obrigado. Se mais alguém souber de novidades, poste s.f.f.



Offline Dark Fenix

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Configurando sua Webcam no Ubuntu
« Resposta #48 Online: 19 de Dezembro de 2006, 16:50 »
Boa tarde ppl, eu tenho uma Creative Technology, Ltd WebCam PD1001, pelo menos é assim que aparece com o lsusb, e nao sei como a configurar... alguem me pode ajudar? eu sou novo nisto :S

Offline rjbgbo

  • Usuário Ubuntu
  • *
  • Mensagens: 3.889
  • Xubuntu 18.04LTS
    • Ver perfil
    • Twitter
Re: Configurando sua Webcam no Ubuntu
« Resposta #49 Online: 19 de Dezembro de 2006, 17:56 »
Boa tarde ppl, eu tenho uma Creative Technology, Ltd WebCam PD1001, pelo menos é assim que aparece com o lsusb, e nao sei como a configurar... alguem me pode ajudar? eu sou novo nisto :S

Instale o programa Camorana pelo Adicionar/Remover

Se o programa não reconhecer a tua webcam, pode ser que ela não seja compatível outro problema, neste caso continue perguntando no fórum.
Linux User #440843 | Ubuntu User #11469

Offline Dark Fenix

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Configurando sua Webcam no Ubuntu
« Resposta #50 Online: 19 de Dezembro de 2006, 18:42 »
Ok vou testar e dp digo o resultado... obrigado ;)

Offline wiskzito

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Webcam Lg webpro²
« Resposta #51 Online: 06 de Abril de 2007, 01:38 »
Citação de: wiskzito
Cara eu to tantando instalar minha cam Webcam Lg webpro², grep Camera, não retorna nada.  usando o 
 
Bus 001 Device 002: ID 05a9:4519 OmniVision Technologies, Inc.
 
Dando uma olhada aqui na máquina eu achei o spca5xx.ko dentro da pasta spca5xx
já olhei também lá no site, mas não tem driver pra minha cam
LG LIC-300 - Webcam webpro2
Bus 001 Device 002: ID 05a9:4519 OmniVision Technologies, Inc.

 Depois de muito pesquisar, descobri que o driver mais apropriado para LIC-300 da LG não é o spca5xx e sim o ov519, só que este driver ainda está em testes. Existe o ov51*, mas não funciona.

http://blognux.free.fr/Liste/ov519

Valeu pela busca RC,  to tentando achar um lugar pra baixar o ov519, pois eu não achei ele lá nesse site

Wisk, na jornada para fazer a webcam funcionar .  8)
Alienware m17x

Offline tchodz

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Configurando sua Webcam no Ubuntu
« Resposta #52 Online: 25 de Abril de 2009, 15:57 »
A minha webcam é uma braview modelo 430mp

Bus 002 Device 002: ID 0c45:612f Microdia PC Camera (SN9C110)

Mas nao estou achando o caminho correto. Alguém pode me ajudar.

Offline felipeoi

  • Usuário Ubuntu
  • *
  • Mensagens: 27
    • Ver perfil
Re: Configurando sua Webcam no Ubuntu
« Resposta #53 Online: 26 de Abril de 2009, 00:16 »
Tópico perfeito
resolveu aki

vlwww!

Offline SergioJP

  • Usuário Ubuntu
  • *
  • Mensagens: 220
  • Nada é melhor do que aprender e compartilhar.
    • Ver perfil
Re: Configurando sua Webcam no Ubuntu
« Resposta #54 Online: 20 de Maio de 2009, 22:04 »
A minha webcam é a Logitech quickcam pro 4000

id dela é:   Bus 002 Device 002: ID 046d:08b2 Logitech, Inc. QuickCam Pro 4000

Para instalar o driver no Jaunty Jackalope foi só instalar o programa Camorama e está funcionado legal,  usando o skype com imagem muito boa.
Ubuntu Gnome 17.04 LTS GIGABYTE H61M-S1- CORE i3 - NVidia GT 420 - 12G RAM

Offline Gabriel087

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Configurando sua Webcam no Ubuntu
« Resposta #55 Online: 17 de Setembro de 2009, 21:02 »
como q eu faço para instalar o driver da minha webcam logitech quikcam ?
sempre me deparo com >> make all erro 2 :-\

Offline lesma10

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Configurando sua Webcam no Ubuntu
« Resposta #56 Online: 18 de Fevereiro de 2010, 11:14 »
eu tenho uma webcam logitech usb 2.0 quickcam messenger,quando coloco o cd de instalaçao recebo uma mensagem de erro:
O software executará diretamente a partir da mídia "QC_9_50". Você nunca deve executar um software no qual você não confia.
Erro ao iniciar programa automaticamente executável: Permissão negada

como devo prosseguir para conseguir instalar minha webcam?
Obrigado.



Offline Madrigal

  • Usuário Ubuntu
  • *
  • Mensagens: 836
    • Ver perfil
Re: Configurando sua Webcam no Ubuntu
« Resposta #57 Online: 10 de Maio de 2010, 18:56 »
Comigo não resolveu no Ubuntu 10.04 com a LG Lic-300 Webpro2, tentei adaptar colocando a versão atual... veja o que fiz:

junior@junior:~$ lsusb | grep Camera
Bus 008 Device 003: ID 0c45:60fc Microdia PC Camera with Mic (SN9C105)
junior@junior:~$


junior@junior:~$ sudo apt-get install build-essential
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os pacotes extra a seguir serão instalados:
  dpkg-dev g++ g++-4.4 libstdc++6-4.4-dev xz-utils
Pacotes sugeridos:
  debian-keyring debian-maintainers g++-multilib g++-4.4-multilib gcc-4.4-doc
  libstdc++6-4.4-dbg libstdc++6-4.4-doc
Os NOVOS pacotes a seguir serão instalados:
  build-essential dpkg-dev g++ g++-4.4 libstdc++6-4.4-dev xz-utils
0 pacotes atualizados, 6 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 7331kB de arquivos.
Depois desta operação, 23,9MB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]?
Obter:1 http://archive.ubuntu.com/ubuntu/ lucid/main libstdc++6-4.4-dev 4.4.3-4ubuntu5 [1491kB]
Obter:2 http://archive.ubuntu.com/ubuntu/ lucid/main g++-4.4 4.4.3-4ubuntu5 [4950kB]
Obter:3 http://archive.ubuntu.com/ubuntu/ lucid/main g++ 4:4.4.3-1ubuntu1 [1442B]
Obter:4 http://archive.ubuntu.com/ubuntu/ lucid/main xz-utils 4.999.9beta+20091116-1 [228kB]
Obter:5 http://archive.ubuntu.com/ubuntu/ lucid/main dpkg-dev 1.15.5.6ubuntu4 [653kB]
Obter:6 http://archive.ubuntu.com/ubuntu/ lucid/main build-essential 11.4build1 [7278B]
Baixados 7331kB em 1min 3s (116kB/s)                                           
Selecionando pacote previamente não selecionado libstdc++6-4.4-dev.
(Lendo banco de dados ... 152675 arquivos e diretórios atualmente instalados).
Desempacotando libstdc++6-4.4-dev (de .../libstdc++6-4.4-dev_4.4.3-4ubuntu5_i386.deb) ...
Selecionando pacote previamente não selecionado g++-4.4.
Desempacotando g++-4.4 (de .../g++-4.4_4.4.3-4ubuntu5_i386.deb) ...
Selecionando pacote previamente não selecionado g++.
Desempacotando g++ (de .../g++_4%3a4.4.3-1ubuntu1_i386.deb) ...
Selecionando pacote previamente não selecionado xz-utils.
Desempacotando xz-utils (de .../xz-utils_4.999.9beta+20091116-1_i386.deb) ...
Selecionando pacote previamente não selecionado dpkg-dev.
Desempacotando dpkg-dev (de .../dpkg-dev_1.15.5.6ubuntu4_all.deb) ...
Selecionando pacote previamente não selecionado build-essential.
Desempacotando build-essential (de .../build-essential_11.4build1_i386.deb) ...
Processando gatilhos para man-db ...
Configurando xz-utils (4.999.9beta+20091116-1) ...
Configurando dpkg-dev (1.15.5.6ubuntu4) ...
Configurando libstdc++6-4.4-dev (4.4.3-4ubuntu5) ...
Configurando g++-4.4 (4.4.3-4ubuntu5) ...
Configurando g++ (4:4.4.3-1ubuntu1) ...
update-alternatives: usando /usr/bin/g++ para fornecer /usr/bin/c++ (c++) em modo automático.

Configurando build-essential (11.4build1) ...


junior@junior:~$ sudo apt-get install gcc-4.3
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os pacotes extra a seguir serão instalados:
  cpp-4.3 gcc-4.3-base
Pacotes sugeridos:
  gcc-4.3-locales gcc-4.3-multilib libmudflap0-4.3-dev gcc-4.3-doc libgcc1-dbg
  libgomp1-dbg libmudflap0-dbg
Os NOVOS pacotes a seguir serão instalados:
  cpp-4.3 gcc-4.3 gcc-4.3-base
0 pacotes atualizados, 3 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 6141kB de arquivos.
Depois desta operação, 12,5MB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]?
Obter:1 http://archive.ubuntu.com/ubuntu/ lucid/universe gcc-4.3-base 4.3.4-10ubuntu1 [111kB]
Obter:2 http://archive.ubuntu.com/ubuntu/ lucid/universe cpp-4.3 4.3.4-10ubuntu1 [3093kB]
Obter:3 http://archive.ubuntu.com/ubuntu/ lucid/universe gcc-4.3 4.3.4-10ubuntu1 [2937kB]
Baixados 6141kB em 52s (116kB/s)                                               
Selecionando pacote previamente não selecionado gcc-4.3-base.
(Lendo banco de dados ... 153657 arquivos e diretórios atualmente instalados).
Desempacotando gcc-4.3-base (de .../gcc-4.3-base_4.3.4-10ubuntu1_i386.deb) ...
Selecionando pacote previamente não selecionado cpp-4.3.
Desempacotando cpp-4.3 (de .../cpp-4.3_4.3.4-10ubuntu1_i386.deb) ...
Selecionando pacote previamente não selecionado gcc-4.3.
Desempacotando gcc-4.3 (de .../gcc-4.3_4.3.4-10ubuntu1_i386.deb) ...
Processando gatilhos para man-db ...
Configurando gcc-4.3-base (4.3.4-10ubuntu1) ...
Configurando cpp-4.3 (4.3.4-10ubuntu1) ...
Configurando gcc-4.3 (4.3.4-10ubuntu1) ...



junior@junior:~$ CC=gcc-4.3
junior@junior:~$ export CC



junior@junior:~$ sudo ln -s /usr/include/linux /usr/src/linux


junior@junior:~$ cd Download/


junior@junior:~/Download$ tar -zxvf gspcav1-20071224.tar.gz
gspcav1-20071224/
gspcav1-20071224/decoder/
gspcav1-20071224/decoder/gspcadecoder.c
gspcav1-20071224/decoder/gspcadecoder.h
gspcav1-20071224/decoder/gspcadecoder-OSX.c
gspcav1-20071224/decoder/gspcadecoder-OSX.h
gspcav1-20071224/Makefile
gspcav1-20071224/Vimicro/
gspcav1-20071224/Vimicro/vc032x_sensor.h
gspcav1-20071224/Vimicro/zc3xx.h
gspcav1-20071224/Vimicro/cs2102.h
gspcav1-20071224/Vimicro/vc032x.h
gspcav1-20071224/Vimicro/pas106b.h
gspcav1-20071224/Vimicro/icm105a.h
gspcav1-20071224/Vimicro/hv7131b.h
gspcav1-20071224/Vimicro/hv7131c.h
gspcav1-20071224/Vimicro/pb0330.h
gspcav1-20071224/Vimicro/ov7630c.h
gspcav1-20071224/Vimicro/mc501cb.h
gspcav1-20071224/Vimicro/tas5130c_vf0250.h
gspcav1-20071224/Vimicro/ov7620.h
gspcav1-20071224/Vimicro/tas5130c.h
gspcav1-20071224/Vimicro/hdcs2020.h
gspcav1-20071224/Etoms/
gspcav1-20071224/Etoms/et61xx51.h
gspcav1-20071224/Sonix/
gspcav1-20071224/Sonix/sn9cxxx.h
gspcav1-20071224/Sonix/sonix.h
gspcav1-20071224/utils/
gspcav1-20071224/utils/spcagamma.h
gspcav1-20071224/utils/spcausb.h
gspcav1-20071224/utils/spcaCompat.h
gspcav1-20071224/Conexant/
gspcav1-20071224/Conexant/cx11646.h
gspcav1-20071224/Conexant/cxlib.h
gspcav1-20071224/Pixart/
gspcav1-20071224/Pixart/pac207-OSX.h
gspcav1-20071224/Pixart/pac7311.h
gspcav1-20071224/Pixart/pac207.h
gspcav1-20071224/changelog
gspcav1-20071224/license
gspcav1-20071224/gspca_core.c
gspcav1-20071224/Transvision/
gspcav1-20071224/Transvision/tv8532.h
gspcav1-20071224/Makefile.kld
gspcav1-20071224/gspca.h
gspcav1-20071224/Sunplus/
gspcav1-20071224/Sunplus/spca501.dat
gspcav1-20071224/Sunplus/spca505.dat
gspcav1-20071224/Sunplus/spca508.dat
gspcav1-20071224/Sunplus/spca561-OSX.h
gspcav1-20071224/Sunplus/spca506.h
gspcav1-20071224/Sunplus/spca561.h
gspcav1-20071224/Sunplus/spca501_init.h
gspcav1-20071224/Sunplus/spca508_init-OSX.h
gspcav1-20071224/Sunplus/spca508_init.h
gspcav1-20071224/Sunplus/spca501_init-OSX.h
gspcav1-20071224/Sunplus/spca505_init.h
gspcav1-20071224/Sunplus-jpeg/
gspcav1-20071224/Sunplus-jpeg/spca500.dat
gspcav1-20071224/Sunplus-jpeg/jpeg_qtables.h
gspcav1-20071224/Sunplus-jpeg/sp5xxfw2.h
gspcav1-20071224/Sunplus-jpeg/sp5xxfw2.dat
gspcav1-20071224/Sunplus-jpeg/spca500_init.h
gspcav1-20071224/gspca_build
gspcav1-20071224/READ_AND_INSTALL
gspcav1-20071224/Mars-Semi/
gspcav1-20071224/Mars-Semi/mr97311.h
gspcav1-20071224/cutlog.py
junior@junior:~/Download$


junior@junior:~/Download$ cd gspcav1-20071224/


junior@junior:~/Download/gspcav1-20071224$ make clean
rm -r -f *.o decoder/.gspcadecoder.o.cmd decoder/*.o \
   .gspca.o.cmd  *.o *.ko *.mod.* .[a-z]* core *.i \
   *.symvers *.err


junior@junior:~/Download/gspcav1-20071224$ make
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/junior/Download/gspcav1-20071224 CC=gcc-4.3 modules
make[1]: Entrando no diretório `/usr/src/linux-headers-2.6.32-22-generic'
  CC [M]  /home/junior/Download/gspcav1-20071224/gspca_core.o
/home/junior/Download/gspcav1-20071224/gspca_core.c:54:27: error: asm/semaphore.h: Arquivo ou diretório não encontrado
In file included from /home/junior/Download/gspcav1-20071224/gspca_core.c:845:
/home/junior/Download/gspcav1-20071224/utils/spcausb.h: In function ‘spca5xxRegRead’:
/home/junior/Download/gspcav1-20071224/utils/spcausb.h:95: error: implicit declaration of function ‘info’
/home/junior/Download/gspcav1-20071224/utils/spcausb.h: In function ‘spca_set_interface’:
/home/junior/Download/gspcav1-20071224/utils/spcausb.h:278: error: implicit declaration of function ‘warn’
In file included from /home/junior/Download/gspcav1-20071224/gspca_core.c:853:
/home/junior/Download/gspcav1-20071224/Sunplus-jpeg/sp5xxfw2.h: In function ‘sp5xxfw2_init’:
/home/junior/Download/gspcav1-20071224/Sunplus-jpeg/sp5xxfw2.h:122: error: called object ‘info’ is not a function
/home/junior/Download/gspcav1-20071224/Sunplus-jpeg/sp5xxfw2.h:136: error: called object ‘info’ is not a function
/home/junior/Download/gspcav1-20071224/Sunplus-jpeg/sp5xxfw2.h:141: error: called object ‘info’ is not a function
/home/junior/Download/gspcav1-20071224/Sunplus-jpeg/sp5xxfw2.h:148: error: called object ‘info’ is not a function
/home/junior/Download/gspcav1-20071224/Sunplus-jpeg/sp5xxfw2.h:176: error: called object ‘info’ is not a function
/home/junior/Download/gspcav1-20071224/Sunplus-jpeg/sp5xxfw2.h: In function ‘sp5xxfw2_start’:
/home/junior/Download/gspcav1-20071224/Sunplus-jpeg/sp5xxfw2.h:214: error: called object ‘info’ is not a function
/home/junior/Download/gspcav1-20071224/Sunplus-jpeg/sp5xxfw2.h:230: error: called object ‘info’ is not a function
/home/junior/Download/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_ioctl’:
/home/junior/Download/gspcav1-20071224/gspca_core.c:2463: error: implicit declaration of function ‘video_usercopy’
/home/junior/Download/gspcav1-20071224/gspca_core.c: At top level:
/home/junior/Download/gspcav1-20071224/gspca_core.c:2609: error: unknown field ‘owner’ specified in initializer
/home/junior/Download/gspcav1-20071224/gspca_core.c:2609: warning: initialization from incompatible pointer type
/home/junior/Download/gspcav1-20071224/gspca_core.c:2611: error: unknown field ‘type’ specified in initializer
/home/junior/Download/gspcav1-20071224/gspca_core.c:2615: warning: initialization from incompatible pointer type
/home/junior/Download/gspcav1-20071224/gspca_core.c: In function ‘spca50x_create_sysfs’:
/home/junior/Download/gspcav1-20071224/gspca_core.c:2769: error: implicit declaration of function ‘video_device_create_file’
/home/junior/Download/gspcav1-20071224/gspca_core.c:2780: error: implicit declaration of function ‘video_device_remove_file’
/home/junior/Download/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_probe’:
/home/junior/Download/gspcav1-20071224/gspca_core.c:4301: error: incompatible types in assignment
make[2]: ** [/home/junior/Download/gspcav1-20071224/gspca_core.o] Erro 1
make[1]: ** [_module_/home/junior/Download/gspcav1-20071224] Erro 2
make[1]: Saindo do diretório `/usr/src/linux-headers-2.6.32-22-generic'
make: ** [default] Erro 2



junior@junior:~/Download/gspcav1-20071224$ sudo make install
mkdir -p /lib/modules/`uname -r`/kernel/drivers/usb/media/
rm -f /lib/modules/`uname -r`/kernel/drivers/usb/media/spca5xx.ko
rm -f /lib/modules/`uname -r`/kernel/drivers/media/video/gspca.ko
install -c -m 0644 gspca.ko /lib/modules/`uname -r`/kernel/drivers/usb/media/
install: impossível obter estado de `gspca.ko': Arquivo ou diretório não encontrado
make: ** [install] Erro 1



junior@junior:~/Download/gspcav1-20071224$ sudo rm /lib/modules/2.6.12-10-386/kernel/drivers/usb/media/spca5xx/spca5xx.ko
rm: não foi possível remover `/lib/modules/2.6.12-10-386/kernel/drivers/usb/media/spca5xx/spca5xx.ko': Arquivo ou diretório não encontrado


junior@junior:~/Download/gspcav1-20071224$ modprobe spca5xx
FATAL: Module spca5xx not found.


junior@junior:~/Download/gspcav1-20071224$


O que será que eu estou fazendo de errado?