Autor Tópico: Deixe as cores do Ubuntu mais bonitas  (Lida 6972 vezes)

Offline LaSSarD

  • Usuário Ubuntu
  • *
  • Mensagens: 1.144
    • Ver perfil
Deixe as cores do Ubuntu mais bonitas
« Online: 04 de Janeiro de 2006, 18:49 »
  • Por onde você passa só vê gradientes feios?
  • Os temas GTK e splash screens com gradientes lindos que você usa ficam ridículos no seu computador?
  • Seus vizinhos zombam de você porque seus gradientes parecem linhas grossas seguidas uma atrás da outra?
Veja algumas declarações de usuários felizes:
Citação de: "migraineboy"
Obrigado!!! Meus problemas acabaram!!

Citação de: "John Smith"
This tip rocks the socks! I've finally got my Ubuntu working with super colors!

Citação de: "Davi Henrique"
Graças ao LaSSarD minha vida mudou! Antes eu estava na pior, não tinha noção alguma de bom gosto, mas ele, meu salvador, mudou minha vida! Agora meus temas sorriem para mim! LaSSarD é meu herói!


Na verdade é uma dica até idiota e muita gente sabe, mas às vezes certas coisas fogem de nossa cabeça e parecemos não ligar os fatos. O que acontece é que o Ubuntu vem configurado por padrão para 16 bits, que segundo eles deixa o computador mais leve. Eu testei aqui e o modo 24 bits parece não perder em nada para 16 bits, sendo que é ele o salvador das cores.

Vamos à alteração:
[list=1]
  • Edite o arquivo /etc/X11/xorg.conf:
Código: [Selecionar]
sudo gedit /etc/X11/xorg.conf
  • Procure a linha DefaultDepth dentro de Section "Screen" e deixe-a assim:
Código: [Selecionar]
DefaultDepth 24
  • Salve, feche e reinicie o X (Ctrl+Alt+Backspace)[/list:o]
    Pronto, falei que era fácil :mrgreen:
desculpem as mensagens não respondidas, mas eu tô afastado há mais de ano...
um dia eu volto ;)

Offline LNAS90

  • Usuário Ubuntu
  • *
  • Mensagens: 124
    • Ver perfil
    • http://linux-sem-misterio.blogspot.com/
Deixe as cores do Ubuntu mais bonitas
« Resposta #1 Online: 13 de Janeiro de 2006, 12:00 »
no meu ja veio assim
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/X11/fonts/misc"
   FontPath   "/usr/share/X11/fonts/cyrillic"
   FontPath   "/usr/share/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/Type1"
   FontPath   "/usr/share/X11/fonts/CID"
   FontPath   "/usr/share/X11/fonts/100dpi"
   FontPath   "/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
   Load   "GLcore"
   Load   "i2c"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "type1"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "abnt2"
   Option      "XkbLayout"   "br"
   Option      "XkbVariant"   "abnt2"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "Emulate3Buttons"   "true"
   Option      "ZAxisMapping"      "4 5"
EndSection

Section "Device"
   Identifier   "NVIDIA Corporation NV11DDR [GeForce2 MX 100 DDR/200 DDR]"
   Driver      "nv"
   BusID      "PCI:1:0:0"
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "NVIDIA Corporation NV11DDR [GeForce2 MX 100 DDR/200 DDR]"
   Monitor      "Generic Monitor"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1024x768" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1024x768" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1024x768" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1024x768" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1024x768" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1024x768" "800x600" "720x400" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
EndSection

Section "DRI"
   Mode   0666
EndSection
Meu blog (reativado a pouco tempo) http://linux-sem-misterio.blogspot.com/

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.352
  • @Ceará
    • Ver perfil
Deixe as cores do Ubuntu mais bonitas
« Resposta #2 Online: 13 de Janeiro de 2006, 12:18 »
O meu tava em 24, mas não sei se teve alguma alteração automática ao instalar os drivers da NVidia.
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline biohazard

  • Usuário Ubuntu
  • *
  • Mensagens: 523
  • <thug life>
    • Ver perfil
Deixe as cores do Ubuntu mais bonitas
« Resposta #3 Online: 13 de Janeiro de 2006, 12:49 »
o meu também ja tava em 24
Arch Linux Overlord
Kernel 2.6.25-ARCH

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.677
    • Ver perfil
Deixe as cores do Ubuntu mais bonitas
« Resposta #4 Online: 13 de Janeiro de 2006, 13:07 »
O meu também!
Linux Mint 19.3 XFCE

Piras

  • Visitante
Deixe as cores do Ubuntu mais bonitas
« Resposta #5 Online: 15 de Janeiro de 2006, 16:50 »
O meu também já estava em 24, mas achei o máximo o "reclame" de abertura do tópico...

Offline LedStyle

  • Usuário Ubuntu
  • *
  • Mensagens: 1.347
    • Ver perfil
    • http://www.tuxresources.org
Deixe as cores do Ubuntu mais bonitas
« Resposta #6 Online: 15 de Janeiro de 2006, 19:07 »
Faltou o "Seus problemas acabarium!!"

Offline cypherbios

  • Usuário Ubuntu
  • *
  • Mensagens: 92
  • Líder do Time de Documentação do Ubuntu-BR
    • Ver perfil
    • CypherBIOS.org
Deixe as cores do Ubuntu mais bonitas
« Resposta #7 Online: 15 de Janeiro de 2006, 22:18 »
O meu também já estava assim,

mas isso é por padrão quando se instala o driver da Nvidia, acredito que da ATI também (eles não iriam querer ficar atráz)
Rafael "CypherBIOS" Proença
http://www.cypherbios.org/blog
Desenvolvedor - APTonCD
Interessado em aprender mais sobre o Ubuntu em português? Comece Aqui

Nick

  • Visitante
Deixe as cores do Ubuntu mais bonitas
« Resposta #8 Online: 16 de Janeiro de 2006, 10:04 »
E se nois colocar 32?

Offline Snails

  • Usuário Ubuntu
  • *
  • Mensagens: 39
  • Voltei Para Ficar
    • Ver perfil
    • http://www.snails.alojagratis.org
Deixe as cores do Ubuntu mais bonitas
« Resposta #9 Online: 18 de Janeiro de 2006, 07:33 »
Citar
Graças ao LaSSarD minha vida mudou! Antes eu estava na pior, não tinha noção alguma de bom gosto, mas ele, meu salvador, mudou minha vida! Agora meus temas sorriem para mim! LaSSarD é meu herói!
Voltei Para Ficar... depois do tal "libicu" do FC que ferrou o meu sistema -.-

Offline LaSSarD

  • Usuário Ubuntu
  • *
  • Mensagens: 1.144
    • Ver perfil
Deixe as cores do Ubuntu mais bonitas
« Resposta #10 Online: 21 de Janeiro de 2006, 14:32 »
Estranho, podia jurar que o padrão era 24.. o_O
Erro meu, então. Vai ver foi em algum lugar que eu vi que colocando em 16 ficava mais rápido, mas que nada, eu mudei e não senti diferença alguma.
Desculpem aí pelo meu erro, mas vou deixar a dica aí igual pra quem botou em 16 e tá vendo aqueles gradientes horríveis :mrgreen:

Nick, dá pra colocar 32 também, mas eu ouvi falar que o olho humano não vê diferença entre 32 e 24, apesar de alguns programas exigirem o modo 32 bits de cores e por isso ele existe...
desculpem as mensagens não respondidas, mas eu tô afastado há mais de ano...
um dia eu volto ;)

Offline cafecraft

  • Usuário Ubuntu
  • *
  • Mensagens: 138
    • Ver perfil
    • http://www.linuxval.org
Deixe as cores do Ubuntu mais bonitas
« Resposta #11 Online: 22 de Janeiro de 2006, 14:19 »
Citação de: "LaSSarD"
Estranho, podia jurar que o padrão era 24.. o_O
Erro meu, então. Vai ver foi em algum lugar que eu vi que colocando em 16 ficava mais rápido, mas que nada, eu mudei e não senti diferença alguma.
Desculpem aí pelo meu erro, mas vou deixar a dica aí igual pra quem botou em 16 e tá vendo aqueles gradientes horríveis :mrgreen:

Nick, dá pra colocar 32 também, mas eu ouvi falar que o olho humano não vê diferença entre 32 e 24, apesar de alguns programas exigirem o modo 32 bits de cores e por isso ele existe...


auhuahua!.. sem querer achei isso no debconf do Xorg:

(As famosas "cores de 32 bits" são na verdade 24 bits de informações de cores mais 8 bits de canal alfa ou simples enchimentos de zeros; o Sistema de Janelas X pode gerenciar ambos os casos. Caso você um dos dois, escolha 24 bits.)
Assinatura removida conforme a regra 8. O prazo era até 13/02.