Autor Tópico: [Solucionado] Placa de som onboard, desabilitada no Bios, continua funcionando  (Lida 3127 vezes)

Offline vítor

  • Usuário Ubuntu
  • *
  • Mensagens: 105
    • Ver perfil
    • Grupo Mosaicos
Olá amigos!

Desde que eu comprei uma placa de som nova há alguns meses tenho observado um problema que às vezes me causa algum transtorno.
Apesar de eu ter desabilitado a placa de som onboard na Bios e de já ter até feito uma reinstalação completa do Ubuntu depois disso, aparentemente a placa onboard continua funcionando. E na inicialização o sistema escolhe uma ou outra. É engraçado porque ora a música da abertura do Ubuntu toca nas minhas caixinhas que estão ligadas à placa onboard, ora ela toca no aparelho de som ligado à placa nova.
De fato a placa está desabilitada, pois no windows ela desapareceu. E no entanto, o Jack continua exibindo as duas placas como opção.
O problema é que os aplicativos também ficam nesse vai-e-vem de placa de som e eu tenho que reiniciar o sistema pra ver se eles voltam a funcionar com placa principal.
Uma coisa que eu observei é que o nome dela no Bios e no windows é Via-3058 AC97 Audio e no Ubuntu é VT8237 AC97 Audio.
Alguém sabe como desabilitar de verdade a placa onboard?

Mais abaixo eu colei a saída do lspci.
Neste endereço dá pra ver uma imagem de tela do gerenciador do dispositivo do Ubuntu: http://adeiss.vc.angelfire.com/placas.png





00:00.0 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
00:09.0 Multimedia audio controller: VIA Technologies Inc. ICE1712 [Envy24] PCI Multi-Channel I/O Controller (rev 02)
00:0f.0 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation NV44A [GeForce 6200] (rev a1)
« Última modificação: 27 de Fevereiro de 2008, 23:44 por vítor »

Offline vítor

  • Usuário Ubuntu
  • *
  • Mensagens: 105
    • Ver perfil
    • Grupo Mosaicos
Re: Placa de som onboard, desabilitada no Bios, continua funcionando
« Resposta #1 Online: 27 de Fevereiro de 2008, 09:29 »
Nenhuma idéia?
Será que tem alguma forma de tirar o módulo da placa onboard do kernel?
Recompilar o kernel?
Qualquer coisa.
« Última modificação: 27 de Fevereiro de 2008, 09:38 por vítor »

Offline vítor

  • Usuário Ubuntu
  • *
  • Mensagens: 105
    • Ver perfil
    • Grupo Mosaicos
Re: [Solucionado] Placa de som onboard, desabilitada no Bios, continua funcionan
« Resposta #2 Online: 27 de Fevereiro de 2008, 23:54 »
Consegui encontrar a solução.
Bastou eu localizar o módulo do driver da placa de som onboard comparando o resultado do lspci com o do lsmod. No meu caso era o "snd_via82xx".
Depois eu coloquei este módulo na lista negra para ele não ser carregado na inicialização do sistema. A lista negra no Ubuntu fica em /etc/modprobe.d/blacklist.
Basta colocar o nome do módulo na lista precedido pelo termo "blacklist" e reiniciar o sistema.

Abs