Autor Tópico: Erro para instalar pacotes!  (Lida 2579 vezes)

Offline sottam

  • Usuário Ubuntu
  • *
  • Mensagens: 309
    • Ver perfil
Erro para instalar pacotes!
« Online: 04 de MAR?O de 2008, 19:16 »
Boa noite pessoal... hoje a tarde eu instalei esse  build-essential no meu pc no meu trampo.... instalou blz....

mas aqui em casa ta dando erro......

sottam@sottam-desktop:~$ sudo apt-get install build-essential
Lendo lista de pacotes... Pronto
Construindo árvore de dependências       
Reading state information... Pronto
Os seguintes pacotes foram instalados automaticamente e não são mais necessários:
  libgnome-compiz-manager0
Use 'apt-get autoremove' para removê-los.
Os pacotes extra a seguir serão instalados:
  g++ g++-4.1 libc6-dev libstdc++6-4.1-dev linux-libc-dev
Pacotes sugeridos:
  g++-multilib g++-4.1-multilib gcc-4.1-doc glibc-doc manpages-dev
  libstdc++6-4.1-doc
Os NOVOS pacotes a seguir serão instalados:
  build-essential g++ g++-4.1 libc6-dev libstdc++6-4.1-dev linux-libc-dev
0 pacotes atualizados, 6 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso fazer o download de 7677kB de arquivos.
Depois de desempacotar, 31,0MB adicionais de espaço em disco serão usados.
Quer continuar [S/n]? s
Obtendo:1 http://br.archive.ubuntu.com gutsy-updates/main linux-libc-dev 2.6.22-14.52 [653kB]
Obtendo:2 http://br.archive.ubuntu.com gutsy-updates/main libc6-dev 2.6.1-1ubuntu10 [3287kB]
Obtendo:3 http://br.archive.ubuntu.com gutsy/main libstdc++6-4.1-dev 4.1.2-16ubuntu2 [1129kB]
Obtendo:4 http://br.archive.ubuntu.com gutsy/main g++-4.1 4.1.2-16ubuntu2 [2600kB]
Obtendo:5 http://br.archive.ubuntu.com gutsy/main g++ 4:4.1.2-9ubuntu2 [1440B]
Obtendo:6 http://br.archive.ubuntu.com gutsy/main build-essential 11.3ubuntu1 [7066B]
Baixados 7677kB em 2m47s (46,0kB/s)                                           
(Lendo banco de dados ... dpkg: erro processando /var/cache/apt/archives/linux-libc-dev_2.6.22-14.52_i386.deb (--unpack):
 falha em buffer_read(fd): lista de arquivos do pacote `gnome-applets-data': Erro de entrada/saída
Erros foram encontrados durante processamento de:
 /var/cache/apt/archives/linux-libc-dev_2.6.22-14.52_i386.deb
Processamento parou porque haviam muitos erros.
E: Sub-process /usr/bin/dpkg returned an error code (1)
sottam@sottam-desktop:~$

alguem pode ajudar???
« Última modificação: 05 de MAR?O de 2008, 18:39 por ins3rt c0in »

Offline sottam

  • Usuário Ubuntu
  • *
  • Mensagens: 309
    • Ver perfil
Re: Erro para instalar pacotes!!!!! Ajuda PLX
« Resposta #1 Online: 05 de MAR?O de 2008, 18:20 »
Pessoal..... ajuda ai pls..... agora nem as atualizações ta instalando..... olhem a imagem....



Offline ins3rt c0in

  • Usuário Ubuntu
  • *
  • Mensagens: 700
    • Ver perfil
Re: Erro para instalar pacotes!
« Resposta #2 Online: 05 de MAR?O de 2008, 18:41 »
sottam,

Não use exclamações do gênero "ajuda PLX". Vai contra as regras do fórum.

Offline sottam

  • Usuário Ubuntu
  • *
  • Mensagens: 309
    • Ver perfil
Re: Erro para instalar pacotes!
« Resposta #3 Online: 05 de MAR?O de 2008, 18:44 »
sottam,

Não use exclamações do gênero "ajuda PLX". Vai contra as regras do fórum.



muito obrigado... resolveu meu problema......

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Erro para instalar pacotes!
« Resposta #4 Online: 05 de MAR?O de 2008, 18:52 »
Experimente entrar no terminal e digitar>

sudo apt-get autoclean <enter>

sudo apt-get autoremove <enter>

Veja se resolve.

O que parece 'e que o linux gravou os arquivos numa parte danificada do HD ou baixou o pacote com quebras

finalmente va na pasta /var/cache/apt/archives/

e remova manualmente o pacote > linux-libc-dev_2.6.22-14.52_i386.deb se ele ainda estiver la.

baixe e instale ele novamente.

Deve resolver.

Offline ins3rt c0in

  • Usuário Ubuntu
  • *
  • Mensagens: 700
    • Ver perfil
Re: Erro para instalar pacotes!
« Resposta #5 Online: 05 de MAR?O de 2008, 19:00 »
muito obrigado... resolveu meu problema......

Se posso fazer uma sugestão, não use sarcasmo, todos aqui estão tentando ajudar. Se não quiser ser corrigido novamente leia as regras do Fórum.
Citar
7 - Devem ser evitadas mensagens dizendo apenas "Legal!", "Valeu" (e suas derivações onomatopaicas atuais), "Comigo funciona..." e similares. Mensagens desse tipo incham os tópicos e atrapalham quem está procurando solução para algum problema. Mensagens com título de "SOCORRO", "URGENTE", "ME AJUDEM" (ou seja, todo em maiúsculas e/ou sem explicitação do conteúdo da mensagem) e similares serão imediatamente apagadas.

http://ubuntuforum-br.org/index.php/topic,22077.0.html

Offline sottam

  • Usuário Ubuntu
  • *
  • Mensagens: 309
    • Ver perfil
Re: Erro para instalar pacotes!
« Resposta #6 Online: 06 de MAR?O de 2008, 08:31 »
Experimente entrar no terminal e digitar>

sudo apt-get autoclean <enter>

sudo apt-get autoremove <enter>

Veja se resolve.

O que parece 'e que o linux gravou os arquivos numa parte danificada do HD ou baixou o pacote com quebras

finalmente va na pasta /var/cache/apt/archives/

e remova manualmente o pacote > linux-libc-dev_2.6.22-14.52_i386.deb se ele ainda estiver la.

baixe e instale ele novamente.

Deve resolver.

Bom dia Amigo.... cara lamentavelmente não deu certo tua dica..... entrei na pasta lá apaguei tudo.... mas mesmo assim naum resolveu o problema... o pior de tudo é que fui gravar um DVD ontem e também naum deu..... vou formatar o micro hoje a noite.....

mas obrigado por tentar me ajudar...

  :)

Offline ins3rt c0in

  • Usuário Ubuntu
  • *
  • Mensagens: 700
    • Ver perfil
Re: Erro para instalar pacotes!
« Resposta #7 Online: 06 de MAR?O de 2008, 13:04 »
Na tela que você postou, clique em detalhes e veja se a resposta foi a mesma do primeiro tópico. Se for diferente poste aqui o resultado.

Aproveite e cole o resultado do comendo:

Código: [Selecionar]
df
Executando no terminal. Ele listará as partições montadas para que analisemos o uso do seu disco. A resposta de erro está geralmente ligada ao esgotamento da capacidade de uma das unidades.
« Última modificação: 06 de MAR?O de 2008, 13:19 por ins3rt c0in »

Offline sottam

  • Usuário Ubuntu
  • *
  • Mensagens: 309
    • Ver perfil
Re: Erro para instalar pacotes!
« Resposta #8 Online: 06 de MAR?O de 2008, 13:16 »
Na tela que você postou, clique em detalhes e veja se a resposta foi a mesma do primeiro tópico. Se for diferente poste aqui o resultado.


opa blz.... sim amigo é a mesma msg... diz q possuiu muitos erros


Processamento parou porque haviam muitos erros.
E: Sub-process /usr/bin/dpkg returned an error code (1)

Offline ins3rt c0in

  • Usuário Ubuntu
  • *
  • Mensagens: 700
    • Ver perfil
Re: Erro para instalar pacotes!
« Resposta #9 Online: 06 de MAR?O de 2008, 13:34 »
Só para aproveitar que você está por aqui, antes de responder a pergunta do tópico anterior, tente o seguinte:

Código: [Selecionar]
sudo apt-get remove "nome do pacote que causou o primeiro problema"
Presumo que seja o build essential. Tente instalar novamente.

Você também pode usar o método Capitão Nascimento, forçar a instalação do pacote, lembrando que é o primeiro que deu erro.

Código: [Selecionar]
sudo apt-get -f install "nome do pacote"
Depois que você forçar a instalação do aspira ou ele pedir pra sair (primeiro comando), execute um:

Código: [Selecionar]
sudo apt-get upgrade
para deixar tudo lustrando.