Autor Tópico: Problemas com MPLAYER. Alguém pode ajudar? ****RESOLVIDO****  (Lida 12540 vezes)

Offline allan_nogueira

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Problemas com MPLAYER. Alguém pode ajudar? ****RESOLVIDO****
« Online: 04 de Abril de 2005, 22:40 »
Olá,

Primeiro gostaria de me apresentar. (esse é meu primeiro post :D)
Meu nome é Allan Nogueira, sou de Salvador - Ba.
Sou novo na comunidade Linux em geral, e estou tendo meus primeiros contatos com o UBUNTU por agora.
Eu  estou tendo alguns problemas com o MPLAYER.

Eu baixei ele e instalei nnuma boa.
Porém alguns vídeos não funcionam bem, eu baixei uns codecs e tal, mas não sei instalar.
Também baixei uma "Skin" e "Font's" para adicionar ao software e também gostaria de saber com instalar.

No caso da Skin, eu simplesmente descompactei os arquivos na pasta: "/usr/local/share/mplayer/Skin/default/skin"
Mas quando eu dou  o comando "gmplayer arkivo_de_video" Ele trava o Terminal.

Segue a baixo o log da execução:

root@ubuntu:/home/allan/Documentos # gmplayer Dormindo\ na\ Globo.mpg
MPlayer 0.93-3.3.4  (C) 2000-2003 MPlayer Team
CPU: Advanced Micro Devices  (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: Arquivo ou diretório não encontrado
Reading config file /root/.mplayer/config
[cfg] read config file: /root/.mplayer/gui.conf
Reading config file /root/.mplayer/gui.conf: No such file or directory
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Disabling DPMS
Reading /root/.mplayer/codecs.conf: can't open '/root/.mplayer/codecs.conf': Arquivo ou diretório não encontrado
Reading /usr/local/etc/mplayer/codecs.conf: can't open '/usr/local/etc/mplayer/codecs.conf': Arquivo ou diretório não encontrado
Using built-in default codecs.conf
font: can't open file: /root/.mplayer/font/font.desc
Font /usr/local/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /root/.mplayer/input.conf: Arquivo ou diretório não encontrado
Can't open input config file /usr/local/etc/mplayer/input.conf: Arquivo ou diretório não encontrado
Falling back on default (hardcoded) input config
SKIN dir 1: '/root/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
Atenciosamente,
Allan Nogueira
(allan.nogueira@gmail.com)

holokaustu

  • Visitante
Problemas com MPLAYER. Alguém pode ajudar? ****RESOLVIDO****
« Resposta #1 Online: 05 de Abril de 2005, 09:18 »
Olá,

Pq não usas o xmms com alguns codecs??

Na Area Geral > Ubuntistas é o sitio indicado para te apresentares

cumprimentos

Offline allan_nogueira

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Problemas com MPLAYER. Alguém pode ajudar? ****RESOLVIDO****
« Resposta #2 Online: 05 de Abril de 2005, 10:14 »
Citação de: "holokaustu"
Olá,

Pq não usas o xmms com alguns codecs??

Na Area Geral > Ubuntistas é o sitio indicado para te apresentares

cumprimentos


Eu instalei o XMMS, mas pra escutar minhas músicas.
Queria um player pra tocar meus VCD's e DVD's.
Me falaram muito bem do MPLAYER, mas estou tendo esses problemas.

Alguém saberia me dizer o que está acontecendo?

Grato,

Allan Nogueira

ps.: foi mal pela apresentação aqui, vou "transferilá pra lá!"
Atenciosamente,
Allan Nogueira
(allan.nogueira@gmail.com)

boi

  • Visitante
Problemas com MPLAYER. Alguém pode ajudar? ****RESOLVIDO****
« Resposta #3 Online: 05 de Abril de 2005, 10:57 »
Você instalou como? O recomendável é instalar pelo apt-get ou synaptic. Esta versão que você tem, a 0.93 é antiga, é melhor desisntalar e instalar a mais recente pelo apt.

Offline allan_nogueira

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Problemas com MPLAYER. Alguém pode ajudar? ****RESOLVIDO****
« Resposta #4 Online: 05 de Abril de 2005, 11:07 »
Citação de: "boi"
Você instalou como? O recomendável é instalar pelo apt-get ou synaptic. Esta versão que você tem, a 0.93 é antiga, é melhor desisntalar e instalar a mais recente pelo apt.


Ihh cara falou grego :p.. Zueira..
Como eu faço pra desinstalar isso agora? (sou meio "lerdo" ainda em algumas coisas.. alias.. muitas coisas :D)

Valeu
Atenciosamente,
Allan Nogueira
(allan.nogueira@gmail.com)

boi

  • Visitante
Problemas com MPLAYER. Alguém pode ajudar? ****RESOLVIDO****
« Resposta #5 Online: 05 de Abril de 2005, 11:29 »
Citação de: "allan_nogueira"

Como eu faço pra desinstalar isso agora?

Depende de como você instalou. Se foi pelos fontes, isto é, se você compilou e instalou com "sudo make install", basta entrar no diretório onde estão os fontes e dar um "sudo make uninstall".

Offline allan_nogueira

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Problemas com MPLAYER. Alguém pode ajudar? ****RESOLVIDO****
« Resposta #6 Online: 05 de Abril de 2005, 11:35 »
Citação de: "boi"
Citação de: "allan_nogueira"

Como eu faço pra desinstalar isso agora?

Depende de como você instalou. Se foi pelos fontes, isto é, se você compilou e instalou com "sudo make install", basta entrar no diretório onde estão os fontes e dar um "sudo make uninstall".


Eu baixei o arquivo "MPlayer-0.93.tar.bz2", extrai ele, depois dei os comandos básicos..

./configure
make
make install

Como remover? Onde fica o diretorio que estão os fontes?

Ps.: Desculpa pela ignorancia..  :roll:
Atenciosamente,
Allan Nogueira
(allan.nogueira@gmail.com)

Offline allan_nogueira

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Problemas com MPLAYER. Alguém pode ajudar? ****RESOLVIDO****
« Resposta #7 Online: 05 de Abril de 2005, 11:38 »
Ae fiz isso:

root@ubuntu:/home/allan/My Downloads/MPlayer-0.93 # make uninstall
rm -f /usr/local/bin/mplayer /usr/local/bin/gmplayer /usr/local/man/man1/mplayer.1
rm -f /usr/local/bin/fibmap_mplayer
rm -f  /usr/local/bin/mencoder /usr/local/man/man1/mencoder.1
Uninstall completed
root@ubuntu:/home/allan/My Downloads/MPlayer-0.93 # mplayer


Agora ele não reconhece mais o comando "mplayer".. Agora vou tentar instalar outro pacote ".deb" da versão mais nova. Valeuu!!
Atenciosamente,
Allan Nogueira
(allan.nogueira@gmail.com)

holokaustu

  • Visitante
Problemas com MPLAYER. Alguém pode ajudar? ****RESOLVIDO****
« Resposta #8 Online: 05 de Abril de 2005, 11:51 »
Olá de novo,

Bem o xmms para além de ser um optimo player de musicas também permite a vizualização de videos Divx e afins...

Cumprimentos...

Offline allan_nogueira

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Problemas com MPLAYER. Alguém pode ajudar? ****RESOLVIDO****
« Resposta #9 Online: 05 de Abril de 2005, 16:23 »
Citação de: "holokaustu"
Olá de novo,

Bem o xmms para além de ser um optimo player de musicas também permite a vizualização de videos Divx e afins...

Cumprimentos...


Aqui só consigo fazer com que o XMMS toque audio  :shock:  :shock:
Quando eu coloco ele pra tocar algum vídeo, não acontece nada! Ele nem abre o vídeo! Mas também não da nenhum erro....

Vc sabe o que pode estar acontecendo?

E sobre o MPLAYER, vc pode ajudar?
Atenciosamente,
Allan Nogueira
(allan.nogueira@gmail.com)

boi

  • Visitante
Problemas com MPLAYER. Alguém pode ajudar? ****RESOLVIDO****
« Resposta #10 Online: 05 de Abril de 2005, 16:52 »
Faça o seguinte:

- conecte-se à internet
- abra o synaptic (sistem/gerenciador de pacotes)
- vá em configurações/repositórios
- edite a linha "deb http://archive.ubuntu.com/ubuntu/"
- na parte "seções", deve estar "main restricted", coloque assim: "main restricted universe multiverse"
- clique no botão recarregar (reload) para atualizar a lista de pacotes
- Clique no botão "sections" (embaixo à esquerda) e no painel da esquerda, selecione "gráficos (multiverse)"
- no painel da direita, procure pelo mplayer, e selecione de acordo com seu processador (p. ex. mplayer-686 para P4 ou mplayer-k7 para Athlon), clique e selecione "marcar para instalação"
- clique no botão "aplicar"

é só  :P

Offline allan_nogueira

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Problemas com MPLAYER. Alguém pode ajudar? ****RESOLVIDO****
« Resposta #11 Online: 06 de Abril de 2005, 09:48 »
Citação de: "boi"
Faça o seguinte:

- conecte-se à internet
- abra o synaptic (sistem/gerenciador de pacotes)
- vá em configurações/repositórios
- edite a linha "deb http://archive.ubuntu.com/ubuntu/"
- na parte "seções", deve estar "main restricted", coloque assim: "main restricted universe multiverse"
- clique no botão recarregar (reload) para atualizar a lista de pacotes
- Clique no botão "sections" (embaixo à esquerda) e no painel da esquerda, selecione "gráficos (multiverse)"
- no painel da direita, procure pelo mplayer, e selecione de acordo com seu processador (p. ex. mplayer-686 para P4 ou mplayer-k7 para Athlon), clique e selecione "marcar para instalação"
- clique no botão "aplicar"

é só  :P


Ae.. Eu tow sem meu micro agora..
Mas assim que eu pegar ele de novo eu vou testar e posto os resultados.
Valeu =]
Atenciosamente,
Allan Nogueira
(allan.nogueira@gmail.com)

Offline deusr

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Problemas com MPLAYER. Alguém pode ajudar? ****RESOLVIDO****
« Resposta #12 Online: 07 de Abril de 2005, 12:20 »
Use esses pacotes, é soh instalar e se divertir, eu mesmo compilei e criei os pacotes, jah estão em pt_BR com todos codecs nescessários e é a versão mais nova do mplayer, divirta-se ;)

http://www.linuxhard.org/publicacoes.php?acessar=categoria&vercategoria=8

vc soh precisa do 'mplayer-1.0pre6a' mas o common tem todos os codecs não livre que roda mais vídeos, entao recomando baixar e instalar esses 2 pacotes.

Offline allan_nogueira

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Problemas com MPLAYER. Alguém pode ajudar? ****RESOLVIDO****
« Resposta #13 Online: 07 de Abril de 2005, 14:28 »
Citação de: "deusr"
Use esses pacotes, é soh instalar e se divertir, eu mesmo compilei e criei os pacotes, jah estão em pt_BR com todos codecs nescessários e é a versão mais nova do mplayer, divirta-se ;)

http://www.linuxhard.org/publicacoes.php?acessar=categoria&vercategoria=8

vc soh precisa do 'mplayer-1.0pre6a' mas o common tem todos os codecs não livre que roda mais vídeos, entao recomando baixar e instalar esses 2 pacotes.


Muito boa!
Agora ele ta funcionando direitinho!!
Muito obrigado!!!


Aee, não sei se alguém pode ter o mesmo probleminha que eu..
Mas eu tava sem essa biblioteca: libdivxencore0_5.0.1-1_i386.deb
Aí não tava instalando...
Aí eu peguei ela aqui:
http://ftp://ftp.nerim.net/debian-marillat/dists/stable/main/binary-i386/

Muito Obrigado a todos que me ajudaram!
Atenciosamente,
Allan Nogueira
(allan.nogueira@gmail.com)