Autor Tópico: Reinstalando o POSTGRESQL-8.1  (Lida 1122 vezes)

Offline Belotto

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Reinstalando o POSTGRESQL-8.1
« Online: 30 de MAR?O de 2008, 22:21 »
"Could not initialize the package information

A unresolvable problem occurred while initializing the package information.

Please report this bug against the 'update-manager' package and include the following error message:

'E:The package postgresql-8.1 needs to be reinstalled, but I can't find an archive for it."


Boa tarde Galerinha, fiz uma bobagem!!

sem querer, exclui a pasta do postgresql-8.1 do ubuntu!

nao que esse programa esteja me fazendo falta, mas por causa dele o SYNAPTIC nem o UPDATE-MANAGER estao funcionando!!

como posso reinstalar esse programa? nao consigo achar um jeito de forçar "manualmente" a instalaçao pq estava olhando no site da desenvolvedora, só tem versão RPM para instalaçao.


Offline ricardofantin

  • Usuário Ubuntu
  • *
  • Mensagens: 105
    • Ver perfil
Re: Reinstalando o POSTGRESQL-8.1
« Resposta #1 Online: 02 de Abril de 2008, 20:05 »
Rode:
sudo apt-get update
as vezes quando eu rodo esse comando ele da algumas dicas para resolver problemas ou melhorar. Se você desinstalou alguma coisa e esqueceu de tirar uma biblioteca ele diz que tem bibliotecas que podem ser removidas para liberar espaço, rode apt-get autoclean (não tenho certeza do comando). Eu acho que no terminal vai te retornar alguma dica. Se não retornar nada tente ler no manual man apt-get . Eu achei uma variação legal:
sudo apt-get --reinstall postgresql-8.1
rode "apt-cache search postgres" se o nome do pacote não for exatamente postgresql-8.1