Autor Tópico: Montagem de volumes  (Lida 14019 vezes)

Offline Nadab

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Re: Montagem de volumes
« Resposta #15 Online: 04 de Maio de 2008, 10:25 »
Boa dia pessoal,

Eu modifiquei meu /etc/fstab disso:
Código: [Selecionar]
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sdb1
UUID=03d1f4ea-b324-4f3e-9243-04057f44c848 /               ext3    relatime,errors=remount-ro 0       1
# /dev/sdb4
UUID=26d48fe6-bd40-41f6-bda0-159e85334512 none            swap    sw              0       0
/dev/scd1       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/scd0       /media/cdrom1   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

para isso:
Código: [Selecionar]
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sdb1
UUID=03d1f4ea-b324-4f3e-9243-04057f44c848 /               ext3    relatime,errors=remount-ro 0       1
# /dev/sdb4
UUID=26d48fe6-bd40-41f6-bda0-159e85334512 none            swap    sw              0       0
/dev/scd1       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/scd0       /media/cdrom1   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
# ARQUIVOS
/dev/sda5      /media/ARQUIVOS fat32        defaults,umask=007,gid=46 0       0
# Windows XP
/dev/sda1      /media/WINDOWS XP ntfs       defaults,umask=007,gid=46 0       0
# Windows Vista
/dev/sdb2      /media/WINDOWS VISTA ntfs    defaults,umask=007,gid=46 0       0
# Músicas_Videos
/dev/sdb3      /media/Músicas_Videos ntfs   defaults,umask=007,gid=46 0       0

mas não funcionou. Aliás, só funcionou para a partição "Músicas_Videos", quanto às outras: apareceram, mas quando eu fui acessar, recebi uma mensagem de que as pastas /media/"partição em questão" não existiam! mas elas existiam antes de eu modificar o fstab... será que eu tenho que criar as pastas em /media novamente?

Nadab

Offline Éderson

  • Usuário Ubuntu
  • *
  • Mensagens: 203
    • Ver perfil
Re: Montagem de volumes
« Resposta #16 Online: 04 de Maio de 2008, 11:02 »
Você deveria ter criado as pastas em /media;
sudo mkdir /media/ARQUIVOS
sudo mkdir /media/WINDOWS XP
sudo mkdir /media/WINDOWS VISTA
sudo mkdir /media/Músicas_Videos

Offline Nadab

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Re: Montagem de volumes
« Resposta #17 Online: 04 de Maio de 2008, 11:19 »
Você deveria ter criado as pastas em /media;
sudo mkdir /media/ARQUIVOS
sudo mkdir /media/WINDOWS XP
sudo mkdir /media/WINDOWS VISTA
sudo mkdir /media/Músicas_Videos

Éderson, essas pastas já existiam antes de eu modificar o fstab

Offline Razien

  • Usuário Ubuntu
  • *
  • Mensagens: 291
  • Zzzz...
    • Ver perfil
    • Meu multiply ja abandonado
Re: Montagem de volumes
« Resposta #18 Online: 04 de Maio de 2008, 12:31 »
Se só a music_videos funcionou pode ser que o fstab não reconheça os espaços em "windows xp" .

Por exemplo, quando vc abre uma pasta como "area de trabalho" no terminal, ela vai aparecer mais ou menos assim "area/ de/ trabalho/" eh algo assi, não tenho certeza do formato.

Experimenta só utilizar nomes sem espaços, e provavelmente vai dar certo.
yari yari...

Offline Nadab

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Re: Montagem de volumes
« Resposta #19 Online: 04 de Maio de 2008, 18:50 »
Se só a music_videos funcionou pode ser que o fstab não reconheça os espaços em "windows xp" .

Por exemplo, quando vc abre uma pasta como "area de trabalho" no terminal, ela vai aparecer mais ou menos assim "area/ de/ trabalho/" eh algo assi, não tenho certeza do formato.

Experimenta só utilizar nomes sem espaços, e provavelmente vai dar certo.

Não acredito que o espaço seja o problema, pois no UBUNTU 7.10 isso funcionava perfeitamente.
E para representar o espaço é só substituí-lo por "\x20", por exemplo:/media/WINDOWS\x20XP
Bom, eu mudei novamente o fstab e agora o problema parece ser com o ntfs-3g uma vez que recebo a mensagem que somente o root pode montar as partições "WINDOWS XP" e "WINDOWS VISTA", as outras estão montando normalmente.

Eu descobri também que o último fstab que eu postei está errado, agora o meu está assim:

Código: [Selecionar]
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sdb1
UUID=03d1f4ea-b324-4f3e-9243-04057f44c848 /               ext3    relatime,errors=remount-ro 0       1
# /dev/sdb4
UUID=26d48fe6-bd40-41f6-bda0-159e85334512 none            swap    sw              0       0
/dev/scd1       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/scd0       /media/cdrom1   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
# ARQUIVOS
/dev/sda5      /media/ARQUIVOS vfat        users,umask=0000,utf8,gid=100 0       0
# Windows XP
/dev/sda1      /media/WINDOWS\x20XP ntfs-3g     users,umask=0000,utf8,gid=100 0       0
# Windows Vista
/dev/sdb2      /media/WINDOWS\x20VISTA ntfs-3g   users,umask=0000,utf8,gid=100 0       0
# Músicas_Videos
/dev/sdb3      /media/Músicas_Videos ntfs-3g   users,umask=0000,utf8,gid=100 0       0

As partições ARQUIVOS e Músicas_Videos montam perfeitamente, já as outras duas...talvez seja a falta de apreço que o UBUNTU tem com o Windows hahaha.
Se alguém souber como resolver isso, eu agradeço.

Nadab

Offline advi

  • Usuário Ubuntu
  • *
  • Mensagens: 62
    • Ver perfil
Re: Montagem de volumes
« Resposta #20 Online: 04 de Maio de 2008, 20:27 »
Oi, Nadab.

Experimente instalar o ntfs-config.

Fui!
Ezcreve herrado é coiza de quem uza o IE6. Eu uso Firefox com dicionário de português! 8)

Offline Franco Almeida

  • Usuário Ubuntu
  • *
  • Mensagens: 123
    • Ver perfil
Re: Montagem de volumes
« Resposta #21 Online: 07 de Maio de 2008, 21:45 »
Se só a music_videos funcionou pode ser que o fstab não reconheça os espaços em "windows xp" .

Por exemplo, quando vc abre uma pasta como "area de trabalho" no terminal, ela vai aparecer mais ou menos assim "area/ de/ trabalho/" eh algo assi, não tenho certeza do formato.

Experimenta só utilizar nomes sem espaços, e provavelmente vai dar certo.

Não acredito que o espaço seja o problema, pois no UBUNTU 7.10 isso funcionava perfeitamente.
E para representar o espaço é só substituí-lo por "\x20", por exemplo:/media/WINDOWS\x20XP
Bom, eu mudei novamente o fstab e agora o problema parece ser com o ntfs-3g uma vez que recebo a mensagem que somente o root pode montar as partições "WINDOWS XP" e "WINDOWS VISTA", as outras estão montando normalmente.

Eu descobri também que o último fstab que eu postei está errado, agora o meu está assim:

Código: [Selecionar]
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sdb1
UUID=03d1f4ea-b324-4f3e-9243-04057f44c848 /               ext3    relatime,errors=remount-ro 0       1
# /dev/sdb4
UUID=26d48fe6-bd40-41f6-bda0-159e85334512 none            swap    sw              0       0
/dev/scd1       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/scd0       /media/cdrom1   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
# ARQUIVOS
/dev/sda5      /media/ARQUIVOS vfat        users,umask=0000,utf8,gid=100 0       0
# Windows XP
/dev/sda1      /media/WINDOWS\x20XP ntfs-3g     users,umask=0000,utf8,gid=100 0       0
# Windows Vista
/dev/sdb2      /media/WINDOWS\x20VISTA ntfs-3g   users,umask=0000,utf8,gid=100 0       0
# Músicas_Videos
/dev/sdb3      /media/Músicas_Videos ntfs-3g   users,umask=0000,utf8,gid=100 0       0

As partições ARQUIVOS e Músicas_Videos montam perfeitamente, já as outras duas...talvez seja a falta de apreço que o UBUNTU tem com o Windows hahaha.
Se alguém souber como resolver isso, eu agradeço.

Nadab

Caro Nadab,

Você tem que acrescentar a UUID de cada partição como está no seu fstab para as partições sdb1 e sdb4. Com isto elas serão montadas na área detrabalho.

Para descobrir a UUID de uma partição digite no terminal:  sudo blkid ou sudo vol_id /dev/hda1( aqui você deve substituir hda1 conforme a partição que quer saber a UUID

[ ]s

Franco
« Última modificação: 07 de Maio de 2008, 22:07 por Franco Almeida »
Disposto a aprender, disposto a compartilhar

Offline Nadab

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Re: Montagem de volumes
« Resposta #22 Online: 08 de Maio de 2008, 16:07 »
Se só a music_videos funcionou pode ser que o fstab não reconheça os espaços em "windows xp" .

Por exemplo, quando vc abre uma pasta como "area de trabalho" no terminal, ela vai aparecer mais ou menos assim "area/ de/ trabalho/" eh algo assi, não tenho certeza do formato.

Experimenta só utilizar nomes sem espaços, e provavelmente vai dar certo.

Não acredito que o espaço seja o problema, pois no UBUNTU 7.10 isso funcionava perfeitamente.
E para representar o espaço é só substituí-lo por "\x20", por exemplo:/media/WINDOWS\x20XP
Bom, eu mudei novamente o fstab e agora o problema parece ser com o ntfs-3g uma vez que recebo a mensagem que somente o root pode montar as partições "WINDOWS XP" e "WINDOWS VISTA", as outras estão montando normalmente.

Eu descobri também que o último fstab que eu postei está errado, agora o meu está assim:

Código: [Selecionar]
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sdb1
UUID=03d1f4ea-b324-4f3e-9243-04057f44c848 /               ext3    relatime,errors=remount-ro 0       1
# /dev/sdb4
UUID=26d48fe6-bd40-41f6-bda0-159e85334512 none            swap    sw              0       0
/dev/scd1       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/scd0       /media/cdrom1   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
# ARQUIVOS
/dev/sda5      /media/ARQUIVOS vfat        users,umask=0000,utf8,gid=100 0       0
# Windows XP
/dev/sda1      /media/WINDOWS\x20XP ntfs-3g     users,umask=0000,utf8,gid=100 0       0
# Windows Vista
/dev/sdb2      /media/WINDOWS\x20VISTA ntfs-3g   users,umask=0000,utf8,gid=100 0       0
# Músicas_Videos
/dev/sdb3      /media/Músicas_Videos ntfs-3g   users,umask=0000,utf8,gid=100 0       0

As partições ARQUIVOS e Músicas_Videos montam perfeitamente, já as outras duas...talvez seja a falta de apreço que o UBUNTU tem com o Windows hahaha.
Se alguém souber como resolver isso, eu agradeço.

Nadab

Caro Nadab,

Você tem que acrescentar a UUID de cada partição como está no seu fstab para as partições sdb1 e sdb4. Com isto elas serão montadas na área detrabalho.

Para descobrir a UUID de uma partição digite no terminal:  sudo blkid ou sudo vol_id /dev/hda1( aqui você deve substituir hda1 conforme a partição que quer saber a UUID

[ ]s

Franco

Franco, eu acredito que citar o UUID é uma outra forma de identificar a partição, equivalente a escrever por exemplo "/dev/sdb2" ou então "LABEL="WINDOWS VISTA"". por via das dúvidas eu tentei o que você disse, mas o problema persiste: Uma tela aparece quando eu quero montar o volume dizendo que há erros de montagem, pois somente o root pode fazer isso.

abraço

alarcon

  • Visitante
Re: Montagem de volumes
« Resposta #23 Online: 08 de Maio de 2008, 17:19 »
tenta assim:


Citar
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sdb1
UUID=03d1f4ea-b324-4f3e-9243-04057f44c848 /               ext3    relatime,errors=remount-ro 0       1
# /dev/sdb4
UUID=26d48fe6-bd40-41f6-bda0-159e85334512 none            swap    sw              0       0
/dev/scd1       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/scd0       /media/cdrom1   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
# ARQUIVOS
/dev/sda5      /media/ARQUIVOS vfat        users,umask=0000,utf8,gid=100 0       0
# Windows XP
/dev/sda1      /media/WINDOWS\x20XP ntfs    defaults,umask=007,gid=46 0       1
# Windows Vista
/dev/sdb2      /media/WINDOWS\x20VISTA ntfs    defaults,umask=007,gid=46 0       1
# Músicas_Videos
/dev/sdb3      /media/Músicas_Videos ntfs    defaults,umask=007,gid=46 0       1


e veja se seu usuário pertence ao grupo fuse.

para adicioná-lo:

sudo adduser usuario fuse

onde usuario mude para o seu nome de usuário.

OBS: Se você quiser substituir os /dev/sda? ou /dev/sdb? por UUID no seu fstab, execute o comando blkid no terminal para que você veja quais são as UUID respectivas aos /dev/sda? ou /dev/sdb? ok.
« Última modificação: 08 de Maio de 2008, 17:43 por alarcon »

Offline Nadab

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Re: Montagem de volumes
« Resposta #24 Online: 09 de Maio de 2008, 16:32 »
tenta assim:


Citar
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sdb1
UUID=03d1f4ea-b324-4f3e-9243-04057f44c848 /               ext3    relatime,errors=remount-ro 0       1
# /dev/sdb4
UUID=26d48fe6-bd40-41f6-bda0-159e85334512 none            swap    sw              0       0
/dev/scd1       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/scd0       /media/cdrom1   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
# ARQUIVOS
/dev/sda5      /media/ARQUIVOS vfat        users,umask=0000,utf8,gid=100 0       0
# Windows XP
/dev/sda1      /media/WINDOWS\x20XP ntfs    defaults,umask=007,gid=46 0       1
# Windows Vista
/dev/sdb2      /media/WINDOWS\x20VISTA ntfs    defaults,umask=007,gid=46 0       1
# Músicas_Videos
/dev/sdb3      /media/Músicas_Videos ntfs    defaults,umask=007,gid=46 0       1


e veja se seu usuário pertence ao grupo fuse.

para adicioná-lo:

sudo adduser usuario fuse

onde usuario mude para o seu nome de usuário.

OBS: Se você quiser substituir os /dev/sda? ou /dev/sdb? por UUID no seu fstab, execute o comando blkid no terminal para que você veja quais são as UUID respectivas aos /dev/sda? ou /dev/sdb? ok.

Obrigado pela dica Alarcon, mas não funcionou...eu já fazia parte do grupo "fuse".
Me parece que existe um bug do ntfs-3g relacionado a isso. A mensagem de erro que aparece é a seguinte:
Citar
Mount is denied because setuid and setgid root ntfs-3g is insecure with the
external FUSE library. Either remove the setuid/setgid bit from the binary
or rebuild NTFS-3G with integrated FUSE support and make it setuid root.
Please see more information at http://ntfs-3g.org/support.html#unprivileged

Nadab.

Offline mskuster

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re: Montagem de volumes
« Resposta #25 Online: 12 de Maio de 2008, 22:54 »
Pessoal,
No Ubuntu 8.04 consegui resolver este problema instalando o pacote "ntfs-config" pelo Synaptic. No terminal como root digitei "gksu ntfs-config" (sem aspas) e habilitei as particoes que quero carregar na inicializacao. Claro que isso foi para as particoes NTFS. Como nao tenho outras particoes linux na maquina, fico devendo como faz para monta-las.
Um forte abraco a todos! 

Offline Nadab

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Re: Montagem de volumes
« Resposta #26 Online: 14 de Maio de 2008, 12:24 »
Pessoal,
No Ubuntu 8.04 consegui resolver este problema instalando o pacote "ntfs-config" pelo Synaptic. No terminal como root digitei "gksu ntfs-config" (sem aspas) e habilitei as particoes que quero carregar na inicializacao. Claro que isso foi para as particoes NTFS. Como nao tenho outras particoes linux na maquina, fico devendo como faz para monta-las.
Um forte abraco a todos! 

Valeu mskuster, funcionou perfeitamente.

Depois de configurar as partições eu dei uma olhada no fstab pra ver como eu deveria ter feito e vi que tinham mais duas linhas adicionadas no final:

/dev/sdb2 /media/WINDOWS\040VISTA ntfs umask=222,utf8 0 0
/dev/sda1 /media/WINDOWS\040XP ntfs umask=222,utf8 0 0


Parece que o assunto está encerrado.  ;)

Obrigado
abraço

Offline Madrigal

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Montagem de volumes
« Resposta #27 Online: 16 de Maio de 2008, 23:35 »
Vou aproveitar esse tópico para ao mesmo tempo ajudar, e pedir para observarem se estão corretas as minhas informações abaixo, eu as colocarei na atualização de minha apostila: ;)


Montar partições automaticamente

   A partir da versão 8.04, as partições não são montadas automaticamente ao iniciar o computador, devem ser abertas primeiramente em Locais > Mídia Removível > Mídia de XX,X GB, onde XX,X é o tamanho da partição.
   Caso você queira que alguma partição já esteja montada desde o início, aparecendo na área de trabalho, precisa acrescentar uma linha no arquivo fstab.
   Para dar uma olhada em seu sistema de partições, dê o comando:
sudo fdisk -l
   Por exemplo, caso você queira que a partição sda3 esteja sempre montada:
   1) Crie uma pasta dentro de /media, com um nome qualquer, no meu exemplo coloquei “arquivo”.
sudo mkdir /media arquivo
   2) Abra o arquivo fstab:
sudo gedit /etc/fstab
   3) Dependendo de seu filesystem (tipo de formatação da partição), deverá colocar uma linha no final deste arquivo:
   Para filesystem:

fat32:
/dev/sda3 /media/arquivos vfat defaults,utf8,umask=007,gid=46 0 1

NTFS:
   Substitua o “???” pelo número do uid de seu usuário, vc sabe que número é este fazendo o comando: id seu_usuário no terminal.
/dev/sda3 /media/arquivos ntfs ro,uid=??? 1 0

Ext3:
/dev/sda3 /media/arquivos ext3    defaults        0       2

Reiserfs
/dev/sda3 /media/arquivos reiserfs    defaults        0       2

   Salve e dê o comando para reler as partições:
 sudo mount -a

Offline Nadab

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Re: Montagem de volumes
« Resposta #28 Online: 17 de Maio de 2008, 14:58 »
Vou aproveitar esse tópico para ao mesmo tempo ajudar, e pedir para observarem se estão corretas as minhas informações abaixo, eu as colocarei na atualização de minha apostila: ;)


Montar partições automaticamente

   A partir da versão 8.04, as partições não são montadas automaticamente ao iniciar o computador, devem ser abertas primeiramente em Locais > Mídia Removível > Mídia de XX,X GB, onde XX,X é o tamanho da partição.
   Caso você queira que alguma partição já esteja montada desde o início, aparecendo na área de trabalho, precisa acrescentar uma linha no arquivo fstab.
   Para dar uma olhada em seu sistema de partições, dê o comando:
sudo fdisk -l
   Por exemplo, caso você queira que a partição sda3 esteja sempre montada:
   1) Crie uma pasta dentro de /media, com um nome qualquer, no meu exemplo coloquei “arquivo”.
sudo mkdir /media arquivo
   2) Abra o arquivo fstab:
sudo gedit /etc/fstab
   3) Dependendo de seu filesystem (tipo de formatação da partição), deverá colocar uma linha no final deste arquivo:
   Para filesystem:

fat32:
/dev/sda3 /media/arquivos vfat defaults,utf8,umask=007,gid=46 0 1

NTFS:
   Substitua o “???” pelo número do uid de seu usuário, vc sabe que número é este fazendo o comando: id seu_usuário no terminal.
/dev/sda3 /media/arquivos ntfs ro,uid=??? 1 0

Ext3:
/dev/sda3 /media/arquivos ext3    defaults        0       2

Reiserfs
/dev/sda3 /media/arquivos reiserfs    defaults        0       2

   Salve e dê o comando para reler as partições:
 sudo mount -a


Madrigal,

Parece bom, mas essa é a opinião de um iniciante hehe...e o que significa a opção "ro" em "/dev/sda3 /media/arquivos ntfs ro,uid=??? 1 0" ?
Acho que você poderia também citar o "gksu ntfs-config" para iniciar partições NTFS, é muito mais prático.

abraço.

alarcon

  • Visitante
Re: Montagem de volumes
« Resposta #29 Online: 17 de Maio de 2008, 16:29 »

Madrigal,

Parece bom, mas essa é a opinião de um iniciante hehe...e o que significa a opção "ro" em "/dev/sda3 /media/arquivos ntfs ro,uid=??? 1 0" ?
Acho que você poderia também citar o "gksu ntfs-config" para iniciar partições NTFS, é muito mais prático.

abraço.

ro = read only = somente leitura