Autor Tópico: TIM Web no Kubuntu 8.04 com o modem ONDA MSA501HS  (Lida 20942 vezes)

Offline diaconojgr

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
TIM Web no Kubuntu 8.04 com o modem ONDA MSA501HS
« Online: 27 de Junho de 2008, 01:36 »
Olá, amigos, blz? Tenho uma dúvida p/ ser solucionada! Estou com o Kubuntu 8.04 e estou com o TIM Web. No Windows, funciona normal, mas no Kubuntu, não consigo fazer o modem reconheçer... Alguma dica? Algo que não tenha que baixar nada, ou se tiver, eu baixo no Windows e acesso pelo Linux e faço os passos! O modem é ONDA HSDPA/EDGE/GPRS. Model: MSA501HS



Já encontrei tutoriais na internet, mas nada ajudou... Bom, é isso! Aguardo ajuda!

Luiz Carlos Querido

  • Visitante
Re: TIM Web no Kubuntu 8.04 com o modem ONDA MSA501HS
« Resposta #1 Online: 28 de Junho de 2008, 17:50 »
Eu ainda não testei, mas o Livio conseguiu no SuSe. Teve um comentário de umap pessoa que conseguiu no Ubuntu 7.x e que depois de atualizar para o 8.04 perdeu a configuração e não conseguiu, mas ele não disse se refez os passos do Livio. Segue link do passo a passo. Acho que vou tentar amanhã com o Ubuntu. S enão der, tento com o SuSe 10.04 e depois eu posto aqui.
Abraços.

http://www.fre.eti.br/livio/2008/04/timweb-no-linux-onda-msa501hs.html

Luiz Carlos Querido

  • Visitante
Re: TIM Web no Kubuntu 8.04 com o modem ONDA MSA501HS
« Resposta #2 Online: 30 de Junho de 2008, 12:40 »
Bem, testei e "quase" funcionou com o tutorial. Digo quase porque ele reconhece, faz a ligação e fica parado nas linhas de DNS (estou no trabalho agora e não tive tempo de copiar o script que "rolou")

Uma pergunta que fica é: Quando digo para a configuração que o modem está no USB0, ele pode estar em qualquer porta ou tem que ser a USB0 (ou para o Linux tanto faz)? OUtra coisa, se funcionar quando uso o comando sudo wvdial tim (conforme o tutorial) eu devo usar (chamar) o navegador como usuárionormal ou com o sudo também?

Offline sar332

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re: TIM Web no Kubuntu 8.04 com o modem ONDA MSA501HS
« Resposta #3 Online: 07 de Julho de 2008, 14:53 »
Olá pessoal, sou novo aqui e também migrei recentemente do windows para o ubuntu. Já passei por alguns desafios, como fazer a webcam funcionar, wireless, etc... Uso um notebook e recentemente adquiri o modem onda msa501hs da tim, segui todos os tutoriais disponívies que encontrei, o meu modem é reconhecido, ele conecta mas para no dns... utilizei o vodafone, e da amesma coisa, no vodafone troquei para o opendns e nada... até conecta mas nao pinga nada.. nem tráfego vejo... o q fazer?

Offline winckler

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: TIM Web no Kubuntu 8.04 com o modem ONDA MSA501HS
« Resposta #4 Online: 15 de Julho de 2008, 18:23 »
Olá.

Eu também estou no quase. Meu problema é o mesmo, o wvdial para depois de receber o DNS. A interfacie sobe, mas nenhum dado é recebido de volta.

Alguem fez algum progresso?

Abraços

Offline sar332

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re: TIM Web no Kubuntu 8.04 com o modem ONDA MSA501HS - RESOLVIDO NO HARDY
« Resposta #5 Online: 20 de Julho de 2008, 09:07 »
ONDA MSA501HS RESOLVIDO NO UBUNTU 8.04 (só 32bits - no 64 bits não consegui, pois acho que o usbmodeswitch.bin é incompatível)
olá  pessoal,
após infinitas pesquisas nos foruns, aproveitando o que um diz, juntando com o que outro descobriu (essa é uma grande vantagem do mundo livre) resolvi o meu problema com o modem ONDA MSA501HS para utilização da timweb 3G. Inicialmente ele atribuia o DNS mas não abria o firefox... depois descobri que o firefox só entrava no modo off-line, o que era facilmente resolvido clicando no modo on-line. Para melhorar, desinstalei o network manager e segui o conselho de muitos instalando o wicd (claro que para o onda 501hs a influência na conexão foi mínima - exceto pq corrigiu o problema do firefox off-line). Bem, resumindo, fiz um tutorial e um script que deixa tudinho automáitco (fiz não, adaptei de outros) e instalei também o vodafone (que é um software semelhante aos que vem com o modem - atribui o opendns). Resumindo, tá rodando beleza, 100%. Quem desejar envio o script por e-mail, pois não sei como postar um arquivo aqui. (há só testei no ubuntu 8.04 hardy e não sei se vai funcionar em outros). Agora só falta aplicar aquele patch brasileiro que dobra a capacidade do tráfego no modem - que eu não sei como fazer... tem um tutorial, mas o usbserial.ko que disponibilizam via download dá erro quando carregado.

Offline oordnave

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: TIM Web no Kubuntu 8.04 com o modem ONDA MSA501HS
« Resposta #6 Online: 23 de Julho de 2008, 10:29 »
Ae pessoal...

Consegui configurar a TimWeb para o meu Ubuntu também!

O que acontece é o seguinte: fiz um cruzado com outros tutoriais para modems 3g e percebi que no tutorial do Lívio ficou faltando dois arquivos (no meu caso): o Gcom e o Libusb-dev.

Como no meu laptop não tinha internet, usei o Wget lá no Windows para pegá-los. E a minha ordem de instalação foi esta:

1 - Gcom
2 - Libusb-dev
3 - usb_modeswitch
4 - Tutorial do Lívio

Para aqueles que chegaram no ponto de digitar no terminal wvdial tim, e que no mesmo apresenta no final dois DNS's, já podem navegar! Apesar do terminal não apresentar outras coisas, nós já podemos navegar com o modem assim mesmo! (Novamente fazendo um cruzado, dedizi que o script que deveria ser carregado, no Ubuntu existe, mas não foi necessário).

E se você conseguiu fazer tudo certinho (instalação, chegar até o ip do DNS), mas o Firefox não abre qualquer página, é só ir em Arquivo e tirar ele do modo offline. Aí, só alegria, hehe.

Para comprovar:

http://img378.imageshack.us/my.php?image=capturadatelaqc4.png

É isso aí pessoal =D

É só tentar que dá certo!

* Lancei este mesmo depoimento lá no Orkut para o pessoal...

Offline Weslei Chaves

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: TIM Web no Kubuntu 8.04 com o modem ONDA MSA501HS
« Resposta #7 Online: 27 de Julho de 2008, 10:39 »
Olá oordnave!!!
Pode me mandar com mais detalhes os passos da sua configuração do timweb no Ubuntu 8.04?
i-mail; wesleichaves@yahoo.com.br
 Se puder mande tudo explicadinho mensmo, pois sou novo em linux, tentei procurar pelo arquivo gcom e outros mas não sabia onde conseguir, sozinho ta difícil. Aki em BH parece não ter ninguem que saiba resolver isso, ta complicado mesmo...

Offline winckler

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: TIM Web no Kubuntu 8.04 com o modem ONDA MSA501HS
« Resposta #8 Online: 01 de Agosto de 2008, 11:49 »
O modem funciona normalmente para mim agora (Ubuntu 8.04 amd64). O meu erro era o teste que eu estava fazendo: o IP do PPP (da outra ponta) nao 'e real. Ele nao responde ao ping! Cuidado ao testar pois perdi algumas horas nisso. O outro ponto, j'a levantado 'e que o firefox pode entrar em modo off-line.

No ubuntu, o padrao 'e n~ao mostrar as ultimas linhas do wvdial mostradas no tutorial (com o DNS). Para ver, 'e preciso especificar o modo verbose no arquivo de configuracao.

Outro ponto 'e que 'e poss'ivel usar o programa da vodafone, que permite mandar SMS, ver nivel de sinal e outras coisas legais.

Qualquer d'uvida avise e desculpe pela acentuac~ao prec'aria (n~ao estou no meu computador :-().

Offline AquaMan

  • Usuário Ubuntu
  • *
  • Mensagens: 138
  • <Ubunteiro desde jul/07> Hardy Haron
    • Ver perfil
Re: TIM Web no Kubuntu 8.04 com o modem ONDA MSA501HS
« Resposta #9 Online: 08 de Agosto de 2008, 18:12 »
Salve, Pessoal!

Fiz todo o passo-a-passo e consegui chegar na tela do console que mostra os DNS's primários e secundários, mas não consigo navegar.

Código: [Selecionar]
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Fri Aug  8 18:03:27 2008
--> Pid of pppd: 5300
--> Using interface ppp0
--> local  IP address 189.66.83.240
--> remote IP address 10.64.64.64
--> primary   DNS address 189.40.238.6
--> secondary DNS address 10.223.246.102

Li em algum lugar que temos que informar DNS alternativos (OpenDNS) e coloquei os valores

Código: [Selecionar]
nameserver 208.67.222.222
nameserver 208.67.220.220

no arquivo /etc/resolv.conf, mas como se vê na mensagem de conexão, os DNS mostrados não são os que eu fixei neste arquivo. Li também sobre uma variável de ambiente MODIFY_RESOLV_CONF_DYNAMICALLY que não achei o arquivo de edição no Ubuntu 8.04, pois o passo-a-passo para isto era para o OpenSUSE.

Alguém poderia me ajudar?

Desde já agradeço!

(AMD Athlon 64 3.5Ghz/1Gb RAM/80Gb+250Gb/Geforce FX 6200 128Mb/Palm T5)

Offline mstr

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
    • instalar qualquer placas de captura PCI
Re: TIM Web no Kubuntu 8.04 com o modem ONDA MSA501HS
« Resposta #10 Online: 09 de Agosto de 2008, 03:48 »
Citar
Fiz todo o passo-a-passo e consegui chegar na tela do console que mostra os DNS's primários e secundários, mas não consigo navegar.

Código:

--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Fri Aug  8 18:03:27 2008
--> Pid of pppd: 5300
--> Using interface ppp0
--> local  IP address 189.66.83.240
--> remote IP address 10.64.64.64
--> primary   DNS address 189.40.238.6
--> secondary DNS address 10.223.246.102
se não consegue navegar deve ser pq faltam os DNS no resolv

verifique se os DNS primario e secundario estão no arquivo /etc/resolv.conf

Offline AquaMan

  • Usuário Ubuntu
  • *
  • Mensagens: 138
  • <Ubunteiro desde jul/07> Hardy Haron
    • Ver perfil
Re: TIM Web no Kubuntu 8.04 com o modem ONDA MSA501HS
« Resposta #11 Online: 09 de Agosto de 2008, 09:09 »
se não consegue navegar deve ser pq faltam os DNS no resolv

verifique se os DNS primario e secundario estão no arquivo /etc/resolv.conf


mstr,
conforme eu informei na minha mensagem

Citar
Li em algum lugar que temos que informar DNS alternativos (OpenDNS) e coloquei os valores

Código:

nameserver 208.67.222.222
nameserver 208.67.220.220


no arquivo /etc/resolv.conf, mas como se vê na mensagem de conexão, os DNS mostrados não são os que eu fixei neste arquivo. Li também sobre uma variável de ambiente MODIFY_RESOLV_CONF_DYNAMICALLY que não achei o arquivo de edição no Ubuntu 8.04, pois o passo-a-passo para isto era para o OpenSUSE.

eu já havia atualizado o resolv.

(AMD Athlon 64 3.5Ghz/1Gb RAM/80Gb+250Gb/Geforce FX 6200 128Mb/Palm T5)


Offline AquaMan

  • Usuário Ubuntu
  • *
  • Mensagens: 138
  • <Ubunteiro desde jul/07> Hardy Haron
    • Ver perfil
Re: TIM Web no Kubuntu 8.04 com o modem ONDA MSA501HS
« Resposta #13 Online: 09 de Agosto de 2008, 16:05 »
Vejam se estes tutoriais ajudam vocês:

http://www.lucasleao.net/wordpress/?p=24
http://www.fre.eti.br/livio/2008/04/timweb-no-linux-onda-msa501hs.html
http://www.guiadohardware.net/tutoriais/acesso-movel/pagina3.html


kernel_script,
ótimas dicas estas! No final das contas, antes de ler este seu post, eu hoje pela manhã acabei conseguindo fazer o bixim funcionar no notebook. As duas primeiras dicas de site eu já tinha "colecionado" para mim, via Google, e segui os passos que elas propõem. A do Lucas Leão foi tranquila. Mas depois de analisar a página do Guia do Hardware (essa eu não tinha encontrado pelo Google), vou fazer os ajustes finos que eles falam por lá.

Valeu!
Aquele abraço!

(AMD Athlon 64 3.5Ghz/1Gb RAM/80Gb+250Gb/Geforce FX 6200 128Mb/Palm T5)

kErNeL_sCrIpT

  • Visitante
Re: TIM Web no Kubuntu 8.04 com o modem ONDA MSA501HS
« Resposta #14 Online: 09 de Agosto de 2008, 16:38 »
kernel_script,
ótimas dicas estas! No final das contas, antes de ler este seu post, eu hoje pela manhã acabei conseguindo fazer o bixim funcionar no notebook. As duas primeiras dicas de site eu já tinha "colecionado" para mim, via Google, e segui os passos que elas propõem. A do Lucas Leão foi tranquila. Mas depois de analisar a página do Guia do Hardware (essa eu não tinha encontrado pelo Google), vou fazer os ajustes finos que eles falam por lá.

Valeu!
Aquele abraço!

De nada :)
Fico feliz que as dicas tenham sido úteis de alguma forma :)