Autor Tópico: "ALT+F2" não funciona  (Lida 21822 vezes)

Offline Mauzão

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
"ALT+F2" não funciona
« Online: 30 de Junho de 2008, 22:56 »
Galera,
meu "ALT+F2" não funciona...

uso ubuntu 8.04 Hardy Heron...

tem alguma coisa que posso fazer???
"Quem quer fazer alguma coisa, encontra um meio.
Quem não quer fazer nada, encontra uma desculpa."

Offline 0tacon

  • Usuário Ubuntu
  • *
  • Mensagens: 439
    • Ver perfil
Re: "ALT+F2" não funciona
« Resposta #1 Online: 01 de Julho de 2008, 04:01 »
 Tem certeza que não funciona? Experimenta aperar o ALT+F2 e depois alternar entre janelas usando o ALT+TAB, pra ver se o Executar Aplicações não ficou por baixo de tudo. Tente também o ALT+F2 sem o compiz e o emerald. Remapear o atalho (colocando, por exemplo, WIN+F2) pode resolver também.


Offline Mauzão

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: "ALT+F2" não funciona
« Resposta #2 Online: 01 de Julho de 2008, 12:28 »
Seguinte...
tentei "aperar o ALT+F2 e depois alternar entre janelas usando o ALT+TAB"... nada.. ele não aparece...
tentei achá-lo no monitor de sistema, mas não tá lá...

Tentei remapear meu atalho de teclado, mas não há essa opção lá, também...

pois é amigo, tenho impressão de que não há o "executar" no meu ubuntu... então quando preciso executar algum comando, tenho que ir p/ shell... (terminal ou console)... isso é chato...

sabe como reinstalar o "executar"???
"Quem quer fazer alguma coisa, encontra um meio.
Quem não quer fazer nada, encontra uma desculpa."

Offline 0tacon

  • Usuário Ubuntu
  • *
  • Mensagens: 439
    • Ver perfil
Re: "ALT+F2" não funciona
« Resposta #3 Online: 02 de Julho de 2008, 01:56 »
 Tente mais uma coisa então...
 Clique com o botão direito em uma parte vazia do painel, vá em Adicionar ao painel (+), e role a janela que aparece até o final, onde vai estar a seção "utilitários". O Botão "executar aplicação" tem que estar lá, para ser adicionado ao painel. Se ele não estiver lá...  ???


Offline Mauzão

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: "ALT+F2" não funciona
« Resposta #4 Online: 03 de Julho de 2008, 20:47 »
Cara,
fiz esse teste e o aplicativo estava lá...
consegui adicionar ele na barra de ferramentas...

porém, o "ALT+F2" ainda não faz nada...

sabe como consigo alterar as teclas de atalho, ou configurar nova tecla, sem ser pelo [Sistema]->[Prefeências]->[Tecla de Atalho]????

 :-\
"Quem quer fazer alguma coisa, encontra um meio.
Quem não quer fazer nada, encontra uma desculpa."

Offline bl4z3

  • Usuário Ubuntu
  • *
  • Mensagens: 46
    • Ver perfil
Re: "ALT+F2" não funciona
« Resposta #5 Online: 16 de Julho de 2008, 17:08 »
Seguinte...
tentei "aperar o ALT+F2 e depois alternar entre janelas usando o ALT+TAB"... nada.. ele não aparece...
tentei achá-lo no monitor de sistema, mas não tá lá...

Tentei remapear meu atalho de teclado, mas não há essa opção lá, também...

pois é amigo, tenho impressão de que não há o "executar" no meu ubuntu... então quando preciso executar algum comando, tenho que ir p/ shell... (terminal ou console)... isso é chato...

sabe como reinstalar o "executar"???

Ja conferiu se seu teclado nao eh aqueles com o botao "FN" (function) e vc ta marcando bobera? :x
Nao custa nada lembrar :P
"Dê livremente todo o conhecimento que recebestes gratuitamente"

Offline Mauzão

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: "ALT+F2" não funciona
« Resposta #6 Online: 16 de Julho de 2008, 17:29 »
Meu teclado tem sim o "FN"...
porém essa tecla é para as outras que estão em azul (cor diferente do teclado), e funciona direitinho... como por exemplo, aumentar e diminuir a intensidade de brilho do LCD, som, ativar e desativar o touchpad, etc...

e na tecla "F2" tem em azul o símbolo de hibernar...

mas em todo caso, consegui colocar na barra de atalhos o programa executar...

mas pelo ALT+F2... nada...

 :-\
"Quem quer fazer alguma coisa, encontra um meio.
Quem não quer fazer nada, encontra uma desculpa."

Offline Mauzão

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: "ALT+F2" não funciona
« Resposta #7 Online: 19 de Julho de 2008, 13:00 »
Galera, achei uma possível saída...

no site do grande Alexandre Cavedon, achei a seguinte saída...

http://cavedon.net/blog/?p=32#comments



trabalhando com o gnome-run
08 de outubro de 2007

Me debati hoje com um problema no mínimo curioso: precisei realizar uma chamada (a partir de outro ambiente gráfico) daquele frontend “executar aplicação” do GNOME e vi que não existe chamada externa, pois o mesmo é compilado junto com o gnome-panel.

Para resolver isso, precisei recompilar este aplicativo específico. Realizei da segunte forma:

1) Baixei o fonte do gnome panel:

    apt-get source gnome-panel

2) Extraí o arquivo gnome-run.c;

3) Compilei na unha:

    gcc gnome-run.c -o gnome-run -L/usr/X11R6/lib -lX11

4) E copiei o binário resultante para o “usr bin”:

    cp gnome-run /usr/bin

Para que tudo corra bem o .glade original deve estar setado corretamente no /usr/share/gnome/panel/glade (seu nome é panel-run-dialog.glade).

Para rodar:

    gnome-run

Salut!

Postado em gnome


Vou tentar fazer isso, e depois relato o resultado...

 :P
"Quem quer fazer alguma coisa, encontra um meio.
Quem não quer fazer nada, encontra uma desculpa."

alarcon

  • Visitante
Re: "ALT+F2" não funciona
« Resposta #8 Online: 19 de Julho de 2008, 13:15 »
Acho que isso aí de logo acima não é o seu caso, pois pelo que entendi o dono do texto queria ter a possibilidade de chamar o executar gráfico pelo terminal (comando gnome-run) e não usar as teclas de atalho Alt+F2 que é o seu caso.

Seu problema deve ser mesmo quanto a configuração do teclado no xorg (talvez).

O teclado escolhido pela detecção deve ter sido um modelo bem próximo ao seu, mais não o mesmo e aí algumas teclas podem não estar funcionando com o caso do Alt+F2.

Aqui indo no menu Sistema > Preferências > Atalhos de Teclado, lá em  Área de Trabalho para a opção Mostrar o diálogo Executar Aplicação esta ajustado para o Alt+F2
« Última modificação: 19 de Julho de 2008, 13:25 por alarcon »

Offline Mauzão

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: "ALT+F2" não funciona
« Resposta #9 Online: 19 de Julho de 2008, 13:58 »
Pois é Alarcon...
mas no atalho de teclado eu tenho apenas dois grupos: SOM e AMBIENTE...

e nesses não há essa opção... mas lembro-me de que nas versões anteriores de todos meus Ubuntu, tinham...

e agora, fiquei na mesma...
 ???

mas tem que ter uma forma de arrumar isso...

mas valeu assim mesmo...
"Quem quer fazer alguma coisa, encontra um meio.
Quem não quer fazer nada, encontra uma desculpa."

Offline Mauzão

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: "ALT+F2" não funciona
« Resposta #10 Online: 22 de Julho de 2008, 13:21 »
Galera,
achei uma possível resolução:
no tópico  http://ubuntuforum-br.org/index.php/topic,15390.msg82545.html#msg82545
diz para fazer o seguinte:

"Abra o gconf (Aplicações, Ferramentas do Sistema, Editor de Configurações) e navegue pela árvore de opções selecionando "apps" > "metacity" > "keybinding_commands". Você verá várias linhas como command_1, command_10, command_11, etc. Seleciona uma linha que tenha o campo Valor vazio e digite o comando usado para abrir o aplicativo desejado.
Supondo que command_1 esteja vazio, altere o campo Valor desta linha para gksudo synaptic.
Agora precisamos definir as teclas de atalho. Volte para a árvore de opções e selecione "apps" > "metacity" > "global_keybindings". Novamente você verá várias linhas. Procure pela linha referente ao command_1 que usamos anteriormente. O nome dela é run_command_1. Seu valor deve estar como disabled. Alterando este valor para <Control><Alt>S o synaptic abrirá com essa combinação de teclas, ctrl+alt+s."


no meu caso não quero abrir o synaptic, mas o "Executar Aplicação"...

Será que alguém sabe o nome do aplicativo "Executar Aplicação" ?????

mauzão
"Quem quer fazer alguma coisa, encontra um meio.
Quem não quer fazer nada, encontra uma desculpa."

alarcon

  • Visitante
Re: "ALT+F2" não funciona
« Resposta #11 Online: 22 de Julho de 2008, 13:54 »
É o seguinte em / > apps > metacity > global_keybinding no gconf tem lá, ou pelo menos aqui no meu, a entrada panel_run_dialog com o valor <Alt>F2 que é exatamente o Executar Aplicação, portanto se você quer saber qual é o nome para chamar o executar programa deve ser panel_run_dialog que você deve associar ao Alt+F2

Veja que é exatamente o que aqule link que você falou anteriormente fala:

Citar
trabalhando com o gnome-run
08 de outubro de 2007

Me debati hoje com um problema no mínimo curioso: precisei realizar uma chamada (a partir de outro ambiente gráfico) daquele frontend “executar aplicação” do GNOME e vi que não existe chamada externa, pois o mesmo é compilado junto com o gnome-panel.

Ou seja, o comando que normalmente deveria abrir o executar aplicação deveria ser o gnome-run, mais como o dono do texto indicado por você constatou ele é compilado junto com o gnome-painel. Perceba que o nome associado ao Alt+F2 no gconf, no local indicado, é panel_run_dialog

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.285
    • Ver perfil
Re: "ALT+F2" não funciona
« Resposta #12 Online: 22 de Julho de 2008, 18:40 »
Só para constar o comando gnome-run não existe mais nas versões novas do gnome.
experimente, gnome-panel-control --run-dialog
PS: os atalhos do teclado só funcionam 100% se o gerenciador de janelas for o metacity, se você usa compiz etc.. veja se existe alguma forma de fazẽ-los funcionar perfeitamente.
você pode também adicionar ao painel o diálogo executar, não é a melhor solução.
Clicar com o botão direito em uma área vazia do painel->adicionar ao painel->executar aplicação
ou criar uma lançador até que você consiga resolver o problema.
« Última modificação: 22 de Julho de 2008, 18:47 por Xterminator »

Offline Mauzão

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: "ALT+F2" não funciona
« Resposta #13 Online: 22 de Julho de 2008, 19:01 »
pois é Alarcon...

tá muito estranho isso tudo...

não tenho gnome-run nem panel_run_dialog, apesar de no meu > apps > metacity > global_keybinding no gconf conter uma entrada para ele e com o atalho e tudo (ALT+F2)...

e nem sabemos porque o atalho não funciona, (sabe-se lá porque...) mas o atalho no botão na barra de atalhos, funciona...

então???? o que fazer????

tento baixar e compilar o programa, como indicado????

baixei o gnome-panel novamente, aliás, todo gnome, e reinstalei, mas sem resultado...

baixei tbem o grun e esse funcionou, mas só chamando na linha de comando...

 >:(
"Quem quer fazer alguma coisa, encontra um meio.
Quem não quer fazer nada, encontra uma desculpa."

Offline Mauzão

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: "ALT+F2" não funciona
« Resposta #14 Online: 22 de Julho de 2008, 20:06 »
Valeu pela dica Xterminator...

rodei pelo terminal o gnome-panel-control --run-dialog e funcionou...

apesar de já ter colocado na barra de atalhos e no menu, ainda gostaria de adicionar o Alt+F2... (sou teimoso...  ;D)

não tenho o compiz instalado... já o tive, mas não mais... (será que pode ser isso  ???)...

e tenho sim o metacity funcionando...

and now budy ???  :-\
"Quem quer fazer alguma coisa, encontra um meio.
Quem não quer fazer nada, encontra uma desculpa."