Autor Tópico: Problemas com NFS e NIS  (Lida 16388 vezes)

Offline Paulo Lanza

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Problemas com NFS e NIS
« Online: 23 de Julho de 2008, 21:49 »
Olá Pessoal!! É o seguinte,
Estou montando uma rede na empresa onde trabalho, é um projeto de inclusão digital e estamos usando um servidor Ubuntu 8.04 server e as maquinas clientes com Ubuntu 8.04 desktop. Segui este tutorial: http://colab.interlegis.gov.br/wiki/CriandoServidordeArquivosAutenticacao.Tudo da certo, mas quando vou logar na maquina cliente com um usuario criado no servidor ele aprece alguns erros.

No primeiro alerta aparece:

Sua pasta pessoal está definida como "/home/instrutores/paulo" mas parece não existir. Você deseja iniciar uma sessão com o diretório /(Raiz) como sua pasta pessoal? É provável que nada funcione a menos que você utilize uma sessão de segurança.

Tenho a opção de [Sim] ou [Não] se eu escolher não ele fecha a tela e pede pra digitar o login denovo mas se coloco sim ele aparece essa outra janela:

O seu arquivo $HOME/.dmrc está sendo ignorado. Isto impede que a sessão padrão e o idioma sejam salvos. O arquivo precisa ser de prioridade so usuario e ter permissões 644(não ter permissão de escrita por outros usuarios). O diretório $HOME do usuario deve ser de propriedade do usuario e outros usuarios não devem ter permissões de escrita.

Aqui só tenho a opção de [OK]. Então aparece a seguinte mensagem:

Sua sessão durou menos de 10 segundos se você não terminou um sessão, isso pode significar que há algum problema de instalação ou que pode estar sem espaço em disco. Tente iniciar uma sessão de segurança para verificar se você consegue consertar o problema.

Já instalei várias vezes e sempre da este mesmo problema, o Cliente encontra o Servidor e o Servidor também encontra o Cliente mas sempre que tento logar aparece essas mensagens. Sou iniciante em Linux, mas creio que o problema esta na montagem no NFS do Cliente, coloquei da seguinte forma mount -t nfs <IP do meu Servidor>:/home/instrutores/paulo /home....não tenho certeza se esse é o problema...mas se alguém puder ajudar, os ususarios e os grupos também criei de acordo com o tutorial. Desde já agradeço, uma boa semana a todos!



Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problemas com NFS e NIS
« Resposta #1 Online: 23 de Julho de 2008, 21:55 »
Opa... então não funcionou seguir o tuto né... bem, vamos ver se posso ajudar já que fui eu que escrevi aquilo.

Você esta com o diretório HOME montado corretamente?

Execute o comando  df no terminal e cole ele aqui.
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problemas com NFS e NIS
« Resposta #2 Online: 23 de Julho de 2008, 21:57 »
Mais uma coisa, onde esta montando o diretório dos usuários?
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline Paulo Lanza

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com NFS e NIS
« Resposta #3 Online: 24 de Julho de 2008, 13:58 »
Olá amigo!!
essa é a resposta  utilizando o comando no servidor:

Filesystem        1k-blocks       User available               Use%        Mounted on
/dev/sda1          152051968      3221224 141167744      3%            /
varrun               516952           264  516688                 1%          /var/run
vsrlock              516952            0    516952                  0%          /var/lock
udev                 516952           48   516904                  1%          /dev
devshm             516952           0      516952                 0%          /dev/shm
lrm                   516952           39760  477192              8%          /lib/modules/2.6.24-19-g
eneric/voltatile

E no cliente é:

Sistem. Arq.        1k-blocos       Usado   Dispo               Uso%        Montado em
/dev/sda1          76232764      2451244 69939580          4%            /
varrun               224724           112  224724                 1%          /var/run
vsrlock              224724            0    224724                  0%          /var/lock
udev                 224724           44   224724                  1%          /dev
devshm             224724            12  224724                 1%          /dev/shm
lrm                   224724           38176  186548              17%          /lib/modules/2.6.24-16-g
eneric/voltatile

Usei o mount no cliente como coloquei acima e a criação das pastas fiz pela rotina que estava no tutorial. Obrigado!
 :)

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problemas com NFS e NIS
« Resposta #4 Online: 24 de Julho de 2008, 14:49 »
Seu problema é não ter montado a HOME do servidor no cliente.

Seguindo o tutorial (na parte do NFS, em particular) no servidor você define a exportação do diretório /home para sua rede, ou parte dela, e na estação além de instalar o pacote relativo ao NFS, você também altera seu fstab para montar automáticamente o diretório do server dentro de /home.

Outra coisa que não entendi é como você criou os diretórios dos usuários, o porque de ter o diretório do usuário dentro do diretório instrutores (/home/instrutores/paulo).
« Última modificação: 24 de Julho de 2008, 14:53 por clcampos »
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline Paulo Lanza

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com NFS e NIS
« Resposta #5 Online: 24 de Julho de 2008, 15:01 »
Certo vou tentar aqui!!
Isso foia penas um teste, o diretorio instrutores seria o grupo de usuarios. Porque na minha rede nem todos os usuarios terao a mesma permissão. como nao estava dando certo usando o  mount -t nfs <IP do meu Servidor>:/home/paulo /home, entao coloquei apenas apra testar  mount -t nfs <IP do meu Servidor>:/home/instrutores/paulo /home que é como seguindo a rotina de criacao de usuario criou as pastas no servidor.

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problemas com NFS e NIS
« Resposta #6 Online: 24 de Julho de 2008, 15:09 »
Certo vou tentar aqui!!
Isso foia penas um teste, o diretorio instrutores seria o grupo de usuarios. Porque na minha rede nem todos os usuarios terao a mesma permissão. como nao estava dando certo usando o  mount -t nfs <IP do meu Servidor>:/home/paulo /home, entao coloquei apenas apra testar  mount -t nfs <IP do meu Servidor>:/home/instrutores/paulo /home que é como seguindo a rotina de criacao de usuario criou as pastas no servidor.

Aqui tenho vários grupos de usuário, e as permissões são apertadas, dando direitos aos usuários de verem apenas sua HOME e mais alguns diretórios de compartilhamento. O texto Estrutura Básica de Rede, que esta no mesmo lugar em que achou o outro, fala mais sobre permissões e estrutura de diretórios.

Quanto a montagem o correto seria mount -t nfs <IP do server>:/home   /home

Na máquina do usuário podem ser vistos todos os diretórios dos outros usuários, porém ele não tem acesso.
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline Paulo Lanza

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com NFS e NIS
« Resposta #7 Online: 24 de Julho de 2008, 15:21 »
Certo vou tentar aqui!!
Muito obrigado!!!
ahh...só uma coisinha a mais...no arquivo fstab que você disse, tenho que modifica-lo da mesma forma no cliente e no servidor?? ???

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problemas com NFS e NIS
« Resposta #8 Online: 24 de Julho de 2008, 15:23 »
Certo vou tentar aqui!!
Muito obrigado!!!
ahh...só uma coisinha a mais...no arquivo fstab que você disse, tenho que modifica-lo da mesma forma no cliente e no servidor?? ???

Em relação a configuação do NFS no servidor só irá editar o arquivo /etc/exports, e é nas estações que você altera o /etc/fstab, até porque é nela que você irá disponibilizar os dados exportados.
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline Paulo Lanza

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com NFS e NIS
« Resposta #9 Online: 24 de Julho de 2008, 15:29 »
Ah sim entendi, mas isso eu ja tinha feito!! :-[
Modifiquei este arquivo no cliente da seguinte forma:

<ip do meu servidor>:/home /home nsf defaults 0 0

Será que o problema esta aqui??
« Última modificação: 24 de Julho de 2008, 15:35 por Paulo Lanza »

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problemas com NFS e NIS
« Resposta #10 Online: 24 de Julho de 2008, 15:39 »
Ah sim entendi, mas isso eu ja tinha feito!! :-[
Modifiquei este arquivo no cliente da seguinte forma:

<ip do meu servidor>:/home /home nsf defaults 0 0

Será que o problema esta aqui??

Teoricamente não tem erro... mas nunca usei no meu server o 8.04.

A sorte é que segunda devo começar a migrar para um novo hardware.

Faça a montagem na mão caso não monte automático para gente ver o que tá acontecendo.
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline Paulo Lanza

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com NFS e NIS
« Resposta #11 Online: 24 de Julho de 2008, 15:52 »
Certo vou tentar aqui!!
Você usa qual no seu server?? ::)

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problemas com NFS e NIS
« Resposta #12 Online: 24 de Julho de 2008, 15:56 »
Certo vou tentar aqui!!
Você usa qual no seu server?? ::)

Meu server de arquivos, que já esta rodando a anos, e no final de sua capacidade usa hoje o 6.06 server.
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline Paulo Lanza

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com NFS e NIS
« Resposta #13 Online: 24 de Julho de 2008, 16:01 »
Se não der certo vou tentar utilizar o 6 também, teria algum problema o servidor ser o 6 e o desktop continuar sendo o 8?? ???

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problemas com NFS e NIS
« Resposta #14 Online: 24 de Julho de 2008, 16:04 »
Se não der certo vou tentar utilizar o 6 também, teria algum problema o servidor ser o 6 e o desktop continuar sendo o 8?? ???

Não use o 6 para servidor, já esta defasada, e daqui um tempo não terá mais suporte.

Quanto a desktop hj uso todas as versões do ubuntu... da 5.10 até a 7.10.

Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!