Autor Tópico: Compilação e instalação do Open Movie Editor  (Lida 2044 vezes)

Offline GuidjeLeGamba

  • Usuário Ubuntu
  • *
  • Mensagens: 191
  • Não há fatos eternos ou verdades absolutas
    • Ver perfil
Compilação e instalação do Open Movie Editor
« Online: 24 de Agosto de 2009, 21:35 »
Pessoal,

Boa noite. Descobri um programa de edição de vídeos chamados Open Movie Editor. Há uma versão dele nos repositórios mas ela é uma tanto antiga e instável. Dessa forma, resolvi compilar o programa em sua versão mais atual: http://downloads.sourceforge.net/openmovieeditor/openmovieeditor-0.0.20090105.tar.gz

Claro que o programa em si dependia de algumas bibliotecas, sendo que consegui praticamente todas elas, ou compilando ou baixando os pacotes já compilados (*.deb)

Acontece que uma biblioteca mostra um erro que eu não descobri, mesmo após muita pesquisa, como resolver. É o seguinte:

Citar
params.c:149: erro: ‘FF_CODER_TYPE_RAW’ undeclared here (not in a function)
params.c:150: erro: ‘FF_CODER_TYPE_RLE’ undeclared here (not in a function)
params.c:151: erro: ‘FF_CODER_TYPE_DEFLATE’ undeclared here (not in a function)
make[3]: ** [params.lo] Erro 1
make[3]: Saindo do diretório `/home/guidje/libquicktime-1.1.3/plugins/ffmpeg'
make[2]: ** [all-recursive] Erro 1
make[2]: Saindo do diretório `/home/guidje/libquicktime-1.1.3/plugins'
make[1]: ** [all-recursive] Erro 1
make[1]: Saindo do diretório `/home/guidje/libquicktime-1.1.3'
make: ** [all] Erro 2

Trata-se dessa biblioteca, libquicktime. Tentei compilar diversas versões, mas todas mostram esse mesmo erro. Essa biblioteca existe nos repositórios, porém, ela não está compilada com o suporte lame (para mp3) que é necessário para compilar o programa (se se tentar compilar o programa com a biblioteca libquicktime sem o recurso lame, a compilação pára.) Descobri que, para conseguir inserir aquele suporte a essa biblioteca, é necessário instalar os recursos (nesse caso, a biblioteca lame) e compilar a biblioteca a partir do código fonte.

Tentei "forçar" a utilização do suporte ao lame fazendo o seguinte: instalei a biblioteca a partir dos repositórios e, em seguida, peguei uma biblioteca já compilada, para RedHat ou Fedora, e extrai os arquivos necessários (lqt_lame.so e lqt_lame.la) para a pasta aonde eles deveriam ficar (/usr/lib/libquicktime1). Entretanto, como a versão desses arquivos é a 0.9.3, a biblioteca libquicktime não consegue "acioná-los" (e o programa requer, no mínimo, a versão 1.0.0, de qualquer maneira.)

Gostaria que alguém me auxiliasse para tentar descobrir como contornar o problema e prosseguir a instalação. O programa em questão funciona em ambiente Gtk, de maneira que se conseguirmos fazê-lo funcionar perfeitamente, será uma alternativa ao Kdenlive, de maneira que não precisaremos mais utilizar as bibliotecas do KDE (pelo menos para edições de vídeo) além de uma maior estabilidade para isso.

Em pesquisas, descobri que o erro pode estar no arquivo "/plugins/ffmpeg" do código fonte da aplicação.

Fico no aguardo!

Um abraço!!



« Última modificação: 24 de Agosto de 2009, 21:41 por GuidjeLeGamba »