Autor Tópico: Assistindo videos no mplayer pelo COMPIZ/XGL  (Lida 3545 vezes)

Offline hanover

  • Usuário Ubuntu
  • *
  • Mensagens: 45
    • Ver perfil
    • http://www.sodavirtual.com.br
Assistindo videos no mplayer pelo COMPIZ/XGL
« Online: 02 de Junho de 2006, 15:11 »
Se você não consegue assistir nenhum video no mplayer dentro do compiz/xgl, faça o seguinte.

Abra o mplayer
Clique com o botão direito sobre ele e va em preferences
De ok na mensagem que aparece e clique na aba video
Em available drivers: selecione o driver gl2
De ok.

Pronto
Agora é so dar o play =P
GNU/Linux. Viva essa liberdade!

Offline rodrigobr

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: Assistindo videos no mplayer pelo COMPIZ/XGL
« Resposta #1 Online: 14 de Julho de 2007, 03:06 »
O problema não é assistir.. e sim a transparencia..

Darcamo

  • Visitante
Re: Assistindo videos no mplayer pelo COMPIZ/XGL
« Resposta #2 Online: 14 de Julho de 2007, 11:00 »
O melhor não é mexer no mplayer, mas sim no compiz.

Antes eu estava usando essa solução de mudar o driver de saída de vídeo do mplayer para gl e, embora o vídeo ficasse visível, outros problemas apareciam. Testei também o X11(XImage/Shm) com o qual a imagem ficava ótima, mas o vídeo não ficava em tela cheia. Até que percebi que tinha que mudar era o compiz.

Primeiro, deixe o drive de saída de vídeo do mplayer no X11/xv mesmo.

Vá nas configurações do compiz (Sistema > Preferências > CompizConfig Settings Manager) e escolha a categoria "General Options". Nessa categoria, vá na aba "Opacity Settings".

Onde tem "Opacity Windows", mude
((type=Unknown | Menu | PopupMenu | DropdownMenu | Tooltip | Notification | Combo | Dnd | name=sun-awt-X11-XWindowPeer) | (type=Normal & override_redirect=1)) & !(name=sun-awt-X11-XFramePeer | name=sun-awt-X11-XDialogPeer)

Para
((Menu | PopupMenu | DropdownMenu | Tooltip | Notification | Combo | Dnd | name=sun-awt-X11-XWindowPeer) | (type=Normal & override_redirect=1)) & !(name=sun-awt-X11-XFramePeer | name=sun-awt-X11-XDialogPeer | state=fullscreen)

Com isso, mplayer e xine funcionam perfeitamente aqui e de quebra minha proteção de tela (que é apenas uma tela preta) não está mais transparente.
Só não funciona o totem (com backend do gstreamer - acho que com backend do xine deve funcionar, mas não testei).
Só preciso agora descobrir como fazer o totem (gstreamer) funcionar. Testei mudar o driver de saída de vídeo do gstreamer com o gstreamer-properties, mas sem sucesso. De qualquer forma, com a dupla mplayer/xine funcionando eu posso rodar qualquer vídeo.