Autor Tópico: Tutorial XGL ( Dapper, Gnome e Nvidia )  (Lida 59283 vezes)

Offline gwegs

  • Usuário Ubuntu
  • *
  • Mensagens: 83
    • Ver perfil
nao deu certo
« Resposta #45 Online: 20 de Maio de 2006, 18:31 »
Instalei aqui o xgl, mas na hora d iniciar o x da erro, deu uma mensagem que o X nao poderia ser iniciado e que era pra alterar o gdm.
Alguem teve esse mesmo problema???

Ah, Detalhe, minha placa de video nao e nvdia, e uma intel 915, porem na hora q estava configurando o xorg onde tem a parte de colocar nvidia eu deixei como estava. sera por isto?? eu acredito q nao ja q o x nem iniciou.

Aqui ta o xorg ja modificicado: o resto fiz com manda o tutorial. ah no meu xorg tbm nao tinha linhda do GLcore, mas como iria ser comentada acho q nao teria problema
a instalacao do xgl e do resto deu tudo certo, intaaum acho q  o problema e com o xorg mesmo. alguem pode me ajudar,

vle\w


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/X11/fonts/misc"
   FontPath   "/usr/share/X11/fonts/cyrillic"
   FontPath   "/usr/share/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/Type1"
   FontPath   "/usr/share/X11/fonts/100dpi"
   FontPath   "/usr/share/X11/fonts/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "bitmap"
   Load   "ddc"
#   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "type1"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "abnt2"
   Option      "XkbLayout"   "br"
   Option      "XkbVariant"   "abnt2"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ExplorerPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Identifier   "Synaptics Touchpad"
   Driver      "synaptics"
   Option      "SendCoreEvents"   "true"
   Option      "Device"      "/dev/psaux"
   Option      "Protocol"      "auto-dev"
   Option      "HorizScrollDelta"   "0"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
   Driver      "i810"
   BusID      "PCI:0:2:0"
   VideoRam   128000
   Option      "UseFBDev"      "true"
        Option          "RenderAccel"           "true"
        Option          "AllowGLXWithComposite" "true"
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
   HorizSync   28-49
   VertRefresh   43-72
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
   Monitor      "Generic Monitor"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1280x800"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1280x800"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1280x800"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1280x800"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1280x800"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1280x800"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus" "SendCoreEvents"
   InputDevice     "cursor" "SendCoreEvents"
   InputDevice     "eraser" "SendCoreEvents"
   InputDevice   "Synaptics Touchpad"
EndSection

Section "DRI"
   Mode   0666
EndSection
Section "Extensions"
               Option  "Composite" "Enable"
EndSection
"Porque o conhecimento deve ser compartilhado e assim aprendemos!"

Athlon X2 4200, 2Gb ddr2 667,9600 GT 512MB DDR3 ;D,22" LG M228WA ;D

Offline Lex Luthor

  • Usuário Ubuntu
  • *
  • Mensagens: 628
    • Ver perfil
Maravilha !!
« Resposta #46 Online: 27 de Maio de 2006, 16:38 »
Cara, em uns 5 minutinhos eu fiz o bicho funcionar !!! Putz...

Notei que ele desabilita o menu SISTEMA das janelas...

Ah, e como eu configuro o número de DEsktops meu computador vai ter ?

Show de bola...

Ah, meu computador não é lá rápido não, é claro que sofre uma perda de desempenho, mas nada que deixe inutilizável... minha placa de vídeo é ainda uma Geforce2 MX 200 64Mb

Abraços...
Analista de Redes- Segurança da Informação
Bacharel em Ciências da Computação - UnB
Ubuntu Forever - Compiz Fusion -

Offline gony64

  • Usuário Ubuntu
  • *
  • Mensagens: 558
    • Ver perfil
xgl - kde RESOLVIDO
« Resposta #47 Online: 27 de Maio de 2006, 19:21 »
pessoal instalei o xgl aqui no meu kde, ta funcionando so que as janelas  nao aparecem as bodas bem como o menu " arquivo" "editar" "exibir" etc.

e so ir no gset-compiz e ativar " decoration"

Offline hanover

  • Usuário Ubuntu
  • *
  • Mensagens: 45
    • Ver perfil
    • http://www.sodavirtual.com.br
mão na roda!
« Resposta #48 Online: 27 de Maio de 2006, 20:58 »
Essa dica é do forum gringo do ubuntu, mas o amigo do blog pittlandia.net divulgou a dica traduzida pelo link http://blog.pittlandia.net/2006/04/27/ubuntu-dapper-xglcompiz-recentes/
Acredito que essa dica seja mais eficiente do que a do inicio do post.
GNU/Linux. Viva essa liberdade!

Offline Lex Luthor

  • Usuário Ubuntu
  • *
  • Mensagens: 628
    • Ver perfil
Tutorial XGL ( Dapper, Gnome e Nvidia )
« Resposta #49 Online: 30 de Maio de 2006, 09:12 »
Pessoal,
 
   Notei que algumas janelas o XGL não deixa mais serem movidas. Por que isso ? Tipo a janela de atualização automática, quando está fazendo o download. Antes podia ser movida, e agora não... tem como mudar isso ?

Abraços....
Analista de Redes- Segurança da Informação
Bacharel em Ciências da Computação - UnB
Ubuntu Forever - Compiz Fusion -

Offline dejahbrasil

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Tutorial XGL ( Dapper, Gnome e Nvidia )
« Resposta #50 Online: 02 de Junho de 2006, 06:12 »
Depois que instalei o XGL não consigo mais bloquear a tela.

Depois que instalei o XGL o mplayer, quando começa a rodar um vídeo, nao aparece a janela em tamanho normal do vídeo. Dá somente para ouvir o áudio. Aí quando teclo "F", o vídeo aparece em modo fullscreen.

Depois que instalei o XGL, o xmms não fica com a parte principal do programa quando eu desfaço uma minimização, aparece somente a playlist e o equalizador.


Alguém tem Solução?

Offline vampaz

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: nao deu certo
« Resposta #51 Online: 08 de Junho de 2006, 12:59 »
Citação de: "gwegs"
Instalei aqui o xgl, mas na hora d iniciar o x da erro, deu uma mensagem que o X nao poderia ser iniciado e que era pra alterar o gdm.
Alguem teve esse mesmo problema???

Ah, Detalhe, minha placa de video nao e nvdia, e uma intel 915, porem na hora q estava configurando o xorg onde tem a parte de colocar nvidia eu deixei como estava. sera por isto?? eu acredito q nao ja q o x nem iniciou.

Aqui ta o xorg ja modificicado: o resto fiz com manda o tutorial. ah no meu xorg tbm nao tinha linhda do GLcore, mas como iria ser comentada acho q nao teria problema
a instalacao do xgl e do resto deu tudo certo, intaaum acho q  o problema e com o xorg mesmo. alguem pode me ajudar,

vle\w


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/X11/fonts/misc"
   FontPath   "/usr/share/X11/fonts/cyrillic"
   FontPath   "/usr/share/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/Type1"
   FontPath   "/usr/share/X11/fonts/100dpi"
   FontPath   "/usr/share/X11/fonts/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "bitmap"
   Load   "ddc"
#   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "type1"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "abnt2"
   Option      "XkbLayout"   "br"
   Option      "XkbVariant"   "abnt2"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ExplorerPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Identifier   "Synaptics Touchpad"
   Driver      "synaptics"
   Option      "SendCoreEvents"   "true"
   Option      "Device"      "/dev/psaux"
   Option      "Protocol"      "auto-dev"
   Option      "HorizScrollDelta"   "0"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
   Driver      "i810"
   BusID      "PCI:0:2:0"
   VideoRam   128000
   Option      "UseFBDev"      "true"
        Option          "RenderAccel"           "true"
        Option          "AllowGLXWithComposite" "true"
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
   HorizSync   28-49
   VertRefresh   43-72
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
   Monitor      "Generic Monitor"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1280x800"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1280x800"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1280x800"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1280x800"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1280x800"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1280x800"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus" "SendCoreEvents"
   InputDevice     "cursor" "SendCoreEvents"
   InputDevice     "eraser" "SendCoreEvents"
   InputDevice   "Synaptics Touchpad"
EndSection

Section "DRI"
   Mode   0666
EndSection
Section "Extensions"
               Option  "Composite" "Enable"
EndSection


Exatamente o mesmo problema por aqui, alguem me diz como resolver isto.

Offline Lex Luthor

  • Usuário Ubuntu
  • *
  • Mensagens: 628
    • Ver perfil
Tutorial XGL ( Dapper, Gnome e Nvidia )
« Resposta #52 Online: 08 de Junho de 2006, 13:48 »
Sua placa tem openGL ? Será que isso tem alguma coisa a ver ??
Veja no Xorg.0.log a mensagem de erro que dá lá e posta aqui...
Abraços...
Analista de Redes- Segurança da Informação
Bacharel em Ciências da Computação - UnB
Ubuntu Forever - Compiz Fusion -

Offline Kwezer

  • Usuário Ubuntu
  • *
  • Mensagens: 144
    • Ver perfil
Tutorial XGL ( Dapper, Gnome e Nvidia )
« Resposta #53 Online: 08 de Junho de 2006, 14:47 »
Só uma coisa, como que eu tiro aquele atalho "idiota" que reinicia o servidor?
Estou falando do shift + backspace.
Atalho mais desnecessário.
Essa já é a versão final do XGL?caso não seja, alguem sabe se eles pretendem adicionar novos efeitos?
E outra coisa, como eu faço para habilitar a tecla do Windows?Porque eu não to conseguindo utilizar o zoom.ele simplesmente não funciona, já testei com outros atalhos e foi normal, ele só da erro com o atalho padrão.
Valeu!

Offline fabriciolf

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
funcionou...muito show!!!
« Resposta #54 Online: 08 de Junho de 2006, 14:55 »
hey Fagner...
gostaria de lhe agradecer pela iniciativa em colocar esse post!

eu estava testando o XGL como SUSE 10.1, e te confesso que achei mais simples configurar no Dapper!!!
agora esta show.. tudo funcionando 100 % !!!

Abraço,
[ ]'s
Fabrício Leite Ferreira
msn: fabriciolf@gmail.com
skype: fabricioatphone

Offline Lex Luthor

  • Usuário Ubuntu
  • *
  • Mensagens: 628
    • Ver perfil
Tutorial XGL ( Dapper, Gnome e Nvidia )
« Resposta #55 Online: 08 de Junho de 2006, 15:00 »
Aonde eu consigo uma lista de todos os atalhos do XGL ?
Abraços...
Analista de Redes- Segurança da Informação
Bacharel em Ciências da Computação - UnB
Ubuntu Forever - Compiz Fusion -

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.369
  • @Ceará
    • Ver perfil
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline mur

  • Usuário Ubuntu
  • *
  • Mensagens: 91
    • Ver perfil
    • mur @ last.fm
Re: xgl - kde RESOLVIDO
« Resposta #57 Online: 08 de Junho de 2006, 18:12 »
Citação de: "gony64"
pessoal instalei o xgl aqui no meu kde, ta funcionando so que as janelas  nao aparecem as bodas bem como o menu " arquivo" "editar" "exibir" etc.

e so ir no gset-compiz e ativar " decoration"


O processo de instalação/configuração foi exatamente o mesmo?
Eu to querendo instalar aqui no meu Kubuntu mas to com medo de fazer alguma besteira... o pc é "compartilhado" com outras pessoas e não posso deixar ele parado caso algo dê errado...
AtlhonXP 2400+/Geforce 6200FX/2GB RAM DDR400/HD 80GB+250GB+500GB
Ubuntu 8.04

Offline Lex Luthor

  • Usuário Ubuntu
  • *
  • Mensagens: 628
    • Ver perfil
Tutorial XGL ( Dapper, Gnome e Nvidia )
« Resposta #58 Online: 09 de Junho de 2006, 10:46 »
Antes de modificar os arquivos, tira cópia, se der pau é só copiar novamente os de backup....
Analista de Redes- Segurança da Informação
Bacharel em Ciências da Computação - UnB
Ubuntu Forever - Compiz Fusion -

Offline Fagner Patricio

  • Usuário Ubuntu
  • *
  • Mensagens: 99
    • Ver perfil
    • http://fagnerpatricio.blogspot.com/
Tutorial XGL ( Dapper, Gnome e Nvidia )
« Resposta #59 Online: 11 de Junho de 2006, 13:15 »
Citar
funcionou...muito show!!!
hey Fagner...
gostaria de lhe agradecer pela iniciativa em colocar esse post!

eu estava testando o XGL como SUSE 10.1, e te confesso que achei mais simples configurar no Dapper!!!
agora esta show.. tudo funcionando 100 % !!!

Abraço,

De nada fabrício, estamos aqui para dar a nossa contribuição :)

Citar
Aqui deu pau
http://ubuntuforum-pt.org/index.php?topic=38032#38032

Aqui ele relata que o teclado deu pau, no meu primeiro tutorial e tinha colocado esse comando:

               xmodmap /usr/share/xmodmap/xmodmap.br

Mas muitas pessoas falaram que tinha dado certo sem ter que executar ele, então achei que não precisava, mas quem der pau no teclado usa esse comando que deve concertar.

Citar
Instalei aqui o xgl, mas na hora d iniciar o x da erro, deu uma mensagem que o X nao poderia ser iniciado e que era pra alterar o gdm.
Alguem teve esse mesmo problema???

Ah, Detalhe, minha placa de video nao e nvdia, e uma intel 915, porem na hora q estava configurando o xorg onde tem a parte de colocar nvidia eu deixei como estava. sera por isto?? eu acredito q nao ja q o x nem iniciou.

Aqui ta o xorg ja modificicado: o resto fiz com manda o tutorial. ah no meu xorg tbm nao tinha linhda do GLcore, mas como iria ser comentada acho q nao teria problema
a instalacao do xgl e do resto deu tudo certo, intaaum acho q o problema e com o xorg mesmo. alguem pode me ajudar,

vle\w
.
.
.

Section "Device"
                  Identifier "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
                  Driver "i810"
                  BusID "PCI:0:2:0"
                  VideoRam 128000
                  Option "UseFBDev" "true"
                  Option "RenderAccel" "true"
                  Option "AllowGLXWithComposite" "true"
EndSection
.
.
.

Deixa eu ver se eu ajudo, o problema se concentra aqui na seção device ,não sei te dizer se o ocorrido é isso, mas vamos analisar alguns fatos, primeiro, por sua placa ser uma intel já complica um pouco, a intel não tem drivers livres que utiliza o 3D, o que complica, o XGL utiliza as funções dos driver da NVidia e ATI, delas próprias, pois utilizam melhor o OpenGL, outra coisa  ,estes comandos:

Option          "RenderAccel"           "true"
Option          "AllowGLXWithComposite" "true"


são para as placas da que tem o OpenGL, e declarações dos desenvolvedores dizem que eles mesmo são bugados então são fontes de muitos problemas, nesse caso é torcer para dar certo :), os desenvovedores também valaram que o desenvolvimento foi baseado nas placas da Nvidia da FX5200, que tem o OpenGL em Hardware, em diante, isso que dizer que qualquer outra placa não tem como prever, pelo menos por enquanto o que pode acontecer, então a minha conclusão é, placas onboard e não Nvidia, é torcer para dar certo...

Falou pessoal!!!
« Última modificação: 06 de Julho de 2006, 01:17 por FaBMak »
Viva o mundo Livre!!!