Autor Tópico: Grub no Ubuntu  (Lida 124577 vezes)

Offline vampire_thunder

  • Usuário Ubuntu
  • *
  • Mensagens: 735
    • Ver perfil
Re: Grub no Ubuntu
« Resposta #45 Online: 01 de Novembro de 2007, 00:09 »
Aproveitando, como é que se instala aqueles temas bonitões com movimentação no grub?

É isto? Grub - Aperfeiçoando e Inovando
Isso mesmo, valeu!  ;)

Offline RickMura

  • Usuário Ubuntu
  • *
  • Mensagens: 226
  • ping -f localhost
    • Ver perfil
Re: Grub no Ubuntu
« Resposta #46 Online: 20 de Janeiro de 2008, 21:20 »
Pessoal,

Instalei o Debian, e posteriormente o Windows, consegui restaurar o grub na boa, mas não entendi uma coisa...

Estou tentando adicionar o boot do Windows (o lnx ta legal), no menu.lst eu adicionei estas linhas:
Citar
title      Microsoft Windows XP (Somente para Jogos)
root      (hd0,4)
savedefault
makeactive
chainloader   +1

usando o comando fdisk -l aparece isso:
Citar
Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cilindros of 16065 * 512 = 8225280 bytes

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sda1               1        1824    14651248+  83  Linux
/dev/sda2            1825        2067     1951897+  82  Linux swap / Solaris
/dev/sda3            2068        8454    51303577+  83  Linux
/dev/sda4   *        8455        9729    10241437+   7  HPFS ou NTFS

A dúvida é que meu windows está na partição 4 eu nao entendi direito como fazer no menu.lst com relação a isto.

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Grub no Ubuntu
« Resposta #47 Online: 29 de Janeiro de 2008, 20:06 »
Experimente trocar a linha:

Citar
root      (hd0,4)

Para:

Citar
root      (hd0,3)
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.686
    • Ver perfil
Re: Grub no Ubuntu
« Resposta #48 Online: 04 de Fevereiro de 2008, 11:13 »
Fiz duas alterações no tutorial. A primeira foi a inclusão de outra dica do Aldemir Silva (mais simples e prática) para alterar a ordem do Boot do Grub!

A segunda foi a alteração do Link sobre o Grub do pessoal do BSD. Não sei o que houve com a página do Guia Foca Linux, nada está funcionando.
Linux Mint 19.3 XFCE / Fedora 33 KDE

Offline rheitor

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Grub no Ubuntu
« Resposta #49 Online: 18 de Fevereiro de 2008, 01:50 »
Pessoal, preciso de uma ajuda de vocês, por favor.
Instalei o XP e posteriormente o Ubuntu 7.10.
Acessei o Grub no Boot, mudei o tempo mas não consigo colocar uma linha com o windows para dar boot nele.
O meu HD estava particionado (via instalação do xp) da seguinte forma C: vazio com 10Gb e D: com 60GB e windows nele.
Instalei o Ubuntu no C:
Os arquivos do windows estão em sda05

Alguem pode me ajudar?

Offline rheitor

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Grub no Ubuntu
« Resposta #50 Online: 18 de Fevereiro de 2008, 01:53 »
** fdisk -l

Disco /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cilindros of 16065 * 512 = 8225280 bytes
Disk identifier: 0xf402f402

Dispositivo Boot Início Fim Blocos Id Sistema
/dev/sda1   *           1        1275    10241406   83  Linux
/dev/sda2            1276        9729    67906755    f  Win95 (LBA) Partição Extendida
/dev/sda5            1276        9728    67898691    7  HPFS ou NTFS
/dev/sda6            9729        9729        8001   82  Linux swap / Solaris
rheitor@rheitor-desktop:~$

Offline ffonseca

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re: Grub no Ubuntu
« Resposta #51 Online: 13 de MAR?O de 2008, 18:54 »
Só uma pergunte bem de iniciante.
Eu vi que o grb tá o boot no windows na partição hd0,0
Quando eu fui instalar o ububtu em casa quando chegou no final por um motivo que eu ainda naum me recordo eu pedi para ele instalar nessa partição o dual boot, dai como não funcionou reinstalei o ubuntu com o dual boot no hd0
Só que agora o meu windows não entra mais, quando escolho ele, ele acaba voltando pra mesma opção do grub não dando erro nenhum só uma especie de loop nessa tela.
Alguem ai pode me dizer o que fazer para normalizar o meu acesso ao windows??
Eu tenho uma HD de 80G particionada onde esta o windows e uma de 8G onde esta o linux.

Offline rjbgbo

  • Usuário Ubuntu
  • *
  • Mensagens: 3.889
  • Xubuntu 18.04LTS
    • Ver perfil
    • Twitter
Re: Grub no Ubuntu
« Resposta #52 Online: 06 de Maio de 2008, 08:34 »
Puxando por essa dica do galactus

Citar
Se a opção for a raiz:

Digamos que o Ubuntu ocupou a partição hda6, você usaria o comando:

Código:

# sudo grub-install /dev/hda6


Com este procedimento, eu estou incluindo o Ubuntu a fazer parte de um leque de opções feito por outras distros usando inclusive o lilo no MBR.

Explicando melhor: Se tenho 2 linux e um windows instalado no meu micro.

Ordem de instalação:

1. Windows xp (hda1)
2. Ubuntu 5.10 (disquete + hda6)
3. Kurumin 6.0 (MBR)

No caso do link abaixo, o lilo foi instalado na MBR usando o kurumin, e o Ubuntu está com o boot em hda6.

http://img356.imageshack.us/my.php?image=3boot6pu.jpg


Conclusão: Fico com 3 SOs convivendo harmoniosamente com um quadro de opções do lilo. A cada vez que formatar e reinstalar a partição do Kurumin por uma versão mais atualizada, as partições do Windows e Ubuntu permanecem preservadas.

Que prefiro adotar, atual/ tenho deixado meu boot pelo disquete. Quero evitar a MBR, que já me deu 2x dor de cabeça bem séria.
Meu Ubuntu está na partição sd6 e meu Windows XP está em /dev/sda1, sendo que está como boot.

Configurando pela dica supracitada, gostaria de que explicassem como esse boot, vai chegar ao gurb do Ubuntu, estando o boot no Windows? Vou precisar trocar a região de boot p/ a /dev/sda6? Se for como poderia fazer isso, pleo Linux e/ou por algum software do Windows.

PS: estranha/ fui fazer 2 cópias do grub p/ disquete, ainda há pouco no Hardy Heron, usando essa dica - http://ubuntuforum-br.org/index.php/topic,17145.0.html e o mesmo ñ gravou.  :-\
« Última modificação: 06 de Maio de 2008, 08:36 por rjbgbo »
Linux User #440843 | Ubuntu User #11469

Offline kcnp

  • Usuário Ubuntu
  • *
  • Mensagens: 88
    • Ver perfil
Re: Grub no Ubuntu
« Resposta #53 Online: 18 de Maio de 2008, 01:34 »
Gente eu to com um problema no boot, acontece que certa vez eu quis testar o debian. Então eu o instalei(depois de uma reinstação do ubuntu) para ficar com um trialboot (DEBIAN-UBUNTU-WINDOWS), so que alem te ter alguns problemas no ubuntu eu acabei perdendo a possibilidade de bootar o windows. Acontece que quando sai a versão final do hardy heron eu resolvi deletar o debian e reinstalar o ubuntu ficando de novo com um simples dualboot windows-ubuntu. Achei que com isso iria resolver o problema por que eu nunca tinha tido problemas com o boot do windows antes de instalar o debian. Bom, mas depois de eu reinstalar o ubuntu hardy heron(muito bom por sinal) e desintalar o debian continuou com o problema do boot no windows.
Não dá nenhum erro, acontece que quando eu mando bootar o windows simplesmente o computador reinicia e volta pra tela do boot. É um problema muito parecido com o problema do colega ffonseca.

Abaixo vai meu arquivo menu.lst pra ver se vocês conseguem achar o erro.


kaio@kaio-world:~$ cat /boot/grub/menu.lst
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default      0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout      10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title      Windows 95/98/NT/2000
# root      (hd0,0)
# makeactive
# chainloader   +1
#
# title      Linux
# root      (hd0,1)
# kernel   /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=84edfad0-efdb-4305-997c-9f2448d0dbc7 ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,6)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash locale=pt_BR

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title      Ubuntu 8.04, kernel 2.6.24-16-generic
root      (hd0,6)
kernel      /vmlinuz-2.6.24-16-generic root=UUID=84edfad0-efdb-4305-997c-9f2448d0dbc7 ro quiet splash locale=pt_BR
initrd      /initrd.img-2.6.24-16-generic
quiet

title      Ubuntu 8.04, kernel 2.6.24-16-generic (recovery mode)
root      (hd0,6)
kernel      /vmlinuz-2.6.24-16-generic root=UUID=84edfad0-efdb-4305-997c-9f2448d0dbc7 ro single
initrd      /initrd.img-2.6.24-16-generic

title      Ubuntu 8.04, memtest86+
root      (hd0,6)
kernel      /memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title      Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda2
title      Windows Vista/Longhorn (loader)
root      (hd0,1)
savedefault
makeactive
chainloader   +1
kcnp

Offline kcnp

  • Usuário Ubuntu
  • *
  • Mensagens: 88
    • Ver perfil
Re: Grub no Ubuntu
« Resposta #54 Online: 11 de Junho de 2008, 19:40 »
 :'(  ??? Gente será que não tem ninguém ai que possa me ajudar? Já faz quase um mês que postei meu problema e ainda ninguém respondeu.
« Última modificação: 11 de Junho de 2008, 19:44 por kcnp »
kcnp

Offline rcampos

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Grub no Ubuntu
« Resposta #55 Online: 05 de Janeiro de 2009, 12:44 »
Gente eu to com um problema no boot, acontece que certa vez eu quis testar o debian. Então eu o instalei(depois de uma reinstação do ubuntu) para ficar com um trialboot (DEBIAN-UBUNTU-WINDOWS), so que alem te ter alguns problemas no ubuntu eu acabei perdendo a possibilidade de bootar o windows. Acontece que quando sai a versão final do hardy heron eu resolvi deletar o debian e reinstalar o ubuntu ficando de novo com um simples dualboot windows-ubuntu. Achei que com isso iria resolver o problema por que eu nunca tinha tido problemas com o boot do windows antes de instalar o debian. Bom, mas depois de eu reinstalar o ubuntu hardy heron(muito bom por sinal) e desintalar o debian continuou com o problema do boot no windows.
Não dá nenhum erro, acontece que quando eu mando bootar o windows simplesmente o computador reinicia e volta pra tela do boot. É um problema muito parecido com o problema do colega ffonseca.

Abaixo vai meu arquivo menu.lst pra ver se vocês conseguem achar o erro.


kaio@kaio-world:~$ cat /boot/grub/menu.lst
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default      0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout      10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title      Windows 95/98/NT/2000
# root      (hd0,0)
# makeactive
# chainloader   +1
#
# title      Linux
# root      (hd0,1)
# kernel   /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=84edfad0-efdb-4305-997c-9f2448d0dbc7 ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,6)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash locale=pt_BR

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title      Ubuntu 8.04, kernel 2.6.24-16-generic
root      (hd0,6)
kernel      /vmlinuz-2.6.24-16-generic root=UUID=84edfad0-efdb-4305-997c-9f2448d0dbc7 ro quiet splash locale=pt_BR
initrd      /initrd.img-2.6.24-16-generic
quiet

title      Ubuntu 8.04, kernel 2.6.24-16-generic (recovery mode)
root      (hd0,6)
kernel      /vmlinuz-2.6.24-16-generic root=UUID=84edfad0-efdb-4305-997c-9f2448d0dbc7 ro single
initrd      /initrd.img-2.6.24-16-generic

title      Ubuntu 8.04, memtest86+
root      (hd0,6)
kernel      /memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title      Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda2
title      Windows Vista/Longhorn (loader)
root      (hd0,1)
savedefault
makeactive
chainloader   +1


experimente assim:

title      Windows Vista/Longhorn (loader)
root      (hd0,1)
savedefault
makeactive
chainloader   +1


title      Ubuntu 8.04, kernel 2.6.24-16-generic
root      (hd0,6)
kernel      /vmlinuz-2.6.24-16-generic root=UUID=84edfad0-efdb-4305-997c-9f2448d0dbc7 ro quiet splash locale=pt_BR
initrd      /initrd.img-2.6.24-16-generic
quiet

title      Ubuntu 8.04, kernel 2.6.24-16-generic (recovery mode)
root      (hd0,6)
kernel      /vmlinuz-2.6.24-16-generic root=UUID=84edfad0-efdb-4305-997c-9f2448d0dbc7 ro single
initrd      /initrd.img-2.6.24-16-generic

title      Ubuntu 8.04, memtest86+
root      (hd0,6)
kernel      /memtest86+.bin
quiet

o grub trabalha de modo diferente do lilo, você apenas precisaria colocar o windows como mostrei acima.

o problema do ffonseca pelo que entendi, ele tem essa configuração já realizada, contudo, ao iniciar com o windows, ele causa loop não entrando no sistema. E esse é um problema que também estou enfretando no momento.

Offline rvcezar

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Grub no Ubuntu
« Resposta #56 Online: 05 de Junho de 2009, 16:46 »
Pessoal, sou novo no forum e no UBUNTU...

procurei a minha dúvida aqui no forum, usei a ferramenta de busca e acabei achando a mesma pergunta mas sem respostas... por isso venho aqui, onde achei mais oportuno, procurar uma resposta para a minha dúvida...

seguinte:

possuo 2 HDs

um HD SATA2 de 500Gb particionado em 3 unidades

um HD IDE 120Gb

eu tinha no meu HD de 500Gb o windows XP (ainda tenho hehehe) e um amigo me convenceu a instalar e testar o UBUNTU... com medo de dr algum erro com o windows e tal eu fiz o seguinte...

desliguei o HD de 500Gb e instalei o UBUNTU no HD de 120, usando TODO o HD...

funcionou que é uma beleza e achei show...

daí religuei o meu HD de 500 (que contém o windows) e utilizei da BIOS para selecionar qual disco eu gostaria que entrasse primeiro, o HD do XP ou o HD do ubuntu... sem problemas....

cabe lembrar que o ubuntu tá lendo tranquilamente esse HD de 500gb, tudo perfeito e quando eu dou BOOT pela bios para o XP também está tudo perfeito...

só que minha esposa de vez em quando acaba utilizando meu pc e ela já é fraquinha no XP então imagina no UBUNTU ou ainda na BIOS para gerenciar qual disco abrirá.. hehehehehe

agora que vem a minha pergunta....

como fazer para aparecer a essas alturas do campeonato o dualboot???? e ainda de uma forma que, se eu tivesse que formatar o XP, eu não perca esse dualboot... outra coisa... também queria que ele apontasse para o XP caso não fosse selecionada uma opção (primeira linha XP)

existe alguma forma?
eu quero que esse dualboot fique nesse HD de 120 e que nada do ubuntu interfirisse no HD de 500....

alguém pode me dar uma luz?

muito obrigado
Roberto Cezar

Offline adrianospk

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Grub no Ubuntu
« Resposta #57 Online: 17 de Janeiro de 2010, 12:42 »
Pessoal ajudaaaaaaaa

eu já fiz o comando abaixo mas sempre abre um editor em branco... no notebook funcionou blz, mais no PC aqui de casa aparece em branco, acho que não tem esse arquivo menu.lst. O que eu faço?

sudo gedit /boot/grub/menu.lst

Offline Andreson Goveia

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.985
  • Kubuntu 14.10
    • Ver perfil
Re: Grub no Ubuntu
« Resposta #58 Online: 17 de Janeiro de 2010, 13:48 »
Pessoal ajudaaaaaaaa

eu já fiz o comando abaixo mas sempre abre um editor em branco... no notebook funcionou blz, mais no PC aqui de casa aparece em branco, acho que não tem esse arquivo menu.lst. O que eu faço?

sudo gedit /boot/grub/menu.lst
Qual ubuntu está instalado??
9.10 ou 9.04???

Offline Marcius

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Tenho o Ubuntu>XP>Vista e Seven, o windows 7 esta em 1 no boot, quero por o XP.
« Resposta #59 Online: 10 de Fevereiro de 2010, 06:51 »
bom, instalei primeiro o XP depois o vista, depois o seven e por ultimo o ubuntu.

antes de instalar o ubuntu o windows seven da uma opcao de boot na ordem abaixo.

Windows XP
Windows Seven
Windows Vista

no grub consegui alterar a ordem pra iniciar direto no windows, so que ele redireciona para a opcao acima, na qual o windows seven e o do meio e inicia automatico depois de 20 segundos.

gostaria que dos tres windows o XP iniciasse primeiro.

segue abaixo as configuracoes do meu grub.

# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default      4 (a opcao DEFAULT 4, faz com que inicie o windows)


title      Ubuntu 9.04 (primeiro da lista)
uuid      b86c880c-5625-4849-865a-848abb15527c
kernel      /boot/vmlinuz-2.6.28-11-generic root=UUID=b86c880c-5625-4849-865a-848abb15527c ro locale=pt_BR quiet splash
initrd      /boot/initrd.img-2.6.28-11-generic
quiet

title      Ubuntu 9.04, (Modo de Seguranca)>>>(Segundo da Lista)
uuid      b86c880c-5625-4849-865a-848abb15527c
kernel      /boot/vmlinuz-2.6.28-11-generic root=UUID=b86c880c-5625-4849-865a-848abb15527c ro locale=pt_BR  single
initrd      /boot/initrd.img-2.6.28-11-generic

title      Ubuntu 9.04, Teste de Memoria(Terceiro da lista)
uuid      b86c880c-5625-4849-865a-848abb15527c
kernel      /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title      Outros Sistemas Operacionais:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title      Windows XP Seven Vista(Quarto da lista, justificando a primeira opcao)
rootnoverify   (hd0,0)
savedefault
makeactive
chainloader   +1


Ate ai tudo bem, mais quando e iniciado a quarta apcao de boot redireciona para:

Windows XP
Windows Seven
Windows Vista

Onde o sistema operacional do meio e iniciado automatico.


gostaria muito de mudar esta ordem para xp primeiro, se alguem souber por favor me da uma luz.
no grub mudei o tempo para 5 segundos mais quando iniciar o boot do windows ele fica em 20 segundos, como faco parra diminuir este tempo.