Autor Tópico: Formatar disquetes no Ubuntu  (Lida 12283 vezes)

Offline FaBMak

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 722
    • Ver perfil
    • fabmak://website
Formatar disquetes no Ubuntu
« Online: 26 de Julho de 2005, 18:38 »
Sei que os disquetes já estão em vias de extinção mas, às vezes, precisamos trocar arquivos entre diferentes estações e o disquete pode quebrar o gralho. No entanto tive problemas ao formatar um disquete no Ubuntu, copiar arquivos e depois tentar abrir o mesmo em estações Windows. O sintoma era: o Ubuntu não aceitava arquivos com nomes longos, limitando os mesmos a 8.3 carateres.

Resolvi este problema editando o arquivo /etc/fstab e modificando o sistema de arquivos do floppy. A configuração padrão do Ubuntu é auto e mudei para vfat e também acrescentei o iocharset=utf8 para que os arquivos não sejam exibidos com nomes com caracteres estranho ao serem acessados no Ubuntu.

Segue a linha de configuração do floppy no meu Ubuntu:
/dev/fd0        /media/floppy0  vfat    rw,user,noauto,iocharset=utf8  0       0


FaBMak
"Não creias impossível o que apenas improvável parece". (Shakespeare)
fabmak://website | http://twitter.com/fabmak

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.683
    • Ver perfil
Formatar disquetes no Ubuntu
« Resposta #1 Online: 27 de Julho de 2005, 12:11 »
Beleza de dica, mas desculpe a pergunta, você passou a usar a opção "noauto", isso quer dizer que quando eu clicar para ele montar o floppy não vai funcionar? Lá na opção Locais > Computador > Unidade de disquetes.
Ou vai continuar tudo como antes?
BigLinux no Notebook  / Várias Distros Virtualizadas no PC.

Offline FaBMak

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 722
    • Ver perfil
    • fabmak://website
Formatar disquetes no Ubuntu
« Resposta #2 Online: 27 de Julho de 2005, 13:08 »
Continua igual, se vc clicar no disquete o mesmo será montado automaticamente. Este "noauto" diz ao kernel para NÃO montar o disquete automaticamente durante o BOOT.

FaBMak
"Não creias impossível o que apenas improvável parece". (Shakespeare)
fabmak://website | http://twitter.com/fabmak

Offline LaSSarD

  • Usuário Ubuntu
  • *
  • Mensagens: 1.144
    • Ver perfil
Formatar disquetes no Ubuntu
« Resposta #3 Online: 27 de Julho de 2005, 13:28 »
Como assim 8.3 caracteres? Ah, eu diria que você é mais sortudo do que eu, porque eu não consigo nem abrir disquetes gravados pelo Windows aqui... :(
desculpem as mensagens não respondidas, mas eu tô afastado há mais de ano...
um dia eu volto ;)

Offline FaBMak

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 722
    • Ver perfil
    • fabmak://website
Formatar disquetes no Ubuntu
« Resposta #4 Online: 27 de Julho de 2005, 13:37 »
Citação de: "LaSSarD"
Como assim 8.3 caracteres? Ah, eu diria que você é mais sortudo do que eu, porque eu não consigo nem abrir disquetes gravados pelo Windows aqui... :(


O chamado 8.3 é uma referência ao sistema de nomes usado até o DOS que permitia que os arquivos pudessem ter nome de até 8 caracteres e extensões de 3 caracteres, daí o 8.3 caracteres.

Quanto à abrir os disquetes no Ubuntu tente fazer a alteração que eu sugeri e veja o ocorre.

FaBMak
"Não creias impossível o que apenas improvável parece". (Shakespeare)
fabmak://website | http://twitter.com/fabmak

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.683
    • Ver perfil
Formatar disquetes no Ubuntu
« Resposta #5 Online: 27 de Julho de 2005, 20:35 »
Citação de: "FaBMak"
Continua igual, se vc clicar no disquete o mesmo será montado automaticamente. Este "noauto" diz ao kernel para NÃO montar o disquete automaticamente durante o BOOT.

FaBMak


Muito obrigado FaBMak, vou testar a sua dica e posto de novo o resultado.
BigLinux no Notebook  / Várias Distros Virtualizadas no PC.

Offline FRNSantos

  • Official Ubuntu Member
  • Usuário Ubuntu
  • *****
  • Mensagens: 39
    • Ver perfil
    • Blog do Ubuntuser
Formatar disquetes no Ubuntu
« Resposta #6 Online: 06 de Outubro de 2005, 15:47 »
Realmente FabMak.. essa dica é 10!

Valeu mesmo!
Fábio "Elvis" Nogueira
Jabber: ubuntuser@jabber.cz  | IRC: Ubuntuser (irc.freenode.net)
http://ubuntuser.com.br/blog

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Formatar disquetes no Ubuntu
« Resposta #7 Online: 28 de Dezembro de 2005, 14:17 »
Citação de: "FaBMak"

Quanto à abrir os disquetes no Ubuntu tente fazer a alteração que eu sugeri e veja o ocorre.


Achei que eu tinha resolvido esse mesmo problema que o Lassard mencionou. Segui a dica do Fab, alterei o fstab, depois dei mount -a. No primeiro disquete que testei, consegui ver todos os arquivos gravados no rwindow$. Gravei um arquivo nele pelo Ubuntu e conseguir abri-lo na outra máquina rwin. Mas aí, fui testar com outros disquetes rwin, e o Ubuntu fala que todos eles estão vazios. E não estão!  :shock: E nem mais no disquete que funcionou no primeiro teste ele acha arquivos.

Onde foi que eu errei?  :?
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |

Offline FaBMak

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 722
    • Ver perfil
    • fabmak://website
Formatar disquetes no Ubuntu
« Resposta #8 Online: 28 de Dezembro de 2005, 19:33 »
Revise o arquivo fstab.

FaBMak
"Não creias impossível o que apenas improvável parece". (Shakespeare)
fabmak://website | http://twitter.com/fabmak

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Formatar disquetes no Ubuntu
« Resposta #9 Online: 29 de Dezembro de 2005, 11:10 »
Citação de: "FaBMak"
Revise o arquivo fstab.


Tentei hoje novamente, e o resultado é o mesmo: o Ubuntu só lê o primeiro disquete formatado em rwindow$ que eu uso. Os seguintes são mostrados sempre como vazios.

Meu fstab está assim:

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hdc1       /               reiserfs notail          0       1
/dev/hda1       /media/hda1     ntfs    defaults        0       0
/dev/hda2       /media/hda2     vfat    defaults        0       0
/dev/hdc2       /media/hdc2     reiserfs defaults        0       2
/dev/hdc4       /media/windows  vfat    rw,user,auto,iocharset=utf8,uid=1000,gid=1000,     0       0
/dev/hdc3       none            swap    sw              0       0
/dev/hdd        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  vfat    rw,user,noauto,iocharset=utf8  0       0
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |

Offline Br1000

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
Formatar disquetes no Ubuntu
« Resposta #10 Online: 29 de Dezembro de 2005, 12:01 »
Olá
No meu também não monta o disquete apesar de ter feito a modificação sugerida.
O fstab ficou assim:
Citar
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hdc1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hdc5       none            swap    sw              0       0
/dev/hdd        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
/dev/sda        /media/usb0     vfat    rw,user,noauto,iocharset=utf8  0       0

e o erro que apresenta é:
Citar
Não foi possível montar o volume selecionado.
mount: I could not determine the filesystem type, and none was specified


Tenho também um Pen Drive USB que está apresentando:
Citar
Não foi possível montar o volume selecionado.
mount: can't find /dev/sdb1 in /etc/fstab or /etc/mtab


Isso ocorreu depois da minha últina atualização.
Apareceu um dispositivo novo em Computador o usb0 o Controle de volume (aquele ao lado do relógio) não funciona mais e diz que:
Citar
O registro não está presente ou está corrompido.
Por favor, atualize-o executando gst-register.

Não sei como executar tal comando.
Onde estará o erro? Como resolver?
Obrigado e descolpe pela quantidade de dúvidas
[]'s

Offline laurofrutal

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Montar e abrir disquete de uma vez só
« Resposta #11 Online: 09 de Maio de 2006, 12:51 »
Bom dia.

Como faço para que ao no ícone floppy0 eu ao mesmo tempo monte e abra o disquete? Acontece que é meio improdutivo e chato ter que clicar duas vezes para montar e depois mais duas vezes para ver o conteúdo de cada disquete. Ouvi dizer que no kurumin isso não acontece. Outra coisa: De dentro de uma aplicação, OpenOffice, por exemplo, não consigo utilizar o salvar como sem antes montar o disquete em outra janela. Será que não tem um meio para que eu montar e salvar no disquete de dentro do aplicativo?

Se puderem me ajudar eu agradeço, senão não vou conseguir convencer algumas pessoas a continuar usando o Ubuntu que instalei para elas.

Obrigado.
Liberdade, Igualdade, Fraternidade.